Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
esmagent 5601 udp Enterprise Security Agent Kimberly Gibbs Kimberly Gibbs
a1-msc 5602 tcp A1-MSC Mike Dolan Mike Dolan
a1-msc 5602 udp A1-MSC Mike Dolan Mike Dolan
a1-bs 5603 tcp A1-BS Mike Dolan Mike Dolan
a1-bs 5603 udp A1-BS Mike Dolan Mike Dolan
a3-sdunode 5604 tcp A3-SDUNode Mike Dolan Mike Dolan
a3-sdunode 5604 udp A3-SDUNode Mike Dolan Mike Dolan
a4-sdunode 5605 tcp A4-SDUNode Mike Dolan Mike Dolan
a4-sdunode 5605 udp A4-SDUNode Mike Dolan Mike Dolan
5606-5617 Unassigned
efr 5618 tcp Fiscal Registering Protocol efsta IT Services GmbH Ernst Bewersdorff 2013-08-13 2022-02-02
5618 udp Reserved
5619-5626 Unassigned
ninaf 5627 tcp Node Initiated Network Association Forma Thomas Scholl Thomas Scholl 2006-03
ninaf 5627 udp Node Initiated Network Association Forma Thomas Scholl Thomas Scholl 2006-03
htrust 5628 tcp HTrust API Karl Olafsson Karl Olafsson 2008-10-24
htrust 5628 udp HTrust API Karl Olafsson Karl Olafsson 2008-10-24
symantec-sfdb 5629 tcp Symantec Storage Foundation for Database Quang Thoi Quang Thoi 2006-11
symantec-sfdb 5629 udp Symantec Storage Foundation for Database Quang Thoi Quang Thoi 2006-11
precise-comm 5630 tcp PreciseCommunication Alon Tamir Alon Tamir 2006-04
precise-comm 5630 udp PreciseCommunication Alon Tamir Alon Tamir 2006-04
pcanywheredata 5631 tcp pcANYWHEREdata Jon Rosarky Jon Rosarky
pcanywheredata 5631 udp pcANYWHEREdata Jon Rosarky Jon Rosarky
pcanywherestat 5632 tcp pcANYWHEREstat Jon Rosarky Jon Rosarky
pcanywherestat 5632 udp pcANYWHEREstat Jon Rosarky Jon Rosarky
beorl 5633 tcp BE Operations Request Listener Chirag Desai Chirag Desai 2006-02
beorl 5633 udp BE Operations Request Listener Chirag Desai Chirag Desai 2006-02
xprtld 5634 tcp SF Message Service VR Satish VR Satish 2007-08-16
xprtld 5634 udp SF Message Service VR Satish VR Satish 2007-08-16
sfmsso 5635 tcp SFM Authentication Subsystem De-Chih Chien De-Chih Chien 2008-09-15
5635 udp Reserved
sfm-db-server 5636 tcp SFMdb - SFM DB server De-Chih Chien De-Chih Chien 2008-10-06
5636 udp Reserved
cssc 5637 tcp Symantec CSSC Amol P Tambe Amol P Tambe 2011-02-02
5637 udp Reserved
flcrs 5638 tcp Symantec Fingerprint Lookup and Container Reference Service Symantec Corp Neel A. Bhatt 2012-01-03
5638 udp Reserved
ics 5639 tcp Symantec Integrity Checking Service Symantec Danzhou Liu 2012-05-07
5639 udp Reserved
5640-5645 Unassigned
vfmobile 5646 tcp Ventureforth Mobile Ventureforth Inc. Blakely Snyder 2011-11-03
5646 udp Reserved
5647-5665 Unassigned
nrpe 5666 tcp Nagios Remote Plugin Executor Nagios Enterprises, LLC Bryan Heden 2017-09-06
5666 udp Reserved
5667-5669 Unassigned
filemq 5670 tcp ZeroMQ file publish-subscribe protocol Pieter Hintjens Pieter Hintjens 2012-11-01 2013-02-25
zre-disc 5670 udp Local area discovery and messaging over ZeroMQ Pieter Hintjens Pieter Hintjens 2012-12-17
amqps 5671 tcp amqp protocol over TLS/SSL Ted Ross Ted Ross 2008-03-26
amqps 5671 udp amqp protocol over TLS/SSL Ted Ross Ted Ross 2008-03-26
amqp 5672 tcp AMQP Pieter Hintjens Pieter Hintjens 2006-01
amqp 5672 udp AMQP Pieter Hintjens Pieter Hintjens 2006-01
amqp 5672 sctp AMQP Martin Sustrik Martin Sustrik 2007-03
jms 5673 tcp JACL Message Server Stuart Allen Stuart Allen 2002-02
jms 5673 udp JACL Message Server Stuart Allen Stuart Allen 2002-02
hyperscsi-port 5674 tcp HyperSCSI Port Data Storage Institute of Singapore Data Storage Institute of Singapore 2002-02
hyperscsi-port 5674 udp HyperSCSI Port Data Storage Institute of Singapore Data Storage Institute of Singapore 2002-02
v5ua 5675 tcp V5UA application port RFC 3807
v5ua 5675 udp V5UA application port RFC 3807
v5ua 5675 sctp V5UA application port RFC 3807
raadmin 5676 tcp RA Administration Sergei Zjaikin Sergei Zjaikin 2002-02
raadmin 5676 udp RA Administration Sergei Zjaikin Sergei Zjaikin 2002-02
questdb2-lnchr 5677 tcp Quest Central DB2 Launchr Robert M. Mackowiak Robert M. Mackowiak 2002-02
questdb2-lnchr 5677 udp Quest Central DB2 Launchr Robert M. Mackowiak Robert M. Mackowiak 2002-02
rrac 5678 tcp Remote Replication Agent Connection
rrac 5678 udp Remote Replication Agent Connection
dccm 5679 tcp Direct Cable Connect Manager Mark Miller Mark Miller
dccm 5679 udp Direct Cable Connect Manager Mark Miller Mark Miller
auriga-router 5680 tcp Auriga Router Service Vincent Gaudeul Vincent Gaudeul 2006-02
auriga-router 5680 udp Auriga Router Service Vincent Gaudeul Vincent Gaudeul 2006-02
ncxcp 5681 tcp Net-coneX Control Protocol Ryan Werber Ryan Werber 2006-06
ncxcp 5681 udp Net-coneX Control Protocol Ryan Werber Ryan Werber 2006-06
5682 tcp Reserved
brightcore 5682 udp BrightCore control & data transfer exchange Marko Bjelac Marko Bjelac 2010-06-10
coap 5683 tcp Constrained Application Protocol (CoAP) IESG IETF Chair 2017-12-22 RFC 8323
coap 5683 udp Constrained Application Protocol IESG IETF Chair 2011-06-13 2013-07-25 RFC 7252
coaps 5684 tcp Constrained Application Protocol (CoAP) IESG IETF Chair 2017-12-22 RFC 7301; RFC 8323
coaps 5684 udp DTLS-secured CoAP IESG IETF Chair 2013-07-25 RFC 7252
5685-5686 Unassigned
gog-multiplayer 5687 udp GOG multiplayer game protocol GOG.com Michał Gruchała 2014-07-31 2014-10-09
5687 tcp Reserved
ggz 5688 tcp GGZ Gaming Zone Josef Spillner Josef Spillner 2003-01
ggz 5688 udp GGZ Gaming Zone Josef Spillner Josef Spillner 2003-01
qmvideo 5689 tcp QM video network management protocol Jamie Lokier Jamie Lokier 2006-05
qmvideo 5689 udp QM video network management protocol Jamie Lokier Jamie Lokier 2006-05
5690-5692 Unassigned
rbsystem 5693 tcp Robert Bosch Data Transfer Syntegon Technology GmbH Klaus Warth 2011-08-01 2020-02-04
5693 udp Reserved
5694-5695 Unassigned
kmip 5696 tcp Key Management Interoperability Protocol OASIS KMIP Technical Committee Robin Cover 2011-07-25
5696 udp Reserved
5697-5699 Unassigned
supportassist 5700 tcp Dell SupportAssist data center management Dell Technologies Rohitdev Kulshrestha 2016-07-05
5700 udp Reserved
5701-5704 Unassigned
storageos 5705 tcp StorageOS REST API StorageOS Simon Croome 2017-03-03
5705 udp Reserved
5706-5712 Unassigned
proshareaudio 5713 tcp proshare conf audio gunner gunner
proshareaudio 5713 udp proshare conf audio gunner gunner
prosharevideo 5714 tcp proshare conf video gunner gunner

Contact Information

Name Organization Contact URI Last Updated
Alon Tamir alon_tamir&symantec.com 2006-04
Amol P Tambe amol_tambe&symantec.com 2011-02-02
Blakely Snyder Ventureforth Inc. bsnyder&ventureforth.com 2011-11-03
Bryan Heden bheden&nagios.com 2017-09-06
Chirag Desai Chirag_Desai&symantec.com 2006-02
Danzhou Liu Symantec Danzhou_Liu&symantec.com 2012-05-07
Data Storage Institute of Singapore Patrick&dsi.nus.edu.sg 2002-02
De-Chih Chien de-chih_chien&symantec.com 2008-10-06
Dell Technologies rohitdev_kulshrestha&dell.com 2016-07-05
efsta IT Services GmbH admin&efsta.eu 2022-02-02
Ernst Bewersdorff efsta IT Services GmbH e.bewersdorff&efsta.eu 2022-02-02
GOG.com admin&gog.com 2014-07-31
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jamie Lokier jamie&jlokier.co.uk 2006-05
Jon Rosarky JRosarky&symantec.com
Josef Spillner admin&ggzgamingzone.org 2003-01
Karl Olafsson Karl.Olafsson&covariant-systems.com 2008-10-24
Kimberly Gibbs kimgib&ccgate-ut.axent.com
Klaus Warth Syntegon Technology GmbH Klaus.Warth&Syntegon.com 2020-02-04
Mark Miller mmiller&microsoft.com
Marko Bjelac marko.bjelac&elma.hr 2010-06-10
Martin Sustrik sustrik&imatix.com 2007-03
Michał Gruchała GOG.com admin&gog.com 2014-07-31
Mike Dolan MDolan&ihcmail.ih.lucent.com
Nagios Enterprises, LLC techteam&nagios.com 2017-09-06
Neel A. Bhatt Symantec Corp neel_bhatt&symantec.com 2012-01-03
OASIS KMIP Technical Committee robin&oasis-open.org 2011-07-25
Pieter Hintjens ph&imatix.com 2006-01
Pieter Hintjens ph&imatix.com 2012-11-01
Pieter Hintjens ph&imatix.com 2012-12-17
Quang Thoi quang_thoi&symantec.com 2006-11
Robert M. Mackowiak rmackowiak&quest.com 2002-02
Robin Cover OASIS KMIP Technical Committee robin&oasis-open.org 2011-07-25
Rohitdev Kulshrestha rohitdev_kulshrestha&dell.com 2016-07-05
Ryan Werber ryan&ncxti.com 2006-06
Sergei Zjaikin serge&previo.ee 2002-02
Simon Croome simon.croome&storageos.com 2017-03-03
StorageOS simon.croome&storageos.com 2017-03-03
Stuart Allen stuart&jacl.animats.net 2002-02
Symantec Corp neel_bhatt&symantec.com 2012-01-03
Symantec info&symantec.com 2012-05-07
Syntegon Technology GmbH Klaus.Warth&syntegon.com 2020-02-04
Ted Ross tross&redhat.com 2008-03-26
Thomas Scholl tscholl&spf.is-is.ca 2006-03
VR Satish vr_satish&symantec.com 2007-08-16
Ventureforth Inc. support&ventureforth.com 2011-11-03
Vincent Gaudeul technique&auriga.fr 2006-02
gunner&ibeam.intel.com