Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 5798 | udp | Reserved | |||||||||
| 5799-5812 | Unassigned | ||||||||||
| icmpd | 5813 | tcp | ICMPD | Shane O'Donnell | Shane O'Donnell | ||||||
| icmpd | 5813 | udp | ICMPD | Shane O'Donnell | Shane O'Donnell | ||||||
| spt-automation | 5814 | tcp | Support Automation | Joshua Hawkins | Joshua Hawkins | 2003-11 | |||||
| spt-automation | 5814 | udp | Support Automation | Joshua Hawkins | Joshua Hawkins | 2003-11 | |||||
| 5815-5819 | Unassigned | ||||||||||
| autopassdaemon | 5820 | tcp | AutoPass licensing | opentext | AutoPass | 2022-06-10 | 2024-08-01 | ||||
| 5820 | udp | Reserved | |||||||||
| 5821-5840 | Unassigned | ||||||||||
| shiprush-d-ch | 5841 | tcp | Z-firm ShipRush interface for web access and bidirectional data | Z-Firm LLC | Rafael Zimberoff | 2014-08-22 | |||||
| 5841 | udp | Reserved | |||||||||
| reversion | 5842 | tcp | Reversion Backup/Restore | Pincoder Diagnostics Inc. | Craig Nelson | 2011-09-26 | 2022-10-12 | ||||
| 5842 | udp | Reserved | |||||||||
| 5843-5858 | Unassigned | ||||||||||
| wherehoo | 5859 | tcp | WHEREHOO | Jim Youll | Jim Youll | ||||||
| wherehoo | 5859 | udp | WHEREHOO | Jim Youll | Jim Youll | ||||||
| 5860-5862 | Unassigned | ||||||||||
| ppsuitemsg | 5863 | tcp | PlanetPress Suite Messeng | Yannick Fortin | Yannick Fortin | 2006-02 | |||||
| ppsuitemsg | 5863 | udp | PlanetPress Suite Messeng | Yannick Fortin | Yannick Fortin | 2006-02 | |||||
| 5864-5867 | Unassigned | ||||||||||
| diameters | 5868 | tcp | Diameter over TLS/TCP | IESG | IETF Chair | RFC 6733 | |||||
| 5868 | udp | Reserved | |||||||||
| diameters | 5868 | sctp | Diameter over DTLS/SCTP | IESG | IETF Chair | RFC 6733 | |||||
| 5869-5882 | Unassigned | ||||||||||
| jute | 5883 | tcp | Javascript Unit Test Environment | Mark Ethan Trostler | Mark Ethan Trostler | 2011-11-23 | |||||
| 5884-5899 | Unassigned | ||||||||||
| rfb | 5900 | tcp | Remote Framebuffer | Tristan Richardson | Tristan Richardson | 2006-03 | RFC 6143 | ||||
| rfb | 5900 | udp | Remote Framebuffer | Tristan Richardson | Tristan Richardson | 2006-03 | RFC 6143 | ||||
| 5901-5902 | Unassigned | ||||||||||
| ff-ice | 5903 | tcp | Flight & Flow Info for Collaborative Env | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: FF-ICE | ||||
| ff-ice | 5903 | udp | Flight & Flow Info for Collaborative Env | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: FF-ICE | ||||
| ff-ice | 5903 | sctp | Flight & Flow Info for Collaborative Env | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: FF-ICE | ||||
| ag-swim | 5904 | tcp | Air-Ground SWIM | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: AG-SWIM | ||||
| ag-swim | 5904 | udp | Air-Ground SWIM | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: AG-SWIM | ||||
| ag-swim | 5904 | sctp | Air-Ground SWIM | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: AG-SWIM | ||||
| asmgcs | 5905 | tcp | Adv Surface Mvmnt and Guidance Cont Sys | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: ASMGCS | ||||
| asmgcs | 5905 | udp | Adv Surface Mvmnt and Guidance Cont Sys | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: ASMGCS | ||||
| asmgcs | 5905 | sctp | Adv Surface Mvmnt and Guidance Cont Sys | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: ASMGCS | ||||
| rpas-c2 | 5906 | tcp | Remotely Piloted Vehicle C&C | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: RPAS-C2 | ||||
| rpas-c2 | 5906 | udp | Remotely Piloted Vehicle C&C | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: RPAS-C2 | ||||
| rpas-c2 | 5906 | sctp | Remotely Piloted Vehicle C&C | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: RPAS-C2 | ||||
| dsd | 5907 | tcp | Distress and Safety Data App | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: DSD | ||||
| dsd | 5907 | udp | Distress and Safety Data App | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: DSD | ||||
| dsd | 5907 | sctp | Distress and Safety Data App | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: DSD | ||||
| ipsma | 5908 | tcp | IPS Management Application | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: IPSMA | ||||
| ipsma | 5908 | udp | IPS Management Application | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: IPSMA | ||||
| ipsma | 5908 | sctp | IPS Management Application | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: IPSMA | ||||
| agma | 5909 | tcp | Air-ground media advisory | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: AGMA | ||||
| agma | 5909 | udp | Air-ground media advisory | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: AGMA | ||||
| agma | 5909 | sctp | Air-ground media advisory | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: AGMA | ||||
| ats-atn | 5910 | tcp | Air Traffic Services applications using ATN | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| ats-atn | 5910 | udp | Air Traffic Services applications using ATN | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| cm | 5910 | sctp | Context Management | Justin Yu | Justin Yu | 2011-05-19 | |||||
| ats-acars | 5911 | tcp | Air Traffic Services applications using ACARS | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| ats-acars | 5911 | udp | Air Traffic Services applications using ACARS | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| cpdlc | 5911 | sctp | Controller Pilot Data Link Communication | Justin Yu | Justin Yu | 2011-05-18 | |||||
| ais-met | 5912 | tcp | Aeronautical Information Service/Meteorological applications using ACARS | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| ais-met | 5912 | udp | Aeronautical Information Service/Meteorological applications using ACARS | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| fis | 5912 | sctp | Flight Information Services | Justin Yu | Justin Yu | 2011-05-25 | |||||
| aoc-acars | 5913 | tcp | Airline operational communications applications using ACARS | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| aoc-acars | 5913 | udp | Airline operational communications applications using ACARS | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| ads-c | 5913 | sctp | Automatic Dependent Surveillance | Justin Yu | Justin Yu | 2011-05-25 | |||||
| ipsdtls | 5914 | tcp | Security for Internet Protocol Suite | International Civil Aviation Organisation (ICAO) | Nathan Lackey | 2024-11-19 | Defined TXT keys: IPSDTLS | ||||
| ipsdtls | 5914 | udp | Security for Internet Protocol Suite | International Civil Aviation Organisation (ICAO) | Nathan Lackey | 2024-11-19 | Defined TXT keys: IPSDTLS | ||||
| ipsdtls | 5914 | sctp | Security for Internet Protocol Suite | International Civil Aviation Organisation (ICAO) | Nathan Lackey | 2024-11-19 | Defined TXT keys: IPSDTLS | ||||
| 5915-5962 | Unassigned | ||||||||||
| indy | 5963 | tcp | Indy Application Server | Bjorn Lantz | Bjorn Lantz | 2004-11 | |||||
| indy | 5963 | udp | Indy Application Server | Bjorn Lantz | Bjorn Lantz | 2004-11 | |||||
| 5964-5967 | Unassigned | ||||||||||
| mppolicy-v5 | 5968 | tcp | mppolicy-v5 | Yutaka Ono | Yutaka Ono | ||||||
| mppolicy-v5 | 5968 | udp | mppolicy-v5 | Yutaka Ono | Yutaka Ono | ||||||
| mppolicy-mgr | 5969 | tcp | mppolicy-mgr | Yutaka Ono | Yutaka Ono | ||||||
| mppolicy-mgr | 5969 | udp | mppolicy-mgr | Yutaka Ono | Yutaka Ono | ||||||
| 5970-5983 | Unassigned | ||||||||||
| couchdb | 5984 | tcp | CouchDB | Noah Slater | Noah Slater | 2007-11-27 | |||||
| couchdb | 5984 | udp | CouchDB | Noah Slater | Noah Slater | 2007-11-27 | |||||
| wsman | 5985 | tcp | WBEM WS-Management HTTP | Jim Davis | Jim Davis | 2006-11 | |||||
| wsman | 5985 | udp | WBEM WS-Management HTTP | Jim Davis | Jim Davis | 2006-11 | |||||
| wsmans | 5986 | tcp | WBEM WS-Management HTTP over TLS/SSL | Jim Davis | Jim Davis | 2006-11 | |||||
| wsmans | 5986 | udp | WBEM WS-Management HTTP over TLS/SSL | Jim Davis | Jim Davis | 2006-11 | |||||
| wbem-rmi | 5987 | tcp | WBEM RMI | Jim Davis | Jim Davis | ||||||
| wbem-rmi | 5987 | udp | WBEM RMI | Jim Davis | Jim Davis | ||||||
| wbem-http | 5988 | tcp | WBEM CIM-XML (HTTP) | Jim Davis | Jim Davis | ||||||
| wbem-http | 5988 | udp | WBEM CIM-XML (HTTP) | Jim Davis | Jim Davis | ||||||
| wbem-https | 5989 | tcp | WBEM CIM-XML (HTTPS) | Jim Davis | Jim Davis | ||||||
| wbem-https | 5989 | udp | WBEM CIM-XML (HTTPS) | Jim Davis | Jim Davis | ||||||
| wbem-exp-https | 5990 | tcp | WBEM Export HTTPS | Denise Eckstein | Denise Eckstein | 2004-11 | |||||
| wbem-exp-https | 5990 | udp | WBEM Export HTTPS | Denise Eckstein | Denise Eckstein | 2004-11 | |||||
| nuxsl | 5991 | tcp | NUXSL | Kai Kretschmann | Kai Kretschmann | 2002-03 | |||||
| nuxsl | 5991 | udp | NUXSL | Kai Kretschmann | Kai Kretschmann | 2002-03 | |||||
| consul-insight | 5992 | tcp | Consul InSight Security | Arthur Hillenaar | Arthur Hillenaar | 2006-01 | |||||
| consul-insight | 5992 | udp | Consul InSight Security | Arthur Hillenaar | Arthur Hillenaar | 2006-01 | |||||
| cim-rs | 5993 | tcp | DMTF WBEM CIM REST | WS, Inc | Jim Davis | 2015-04-24 | |||||
| 5993 | udp | Reserved | |||||||||
| rms-agent | 5994 | tcp | RMS Agent Listening Service | RiverMeadow Software Inc. | Greg Dennis | 2021-03-24 | |||||
| 5994 | udp | Reserved | |||||||||
| 5995-5998 | Unassigned | ||||||||||
| cvsup | 5999 | tcp | CVSup | Randall Atkinson | Randall Atkinson | ||||||
| cvsup | 5999 | udp | CVSup | Randall Atkinson | Randall Atkinson | ||||||
| x11 | 6000-6063 | tcp | X Window System | Stephen Gildea | Stephen Gildea | Known Unauthorized Use on port 6003 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Arthur Hillenaar | arthur.hillenaar&consul.com | 2006-01 | |
| AutoPass | MFI-swpdl.apls_core&opentext.com | 2024-08-01 | |
| Bjorn Lantz | bjorn.lantz&encode.se | 2004-11 | |
| Craig Nelson | Pincoder Diagnostics Inc. | craig&pincoder.ca | 2022-10-12 |
| Denise Eckstein | denise.eckstein&hp.com | 2004-11 | |
| Eivan Cerasi | eivan.cerasi&eurocontrol.int | 2022-08-08 | |
| Greg Dennis | RiverMeadow Software Inc. | gdennis&rivermeadow.com | 2021-03-24 |
| Greg Saccone | gregory.t.saccone&boeing.com | 2022-08-08 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| International Civil Aviation Organisation (ICAO) | gisinbox&icao.int | 2024-11-19 | |
| Jim Davis | jim.davis&wbemsolutions.com | 2007-06 | |
| Jim Davis | WS, Inc | Jim.Davis&ws-inc.com | 2015-04-24 |
| Jim Youll | jim&media.mit.edu | ||
| Joshua Hawkins | joshua.hawkins&hp.com | 2003-11 | |
| Justin Yu | yyu&mitre.org | 2011-05-25 | |
| Kai Kretschmann | K.Kretschmann&security-gui.de | 2002-03 | |
| Mark Ethan Trostler | mark&zzo.com | 2011-11-23 | |
| Nathan Lackey | nathan.lackey&boeing.com | 2024-11-19 | |
| Noah Slater | nslater&bytesexual.org | 2007-11-27 | |
| opentext | MFI-swpdl.apls_core&opentext.com | 2024-08-01 | |
| Pincoder Diagnostics Inc. | craig&pincoder.ca | 2022-10-12 | |
| Rafael Zimberoff | rafael&zfirmllc.com | 2003-11 | |
| Randall Atkinson | rja&inet.org | ||
| RiverMeadow Software Inc. | gdennis&rivermeadow.com | 2021-03-24 | |
| Shane O'Donnell | shane&opennms.org | ||
| Stephen Gildea | gildea&lcs.mit.edu | ||
| Tristan Richardson | iana&realvnc.com | 2006-03 | |
| WS, Inc | Jim.Davis&ws-inc.com | 2015-04-24 | |
| Yannick Fortin | fortiny&ca.objectiflune.com | 2006-02 | |
| Yutaka Ono | ono&saint.nm.fujitsu.co.jp | ||
| Z-Firm LLC | rafael&zfirmllc.com | 2014-08-22 |