Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| x11 | 6000-6063 | tcp | X Window System | Stephen Gildea | Stephen Gildea | Known Unauthorized Use on port 6003 | |||||
| x11 | 6000-6063 | udp | X Window System | Stephen Gildea | Stephen Gildea | Known Unauthorized Use on port 6003 | |||||
| ndl-ahp-svc | 6064 | tcp | NDL-AHP-SVC | John Richmond | John Richmond | ||||||
| ndl-ahp-svc | 6064 | udp | NDL-AHP-SVC | John Richmond | John Richmond | ||||||
| winpharaoh | 6065 | tcp | WinPharaoh | Basil Lee | Basil Lee | ||||||
| winpharaoh | 6065 | udp | WinPharaoh | Basil Lee | Basil Lee | ||||||
| ewctsp | 6066 | tcp | EWCTSP | Mark Bailon | Mark Bailon | ||||||
| ewctsp | 6066 | udp | EWCTSP | Mark Bailon | Mark Bailon | ||||||
| 6067 | Unassigned | 2007-07-17 | |||||||||
| gsmp-ancp | 6068 | tcp | GSMP/ANCP | Avri Doria | Avri Doria | RFC 6320 | |||||
| 6068 | udp | Reserved | |||||||||
| trip | 6069 | tcp | TRIP | Hussein F. Salama | Hussein F. Salama | ||||||
| trip | 6069 | udp | TRIP | Hussein F. Salama | Hussein F. Salama | ||||||
| messageasap | 6070 | tcp | Messageasap | Murray Freeman | Murray Freeman | ||||||
| messageasap | 6070 | udp | Messageasap | Murray Freeman | Murray Freeman | ||||||
| ssdtp | 6071 | tcp | SSDTP | Michael Shearson | Michael Shearson | ||||||
| ssdtp | 6071 | udp | SSDTP | Michael Shearson | Michael Shearson | ||||||
| diagnose-proc | 6072 | tcp | DIAGNOSE-PROC | Allan Miller | Allan Miller | ||||||
| diagnose-proc | 6072 | udp | DIAGNOSE-PROC | Allan Miller | Allan Miller | ||||||
| directplay8 | 6073 | tcp | DirectPlay8 | John Kane | John Kane | ||||||
| directplay8 | 6073 | udp | DirectPlay8 | John Kane | John Kane | ||||||
| max | 6074 | tcp | Microsoft Max | Jay Beavers | Jay Beavers | 2006-02 | |||||
| max | 6074 | udp | Microsoft Max | Jay Beavers | Jay Beavers | 2006-02 | |||||
| dpm-acm | 6075 | tcp | Microsoft DPM Access Control Manager | Prabu Ambravaneswaran | Prabu Ambravaneswaran | 2009-10-29 | |||||
| 6075 | udp | Reserved | |||||||||
| msft-dpm-cert | 6076 | tcp | Microsoft DPM WCF Certificates | Microsoft Corporation | Prateek Sharma | 2011-08-04 | |||||
| 6076 | udp | Reserved | |||||||||
| iconstructsrv | 6077 | tcp | iConstruct Server | iConstruct (Aus) Pty Ltd | Afshin Jafari | 2012-12-21 | |||||
| 6077 | udp | Reserved | |||||||||
| 6078-6079 | Unassigned | ||||||||||
| gue | 6080 | udp | Generic UDP Encapsulation | Tom Herbert | Tom Herbert | 2015-03-05 | draft-herbert-gue-02 | ||||
| 6080 | tcp | Reserved | |||||||||
| geneve | 6081 | udp | Generic Network Virtualization Encapsulation (Geneve) | IESG | IETF Chair | 2014-03-27 | 2020-05-04 | RFC 8926 | |||
| 6081 | tcp | Reserved | |||||||||
| 6082 | tcp | Reserved | |||||||||
| p25cai | 6082 | udp | APCO Project 25 Common Air Interface - UDP encapsulation | Steve Glass | Steve Glass | 2011-05-13 | |||||
| 6083 | tcp | Reserved | |||||||||
| miami-bcast | 6083 | udp | telecomsoftware miami broadcast | Peter Steiner | Peter Steiner | 2011-02-22 | |||||
| reload-config | 6084 | tcp | Peer to Peer Infrastructure Configuration | IESG | IETF Chair | 2009-01-29 | 2013-03-26 | RFC 6940 | |||
| 6084 | udp | Reserved | |||||||||
| konspire2b | 6085 | tcp | konspire2b p2p network | Jason Rohrer | Jason Rohrer | 2002-10 | |||||
| konspire2b | 6085 | udp | konspire2b p2p network | Jason Rohrer | Jason Rohrer | 2002-10 | |||||
| pdtp | 6086 | tcp | PDTP P2P | Tony Arcieri | Tony Arcieri | 2006-03 | |||||
| pdtp | 6086 | udp | PDTP P2P | Tony Arcieri | Tony Arcieri | 2006-03 | |||||
| ldss | 6087 | tcp | Local Download Sharing Service | Clifford Heath | Clifford Heath | 2006-05 | |||||
| ldss | 6087 | udp | Local Download Sharing Service | Clifford Heath | Clifford Heath | 2006-05 | |||||
| doglms | 6088 | tcp | SuperDog License Manager | SafeNet | Rob Tao | 2012-07-26 | |||||
| doglms-notify | 6088 | udp | SuperDog License Manager Notifier | SafeNet | Rob Tao | 2012-07-26 | |||||
| 6089-6098 | Unassigned | ||||||||||
| raxa-mgmt | 6099 | tcp | RAXA Management | Sukanta Ganguly | Sukanta Ganguly | ||||||
| 6099 | udp | Reserved | |||||||||
| synchronet-db | 6100 | tcp | SynchroNet-db | Arne Haugland | Arne Haugland | Known Unauthorized Use on port 6100 | |||||
| synchronet-db | 6100 | udp | SynchroNet-db | Arne Haugland | Arne Haugland | Known Unauthorized Use on port 6100 | |||||
| synchronet-rtc | 6101 | tcp | SynchroNet-rtc | Arne Haugland | Arne Haugland | ||||||
| synchronet-rtc | 6101 | udp | SynchroNet-rtc | Arne Haugland | Arne Haugland | ||||||
| synchronet-upd | 6102 | tcp | SynchroNet-upd | Arne Haugland | Arne Haugland | ||||||
| synchronet-upd | 6102 | udp | SynchroNet-upd | Arne Haugland | Arne Haugland | ||||||
| rets | 6103 | tcp | RETS | Jeremy Crawford | Jeremy Crawford | ||||||
| rets | 6103 | udp | RETS | Jeremy Crawford | Jeremy Crawford | ||||||
| dbdb | 6104 | tcp | DBDB | Aaron Brick | Aaron Brick | ||||||
| dbdb | 6104 | udp | DBDB | Aaron Brick | Aaron Brick | ||||||
| primaserver | 6105 | tcp | Prima Server | Prima Designs Systems Ltd. | Prima Designs Systems Ltd. | ||||||
| primaserver | 6105 | udp | Prima Server | Prima Designs Systems Ltd. | Prima Designs Systems Ltd. | ||||||
| mpsserver | 6106 | tcp | MPS Server | Prima Designs Systems Ltd. | Prima Designs Systems Ltd. | ||||||
| mpsserver | 6106 | udp | MPS Server | Prima Designs Systems Ltd. | Prima Designs Systems Ltd. | ||||||
| etc-control | 6107 | tcp | ETC Control | Electronic Theatre Controls, Inc. | ETC IANA Registration | 2021-09-24 | |||||
| etc-control | 6107 | udp | ETC Control | Electronic Theatre Controls, Inc. | ETC IANA Registration | 2021-09-24 | |||||
| sercomm-scadmin | 6108 | tcp | Sercomm-SCAdmin | Melinda Tsao | Melinda Tsao | ||||||
| sercomm-scadmin | 6108 | udp | Sercomm-SCAdmin | Melinda Tsao | Melinda Tsao | ||||||
| globecast-id | 6109 | tcp | GLOBECAST-ID | Piers Scannell | Piers Scannell | ||||||
| globecast-id | 6109 | udp | GLOBECAST-ID | Piers Scannell | Piers Scannell | ||||||
| softcm | 6110 | tcp | HP SoftBench CM | Scott A. Kramer | Scott A. Kramer | ||||||
| softcm | 6110 | udp | HP SoftBench CM | Scott A. Kramer | Scott A. Kramer | ||||||
| spc | 6111 | tcp | HP SoftBench Sub-Process Control | Scott A. Kramer | Scott A. Kramer | ||||||
| spc | 6111 | udp | HP SoftBench Sub-Process Control | Scott A. Kramer | Scott A. Kramer | ||||||
| dtspcd | 6112 | tcp | Desk-Top Sub-Process Control Daemon | Doug Royer | Doug Royer | 2010-12-08 | |||||
| dtspcd | 6112 | udp | Desk-Top Sub-Process Control Daemon | Doug Royer | Doug Royer | 2010-12-08 | |||||
| dayliteserver | 6113 | tcp | Daylite Server | Brent Gulanowski | Brent Gulanowski | 2009-08-26 | |||||
| 6113 | udp | Reserved | |||||||||
| wrspice | 6114 | tcp | WRspice IPC Service | Stephen R. Whiteley | Stephen R. Whiteley | 2010-10-07 | |||||
| 6114 | udp | Reserved | |||||||||
| xic | 6115 | tcp | Xic IPC Service | Stephen R. Whiteley | Stephen R. Whiteley | 2010-10-07 | |||||
| 6115 | udp | Reserved | |||||||||
| xtlserv | 6116 | tcp | XicTools License Manager Service | Stephen R. Whiteley | Stephen R. Whiteley | 2010-10-07 | |||||
| 6116 | udp | Reserved | |||||||||
| daylitetouch | 6117 | tcp | Daylite Touch Sync | Brent Gulanowski | Brent Gulanowski | 2009-08-26 | |||||
| 6117 | udp | Reserved | |||||||||
| tipc | 6118 | udp | Transparent Inter Process Communication | Ericsson | Erik Hugne | 2012-09-05 | |||||
| 6118 | tcp | Reserved | |||||||||
| 6119-6120 | Unassigned | ||||||||||
| spdy | 6121 | tcp | SPDY for a faster web | Matthew Lloyd | Matthew Lloyd | 2010-04-26 | |||||
| 6121 | udp | Reserved | |||||||||
| bex-webadmin | 6122 | tcp | Backup Express Web Server | Catalogic Software, Inc. | Chi Shih Chang | 2008-03-19 | 2015-02-04 | ||||
| bex-webadmin | 6122 | udp | Backup Express Web Server | Catalogic Software, Inc. | Chi Shih Chang | 2008-03-19 | 2015-02-04 | ||||
| backup-express | 6123 | tcp | Backup Express | Catalogic Software, Inc. | Chi Shih Chang | 2008-03-19 | 2015-02-04 | ||||
| backup-express | 6123 | udp | Backup Express | Catalogic Software, Inc. | Chi Shih Chang | 2008-03-19 | 2015-02-04 | ||||
| pnbs | 6124 | tcp | Phlexible Network Backup Service | William R. Lear | William R. Lear | 2008-10-23 | |||||
| pnbs | 6124 | udp | Phlexible Network Backup Service | William R. Lear | William R. Lear | 2008-10-23 | |||||
| 6125-6129 | Unassigned | ||||||||||
| damewaremobgtwy | 6130 | tcp | The DameWare Mobile Gateway Service | SolarWinds | David Gayler | 2013-05-29 | |||||
| 6130 | udp | Reserved |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Steve Glass | APCO Project 25 | admin&sedition.org.au | 2011-05-13 |
| Aaron Brick | aa&lithic.org | ||
| Afshin Jafari | iConstruct (Aus) Pty Ltd | jafari&pdcwa.com.au | 2012-12-21 |
| Allan Miller | amiller&handsfreenetworks.com | ||
| Arne Haugland | Arne.Haugland¶soldev.com | ||
| Avri Doria | avri.doria&nokia.com | ||
| Basil Lee | basil.lee&gnnettest.com | ||
| Brent Gulanowski | bgulanowski&marketcircle.com | 2009-08-26 | |
| Catalogic Software, Inc. | cchang&catalogicsoftware.com | 2015-02-04 | |
| Chi Shih Chang | Catalogic Software, Inc. | cchang&catalogicsoftware.com | 2015-02-04 |
| Clifford Heath | cjh&managesoft.com | 2006-05 | |
| David Gayler | SolarWinds | david.gayler&solarwinds.com | 2013-05-29 |
| Doug Royer | DouglasRoyer&gmail.com | 2010-12-09 | |
| Electronic Theatre Controls, Inc. | ianaregistration&etcconnect.com | 2021-09-24 | |
| Ericsson | erik.hugne&ericsson.com | 2012-09-05 | |
| Erik Hugne | Ericsson | erik.hugne&ericsson.com | 2012-09-05 |
| ETC IANA Registration | Electronic Theatre Controls, Inc. | ianaregistration&etcconnect.com | 2021-09-24 |
| Hussein F. Salama | hsalama&cisco.com | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| iConstruct (Aus) Pty Ltd | jafari&pdcwa.com.au | 2012-12-21 | |
| Jason Rohrer | rohrer&cse.ucsc.edu | 2002-10 | |
| Jay Beavers | Jay.Beaversµsoft.com | 2006-02 | |
| Jeremy Crawford | jeremy&reso.org | 2015-09-07 | |
| John Kane | johnkanµsoft.com | ||
| John Richmond | john&ndl.co.uk | ||
| Mark Bailon | mark.bailon&ericsson.com | ||
| Matthew Lloyd | mlloyd&google.com | 2010-04-26 | |
| Melinda Tsao | melinda_tsao&mail.sercomm.com.tw | ||
| Michael Shearson | mikes&softsys-inc.com | ||
| Microsoft Corporation | pratsharµsoft.com | 2011-08-04 | |
| Murray Freeman | murray&officedomain.com | ||
| Peter Steiner | steiner&telecomsoftware.com | 2011-02-22 | |
| Piers Scannell | piers&globecastne.com | ||
| Prabu Ambravaneswaran | prambravµsoft.com | 2009-10-29 | |
| Prateek Sharma | pratsharµsoft.com | 2011-08-04 | |
| Prima Designs Systems Ltd. | info&prima.com.hk | ||
| Rob Tao | SafeNet | rtao&safenet-inc.com | 2012-07-26 |
| SafeNet | rtao&safenet-inc.com | 2012-07-26 | |
| Scott A. Kramer | sk&tleilaxu.sde.hp.com | ||
| SolarWinds | david.gayler&solarwinds.com | 2013-05-29 | |
| Stephen Gildea | gildea&lcs.mit.edu | ||
| Stephen R. Whiteley | stevew&wrcad.com | 2010-10-07 | |
| Sukanta Ganguly | sganguly&kineticnetworks.com | ||
| Tom Herbert | tom&herbertland.com | 2017-05-19 | |
| Tony Arcieri | bascule&gmail.com | 2006-03 | |
| William R. Lear | wlear&phlexible.com | 2008-10-23 |