IPv6 Low Power Personal Area Network Parameters

Created

  • 2007-05-02

Last Updated

  • 2026-04-17

Available Formats


Dispatch Type Field

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Carles Gomez, Shwetha Bhandari

Reference

  • RFC 4944: Transmission of IPv6 Packets over IEEE 802.15.4 Networks
  • RFC 8025: IPv6 over Low-Power Wireless Personal Area Network (6LoWPAN) Paging Dispatch

Available Formats

Bit Pattern Page Header Type Reference
00 xxxxxx 0 NALP RFC 4944; RFC 8025
00 xxxxxx 1-13 Unassigned
00 000000 14 Uncompressed NDN Interest messages RFC 9139
00 000001 through 00 001111 14 Unassigned
00 01xxxx 14 Compressed NDN Interest messages RFC 9139
00 100000 14 Uncompressed NDN Data messages RFC 9139
00 100001 through 00 101111 14 Unassigned
00 11xxxx 14 Compressed NDN Data messages RFC 9139
00 xxxxxx 15 Reserved for Experimental Use RFC 8025
01 000000 0 ESC RFC 6282
01 000000 1-13 Unassigned
01 000000 14 Uncompressed CCNx Interest messages RFC 9139
01 000000 15 Reserved for Experimental Use RFC 8025
01 000001 0 IPv6 - uncompressed IPv6 Addresses RFC 4944; RFC 8025
01 000001 1-14 Unassigned
01 000001 15 Reserved for Experimental Use RFC 8025
01 000010 0 LOWPAN_HC1 - LOWPAN_HC1 compressed IPv6 RFC 4944; RFC 8025
01 000010 1-14 Unassigned
01 000010 15 Reserved for Experimental Use RFC 8025
01 000011 0 LOWPAN_DFF RFC 6971; RFC 8025
01 000011 1-14 Unassigned
01 000011 15 Reserved for Experimental Use RFC 8025
01 000100 through 01 001111 0-14 Unassigned
01 000100 through 01 001111 15 Reserved for Experimental Use RFC 8025
01 010000 0 LOWPAN_BC0 - LOWPAN_BC0 broadcast RFC 4944; RFC 8025
01 010000 1-13 Unassigned
01 01xxxx 14 Compressed CCNx Interest messages RFC 9139
01 010000 15 Reserved for Experimental Use RFC 8025
01 010001 through 01 011111 0-13 Unassigned
01 010001 through 01 011111 15 Reserved for Experimental Use RFC 8025
01 1xxxxx 0-1 LOWPAN_IPHC RFC 6282; RFC 8025
01 1xxxxx 2-13 Unassigned
01 100000 14 Uncompressed CCNx Content Object messages RFC 9139
01 100001 through 01 101111 14 Unassigned
01 11xxxx 14 Compressed CCNx Content Object messages RFC 9139
01 1xxxxx 15 Reserved for Experimental Use RFC 8025
10 xxxxxx 0 MESH - Mesh header RFC 4944; RFC 8025
10 0xxxxx 1 for Critical 6LoWPAN Routing Headers RFC 8138
10 1xxxxx 1 for Elective 6LoWPAN Routing Headers RFC 8138
10 xxxxxx 2-14 Unassigned
10 xxxxxx 15 Reserved for Experimental Use RFC 8025
11 000xxx 0 FRAG1 -- Fragmentation Header (first) RFC 4944; RFC 8025
11 000xxx 1-14 Unassigned
11 000xxx 15 Reserved for Experimental Use RFC 8025
11 001000 through 11 011111 0-14 Unassigned
11 001000 through 11 011111 15 Reserved for Experimental Use RFC 8025
11 100xxx 0 FRAGN -- Fragmentation Header (subsequent) RFC 4944; RFC 8025
11 100xxx 1-14 Unassigned
11 100xxx 15 Reserved for Experimental Use RFC 8025
11 10100x 0 RFRAG - Recoverable Fragment RFC 8931
11 10100x 1-14 Unassigned
11 10100x 15 Reserved for Experimental Use RFC 8025
11 10101x 0 RFRAG-ACK - RFRAG Acknowledgment RFC 8931
11 10101x 1-14 Unassigned
11 10101x 15 Reserved for Experimental Use RFC 8025
11 101100 through 11 101111 0-14 Unassigned
11 101100 through 11 101111 15 Reserved for Experimental Use RFC 8025
11 11xxxx 0-15 Page switch RFC 8025

Short Address Fields

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Carles Gomez

Reference

  • RFC 4944: Transmission of IPv6 Packets over IEEE 802.15.4 Networks

Available Formats

Address Range Description Reference
0000000000000000 to 0111111111111111 unicast addresses
1000000000000000 to 1001111111111111 multicast addresses
1010000000000000 to 1011111111111111 reserved for future assignment
1100000000000000 to 1101111111111111 reserved for future assignment
1110000000000000 to 1111111111111100 reserved for future assignment
1111111111111110 defined in IEEE 802.15.4 ("unassigned" short address)
1111111111111111 defined in IEEE 802.15.4 (broadcast address)

LOWPAN_NHC Header Type

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 6282: Compression Format for IPv6 Datagrams over IEEE 802.15.4-Based Networks

Available Formats

Value Description Reference
00000000 to 10101111 Unassigned
10110EEN Extension header GHC RFC 7400
10111000 to 11001111 Unassigned
11010CPP UDP GHC RFC 7400
11011000 to 11011110 Unassigned
11011111 ICMPv6 GHC RFC 7400
1110000N IPv6 Hop-by-Hop Options Header RFC 6282
1110001N IPv6 Routing Header RFC 6282
1110010N IPv6 Fragment Header RFC 6282
1110011N IPv6 Destinations Options Header RFC 6282
1110100N IPv6 Mobility Header RFC 6282
1110101N Reserved for future extension headers RFC 6282
1110110N Reserved for future extension headers RFC 6282
1110111N IPv6 Header RFC 6282
11110CPP UDP Header RFC 6282
11111000 to 11111110 Unassigned
11111111 Unassigned, reserved for extensions RFC 6282

ESC Extension Types

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Shwetha Bhandari

Reference

  • RFC 8066: IPv6 over Low-Power Wireless Personal Area Network (6LoWPAN) ESC Dispatch Code Points and Guidelines

Available Formats

Value Description Reference
0 Reserved RFC 8066
1-31 Used by ITU-T G.9903 G.9905 Command IDs ITU-T G.9903; ITU-T G.9905
32-254 Unassigned
255 Reserved RFC 8066

Critical 6LoWPAN Routing Header Type

Registration Procedure(s)

  • RFC Required

Reference

  • RFC 8138: IPv6 over Low-Power Wireless Personal Area Network (6LoWPAN) Routing Header

Available Formats

Value Description Reference
0-4 SRH-6LoRH RFC 8138
5 RPI-6LoRH RFC 8138
6-7 Unassigned
8 P-RPI-6LoRH RFC 9914
9-255 Unassigned

Elective 6LoWPAN Routing Header Type

Registration Procedure(s)

  • RFC Required

Reference

  • RFC 8138: IPv6 over Low-Power Wireless Personal Area Network (6LoWPAN) Routing Header

Available Formats

Value Description Reference
0-5 Unassigned
6 IP-in-IP-6LoRH RFC 8138
7 Deadline-6LoRHE RFC 9034
8 P-RPI-6LoRH RFC 9914
9-255 Unassigned