Authentication, Authorization, and Accounting (AAA) Parameters
Created
- 2003-04-08
Last Updated
- 2026-01-27
Available Formats
AVP Codes
Expert(s)
- Lionel Morand (primary), Jouni Korhonen (secondary)
Reference
- RFC 6733: Diameter Base Protocol
Available Formats
| Range | Registration Procedures |
|---|---|
| block allocation (release of more than three AVPs at a time for a given purpose) | IETF Review |
| other allocation | Specification Required |
| AVP Code | Attribute Name | Reference |
|---|---|---|
| 1-255 | Radius attributes | RADIUS Types |
| 256 | Unassigned | |
| 257 | Host-IP-Address | RFC 6733 |
| 258 | Auth-Application-Id | RFC 6733 |
| 259 | Acct-Application-Id | RFC 6733 |
| 260 | Vendor-Specific-Application-Id | RFC 6733 |
| 261 | Redirect-Host-Usage | RFC 6733 |
| 262 | Redirect-Max-Cache-Time | RFC 6733 |
| 263 | Session-Id | RFC 6733 |
| 264 | Origin-Host | RFC 6733 |
| 265 | Supported-Vendor-Id | RFC 6733 |
| 266 | Vendor-Id | RFC 6733 |
| 267 | Firmware-Version | RFC 6733 |
| 268 | Result-Code | RFC 6733 |
| 269 | Product-Name | RFC 6733 |
| 270 | Session-Binding | RFC 6733 |
| 271 | Session-Server-Failover | RFC 6733 |
| 272 | Multi-Round-Time-Out | RFC 6733 |
| 273 | Disconnect-Cause | RFC 6733 |
| 274 | Auth-Request-Type | RFC 6733 |
| 276 | Auth-Grace-Period | RFC 6733 |
| 277 | Auth-Session-State | RFC 6733 |
| 278 | Origin-State-Id | RFC 6733 |
| 279 | Failed-AVP | RFC 6733 |
| 280 | Proxy-Host | RFC 6733 |
| 281 | Error-Message | RFC 6733 |
| 282 | Route-Record | RFC 6733 |
| 283 | Destination-Realm | RFC 6733 |
| 284 | Proxy-Info | RFC 6733 |
| 285 | Re-Auth-Request-Type | RFC 6733 |
| 286 | Unassigned | |
| 287 | Accounting-Sub-Session-Id | RFC 6733 |
| 288-290 | Unassigned | |
| 291 | Authorization-Lifetime | RFC 6733 |
| 292 | Redirect-Host | RFC 6733 |
| 293 | Destination-Host | RFC 6733 |
| 294 | Error-Reporting-Host | RFC 6733 |
| 295 | Termination-Cause | RFC 6733 |
| 296 | Origin-Realm | RFC 6733 |
| 297 | Experimental-Result | RFC 6733 |
| 298 | Experimental-Result-Code | RFC 6733 |
| 299 | Inband-Security-Id | RFC 6733 |
| 300 | E2E-Sequence | RFC 6733 |
| 301 | DRMP | RFC 7944 |
| 302-317 | Unassigned | |
| 318 | MIP-FA-to-HA-SPI | RFC 4004 |
| 319 | MIP-FA-to-MN-SPI | RFC 4004 |
| 320 | MIP-Reg-Request | RFC 4004 |
| 321 | MIP-Reg-Reply | RFC 4004 |
| 322 | MIP-MN-AAA-Auth | RFC 4004 |
| 323 | MIP-HA-to-FA-SPI | RFC 4004 |
| 324 | Unassigned | |
| 325 | MIP-MN-to-FA-MSA | RFC 4004 |
| 326 | MIP-FA-to-MN-MSA | RFC 4004 |
| 327 | Unassigned | |
| 328 | MIP-FA-to-HA-MSA | RFC 4004 |
| 329 | MIP-HA-to-FA-MSA | RFC 4004 |
| 331 | MIP-MN-to-HA-MSA | RFC 4004 |
| 332 | MIP-HA-to-MN-MSA | RFC 4004 |
| 333 | MIP-Mobile-Node-Address | RFC 4004 |
| 334 | MIP-Home-Agent-Address | RFC 4004 |
| 335 | MIP-Nonce | RFC 4004 |
| 336 | MIP-Candidate-Home-Agent-Host | RFC 4004 |
| 337 | MIP-Feature-Vector | RFC 4004 |
| 338 | MIP-Auth-Input-Data-Length | RFC 4004 |
| 339 | MIP-Authenticator-Length | RFC 4004 |
| 340 | MIP-Authenticator-Offset | RFC 4004 |
| 341 | MIP-MN-AAA-SPI | RFC 4004 |
| 342 | MIP-Filter-Rule | RFC 4004 |
| 343 | MIP-Session-Key | RFC 4004 |
| 344 | MIP-FA-Challenge | RFC 4004 |
| 345 | MIP-Algorithm-Type | RFC 4004 |
| 346 | MIP-Replay-Mode | RFC 4004 |
| 347 | MIP-Originating-Foreign-AAA | RFC 4004 |
| 348 | MIP-Home-Agent-Host | RFC 4004 |
| 349-362 | Unassigned | |
| 363 | Accounting-Input-Octets | RFC 7155; RFC 4004 |
| 364 | Accounting-Output-Octets | RFC 7155; RFC 4004 |
| 365 | Accounting-Input-Packets | RFC 7155; RFC 4004 |
| 366 | Accounting-Output-Packets | RFC 7155; RFC 4004 |
| 367 | MIP-MSA-Lifetime | RFC 4004 |
| 368 | SIP-Accounting-Information | RFC 4740 |
| 369 | SIP-Accounting-Server-URI | RFC 4740 |
| 370 | SIP-Credit-Control-Server-URI | RFC 4740 |
| 371 | SIP-Server-URI | RFC 4740 |
| 372 | SIP-Server-Capabilities | RFC 4740 |
| 373 | SIP-Mandatory-Capability | RFC 4740 |
| 374 | SIP-Optional-Capability | RFC 4740 |
| 375 | SIP-Server-Assignment-Type | RFC 4740 |
| 376 | SIP-Auth-Data-Item | RFC 4740 |
| 377 | SIP-Authentication-Scheme | RFC 4740 |
| 378 | SIP-Item-Number | RFC 4740 |
| 379 | SIP-Authenticate | RFC 4740 |
| 380 | SIP-Authorization | RFC 4740 |
| 381 | SIP-Authentication-Info | RFC 4740 |
| 382 | SIP-Number-Auth-Items | RFC 4740 |
| 383 | SIP-Deregistration-Reason | RFC 4740 |
| 384 | SIP-Reason-Code | RFC 4740 |
| 385 | SIP-Reason-Info | RFC 4740 |
| 386 | SIP-Visited-Network-Id | RFC 4740 |
| 387 | SIP-User-Authorization-Type | RFC 4740 |
| 388 | SIP-Supported-User-Data-Type | RFC 4740 |
| 389 | SIP-User-Data | RFC 4740 |
| 390 | SIP-User-Data-Type | RFC 4740 |
| 391 | SIP-User-Data-Contents | RFC 4740 |
| 392 | SIP-User-Data-Already-Available | RFC 4740 |
| 393 | SIP-Method | RFC 4740 |
| 394-399 | Unassigned | |
| 400 | NAS-Filter-Rule | RFC 7155 |
| 401 | Tunneling | RFC 7155 |
| 402 | CHAP-Auth | RFC 7155 |
| 403 | CHAP-Algorithm | RFC 7155 |
| 404 | CHAP-Ident | RFC 7155 |
| 405 | CHAP-Response | RFC 7155 |
| 406 | Accounting-Auth-Method | RFC 7155 |
| 407 | QoS-Filter-Rule | RFC 7155 |
| 408 | Origin-AAA-Protocol | RFC 7155 |
| 409-410 | Unassigned | |
| 411 | CC-Correlation-Id | RFC 8506 |
| 412 | CC-Input-Octets | RFC 8506 |
| 413 | CC-Money | RFC 8506 |
| 414 | CC-Output-Octets | RFC 8506 |
| 415 | CC-Request-Number | RFC 8506 |
| 416 | CC-Request-Type | RFC 8506 |
| 417 | CC-Service-Specific-Units | RFC 8506 |
| 418 | CC-Session-Failover | RFC 8506 |
| 419 | CC-Sub-Session-Id | RFC 8506 |
| 420 | CC-Time | RFC 8506 |
| 421 | CC-Total-Octets | RFC 8506 |
| 422 | Check-Balance-Result | RFC 8506 |
| 423 | Cost-Information | RFC 8506 |
| 424 | Cost-Unit | RFC 8506 |
| 425 | Currency-Code | RFC 8506 |
| 426 | Credit-Control | RFC 8506 |
| 427 | Credit-Control-Failure-Handling | RFC 8506 |
| 428 | Direct-Debiting-Failure-Handling | RFC 8506 |
| 429 | Exponent | RFC 8506 |
| 430 | Final-Unit-Indication | RFC 8506 |
| 431 | Granted-Service-Unit | RFC 8506 |
| 432 | Rating-Group | RFC 8506 |
| 433 | Redirect-Address-Type | RFC 8506 |
| 434 | Redirect-Server | RFC 8506 |
| 435 | Redirect-Server-Address | RFC 8506 |
| 436 | Requested-Action | RFC 8506 |
| 437 | Requested-Service-Unit | RFC 8506 |
| 438 | Restriction-Filter-Rule | RFC 8506 |
| 439 | Service-Identifier | RFC 8506 |
| 440 | Service-Parameter-Info | RFC 8506 |
| 441 | Service-Parameter-Type | RFC 8506 |
| 442 | Service-Parameter-Value | RFC 8506 |
| 443 | Subscription-Id | RFC 8506 |
| 444 | Subscription-Id-Data | RFC 8506 |
| 445 | Unit-Value | RFC 8506 |
| 446 | Used-Service-Unit | RFC 8506 |
| 447 | Value-Digits | RFC 8506 |
| 448 | Validity-Time | RFC 8506 |
| 449 | Final-Unit-Action | RFC 8506 |
| 450 | Subscription-Id-Type | RFC 8506 |
| 451 | Tariff-Time-Change | RFC 8506 |
| 452 | Tariff-Change-Usage | RFC 8506 |
| 453 | G-S-U-Pool-Identifier | RFC 8506 |
| 454 | CC-Unit-Type | RFC 8506 |
| 455 | Multiple-Services-Indicator | RFC 8506 |
| 456 | Multiple-Services-Credit-Control | RFC 8506 |
| 457 | G-S-U-Pool-Reference | RFC 8506 |
| 458 | User-Equipment-Info | RFC 8506 |
| 459 | User-Equipment-Info-Type | RFC 8506 |
| 460 | User-Equipment-Info-Value | RFC 8506 |
| 461 | Service-Context-Id | RFC 8506 |
| 462 | EAP-Payload | RFC 4072 |
| 463 | EAP-Reissued-Payload | RFC 4072 |
| 464 | EAP-Master-Session-Key | RFC 4072 |
| 465 | Accounting-EAP-Auth-Method | RFC 4072 |
| 466-479 | Unassigned | |
| 480 | Accounting-Record-Type | RFC 6733 |
| 481-482 | Unassigned | |
| 483 | Accounting-Realtime-Required | RFC 6733 |
| 484 | Unassigned | |
| 485 | Accounting-Record-Number | RFC 6733 |
| 486 | MIP6-Agent-Info | RFC 5447 |
| 487 | MIP-Careof-Address | RFC 5778 |
| 488 | MIP-Authenticator | RFC 5778 |
| 489 | MIP-MAC-Mobility-Data | RFC 5778 |
| 490 | MIP-Timestamp | RFC 5778 |
| 491 | MIP-MN-HA-SPI | RFC 5778 |
| 492 | MIP-MN-HA-MSA | RFC 5778 |
| 493 | Service-Selection | RFC 5778 |
| 494 | MIP6-Auth-Mode | RFC 5778 |
| 495 | TMOD-1 | RFC 5624 |
| 496 | Token-Rate | RFC 5624 |
| 497 | Bucket-Depth | RFC 5624 |
| 498 | Peak-Traffic-Rate | RFC 5624 |
| 499 | Minimum-Policed-Unit | RFC 5624 |
| 500 | Maximum-Packet-Size | RFC 5624 |
| 501 | TMOD-2 | RFC 5624 |
| 502 | Bandwidth | RFC 5624 |
| 503 | PHB-Class | RFC 5624 |
| 504 | PMIP6-DHCP-Server-Address | RFC 5779 |
| 505 | PMIP6-IPv4-Home-Address | RFC 5779 |
| 506 | Mobile-Node-Identifier | RFC 5779 |
| 507 | Service-Configuration | RFC 5779 |
| 508 | QoS-Resources | RFC 5777 |
| 509 | Filter-Rule | RFC 5777 |
| 510 | Filter-Rule-Precedence | RFC 5777 |
| 511 | Classifier | RFC 5777 |
| 512 | Classifier-ID | RFC 5777 |
| 513 | Protocol | RFC 5777 |
| 514 | Direction | RFC 5777 |
| 515 | From-Spec | RFC 5777 |
| 516 | To-Spec | RFC 5777 |
| 517 | Negated | RFC 5777 |
| 518 | IP-Address | RFC 5777 |
| 519 | IP-Address-Range | RFC 5777 |
| 520 | IP-Address-Start | RFC 5777 |
| 521 | IP-Address-End | RFC 5777 |
| 522 | IP-Address-Mask | RFC 5777 |
| 523 | IP-Mask-Bit-Mask-Width | RFC 5777 |
| 524 | MAC-Address | RFC 5777 |
| 525 | MAC-Address-Mask | RFC 5777 |
| 526 | MAC-Address-Mask-Pattern | RFC 5777 |
| 527 | EUI64-Address | RFC 5777 |
| 528 | EUI64-Address-Mask | RFC 5777 |
| 529 | EUI64-Address-Mask-Pattern | RFC 5777 |
| 530 | Port | RFC 5777 |
| 531 | Port-Range | RFC 5777 |
| 532 | Port-Start | RFC 5777 |
| 533 | Port-End | RFC 5777 |
| 534 | Use-Assigned-Address | RFC 5777 |
| 535 | Diffserv-Code-Point | RFC 5777 |
| 536 | Fragmentation-Flag | RFC 5777 |
| 537 | IP-Option | RFC 5777 |
| 538 | IP-Option-Type | RFC 5777 |
| 539 | IP-Option-Value | RFC 5777 |
| 540 | TCP-Option | RFC 5777 |
| 541 | TCP-Option-Type | RFC 5777 |
| 542 | TCP-Option-Value | RFC 5777 |
| 543 | TCP-Flags | RFC 5777 |
| 544 | TCP-Flag-Type | RFC 5777 |
| 545 | ICMP-Type | RFC 5777 |
| 546 | ICMP-Type-Number | RFC 5777 |
| 547 | ICMP-Code | RFC 5777 |
| 548 | ETH-Option | RFC 5777 |
| 549 | ETH-Proto-Type | RFC 5777 |
| 550 | ETH-Ether-Type | RFC 5777 |
| 551 | ETH-SAP | RFC 5777 |
| 552 | VLAN-ID-Range | RFC 5777 |
| 553 | S-VID-Start | RFC 5777 |
| 554 | S-VID-End | RFC 5777 |
| 555 | C-VID-Start | RFC 5777 |
| 556 | C-VID-End | RFC 5777 |
| 557 | User-Priority-Range | RFC 5777 |
| 558 | Low-User-Priority | RFC 5777 |
| 559 | High-User-Priority | RFC 5777 |
| 560 | Time-Of-Day-Condition | RFC 5777 |
| 561 | Time-Of-Day-Start | RFC 5777 |
| 562 | Time-Of-Day-End | RFC 5777 |
| 563 | Day-Of-Week-Mask | RFC 5777 |
| 564 | Day-Of-Month-Mask | RFC 5777 |
| 565 | Month-Of-Year-Mask | RFC 5777 |
| 566 | Absolute-Start-Time | RFC 5777 |
| 567 | Absolute-Start-Fractional-Seconds | RFC 5777 |
| 568 | Absolute-End-Time | RFC 5777 |
| 569 | Absolute-End-Fractional-Seconds | RFC 5777 |
| 570 | Timezone-Flag | RFC 5777 |
| 571 | Timezone-Offset | RFC 5777 |
| 572 | Treatment-Action | RFC 5777 |
| 573 | QoS-Profile-Id | RFC 5777 |
| 574 | QoS-Profile-Template | RFC 5777 |
| 575 | QoS-Semantics | RFC 5777 |
| 576 | QoS-Parameters | RFC 5777 |
| 577 | Excess-Treatment | RFC 5777 |
| 578 | QoS-Capability | RFC 5777 |
| 579 | QoS-Authorization-Data | RFC 5866 |
| 580 | Bound-Auth-Session-Id | RFC 5866 |
| 581 | Key | RFC 6734 |
| 582 | Key-Type | RFC 6734 |
| 583 | Keying-Material | RFC 6734 |
| 584 | Key-Lifetime | RFC 6734 |
| 585 | Key-SPI | RFC 6734 |
| 586 | Key-Name | RFC 6734 |
| 587 | IKEv2-Nonces | RFC 6738 |
| 588 | Ni | RFC 6738 |
| 589 | Nr | RFC 6738 |
| 590 | IKEv2-Identity | RFC 6738 |
| 591 | Initiator-Identity | RFC 6738 |
| 592 | ID-Type | RFC 6738 |
| 593 | Identification-Data | RFC 6738 |
| 594 | Responder-Identity | RFC 6738 |
| 595 | NC-Request-Type | RFC 6736 |
| 596 | NAT-Control-Install | RFC 6736 |
| 597 | NAT-Control-Remove | RFC 6736 |
| 598 | NAT-Control-Definition | RFC 6736 |
| 599 | NAT-Internal-Address | RFC 6736 |
| 600 | NAT-External-Address | RFC 6736 |
| 601 | Max-NAT-Bindings | RFC 6736 |
| 602 | NAT-Control-Binding-Template | RFC 6736 |
| 603 | Duplicate-Session-Id | RFC 6736 |
| 604 | NAT-External-Port-Style | RFC 6736 |
| 605 | NAT-Control-Record | RFC 6736 |
| 606 | NAT-Control-Binding-Status | RFC 6736 |
| 607 | Current-NAT-Bindings | RFC 6736 |
| 608 | Dual-Priority | RFC 6735 |
| 609 | Preemption-Priority | RFC 6735 |
| 610 | Defending-Priority | RFC 6735 |
| 611 | Admission-Priority | RFC 6735 |
| 612 | SIP-Resource-Priority | RFC 6735 |
| 613 | SIP-Resource-Priority-Namespace | RFC 6735 |
| 614 | SIP-Resource-Priority-Value | RFC 6735 |
| 615 | Application-Level-Resource-Priority | RFC 6735 |
| 616 | ALRP-Namespace | RFC 6735 |
| 617 | ALRP-Value | RFC 6735 |
| 618 | ERP-RK-Request | RFC 6942 |
| 619 | ERP-Realm | RFC 6942 |
| 620 | Redirect-Realm | RFC 7075 |
| 621 | OC-Supported-Features | RFC 7683 |
| 622 | OC-Feature-Vector | RFC 7683 |
| 623 | OC-OLR | RFC 7683 |
| 624 | OC-Sequence-Number | RFC 7683 |
| 625 | OC-Validity-Duration | RFC 7683 |
| 626 | OC-Report-Type | RFC 7683 |
| 627 | OC-Reduction-Percentage | RFC 7683 |
| 628 | ECN-IP-Codepoint | RFC 7660 |
| 629 | Congestion-Treatment | RFC 7660 |
| 630 | Flow-Count | RFC 7660 |
| 631 | Packet-Count | RFC 7660 |
| 632 | IP-Prefix-Length | RFC 7678 |
| 633 | Border-Router-Name | RFC 7678 |
| 634 | 64-Multicast-Attributes | RFC 7678 |
| 635 | ASM-mPrefix64 | RFC 7678 |
| 636 | SSM-mPrefix64 | RFC 7678 |
| 637 | Tunnel-Source-Pref-Or-Addr | RFC 7678 |
| 638 | Tunnel-Source-IPv6-Address | RFC 7678 |
| 639 | Port-Set-Identifier | RFC 7678 |
| 640 | Lw4o6-Binding | RFC 7678 |
| 641 | Lw4o6-External-IPv4-Addr | RFC 7678 |
| 642 | MAP-E-Attributes | RFC 7678 |
| 643 | MAP-Mesh-Mode | RFC 7678 |
| 644 | MAP-Mapping-Rule | RFC 7678 |
| 645 | Rule-IPv4-Addr-Or-Prefix | RFC 7678 |
| 646 | Rule-IPv6-Prefix | RFC 7678 |
| 647 | EA-Field-Length | RFC 7678 |
| 648 | OC-Peer-Algo | RFC 8581 |
| 649 | SourceID | RFC 8581 |
| 650 | Load | RFC 8583 |
| 651 | Load-Type | RFC 8583 |
| 652 | Load-Value | RFC 8583 |
| 653 | User-Equipment-Info-Extension | RFC 8506 |
| 654 | User-Equipment-Info-IMEISV | RFC 8506 |
| 655 | User-Equipment-Info-MAC | RFC 8506 |
| 656 | User-Equipment-Info-EUI64 | RFC 8506 |
| 657 | User-Equipment-Info-ModifiedEUI64 | RFC 8506 |
| 658 | User-Equipment-Info-IMEI | RFC 8506 |
| 659 | Subscription-Id-Extension | RFC 8506 |
| 660 | Subscription-Id-E164 | RFC 8506 |
| 661 | Subscription-Id-IMSI | RFC 8506 |
| 662 | Subscription-Id-SIP-URI | RFC 8506 |
| 663 | Subscription-Id-NAI | RFC 8506 |
| 664 | Subscription-Id-Private | RFC 8506 |
| 665 | Redirect-Server-Extension | RFC 8506 |
| 666 | Redirect-Address-IPAddress | RFC 8506 |
| 667 | Redirect-Address-URL | RFC 8506 |
| 668 | Redirect-Address-SIP-URI | RFC 8506 |
| 669 | QoS-Final-Unit-Indication | RFC 8506 |
| 670 | OC-Maximum-Rate | RFC 8582 |
| 671 | Session-Group-Info | RFC 9390 |
| 672 | Session-Group-Control-Vector | RFC 9390 |
| 673 | Session-Group-Id | RFC 9390 |
| 674 | Group-Response-Action | RFC 9390 |
| 675 | Session-Group-Capability-Vector | RFC 9390 |
| 676-16777215 | Unassigned |
AVP Specific Values
Registration Procedure(s)
- IETF Review (unless otherwise specified)
Reference
- RFC 6733: Diameter Base Protocol
Redirect-Host-Usage AVP Values (code 261)
Available Formats
Result-Code AVP Values (code 268)
Available Formats
| AVP Value | Attribute Name | Reference |
|---|---|---|
| 0-999 | Reserved |
Result-Code AVP Values (code 268) - Informational
Available Formats
| AVP Value | Attribute Name | Reference |
|---|---|---|
| 1000 | Reserved | |
| 1001 | DIAMETER_MULTI_ROUND_AUTH | RFC 6733 |
| 1002-1999 | Unassigned |
Result-Code AVP Values (code 268) - Success
Available Formats
| AVP Value | Attribute Name | Reference |
|---|---|---|
| 2000 | Reserved | |
| 2001 | DIAMETER_SUCCESS | RFC 6733 |
| 2002 | DIAMETER_LIMITED_SUCCESS | RFC 6733 |
| 2003 | DIAMETER_FIRST_REGISTRATION | RFC 4740 |
| 2004 | DIAMETER_SUBSEQUENT_REGISTRATION | RFC 4740 |
| 2005 | DIAMETER_UNREGISTERED_SERVICE | RFC 4740 |
| 2006 | DIAMETER_SUCCESS_SERVER_NAME_NOT_STORED | RFC 4740 |
| 2007 | DIAMETER_SERVER_SELECTION | RFC 4740 |
| 2008 | DIAMETER_SUCCESS_AUTH_SENT_SERVER_NOT_STORED | RFC 4740 |
| 2009 | DIAMETER_SUCCESS_RELOCATE_HA | RFC 5778 |
| 2010-2999 | Unassigned |
Result-Code AVP Values (code 268) - Protocol Errors
Available Formats
| AVP Value | Attribute Name | Reference |
|---|---|---|
| 3000 | Reserved | |
| 3001 | DIAMETER_COMMAND_UNSUPPORTED | RFC 6733 |
| 3002 | DIAMETER_UNABLE_TO_DELIVER | RFC 6733 |
| 3003 | DIAMETER_REALM_NOT_SERVED | RFC 6733 |
| 3004 | DIAMETER_TOO_BUSY | RFC 6733 |
| 3005 | DIAMETER_LOOP_DETECTED | RFC 6733 |
| 3006 | DIAMETER_REDIRECT_INDICATION | RFC 6733 |
| 3007 | DIAMETER_APPLICATION_UNSUPPORTED | RFC 6733 |
| 3008 | DIAMETER_INVALID_HDR_BITS | RFC 6733 |
| 3009 | DIAMETER_INVALID_AVP_BITS | RFC 6733 |
| 3010 | DIAMETER_UNKNOWN_PEER | RFC 6733 |
| 3011 | DIAMETER_REALM_REDIRECT_INDICATION | RFC 7075 |
| 3012-3999 | Unassigned |
Result-Code AVP Values (code 268) - Transient Failures
Available Formats
| AVP Value | Attribute Name | Reference |
|---|---|---|
| 4000 | Reserved | |
| 4001 | DIAMETER_AUTHENTICATION_REJECTED | RFC 6733 |
| 4002 | DIAMETER_OUT_OF_SPACE | RFC 6733 |
| 4003 | ELECTION_LOST | RFC 6733 |
| 4004 | Unassigned | |
| 4005 | DIAMETER_ERROR_MIP_REPLY_FAILURE | RFC 4004 |
| 4006 | DIAMETER_ERROR_HA_NOT_AVAILABLE | RFC 4004 |
| 4007 | DIAMETER_ERROR_BAD_KEY | RFC 4004 |
| 4008 | DIAMETER_ERROR_MIP_FILTER_NOT_SUPPORTED | RFC 4004 |
| 4009 | Unassigned | |
| 4010 | DIAMETER_END_USER_SERVICE_DENIED | RFC 8506 |
| 4011 | DIAMETER_CREDIT_CONTROL_NOT_APPLICABLE | RFC 8506 |
| 4012 | DIAMETER_CREDIT_LIMIT_REACHED | RFC 8506 |
| 4013 | DIAMETER_USER_NAME_REQUIRED | RFC 4740 |
| 4014 | RESOURCE_FAILURE | RFC 6736 |
| 4015-4999 | Unassigned |
Result-Code AVP Values (code 268) - Permanent Failure
Available Formats
| AVP Value | Attribute Name | Reference |
|---|---|---|
| 5000 | Reserved | |
| 5001 | DIAMETER_AVP_UNSUPPORTED | RFC 6733 |
| 5002 | DIAMETER_UNKNOWN_SESSION_ID | RFC 6733 |
| 5003 | DIAMETER_AUTHORIZATION_REJECTED | RFC 6733 |
| 5004 | DIAMETER_INVALID_AVP_VALUE | RFC 6733 |
| 5005 | DIAMETER_MISSING_AVP | RFC 6733 |
| 5006 | DIAMETER_RESOURCES_EXCEEDED | RFC 6733 |
| 5007 | DIAMETER_CONTRADICTING_AVPS | RFC 6733 |
| 5008 | DIAMETER_AVP_NOT_ALLOWED | RFC 6733 |
| 5009 | DIAMETER_AVP_OCCURS_TOO_MANY_TIMES | RFC 6733 |
| 5010 | DIAMETER_NO_COMMON_APPLICATION | RFC 6733 |
| 5011 | DIAMETER_UNSUPPORTED_VERSION | RFC 6733 |
| 5012 | DIAMETER_UNABLE_TO_COMPLY | RFC 6733 |
| 5013 | DIAMETER_INVALID_BIT_IN_HEADER | RFC 6733 |
| 5014 | DIAMETER_INVALID_AVP_LENGTH | RFC 6733 |
| 5015 | DIAMETER_INVALID_MESSAGE_LENGTH | RFC 6733 |
| 5016 | DIAMETER_INVALID_AVP_BIT_COMBO | RFC 6733 |
| 5017 | DIAMETER_NO_COMMON_SECURITY | RFC 6733 |
| 5018 | DIAMETER_RADIUS_AVP_UNTRANSLATABLE | RFC 4849 |
| 5019-5023 | Unassigned | |
| 5024 | DIAMETER_ERROR_NO_FOREIGN_HA_SERVICE | RFC 4004 |
| 5025 | DIAMETER_ERROR_END_TO_END_MIP_KEY_ENCRYPTION | RFC 4004 |
| 5026-5029 | Unassigned | |
| 5030 | DIAMETER_USER_UNKNOWN | RFC 8506 |
| 5031 | DIAMETER_RATING_FAILED | RFC 8506 |
| 5032 | DIAMETER_ERROR_USER_UNKNOWN | RFC 4740 |
| 5033 | DIAMETER_ERROR_IDENTITIES_DONT_MATCH | RFC 4740 |
| 5034 | DIAMETER_ERROR_IDENTITY_NOT_REGISTERED | RFC 4740 |
| 5035 | DIAMETER_ERROR_ROAMING_NOT_ALLOWED | RFC 4740 |
| 5036 | DIAMETER_ERROR_IDENTITY_ALREADY_REGISTERED | RFC 4740 |
| 5037 | DIAMETER_ERROR_AUTH_SCHEME_NOT_SUPPORTED | RFC 4740 |
| 5038 | DIAMETER_ERROR_IN_ASSIGNMENT_TYPE | RFC 4740 |
| 5039 | DIAMETER_ERROR_TOO_MUCH_DATA | RFC 4740 |
| 5040 | DIAMETER_ERROR_NOT SUPPORTED_USER_DATA | RFC 4740 |
| 5041 | DIAMETER_ERROR_MIP6_AUTH_MODE | RFC 5778 |
| 5042 | UNKNOWN_BINDING_TEMPLATE_NAME | RFC 6736 |
| 5043 | BINDING_FAILURE | RFC 6736 |
| 5044 | MAX_BINDINGS_SET_FAILURE | RFC 6736 |
| 5045 | MAXIMUM_BINDINGS_REACHED_FOR_ENDPOINT | RFC 6736 |
| 5046 | SESSION_EXISTS | RFC 6736 |
| 5047 | INSUFFICIENT_CLASSIFIERS | RFC 6736 |
| 5048 | DIAMETER_ERROR_EAP_CODE_UNKNOWN | RFC 6942 |
| 5049-4294967295 | Unassigned |
Session-Binding AVP Values (code 270)
Available Formats
Session-Server-Failover AVP Values (code 271)
Available Formats
Disconnect-Cause AVP Values (code 273)
Available Formats
Auth-Request-Type AVP Values (code 274)
Available Formats
Auth-Session-State AVP Values (code 277)
Available Formats
Re-Auth-Request-Type AVP Values (code 285)
Available Formats
Termination-Cause AVP Values (code 295)
Available Formats
| AVP Value | Attribute Name | Reference |
|---|---|---|
| 0 | Reserved | |
| 1 | DIAMETER_LOGOUT | RFC 3588; RFC 6733 |
| 2 | DIAMETER_SERVICE_NOT_PROVIDED | RFC 3588; RFC 6733 |
| 3 | DIAMETER_BAD_ANSWER | RFC 3588; RFC 6733 |
| 4 | DIAMETER_ADMINISTRATIVE | RFC 3588; RFC 6733 |
| 5 | DIAMETER_LINK_BROKEN | RFC 3588; RFC 6733 |
| 6 | DIAMETER_AUTH_EXPIRED | RFC 3588; RFC 6733 |
| 7 | DIAMETER_USER_MOVED | RFC 3588; RFC 6733 |
| 8 | DIAMETER_SESSION_TIMEOUT | RFC 3588; RFC 6733 |
| 9-10 | Unassigned | |
| 11 | User Request | RFC 2866; RFC 7155 |
| 12 | Lost Carrier | RFC 2866; RFC 7155 |
| 13 | Lost Service | RFC 2866; RFC 7155 |
| 14 | Idle Timeout | RFC 2866; RFC 7155 |
| 15 | Session Timeout | RFC 2866; RFC 7155 |
| 16 | Admin Reset | RFC 2866; RFC 7155 |
| 17 | Admin Reboot | RFC 2866; RFC 7155 |
| 18 | Port Error | RFC 2866; RFC 7155 |
| 19 | NAS Error | RFC 2866; RFC 7155 |
| 20 | NAS Request | RFC 2866; RFC 7155 |
| 21 | NAS Reboot | RFC 2866; RFC 7155 |
| 22 | Port Unneeded | RFC 2866; RFC 7155 |
| 23 | Port Preempted | RFC 2866; RFC 7155 |
| 24 | Port Suspended | RFC 2866; RFC 7155 |
| 25 | Service Unavailable | RFC 2866; RFC 7155 |
| 26 | Callback | RFC 2866; RFC 7155 |
| 27 | User Error | RFC 2866; RFC 7155 |
| 28 | Host Request | RFC 2866; RFC 7155 |
| 29 | Supplicant Restart | RFC 3580; RFC 7155 |
| 30 | Reauthentication Failure | RFC 3580; RFC 7155 |
| 31 | Port Reinitialized | RFC 3580; RFC 7155 |
| 32 | Port Administratively Disabled | RFC 3580; RFC 7155 |
| 33-4294967295 | Unassigned |
MIP-Feature-Vector AVP (code 337)
Available Formats
| AVP Value | Attribute Name | Reference |
|---|---|---|
| 1 | Mobile-Node-Home-Address-Requested | RFC 4004 |
| 2 | Home-Address-Allocatable-Only-in-Home-Realm | RFC 4004 |
| 3 | Unassigned | |
| 4 | Home-Agent-Requested | RFC 4004 |
| 5-7 | Unassigned | |
| 8 | Foreign-Home-Agent-Available | RFC 4004 |
| 9-15 | Unassigned | |
| 16 | MN-HA-Key-Request | RFC 4004 |
| 17-31 | Unassigned | |
| 32 | MN-FA-Key-Request | RFC 4004 |
| 33-63 | Unassigned | |
| 64 | FA-HA-Key-Request | RFC 4004 |
| 65-127 | Unassigned | |
| 128 | Home-Agent-In-Foreign-Network | RFC 4004 |
| 129-255 | Unassigned | |
| 256 | Co-Located-Mobile-Node | RFC 4004 |
MIP-Algorithm-Type AVP Values (code 345)
Available Formats
| AVP Value | Attribute Name | Reference |
|---|---|---|
| 2 | HMAC-SHA-1 | RFC 4004 |
MIP-Replay-Mode AVP Values (code 346)
Available Formats
SIP-Server-Assignment-Type AVP Values (375)
Available Formats
| AVP Value | Attribute Name | Reference |
|---|---|---|
| 0 | NO_ASSIGNMENT | RFC 4740 |
| 1 | REGISTRATION | RFC 4740 |
| 2 | RE_REGISTRATION | RFC 4740 |
| 3 | UNREGISTERED_USER | RFC 4740 |
| 4 | TIMEOUT_DEREGISTRATION | RFC 4740 |
| 5 | USER_DEREGISTRATION | RFC 4740 |
| 6 | TIMEOUT_DEREGISTRATION_STORE_SERVER_NAME | RFC 4740 |
| 7 | USER_DEREGISTRATION_STORE_SERVER_NAME | RFC 4740 |
| 8 | ADMINISTRATIVE_DEREGISTRATION | RFC 4740 |
| 9 | AUTHENTICATION_FAILURE | RFC 4740 |
| 10 | AUTHENTICATION_TIMEOUT | RFC 4740 |
| 11 | DEREGISTRATION_TOO_MUCH_DATA | RFC 4740 |
SIP-Authentication-Scheme AVP Values (377)
Available Formats
| AVP Value | Attribute Name | Reference |
|---|---|---|
| 0 | DIGEST | RFC 4740 |
SIP-Reason-Code AVP Values (384)
Available Formats
SIP-User-Authorization-Type AVP Values (387)
Available Formats
SIP-User-Data-Already-Available AVP Values (392)
Available Formats
Accounting-Auth-Method AVP Values (code 406)
Available Formats
Origin-AAA-Protocol AVP Values (code 408)
Available Formats
| AVP Value | Attribute Name | Reference |
|---|---|---|
| 1 | RADIUS | RFC 7155 |
CC-Request-Type AVP Values (code 416)
Registration Procedure(s)
- Specification Required
Expert(s)
- Jouni Korhonen, Lionel Morand
Reference
- RFC 8506: Diameter Credit-Control Application
Available Formats
CC-Session-Failover AVP Values (code 418)
Registration Procedure(s)
- Specification Required
Expert(s)
- Jouni Korhonen, Lionel Morand
Reference
- RFC 8506: Diameter Credit-Control Application
Available Formats
Check-Balance-Result AVP Values (code 422)
Registration Procedure(s)
- Specification Required
Expert(s)
- Jouni Korhonen, Lionel Morand
Reference
- RFC 8506: Diameter Credit-Control Application
Available Formats
Credit-Control AVP Values (code 426)
Registration Procedure(s)
- Specification Required
Expert(s)
- Jouni Korhonen, Lionel Morand
Reference
- RFC 8506: Diameter Credit-Control Application
Available Formats
Credit-Control-Failure-Handling AVP Values (code 427)
Registration Procedure(s)
- Specification Required
Expert(s)
- Jouni Korhonen, Lionel Morand
Reference
- RFC 8506: Diameter Credit-Control Application
Available Formats
Direct-Debiting-Failure-Handling AVP Values (code 428)
Registration Procedure(s)
- Specification Required
Expert(s)
- Jouni Korhonen, Lionel Morand
Reference
- RFC 8506: Diameter Credit-Control Application
Available Formats
Redirect-Address-Type AVP Values (code 433)
Registration Procedure(s)
- Specification Required
Expert(s)
- Jouni Korhonen, Lionel Morand
Reference
- RFC 8506: Diameter Credit-Control Application
Available Formats
Requested-Action AVP Values (436)
Registration Procedure(s)
- Specification Required
Expert(s)
- Jouni Korhonen, Lionel Morand
Reference
- RFC 8506: Diameter Credit-Control Application
Available Formats
Final-Unit-Action AVP Values (code 449)
Registration Procedure(s)
- Specification Required
Expert(s)
- Jouni Korhonen, Lionel Morand
Reference
- RFC 8506: Diameter Credit-Control Application
Available Formats
Subscription-Id-Type AVP Values (code 450)
Registration Procedure(s)
- Specification Required
Expert(s)
- Jouni Korhonen, Lionel Morand
Reference
- RFC 8506: Diameter Credit-Control Application
Available Formats
Tariff-Change-Usage AVP Values (code 452)
Registration Procedure(s)
- Specification Required
Expert(s)
- Jouni Korhonen, Lionel Morand
Reference
- RFC 8506: Diameter Credit-Control Application
Available Formats
CC-Unit-Type AVP Values (code 454)
Registration Procedure(s)
- Specification Required
Expert(s)
- Jouni Korhonen, Lionel Morand
Reference
- RFC 8506: Diameter Credit-Control Application
Available Formats
Multiple-Services-Indicator AVP Values (code 455)
Registration Procedure(s)
- Specification Required
Expert(s)
- Jouni Korhonen, Lionel Morand
Reference
- RFC 8506: Diameter Credit-Control Application
Available Formats
User-Equipment-Info-Type AVP Values (code 459)
Registration Procedure(s)
- Specification Required
Expert(s)
- Jouni Korhonen, Lionel Morand
Reference
- RFC 8506: Diameter Credit-Control Application
Available Formats
Accounting-Record-Type AVP Values (code 480)
Available Formats
Accounting-Realtime-Required AVP Values (code 483)
Available Formats
Treatment-Action AVP Values (code 572)
Registration Procedure(s)
- Specification Required
Reference
- RFC 5777: Traffic Classification and Quality of Service (QoS) Attributes for Diameter
Available Formats
QoS-Semantics AVP Values (code 575)
Registration Procedure(s)
- Specification Required
Reference
- RFC 5777: Traffic Classification and Quality of Service (QoS) Attributes for Diameter
Available Formats
Key-Type AVP Values (code 582)
Registration Procedure(s)
- Specification Required
Reference
- RFC 6734: Diameter Attribute-Value Pairs for Cryptographic Key Transport
Available Formats
NC-Request-Type AVP Values (code 595)
Registration Procedure(s)
- Expert Review
Reference
- RFC 6736: Diameter Network Address and Port Translation Control Application
Available Formats
NAT-External-Port-Style AVP Values (code 604)
Registration Procedure(s)
- Expert Review
Reference
- RFC 6736: Diameter Network Address and Port Translation Control Application
Available Formats
NAT-Control-Binding-Status (code 606)
Registration Procedure(s)
- Expert Review
Reference
- RFC 6736: Diameter Network Address and Port Translation Control Application
Available Formats
OC-Feature-Vector AVP Values (code 622)
Registration Procedure(s)
- Specification Required
Expert(s)
- Jouni Korhonen, Lionel Morand
Reference
- RFC 7683: Diameter Overload Indication Conveyance
Available Formats
| AVP Value | Attribute Name | Reference |
|---|---|---|
| 0x0000000000000000 | Reserved | RFC 7683 |
| 0x0000000000000001 | OLR_DEFAULT_ALGO | RFC 7683 |
| 0x0000000000000002 | Unassigned | |
| 0x0000000000000004 | OLR_RATE_ALGORITHM | RFC 8582 |
| 0x0000000000000008 | Unassigned | |
| 0x0000000000000010 | OC_PEER_REPORT | RFC 8581 |
| 0x0000000000000020-0xFFFFFFFFFFFFFFFF | Unassigned |
OC-Report-Type AVP Values (code 626)
Registration Procedure(s)
- Specification Required
Expert(s)
- Jouni Korhonen, Lionel Morand
Reference
- RFC 7683: Diameter Overload Indication Conveyance
Available Formats
Session-Group-Control-Vector AVP Values (code 672)
Registration Procedure(s)
- Specification Required
Expert(s)
- Jouni Korhonen, Lionel Morand
Reference
- RFC 9390: Diameter Group Signaling
Note
Only numeric values that are 2^x (power of two, where 0 <= x < 32) are allowed, as defined in RFC 9390.
Available Formats
Session-Group-Capability-Vector AVP Values (code 675)
Registration Procedure(s)
- Standards Action
Reference
- RFC 9390: Diameter Group Signaling
Note
Only numeric values that are 2^x (power of two, where 0 <= x < 32) are allowed, as defined in RFC 9390.
Available Formats
AVP Flags Value
Registration Procedure(s)
- Standards Action
Reference
- RFC 6733: Diameter Base Protocol
Available Formats
Application IDs
Expert(s)
- Unassigned
Reference
- RFC 6733: Diameter Base Protocol
- RFC 6942: Diameter Support for the EAP Re-authentication Protocol (ERP)
Available Formats
| Range | Registration Procedures | Note |
|---|---|---|
| 0-16777215 | Specification Required | |
| 16777216-4294967294 | First Come First Served | Vendor-Specific |
| ID Value | Name | Reference |
|---|---|---|
| 0 | Diameter common message | RFC 6733 |
| 1 | NASREQ | RFC 7155 |
| 2 | Mobile IPv4 | RFC 4004 |
| 3 | Diameter base accounting | RFC 6733 |
| 4 | Diameter Credit Control | RFC 8506 |
| 5 | Diameter EAP | RFC 4072 |
| 6 | Diameter Session Initiation Protocol (SIP) Application | RFC 4740 |
| 7 | Diameter Mobile IPv6 IKE (MIP6I) | RFC 5778 |
| 8 | Diameter Mobile IPv6 Auth (MIP6A) | RFC 5778 |
| 9 | Diameter QoS application | RFC 5866 |
| 10 | Diameter Capabilities Update | RFC 6737 |
| 11 | Diameter IKE SK (IKESK) | RFC 6738 |
| 12 | Diameter NAT Control Application | RFC 6736 |
| 13 | Diameter ERP | RFC 6942 |
| 14-16777215 | Unassigned | |
| 16777216 | 3GPP Cx | 3GPP TS 29.228; 3GPP TS 29.229 |
| 16777217 | 3GPP Sh | 3GPP TS 29.328; 3GPP TS 29.329 |
| 16777218 | 3GPP Re | 3GPP TS 32.296; Kimmo Kymalainen |
| 16777219 | 3GPP Wx | 3GPP TS 29.234; Kimmo Kymalainen |
| 16777220 | 3GPP Zn | 3GPP TS 29.109; Kimmo Kymalainen |
| 16777221 | 3GPP Zh | 3GPP TS 29.109; Kimmo Kymalainen |
| 16777222 | 3GPP Gq | 3GPP TS 29.209; Kimmo Kymalainen |
| 16777223 | 3GPP Gmb | 3GPP TS 29.061; Kimmo Kymalainen |
| 16777224 | 3GPP Gx | 3GPP TS 29.210; Kimmo Kymalainen |
| 16777225 | 3GPP Gx over Gy | 3GPP TS 29.210; Kimmo Kymalainen |
| 16777226 | 3GPP MM10 | 3GPP TS 29.140; Kimmo Kymalainen |
| 16777227 | Ericsson MSI | German Blanco |
| 16777228 | Ericsson Zx | German Blanco |
| 16777229 | 3GPP Rx | 3GPP TS 29.211; Kimmo Kymalainen |
| 16777230 | 3GPP Pr | 3GPP TS 29.234; Kimmo Kymalainen |
| 16777231 | ETSI e4 | ETSI ES 283 034 |
| 16777232 | Ericsson Charging-CIP | Björn Almén |
| 16777233 | Ericsson Mm | German Blanco |
| 16777234 | Vodafone Gx+ | Torsten Oertel |
| 16777235 | ITU-T Rs | ITU-T Recommendation Q.3301.1 |
| 16777236 | 3GPP Rx | 3GPP TS 29.214; Kimmo Kymalainen |
| 16777237 | 3GPP2 Ty | AC Mahendran |
| 16777238 | 3GPP Gx | 3GPP TS 29.212; Kimmo Kymalainen |
| 16777239 | Juniper Cluster | Vitaly Dzhitenov |
| 16777240 | Juniper Policy-Control-AAA | Steffen Ries |
| 16777241 | iptego USPI | Christian Schubert |
| 16777242 | Covergence-specific SIP routing | Martin Del Vecchio |
| 16777243 | Policy Processing | OMA PEEM V1.0; Michael Brenner |
| 16777244 | Juniper Policy-Control-JSRC | Jun Chang |
| 16777245 | ITU-T S-TC1 | ITU-T Recommendation Q.3221; Kwihoon Kim |
| 16777246 | NSN Unified Charging Trigger Function (UCTF) | http://www.3gpp.org/ftp/Specs/; Dan D'Albuquerque |
| 16777247 | 3GPP2 CAN Access Authentication and Authorization | ftp://ftp.3gpp2.org/TSGX/Projects/; Avi Lior |
| 16777248 | 3GPP2 WLAN Interworking Access Authentication and Authorization | ftp://ftp.3gpp2.org/TSGX/Projects/; Avi Lior |
| 16777249 | 3GPP2 WLAN Interworking Accounting | ftp://ftp.3gpp2.org/TSGX/Projects/; Avi Lior |
| 16777250 | 3GPP Sta | 3GPP TS 29.273; Kimmo Kymalainen |
| 16777251 | 3GPP S6a | 3GPP TS 29.272; Kimmo Kymalainen |
| 16777252 | 3GPP S13 | 3GPP TS 29.272; Kimmo Kymalainen |
| 16777253 | ETSI Re | ETSI TS 183 060; Shicheng Hu |
| 16777254 | ETSI GOCAP | ETSI ES 283 039; Shicheng Hu |
| 16777255 | SLg | 3GPP TS 29.172; Kimmo Kymalainen |
| 16777256 | ITU-T Rw | ITU-T Rec. Q.3303.3; RFC 5431 |
| 16777257 | ETSI a4 | Shicheng Hu |
| 16777258 | ITU-T Rt | ITU-T Rec. Q.3305.1; Tom Taylor |
| 16777259 | CARA | Sachin Rathee |
| 16777260 | CAMA | Sachin Rathee |
| 16777261 | Femtocell extension to Diameter EAP Application | Vitaly Dzhitenov |
| 16777262 | ITU-T Ru | ITU-T Rec. Q.nacp.Ru Q.nacp.Ru; Hyungseok Chung |
| 16777263 | ITU-T Ng | ITU-T Rec. Q.nacp.Ru Q.nacp.Ru; Kwihoon Kim |
| 16777264 | 3GPP SWm | 3GPP TS 29.273; Kimmo Kymalainen |
| 16777265 | 3GPP SWx | 3GPP TS 29.273; Kimmo Kymalainen |
| 16777266 | 3GPP Gxx | 3GPP TS 29.212; Kimmo Kymalainen |
| 16777267 | 3GPP S9 | 3GPP TS 29.215; Kimmo Kymalainen |
| 16777268 | 3GPP Zpn | 3GPP TS 29.109; Kimmo Kymalainen |
| 16777269 | Ericsson HSI | German Blanco |
| 16777270 | Juniper-Example | Aleksey Romanov |
| 16777271 | ITU-T Ri | ITU-T Rec. Q.3307.1; Michiaki Hayashi |
| 16777272 | 3GPP S6b | 3GPP TS 29.273; Kimmo Kymalainen |
| 16777273 | Juniper JGx | Claudio Lordello |
| 16777274 | ITU-T Rd | ITU-T Rec. Q.3306.1; Janusz Pieczerak |
| 16777275 | ADMI Notification Application | Tomas Menzl |
| 16777276 | ADMI Messaging Interface Application | Tomas Menzl |
| 16777277 | Peter-Service VSI | Alexey Grishin |
| 16777278 | ETSI Rr request model | ETSI TS 183 071; Miguel Angel Reina Ortega |
| 16777279 | ETSI Rr delegated model | ETSI TS 183 071; Miguel Angel Reina Ortega |
| 16777280 | WIMAX HRPD Interworking | 3GPP2 X.S0058-0 v1.0; Avi Lior |
| 16777281 | WiMAX Network Access Authentication and Authorization Diameter Application (WNAAADA) | WiMAX Release 1.5; Avi Lior |
| 16777282 | WiMAX Network Accounting Diameter Application (WNADA) | WiMAX Release 1.5; Avi Lior |
| 16777283 | WiMAX MIP4 Diameter Application (WM4DA) | WiMAX Release 1.5; Avi Lior |
| 16777284 | WiMAX MIP6 Diameter Application (WM6DA) | WiMAX Release 1.5; Avi Lior |
| 16777285 | WiMAX DHCP Diameter Application (WDDA) | WiMAX Release 1.5; Avi Lior |
| 16777286 | WiMAX-Location-Authentication-Authorization Diameter Application (WLAADA) | WiMAX Release 1.5; Avi Lior |
| 16777287 | WiMAX-Policy-and-Charging-Control-R3-Policies Diameter Application (WiMAX PCC-R3-P) | WiMAX Release 1.5; Avi Lior |
| 16777288 | WiMAX-Policy-and-Charging-Control-R3-OFfline-Charging Diameter Application (WiMAX PCC-R3-OFC) | WiMAX Release 1.5; Avi Lior |
| 16777289 | WiMAX-Policy-and-Charging-Control-R3-Offline-Charging-Prime Diameter Application (WiMAX PCC-R3-OFC-PRIME) | WiMAX Release 1.5; Avi Lior |
| 16777290 | WiMAX-Policy-and-Charging-Control-R3-Online-Charging Diameter Application (WiMAX PCC-R3-OC) | WiMAX Release 1.5; Avi Lior |
| 16777291 | 3GPP SLh | 3GPP TS 29.173; Kimmo Kymalainen |
| 16777292 | 3GPP SGmb | 3GPP TS 29.061; Kimmo Kymalainen |
| 16777293 | CMDI - Cloudmark Diameter Interface | Sanjiv Parikh |
| 16777294 | Camiant DRMA | Tarek Abou-Assali; Michael Mercurio |
| 16777295 | PiLTE Interworking Diameter Application | 3GPP2 publication X.S0057; Avi Lior |
| 16777296 | Juniper-Sessions-Recovery (JSR) | Aleksey Romanov |
| 16777297 | Vedicis LiveProxy | Francois-Frederic Ozog |
| 16777298 | Pi*3GPP2 Diameter Application | 3GPP2 publication X.S0057A E-UTRAN eHRPD; Avi Lior |
| 16777299 | Sandvine Rf+ | Yoni Eitan |
| 16777300 | Subscription Information Application | Lars Anglert |
| 16777301 | Ericsson Charging-DCIP | Lars Anglert |
| 16777302 | 3GPP Sy | 3GPP TS 29.219; Kimmo Kymalainen |
| 16777303 | 3GPP Sd | 3GPP TS 29.212; Kimmo Kymalainen |
| 16777304 | Ericsson Sy | Lars Anglert |
| 16777305 | HP DTD | Chiranjeev Agrawal; J V Kishore |
| 16777306 | M9 interface between MLM-PE(P) and MLM-PE(C) | ITU-T Q5/Sg11; Jin Seek Choi |
| 16777307 | ITU-T M13 | ITU-T Q.3230; Kwihoon Kim |
| 16777308 | 3GPP S7a | 3GPP TS 29.272; Kimmo Kymalainen |
| 16777309 | 3GPP Tsp | 3GPP TS 29.368; Kimmo Kymalainen |
| 16777310 | 3GPP S6m | 3GPP TS 29.336; Kimmo Kymalainen |
| 16777311 | 3GPP T4 | 3GPP TS 29.337; Kimmo Kymalainen |
| 16777312 | 3GPP S6c | 3GPP TS 29.338; Kimmo Kymalainen |
| 16777313 | 3GPP SGd | 3GPP TS 29.338; Kimmo Kymalainen |
| 16777314 | Intrado-SLg | Scott Luallin |
| 16777315 | Ericsson Diameter Signalling Controller Application (DSC) | Klaus Turina |
| 16777316 | Verizon-Femto-Loc | Niranjan Avula |
| 16777317 | Nokia Siemens Networks (NSN) Hd Application | Hannes Tschofenig |
| 16777318 | 3GPP S15 | 3GPP TS 29.212; Kimmo Kymalainen |
| 16777319 | 3GPP S9a | 3GPP TS 29.215; Kimmo Kymalainen |
| 16777320 | 3GPP S9a* | 3GPP TS 29.215; Kimmo Kymalainen |
| 16777321 | Gateway Location Application | Steve Donovan |
| 16777322 | Verizon Session Recovery | Niranjan Avula |
| 16777323 | 3GPP2 M1 Interface | 3GPP2 X.S0068; Jun Wang |
| 16777324 | MAGIC Client Interface Protocol (CIP) | ARINC 839; Paul Prisaznuk; Manfred Benten |
| 16777325 | ITU-T Nc | ITU-T Rec. Q.nacp.Nc; Kwihoon Kim |
| 16777326 | ITU-T Ne | ITU-T Rec. Q.nacp.Ne; Kwihoon Kim |
| 16777327 | Ericsson Sx | Irene Martin |
| 16777328 | Nokia Service Extension, NSE | Timo Perala |
| 16777329 | Rivada Xd | Vincent D’Onofrio |
| 16777330 | Rivada Xm | Vincent D’Onofrio |
| 16777331 | Rivada Xh | Vincent D’Onofrio |
| 16777332 | Rivada Xf | Vincent D’Onofrio |
| 16777333 | Rivada Xp | Vincent D’Onofrio |
| 16777334 | Rivada Xa | Vincent D’Onofrio |
| 16777335 | 3GPP MB2-C | 3GPP TS 29.468; Kimmo Kymalainen |
| 16777336 | 3GPP PC4a | 3GPP TS 29.344; Kimmo Kymalainen |
| 16777337 | 3GPP PC2 | 3GPP TS 29.343; Kimmo Kymalainen |
| 16777338 | Juniper Domain Policy | Vitaly Dzhitenov |
| 16777339 | Host Observer | Laimutis Slecpenka |
| 16777340 | 3GPP PC6/PC7 | 3GPP TS 29.345; Kimmo Kymalainen |
| 16777341 | Nokia Sdr Application | Timo Perala |
| 16777342 | 3GPP Np | 3GPP TS 29.217; Kimmo Kymalainen |
| 16777343 | Sandvine Location Relay Service | Inian Vasanth |
| 16777344 | Sandvine Fairshare Traffic Management Service | Inian Vasanth |
| 16777345 | 3GPP S6t | 3GPP TS 29.336; Kimmo Kymalainen |
| 16777346 | 3GPP T6a/T6b | 3GPP TS 29.128; Kimmo Kymalainen |
| 16777347 | 3GPP Ns | 3GPP TS 29.153; Kimmo Kymalainen |
| 16777348 | 3GPP Nt | 3GPP TS 29.154; Kimmo Kymalainen |
| 16777349 | 3GPP St | 3GPP TS 29.212; Kimmo Kymalainen |
| 16777350 | 3GPP PC2 | 3GPP TS 29.343; Kimmo Kymalainen |
| 16777351 | 3GPP Diameter Data Management | 3GPP TS 29.283; Kimmo Kymalainen |
| 16777352 | ITU-T M1 | ITU-T Recommendation Q.nacp.M1; Kwihoon Kim |
| 16777353 | ITU-T M2 | ITU-T Recommendation Q.nacp.M2; Kwihoon Kim |
| 16777354 | Verizon-NLS-WDS | Niranjan Avula |
| 16777355 | 3GPP V4 | 3GPP TS 29.388; Kimmo Kymalainen |
| 16777356 | 3GPP V6 | 3GPP TS 29.389; Kimmo Kymalainen |
| 16777357 | OMN Adapt Application | Jarda Nedved |
| 16777358 | 3GPP Nta | 3GPP TS 29.154; Kimmo Kymalainen |
| 16777359 | Ericsson Charging - SBI Policy | S. Dhanalakshmi |
| 16777360 | GSMA-DESS | GSMA PRD FS.19; Wayne Cutler |
| 16777361 | Ericsson Charging - SBI Policy over Ericsson N28 Interface | JayaKrishnan KP |
| 16777362 | OMN Protect Application | Jarda Nedved |
| 16777363 | 3GPP Sc | 3GPP TS 29.330; Kimmo Kymalainen |
| 16777364 | OMN Message Replication | Jarda Nedved |
| 16777365-4294967294 | Unassigned | |
| 4294967295 | Relay | RFC 6733 |
Command Codes
Reference
- RFC 6733: Diameter Base Protocol
- RFC 5719: Updated IANA Considerations for Diameter Command Code Allocations
Available Formats
| Range | Registration Procedures | Note |
|---|---|---|
| 0-255 | Reserved for RADIUS backward compatibility | See RADIUS Packet Type Codes |
| 256-8388607 | IETF Review | |
| 8388608-16777213 | First Come First Served with specification | Vendor-Specific |
| Code Value | Name | Reference |
|---|---|---|
| 0-255 | RADIUS compatability codes | RADIUS Types |
| 256 | Unassigned | |
| 257 | CER / CEA | RFC 6733 |
| 258 | RAR / RAA | RFC 6733 |
| 259 | Unassigned | |
| 260 | AMR / AMA | RFC 4004 |
| 261 | Unassigned | |
| 262 | HAR / HAA | RFC 4004 |
| 263-264 | Unassigned | |
| 265 | AAR / AAA | RFC 7155 |
| 266-267 | Unassigned | |
| 268 | DER / DEA | RFC 4072 |
| 269-270 | Unassigned | |
| 271 | ACR / ACA | RFC 6733 |
| 272 | CCR / CCA | RFC 8506 |
| 273 | Unassigned | |
| 274 | ASR / ASA | RFC 6733 |
| 275 | STR / STA | RFC 6733 |
| 276-279 | Unassigned | |
| 280 | DWR / DWA | RFC 6733 |
| 281 | Unassigned | |
| 282 | DPR / DPA | RFC 6733 |
| 283 | UAR / UAA | RFC 4740 |
| 284 | SAR / SAA | RFC 4740 |
| 285 | LIR / LIA | RFC 4740 |
| 286 | MAR / MAA | RFC 4740 |
| 287 | RTR / RTA | RFC 4740 |
| 288 | PPR / PPA | RFC 4740 |
| 289-299 | Unassigned | |
| 300-313 | Allocated for 3GPP | RFC 3589 |
| 314 | PDR / PDA | RFC 5224 |
| 315 | Policy-Install-Request (PIR)/Policy-Install-Answer (PIA) | ITU-T Rec. Q.3303.3; RFC 5431 |
| 316 | 3GPP-Update-Location-Request/Answer (ULR/ULA) | 3GPP TS 29.272; RFC 5516 |
| 317 | 3GPP-Cancel-Location-Request/Answer (CLR/CLA) | 3GPP TS 29.272; RFC 5516 |
| 318 | 3GPP-Authentication-Information-Request/Answer (AIR/AIA) | 3GPP TS 29.272; RFC 5516 |
| 319 | 3GPP-Insert-Subscriber-Data-Request/Answer (IDR/IDA) | 3GPP TS 29.272; RFC 5516 |
| 320 | 3GPP-Delete-Subscriber-Data-Request/Answer (DSR/DSA) | 3GPP TS 29.272; RFC 5516 |
| 321 | 3GPP-Purge-UE-Request/Answer (PUR/PUA) | 3GPP TS 29.272; RFC 5516 |
| 322 | 3GPP-Reset-Request/Answer (RSR/RSA) | 3GPP TS 29.272; RFC 5516 |
| 323 | 3GPP-Notify-Request/Answer (NOR/NOA) | 3GPP TS 29.272; RFC 5516 |
| 324 | 3GPP-ME-Identity-Check-Request/Answer (ECR/ECA) | 3GPP TS 29.272; RFC 5516 |
| 325 | MIP6-Request/Answer (MIR/MIA) | RFC 5778 |
| 326 | QoS-Authorization-Request/QoS-Authorization-Answer (QAR/QAA) | RFC 5866 |
| 327 | QoS-Install-Request/QoS-Install-Answer (QIR/QIA) | RFC 5866 |
| 328 | Capabilities-Update-Request/Capabilities-Update-Answer (CUR/CUA) | RFC 6737 |
| 329 | IKEv2-SK-Request/Answer (ISR/ISA) | RFC 6738 |
| 330 | NAT-Control-Request/Answer (NCR/NCA) | RFC 6736 |
| 331-8388607 | Unassigned | |
| 8388608 | WIMAX-HRPD-SFF Request/Answer | 3GPP2 X.S0058-0 v1.0; Avi Lior |
| 8388609 | WiMAX-Diameter-EAP-Request/Answer (WDER/WDEA) WDE | WiMAX Release 1.5; Avi Lior |
| 8388610 | WiMAX-Change-of-Authorization-Request/Answer (WCAR/WCAA) WCA | WiMAX Release 1.5; Avi Lior |
| 8388611 | WiMAX-Reauthentication-Request/Answer (WRAR/WRAA) WRA | WiMAX Release 1.5; Avi Lior |
| 8388612 | WiMAX-Session-Termination-Request/Answer (WSTR/WSTA) WST | WiMAX Release 1.5; Avi Lior |
| 8388613 | WiMAX-Abort-Session-Request/Answer (WASR/WASA) WAS | WiMAX Release 1.5; Avi Lior |
| 8388614 | WiMAX-Home-Agent-IPv4-Request/Answer (WHA4R/WHA4A) WHA4 | WiMAX Release 1.5; Avi Lior |
| 8388615 | WiMAX-Home-Agent-IPv6-Request/Answer (WHA6R/WHA6A) WHA6 | WiMAX Release 1.5; Avi Lior |
| 8388616 | WiMAX-DHCP-Request/Answer (WDHCPR/WDHCPA) WDHCP | WiMAX Release 1.5; Avi Lior |
| 8388617 | WiMAX-LAA-Request/Answer (WLAAR/WLAA) WLAA | WiMAX Release 1.5; Avi Lior |
| 8388618 | WiMAX-Location-Accounting-Request/Answer (WLACR/WLACA) WLAC | WiMAX Release 1.5; Avi Lior |
| 8388619 | WiMAX-Location-Measurement-Query-Request/Answer (WLMQR/WLMQA) WLMQ | WiMAX Release 1.5; Avi Lior |
| 8388620 | 3GPP-Provide-Location-Request/Answer (PLR/PLA) | 3GPP TS 29.172; Kimmo Kymalainen |
| 8388621 | 3GPP-Location-Report-Request/Answer (LRR/LRA) | 3GPP TS 29.172; Kimmo Kymalainen |
| 8388622 | 3GPP-LCS-Routing-Info-Request/Answer (RIR/RIA) | 3GPP TS 29.173; Kimmo Kymalainen |
| 8388623 | Notif-Request/Answer (NFR/NFA) | Tomas Menzl |
| 8388624 | Msg-Interface-Request/Answer (MIFR/MIFA) | Tomas Menzl |
| 8388625 | Mobile-Application-Request/Answer (MAPR/MAPA) | Tomas Menzl |
| 8388626 | Update Location Request/Answer (ULR / ULA) | 3GPP2 publication X.S0057; Avi Lior |
| 8388627 | Cancel Location Request/Answer (CLR CLA) | 3GPP2 publication X.S0057; Avi Lior |
| 8388628 | Juniper-Sync-Event (JSE) | Aleksey Romanov |
| 8388629 | Juniper-Session-Discovery (JSD) | Aleksey Romanov |
| 8388630 | Query Profile Request Answer (QPR/QPA) | 3GPP2 publication X.S0057A E-UTRAN eHRPD7; Avi Lior |
| 8388631 | Subscription Information Application (SIR/SIA) | Lars Anglert |
| 8388632 | Distributed Charging Request/Diameter Charging Answer (DCR/DCA) | Lars Anglert |
| 8388633 | Ericsson Spending Limit Request/Answer (SLR/SLA) | Lars Anglert |
| 8388634 | Ericsson Spending Status Notification Request/Answer (SNR/SNA) | Lars Anglert |
| 8388635 | Spending-Limit-Request/Answer (SLR/SLA) | 3GPP TS 29.219; Kimmo Kymalainen |
| 8388636 | Spending-Status-Notification-Request/Answer (SNR/SNA) | 3GPP TS 29.219; Kimmo Kymalainen |
| 8388637 | TDF-Session-Request/Answer (TSR/TSA) | 3GPP TS 29.212; Kimmo Kymalainen |
| 8388638 | 3GPP-Update-VCSG-Location-Request/Answer (UVR/UVA) | 3GPP TS 29.272; Kimmo Kymalainen |
| 8388639 | Device-Action-Request/Answer (DAR/DAA) | 3GPP TS 29.368; Kimmo Kymalainen |
| 8388640 | Device-Notification-Request/Answer (DNR/DNA) | 3GPP TS 29.368; Kimmo Kymalainen |
| 8388641 | Subscriber-Information-Request/Answer (SIR/SIA) | 3GPP TS 29.336; Kimmo Kymalainen |
| 8388642 | Cancel-VCSG-Location-Request/Answer (CVR/CVA) | 3GPP TS 29.272; Kimmo Kymalainen |
| 8388643 | Device-Trigger-Request/Answer (DTR/DTA) | 3GPP TS 29.337; Kimmo Kymalainen |
| 8388644 | Delivery-Report-Request/Answer (DRR/DRA) | 3GPP TS 29.337; Kimmo Kymalainen |
| 8388645 | MO-Forward-Short-Message Request/Answer (OFR/OFA) | 3GPP TS 29.338; Kimmo Kymalainen |
| 8388646 | MT-Forward-Short-Message Request/Answer (TFR/TFA) | 3GPP TS 29.338; Kimmo Kymalainen |
| 8388647 | Send-Routing-Info-for-SM-Request/Answer (SRR/SRA) | 3GPP TS 29.338; Kimmo Kymalainen |
| 8388648 | Alert-Service-Centre-Request/Answer (ALR/ALA) | 3GPP TS 29.338; Kimmo Kymalainen |
| 8388649 | Report-SM-Delivery-Status-Request/Answer (RDR/RDA) | 3GPP TS 29.338; Kimmo Kymalainen |
| 8388650 | NSN Cancel-LocationMS-Request/Answer (CLR/CLA) | Hannes Tschofenig |
| 8388651 | NSN User-DataMS-Request/Answer (UDR/UDA) | Hannes Tschofenig |
| 8388652 | NSN Profile-UpdateMS-Request/Answer (PUR/PUA) | Hannes Tschofenig |
| 8388653 | NSN Subscribe-NotificationsMS-Request/Answer (SNR/SNA) | Hannes Tschofenig |
| 8388654 | NSN Push-NotificationMS-Request/Answer (PNR/PNA) | Hannes Tschofenig |
| 8388655 | Get Gateway Request/Answer (GGR/GGA) | Steve Donovan |
| 8388656 | Trigger-Establishment-Request/Answer (TER/TEA) | 3GPP TS 29.215; Kimmo Kymalainen |
| 8388657 | Ericsson Binding-Data-Request/Answer (BDR/BDA) | Klaus Turina |
| 8388658 | 3GPP2 Subscriber-Information-Request/Answer (SIR/SIA) | 3GPP2 X.S0068; Jun Wang |
| 8388659 | Verizon Session Data Recovery Request/Answer (SDR/SDA) | Niranjan Avula |
| 8388660 | Nokia Core Service Request/Answer (CSR/CSA) | Timo Perala |
| 8388661 | Nokia Extended Command Request/Answer (ECR/ECA) | Timo Perala |
| 8388662 | GCS-Action-Request/Answer (GAR/GAA) | 3GPP TS 29.468; Kimmo Kymalainen |
| 8388663 | GCS-Notification-Request/Answer (GNR/GNA) | 3GPP TS 29.468; Kimmo Kymalainen |
| 8388664 | ProSe-Subscriber-Information-Request/Answer (PIR/PIA) | 3GPP TS 29.344; Kimmo Kymalainen |
| 8388665 | Update-ProSe-Subscriber-Data-Request/Answer (UPR/UPA) | 3GPP TS 29.344; Kimmo Kymalainen |
| 8388666 | ProSe-Notify-Request/Answer (PNR/PNA) | 3GPP TS 29.344; Kimmo Kymalainen |
| 8388667 | Reset-Request/Answer (RSR/RSA) | 3GPP TS 29.344; Kimmo Kymalainen |
| 8388668 | ProSe-Authorization-Request/Answer (PAR/PAA) | 3GPP TS 29.345; Kimmo Kymalainen |
| 8388669 | ProSe-Discovery-Request/Answer (PDR/PDA) | 3GPP TS 29.345; Kimmo Kymalainen |
| 8388670 | ProSe-Match-Request/Answer (PMR/PMA) | 3GPP TS 29.345; Kimmo Kymalainen |
| 8388671 | ProSe-Match-Report-Info-Request/Answer (PIR/PIA) | 3GPP TS 29.345; Kimmo Kymalainen |
| 8388672 | ProSe-Proximity-Request/Answer (PRR/PRA) | 3GPP TS 29.345; Kimmo Kymalainen |
| 8388673 | ProSe-Location-Update-Request (PLR/PLA) | 3GPP TS 29.345; Kimmo Kymalainen |
| 8388674 | ProSe-Alert-Request/Answer (ALR/ALA) | 3GPP TS 29.345; Kimmo Kymalainen |
| 8388675 | ProSe-Cancellation-Request/Answer (RPR/RPA) | 3GPP TS 29.345; Kimmo Kymalainen |
| 8388676 | ProXimity-Action-Request/Answer (PXR/PXA) | 3GPP TS 29.343; Kimmo Kymalainen |
| 8388677 | Rivada Xd DSC-Registration-Request/Answer (DDRR/DDRA) | Vincent D’Onofrio |
| 8388678 | Rivada Xd Heart-Beat-Request/Answer (DHBR/DHBA) | Vincent D’Onofrio |
| 8388679 | Rivada Xd Cell-Info-Transfer-Request/Answer (DCTR/DCTA) | Vincent D’Onofrio |
| 8388680 | Rivada Xd Cell-Info-Notification-Request/Answer (DCNR/DCNA) | Vincent D’Onofrio |
| 8388681 | Rivada Xd Cell-Info-Modification-Request/Answer (DIMR/DIMA) | Vincent D’Onofrio |
| 8388682 | Rivada Xd Cell-Info-Modification-Notification-Request/Answer (DINR/DINA) | Vincent D’Onofrio |
| 8388683 | Rivada Xd Resource-Allocation-Request/Answer (DRAR/DRAA) | Vincent D’Onofrio |
| 8388684 | Rivada Xd Resource-Allocation-Notification-Request/Answer (DANR/DANA) | Vincent D’Onofrio |
| 8388685 | Rivada Xd Resource-Modification-Request/Answer (DRMR/DRMA) | Vincent D’Onofrio |
| 8388686 | Rivada Xd Resource-Modification-Notification-Request/Answer (DMNR/DMNA) | Vincent D’Onofrio |
| 8388687 | Rivada Xd Resource-Hold-Request/Answer (DRHR/DRHA) | Vincent D’Onofrio |
| 8388688 | Rivada Xd Resource-Hold-Notification-Request/Answer (DHNR/DHNA) | Vincent D’Onofrio |
| 8388689 | Rivada Xd Resource-Resume-Request/Answer (DRSR/DRSA) | Vincent D’Onofrio |
| 8388690 | Rivada Xd Resource-Resume-Notification-Request/Answer (DSNR/DSNA) | Vincent D’Onofrio |
| 8388691 | Rivada Xd Resource-Usage-Update-Request/Answer (DRUR/DRUA) | Vincent D’Onofrio |
| 8388692 | Rivada Xd Resource-Usage-Notification-Request/Answer (DUNR/DUNA) | Vincent D’Onofrio |
| 8388693 | Rivada Xd Resource-Release-Request/Answer (DRRR/DRRA) | Vincent D’Onofrio |
| 8388694 | Rivada Xd Resource-Release-Notification-Request/Answer (DRNR/DRNA) | Vincent D’Onofrio |
| 8388695 | Rivada Xm Resource-Allocation-Request/Answer (MRAR/MRAA) | Vincent D’Onofrio |
| 8388696 | Rivada Xm Resource-Hold-Request/Answer (MRHR/MRHA) | Vincent D’Onofrio |
| 8388697 | Rivada Xm Resource-Release-Request/Answer (MRRR/MRRA) | Vincent D’Onofrio |
| 8388698 | Rivada Xm Resource-Modify-Request/Answer (MRMR/MRMA) | Vincent D’Onofrio |
| 8388699 | Rivada Xm Resource-Allocation-Notify-Request/Answer (MANR/MANA) | Vincent D’Onofrio |
| 8388700 | Rivada Xm Resource-Resume-Request/Answer (MRSR/MRSA) | Vincent D’Onofrio |
| 8388701 | Rivada Xm Add-UE-Context-Request/Answer (MAUR/MAUA) | Vincent D’Onofrio |
| 8388702 | Rivada Xm Update-UE-Context-Request/Answer (MUUR/MUUA) | Vincent D’Onofrio |
| 8388703 | Rivada Xm Delete-UE-Context-Request/Answer (MDUR/MDUA) | Vincent D’Onofrio |
| 8388704 | Rivada Xm Detach-UE-Request/Answer (MDTR/MDTA) | Vincent D’Onofrio |
| 8388705 | Rivada Xm Page-UE-Request/Answer (MPUR/MPUA) | Vincent D’Onofrio |
| 8388706 | Rivada Xm Heart-Beat-Request/Answer (MHBR/MHBA) | Vincent D’Onofrio |
| 8388707 | Rivada Xa DPC-Registration-Request/Answer (ADRR/ADRA) | Vincent D’Onofrio |
| 8388708 | Rivada Xa Heart-Beat-Request/Answer (AHBR/AHBA) | Vincent D’Onofrio |
| 8388709 | Rivada Xa Resource-Allocation-Request/Answer (ARAR/ARAA) | Vincent D’Onofrio |
| 8388710 | Rivada Xa Resource-Release-Request/Answer (ARRR/ARRA) | Vincent D’Onofrio |
| 8388711 | Rivada Xa Resource-Release-Notification-Request/Answer (ARNR/ARNA) | Vincent D’Onofrio |
| 8388712 | Rivada Xh User-Data-Request/Answer (HUDR/HUDA) | Vincent D’Onofrio |
| 8388713 | ProSe-Initial-Location-Information-Request/Answer (PSR/PSA) | 3GPP TS 29.344; Kimmo Kymalainen |
| 8388714 | Nokia Session-Sync-Request/Answer (SSR/SSA) | Timo Perala |
| 8388715 | Nokia Session-Mass-Sync-Request/Answer (SMR/SMA) | Timo Perala |
| 8388716 | Nokia Fetch-Session-Request/Answer (FSR/FSA) | Timo Perala |
| 8388717 | Ericsson Trace-Report-Request/Answer (TRR/TRA) | Gerhard Schmidt-Krschka |
| 8388718 | Configuration-Information-Request/Answer (CIR/CIA) | 3GPP TS 29.336; Kimmo Kymalainen |
| 8388719 | Reporting-Information-Request/Answer (RIR/RIA) | 3GPP TS 29.336; Kimmo Kymalainen |
| 8388720 | Non-Aggregated-RUCI-Report-Request/Answer (NRR/NRA) | 3GPP TS 29.217; Kimmo Kymalainen |
| 8388721 | Aggregated-RUCI-Report-Request/Answer (ARR/ARA) | 3GPP TS 29.217; Kimmo Kymalainen |
| 8388722 | Modify-Uecontext-Request/Answer (MUR/MUA) | 3GPP TS 29.217; Kimmo Kymalainen |
| 8388723 | Background-Data-Transfer-Request/Answer (BTR/BTA) | 3GPP TS 29.154; Kimmo Kymalainen |
| 8388724 | Network-Status-Request/Answer (NSR/NSA) | 3GPP TS 29.153; Kimmo Kymalainen |
| 8388725 | Network-Status-Continuous-Report-Request/Answer (NCR/NCA) | 3GPP TS 29.153; Kimmo Kymalainen |
| 8388726 | NIDD-Information-Request/Answer (NIR/NIA) | 3GPP TS 29.336; Kimmo Kymalainen |
| 8388727 | ProXimity-Application-Request/Answer (XAR/XAA) | 3GPP TS 29.343; Kimmo Kymalainen |
| 8388728 | Data-Pull-Request/Answer (DPR/DPA) | 3GPP TS 29.283; Kimmo Kymalainen |
| 8388729 | Data-Update-Request/Answer (DMR/DMA) | 3GPP TS 29.283; Kimmo Kymalainen |
| 8388730 | Notification-Data-Request/Answer (NDR/NDA) | 3GPP TS 29.283; Kimmo Kymalainen |
| 8388731 | TSSF-Notification-Request/Answer (TNR/TNA) | 3GPP TS 29.212; Kimmo Kymalainen |
| 8388732 | Connection-Management-Request/Answer (CMR/CMA) | 3GPP TS 29.128; Kimmo Kymalainen |
| 8388733 | MO-Data-Request/Answer (ODR/ODA) | 3GPP TS 29.128; Kimmo Kymalainen |
| 8388734 | MT-Data-Request/Answer (TDR/TDA) | 3GPP TS 29.128; Kimmo Kymalainen |
| 8388735 | Event-Configuration-Request/Answer (ECR/ECA) | 3GPP TS 29.154; Kimmo Kymalainen |
| 8388736 | Event-Reporting-Request/Answer (ERR/ERA) | 3GPP TS 29.154; Kimmo Kymalainen |
| 8388737 | DESS-DTLS-Handshake-Client-Request/Response | GSMA PRD FS.19; Wayne Cutler |
| 8388738 | DESS-DTLS-Handshake-Server-Request/Response | GSMA PRD FS.19; Wayne Cutler |
| 8388739-16777213 | Unassigned | |
| 16777214 | Experimental code | RFC 6733 |
| 16777215 | Experimental code | RFC 6733 |
Command Flags
Registration Procedure(s)
- Standards Action
Reference
- RFC 6733: Diameter Base Protocol
Available Formats
Mobility Capability Registry
Registration Procedure(s)
- Specification Required
Expert(s)
- Jouni Korhonen
Reference
- RFC 5447: Diameter Mobile IPv6: Support for Network Access Server to Diameter Server Interaction
Note
Only numeric values that are 2^x (power of two, where x >= 2) may be registered.
Available Formats
| Value | Token | Reference |
|---|---|---|
| 0x0000000000000001 | MIP6_INTEGRATED | RFC 5447 |
| 0x0000000000000002 | LOCAL_HOME_AGENT_ASSIGNMENT | RFC 5447 |
| 0x0000010000000000 | PMIP6_SUPPORTED | RFC 5779 |
| 0x0000020000000000 | IP4_HOA_SUPPORTED | RFC 5779 |
| 0x0000040000000000 | LOCAL_MAG_ROUTING_SUPPORTED | RFC 5779 |
| 0x0000080000000000 | ASSIGN_LOCAL_IP | 3GPP TS 29.273; Kimmo Kymalainen |
| 0x0000100000000000 | MIP4_SUPPORTED | 3GPP TS 29.273; Kimmo Kymalainen |
| 0x0000200000000000 | OPTIMIZED_IDLE_MODE_MOBILITY | 3GPP TS 29.273; Kimmo Kymalainen |
| 0x0000400000000000 | GTPv2_SUPPORTED | 3GPP TS 29.273; Kimmo Kymalainen |
| 0x0000800000000000 | IP4_TRANSPORT_SUPPORTED | RFC 6572 |
| 0x0001000000000000 | IP4_HOA_ONLY_SUPPORTED | RFC 6572 |
| 0x0002000000000000 | INTER_MAG_ROUTING_SUPPORTED | RFC 7156 |
MIP6 Authentication Mode Registry
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 5778: Diameter Mobile IPv6: Support for Home Agent to Diameter Server Interaction
Available Formats
QoS Profiles
Expert(s)
- Unassigned
Reference
- RFC 5624: Quality of Service Parameters for Usage with Diameter
Available Formats
| Range | Registration Procedures |
|---|---|
| 0-511 | Standards Action |
| 512-32767 | Specification Required |
| 32768-4294967295 | Reserved |
Contact Information
| Name | Contact URI | Last Updated |
|---|---|---|
| AC Mahendran | ac&qualcomm.com | 2007-08-01 |
| Aleksey Romanov | aromanov&juniper.net | 2010-10-12 |
| Alexey Grishin | Alexei.Grichine&billing.ru | 2009-12-04 |
| Avi Lior | avi&bridgewatersystems.com | 2011-04-07 |
| Björn Almén | bjorn.almen&ericsson.com | 2006-04-11 |
| Chiranjeev Agrawal | chiranjeev.agrawal&hp.com | 2011-11-04 |
| Christian Schubert | christian.schubert&iptego.de | 2007-10-22 |
| Claudio Lordello | clordello&juniper.net | 2009-08-21 |
| Dan D'Albuquerque | dan.dalbuquerque&apertio.com | 2008-04-14 |
| Francois-Frederic Ozog | ff&vedicis.com | 2011-02-25 |
| Gerhard Schmidt-Krschka | gerhard.schmidt-krschka&ericsson.com | 2015-08-19 |
| German Blanco | german.blanco&ericsson.com | 2009-05-12 |
| Hannes Tschofenig | Hannes.Tschofenig&gmx.net | 2013-07-23 |
| Hyungseok Chung | chunghs&etri.re.kr | 2009-04-14 |
| Inian Vasanth | ivasanthp&sandvine.com | 2015-07-26 |
| Irene Martin | irene.martin&ericsson.com | 2014-07-09 |
| J V Kishore | jvkk&hp.com | 2011-11-04 |
| Janusz Pieczerak | janusz.pieczerak&telekomunikacja.pl | 2009-09-08 |
| Jarda Nedved | jaroslav.nedved&openmindnetworks.com | 2024-08-06 |
| JayaKrishnan KP | jayakrishnan.a.k.p&ericsson.com | 2022-03-29 |
| Jin Seek Choi | jinseek&hanyang.ac.kr | 2012-01-04 |
| Jun Chang | jchang&juniper.net | 2007-12-10 |
| Jun Wang | jwang&qti.qualcomm.com | 2013-12-08 |
| Kimmo Kymalainen | kimmo.kymalainen&etsi.org | 2024-03-13 |
| Klaus Turina | Klaus.Turina&ericsson.com | 2013-10-23 |
| Kwihoon Kim | kwihooi&etri.re.kr | 2016-05-16 |
| Lars Anglert | lars.anglert&ericsson.com | 2011-10-27 |
| Laimutis Slecpenka | dev&tridigy.com | 2014-11-06 |
| Manfred Benten | manfred.benten&airbus.com | 2014-04-09 |
| Martin Del Vecchio | marty&covergence.com | 2007-11-06 |
| Michael Brenner | mrbrenner&alcatel-lucent.com | 2007-11-19 |
| Michael Mercurio | mmercurio&camiant.com | 2010-07-29 |
| Michiaki Hayashi | mc-hayashi&kddi.com | 2009-05-21 |
| Miguel Angel Reina Ortega | MiguelAngel.ReinaOrtega&etsi.org | 2010-01-08 |
| Niranjan Avula | niranjan.avula&verizonwireless.com | 2016-07-11 |
| Paul Prisaznuk | pprisaznuk&gmail.com | 2014-04-09 |
| S. Dhanalakshmi | s.dhanalakshmi&ericsson.com | 2018-12-14 |
| Sachin Rathee | sachin.rathee&convergys.com | 2008-12-10 |
| Sanjiv Parikh | sparikh&cloudmark.com | 2010-04-28 |
| Scott Luallin | Scott.Luallin&intrado.com | 2013-04-22 |
| Shicheng Hu | shicheng.hu&etsi.org | 2008-10-22 |
| Steffen Ries | sries&juniper.net | 2007-10-11 |
| Steve Donovan | steve.donovan&oracle.com | 2013-09-23 |
| Tarek Abou-Assali | tassali&camiant.com | 2010-07-29 |
| Timo Perala | timo.perala&nsn.com | 2015-02-17 |
| Tom Taylor | tom.taylor.stds&gmail.com | 2008-12-04 |
| Tomas Menzl | tomas.menzl&acision.com | 2010-05-12 |
| Torsten Oertel | torsten.oertel&vodafone.com | 2006-09-20 |
| Vincent D’Onofrio | registration&rivada.com | 2014-12-29 |
| Vitaly Dzhitenov | vitaly&juniper.net | 2014-10-29 |
| Wayne Cutler | wcutler&gsma.com | 2019-08-28 |
| Yoni Eitan | yeitan&sandvine.com | 2011-04-29 |