Access Node Control Protocol (ANCP)
ANCP Message Types
- RFC 6320: Protocol for Access Node Control Mechanism in Broadband Networks
The values for Message Type MAY range from 0 to 255, but new Message Types SHOULD be
assigned values sequentially from 90 onwards.
| Type |
Name |
Reference |
| 0-9 |
Unassigned |
|
| 10 |
Adjacency Protocol |
RFC 6320 |
| 11-31 |
Unassigned |
|
| 32 |
Port Management |
RFC 6320 |
| 33-79 |
Unassigned |
|
| 80 |
Port Up |
RFC 6320 |
| 81 |
Port Down |
RFC 6320 |
| 82-84 |
Unassigned |
|
| 85 |
Adjacency Update |
RFC 6320 |
| 86-90 |
Unassigned |
|
| 91 |
Generic Response |
RFC 6320 |
| 92 |
Unassigned |
|
| 93 |
Provisioning |
RFC 6320 |
| 94-143 |
Unassigned |
|
| 144 |
Multicast Replication Control |
RFC 7256 |
| 145 |
Multicast Admission Control |
RFC 7256 |
| 146 |
Bandwidth Reallocation Request |
RFC 7256 |
| 147 |
Bandwidth Transfer |
RFC 7256 |
| 148 |
Delegated Bandwidth Query |
RFC 7256 |
| 149 |
Multicast Flow Query |
RFC 7256 |
| 150 |
Committed Bandwidth Report |
RFC 7256 |
| 151-255 |
Unassigned |
|
ANCP Result Codes
- RFC 6320: Protocol for Access Node Control Mechanism in Broadband Networks
| Range |
Registration Procedures |
Note |
| 0x0-0xFFF |
IETF Review |
IANA SHOULD allocate new Result Code values from this range
sequentially beginning at 0x64. |
| 0x1000-0xFFFFFF |
Specification Required |
IANA SHOULD allocate new Result Code values from this
range sequentially beginning at 0x1000. |
| Code |
Description |
Reference |
| 0x0 |
No result |
RFC 6320 |
| 0x1 |
Unassigned |
|
| 0x2 |
Invalid request message |
RFC 6320 |
| 0x3-0x5 |
Unassigned |
|
| 0x6 |
One or more of the specified ports are down |
RFC 6320 |
| 0x7-0x12 |
Unassigned |
|
| 0x13 |
Out of resources |
RFC 6320 |
| 0x14-0x50 |
Unassigned |
|
| 0x51 |
Request message type not implemented |
RFC 6320 |
| 0x52 |
Unassigned |
|
| 0x53 |
Malformed message |
RFC 6320 |
| 0x54 |
Mandatory TLV missing |
RFC 6320 |
| 0x55 |
Invalid TLV contents |
RFC 6320 |
| 0x56-0x63 |
Unassigned |
|
| 0x64 |
Command error. |
RFC 7256 |
| 0x65 |
Invalid flow address. |
RFC 7256 |
| 0x66 |
Multicast flow does not exist. |
RFC 7256 |
| 0x67 |
Invalid preferred bandwidth amount. |
RFC 7256 |
| 0x68 |
Inconsistent views of delegated bandwidth amount. |
RFC 7256 |
| 0x69 |
Bandwidth request conflict. |
RFC 7256 |
| 0x6A-0x495 |
Unassigned |
|
| 0x500 |
One or more of the specified ports do not exist |
RFC 6320 |
| 0x501 |
Loopback test timed out |
RFC 6320 |
| 0x502 |
Reserved |
RFC 6320 |
| 0x503 |
DSL line status showtime |
RFC 6320 |
| 0x504 |
DSL line status idle |
RFC 6320 |
| 0x505 |
DSL line status silent |
RFC 6320 |
| 0x506 |
DSL line status training |
RFC 6320 |
| 0x507 |
DSL line integrity error |
RFC 6320 |
| 0x508 |
DSLAM resource not available |
RFC 6320 |
| 0x509 |
Invalid test parameter |
RFC 6320 |
| 0x50A-0xFFFFFF |
Unassigned |
|
ANCP Port Management Functions
- RFC 6320: Protocol for Access Node Control Mechanism in Broadband Networks
| Value |
Name |
Reference |
| 0 |
Reserved |
RFC 6320 |
| 1-7 |
Unassigned |
|
| 8 |
Configure Connection Service Data |
RFC 6320 |
| 9 |
Remote Loopback |
RFC 6320 |
| 10-255 |
Unassigned |
|
ANCP Technology Types
- RFC 6320: Protocol for Access Node Control Mechanism in Broadband Networks
| Type |
Meaning |
Reference |
| 0 |
Not technology dependent |
RFC 6320 |
| 1 |
Passive Optical Network (PON) |
RFC 6320 |
| 2-4 |
Unassigned |
|
| 5 |
Digital Subscriber Line (DSL) |
RFC 6320 |
| 6-254 |
Unassigned |
|
| 255 |
Reserved |
RFC 6320 |
ANCP Command Codes
- RFC 6320: Protocol for Access Node Control Mechanism in Broadband Networks
ANCP TLV Types
- RFC 6320: Protocol for Access Node Control Mechanism in Broadband Networks
| Range |
Registration Procedures |
Note |
| 0x0000-0x1FFF |
IETF Review |
IANA SHOULD allocate new Result Code values from this range
sequentially beginning at 0x100. |
| 0x2000-0xFFFF |
Specification Required |
IANA SHOULD allocate new Result Code values from this
range sequentially beginning at 0x2000. |
| Code |
Name |
Reference |
| 0x0000 |
Reserved |
RFC 6320 |
| 0x0001 |
Access-Loop-Circuit-ID |
RFC 6320 |
| 0x0002 |
Access-Loop-Remote-ID |
RFC 6320 |
| 0x0003 |
Access-Aggregation-Circuit-ID-ASCII |
RFC 6320 |
| 0x0004 |
DSL-Line-Attributes |
RFC 6320 |
| 0x0005 |
Service-Profile-Name |
RFC 6320 |
| 0x0006 |
Access-Aggregation-Circuit-ID-Binary |
RFC 6320 |
| 0x0007 |
OAM-Loopback-Test-Parameters |
RFC 6320 |
| 0x0008 |
Opaque-Data |
RFC 6320 |
| 0x0009 |
OAM-Loopback-Test-Response-String |
RFC 6320 |
| 0x000A-0x0010 |
Unassigned |
|
| 0x0011 |
Command |
RFC 6320 |
| 0x0012 |
Unassigned |
|
| 0x0013 |
Multicast-Service-Profile |
RFC 7256 |
| 0x0014 |
Unassigned |
|
| 0x0015 |
Bandwidth-Allocation |
RFC 7256 |
| 0x0016 |
Bandwidth-Request |
RFC 7256 |
| 0x0017 |
Unassigned |
|
| 0x0018 |
Multicast-Service-Profile-Name |
RFC 7256 |
| 0x0019 |
Multicast-Flow |
RFC 7256 |
| 0x001a-0x0020 |
Unassigned |
|
| 0x0021 |
List-Action |
RFC 7256 |
| 0x0022 |
Sequence-Number |
RFC 7256 |
| 0x0023 |
Unassigned |
|
| 0x0024 |
White-List-CAC |
RFC 7256 |
| 0x0025 |
MRepCtl-CAC |
RFC 7256 |
| 0x0026-0x0080 |
Unassigned |
|
| 0x0081 |
Actual-Net-Data-Rate-Upstream |
RFC 6320 |
| 0x0082 |
Actual-Net-Data-Rate-Downstream |
RFC 6320 |
| 0x0083 |
Minimum-Net-Data-Rate-Upstream |
RFC 6320 |
| 0x0084 |
Minimum-Net-Data-Rate-Downstream |
RFC 6320 |
| 0x0085 |
Attainable-Net-Data-Rate-Upstream |
RFC 6320 |
| 0x0086 |
Attainable-Net-Data-Rate-Downstream |
RFC 6320 |
| 0x0087 |
Maximum-Net-Data-Rate-Upstream |
RFC 6320 |
| 0x0088 |
Maximum-Net-Data-Rate-Downstream |
RFC 6320 |
| 0x0089 |
Minimum-Net-Low-Power-Data-Rate-Upstream |
RFC 6320 |
| 0x008A |
Minimum-Net-Low-Power-Data-Rate-Downstream |
RFC 6320 |
| 0x008B |
Maximum-Interleaving-Delay-Upstream |
RFC 6320 |
| 0x008C |
Actual-Interleaving-Delay-Upstream |
RFC 6320 |
| 0x008D |
Maximum-Interleaving-Delay-Downstream |
RFC 6320 |
| 0x008E |
Actual-Interleaving-Delay-Downstream |
RFC 6320 |
| 0x008F |
DSL-Line-State |
RFC 6320 |
| 0x0090 |
Access-Loop-Encapsulation |
RFC 6320 |
| 0x0091 |
DSL-Type |
RFC 6320 |
| 0x0092 |
Request-Source-IP |
RFC 7256 |
| 0x0093 |
Request-Source-MAC |
RFC 7256 |
| 0x0094 |
Report-Buffering-Time |
RFC 7256 |
| 0x0095 |
Committed-Bandwidth |
RFC 7256 |
| 0x0096 |
Request-Source-Device-Id |
RFC 7256 |
| 0x0097-0x0105 |
Unassigned |
|
| 0x0106 |
Status-Info |
RFC 6320 |
| 0x0107-0x0FFF |
Unassigned |
|
| 0x1000 |
Target (single access line variant) |
RFC 6320 |
| 0x1001-0x1020 |
Reserved for Target variants |
RFC 6320 |
| 0x1021-0xFFFF |
Unassigned |
|
ANCP Capability Types
- RFC 6320: Protocol for Access Node Control Mechanism in Broadband Networks
| Value |
Name |
Tech Type |
Capability Data? |
Reference |
| 0 |
Reserved |
|
|
RFC 6320 |
| 1 |
DSL Topology Discovery |
5 |
No |
RFC 6320 |
| 2 |
DSL Line Configuration |
5 |
No |
RFC 6320 |
| 3 |
NAS-Initiated Multicast Replication |
0 |
No |
RFC 7256 |
| 4 |
DSL Line Testing |
5 |
No |
RFC 6320 |
| 5 |
Committed Bandwidth Reporting |
0 |
No |
RFC 7256 |
| 6 |
Conditional Access and Admission Control With White and Black Lists |
0 |
No |
RFC 7256 |
| 7 |
Conditional Access and Admission Control With Grey Lists |
0 |
No |
RFC 7256 |
| 8 |
Bandwidth Delegation |
0 |
No |
RFC 7256 |
| 9-255 |
Unassigned |
|
|
|
Joint GSMP / ANCP Version Registry
- RFC 6320: Protocol for Access Node Control Mechanism in Broadband Networks
| Version |
Description |
Reference |
| 0 |
Unassigned |
|
| 1 |
GSMP Version 1 |
RFC 1987 |
| 2 |
GSMP Version 2 |
RFC 2297 |
| 3 |
GSMP Version 3 |
RFC 3292 |
| 4-49 |
Unassigned |
|
| 50 |
ANCP Version 1 |
RFC 6320 |
| 51-255 |
Unassigned |
|