Address Resolution Protocol (ARP) Parameters

Last Updated

  • 2023-05-19

Note

Reverse Address Resolution Protocol Operation Codes The Reverse Address Resolution Protocol (RARP) specified in RFC 903 uses the "Reverse" codes below.

DYNAMIC REVERSE ARP The Dynamic Reverse Address Resolution Protocol (DRARP) uses the "DRARP" codes below. For further information, see RFC 1931.

INVERSE ADDRESS RESOLUTION PROTOCOL The Inverse Address Resolution Protocol (IARP) specified in RFC 2390 uses the "InARP" codes below.

Available Formats


Operation Codes

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 826: An Ethernet Address Resolution Protocol: Or Converting Network Protocol Addresses to 48.bit Ethernet Address for Transmission on Ethernet Hardware
  • RFC 5494: IANA Allocation Guidelines for the Address Resolution Protocol (ARP)

Available Formats

Number Operation Code (op) References
0 Reserved RFC 5494
1 REQUEST RFC 826; RFC 5227
2 REPLY RFC 826; RFC 5227
3 request Reverse RFC 903
4 reply Reverse RFC 903
5 DRARP-Request RFC 1931
6 DRARP-Reply RFC 1931
7 DRARP-Error RFC 1931
8 InARP-Request RFC 2390
9 InARP-Reply RFC 2390
10 ARP-NAK RFC 1577
11 MARS-Request Grenville Armitage
12 MARS-Multi Grenville Armitage
13 MARS-MServ Grenville Armitage
14 MARS-Join Grenville Armitage
15 MARS-Leave Grenville Armitage
16 MARS-NAK Grenville Armitage
17 MARS-Unserv Grenville Armitage
18 MARS-SJoin Grenville Armitage
19 MARS-SLeave Grenville Armitage
20 MARS-Grouplist-Request Grenville Armitage
21 MARS-Grouplist-Reply Grenville Armitage
22 MARS-Redirect-Map Grenville Armitage
23 MAPOS-UNARP Mitsuru Maruyama; RFC 2176
24 OP_EXP1 RFC 5494
25 OP_EXP2 RFC 5494
26-65534 Unassigned
65535 Reserved RFC 5494

Hardware Types

Expert(s)

  • Carlos Pignataro

Reference

  • RFC 826: An Ethernet Address Resolution Protocol: Or Converting Network Protocol Addresses to 48.bit Ethernet Address for Transmission on Ethernet Hardware
  • RFC 5494: IANA Allocation Guidelines for the Address Resolution Protocol (ARP)

Available Formats

Range Registration Procedures Note
requests for values below 256 Expert Review
requests for more than one value Expert Review
requests for one value greater than 255 First Come First Served
requests for one value, no value specified First Come First Served can only be assigned a two-octet value (i.e., a value greater than 255)
Number Hardware Type (hrd) Reference
0 Reserved RFC 5494
1 Ethernet (10Mb) Jon Postel
2 Experimental Ethernet (3Mb) Jon Postel
3 Amateur Radio AX.25 Philip Koch
4 Proteon ProNET Token Ring Avri Doria
5 Chaos Gill Pratt
6 IEEE 802 Networks Jon Postel
7 ARCNET RFC 1201
8 Hyperchannel Jon Postel
9 Lanstar Tom Unger
10 Autonet Short Address Mike Burrows
11 LocalTalk Joyce K. Reynolds
12 LocalNet (IBM PCNet or SYTEK LocalNET) Joseph Murdock
13 Ultra link Rajiv Dhingra
14 SMDS George Clapp
15 Frame Relay Andy Malis
16 Asynchronous Transmission Mode (ATM) [JXB2]
17 HDLC Jon Postel
18 Fibre Channel RFC 4338
19 Asynchronous Transmission Mode (ATM) RFC 2225
20 Serial Line Jon Postel
21 Asynchronous Transmission Mode (ATM) Mike Burrows
22 MIL-STD-188-220 Herb Jensen
23 Metricom Jonathan Stone
24 IEEE 1394.1995 Myron Hattig
25 MAPOS Mitsuru Maruyama; RFC 2176
26 Twinaxial Marion Pitts
27 EUI-64 Kenji Fujisawa
28 HIPARP Jean-Michel Pittet
29 IP and ARP over ISO 7816-3 Scott Guthery
30 ARPSec Jerome Etienne
31 IPsec tunnel RFC 3456
32 InfiniBand (TM) RFC 4391
33 TIA-102 Project 25 Common Air Interface (CAI) Jeff Anderson, Telecommunications Industry of America (TIA) TR-8.5 Formulating Group, <cja015&motorola.com>, June 2004
34 Wiegand Interface Scott Guthery
35 Pure IP Inaky Perez-Gonzalez
36 HW_EXP1 RFC 5494
37 HFI Tseng-Hui Lin
38 Unified Bus (UB) Wei Pan
39-255 Unassigned
256 HW_EXP2 RFC 5494
257 AEthernet Geoffroy Gramaize
258-65534 Unassigned
65535 Reserved RFC 5494

Protocol Type

Registration Procedure(s)

  • The Ethertype space is administered as described in RFC 5342.

Reference

  • RFC 826: An Ethernet Address Resolution Protocol: Or Converting Network Protocol Addresses to 48.bit Ethernet Address for Transmission on Ethernet Hardware
  • RFC 5494: IANA Allocation Guidelines for the Address Resolution Protocol (ARP)
  • RFC 5342: IANA Considerations and IETF Protocol Usage for IEEE 802 Parameters

Note

These numbers share the Ethertype space. See IANA OUI Ethernet Numbers.

No registrations at this time.

Contact Information

Name Contact URI Last Updated
Andy Malis agmalis&gmail.com 2013-05-28
Avri Doria avri&peoteon.com 1994-12
Geoffroy Gramaize geoffroy.iana&gramaize.eu 2016-07-20
George Clapp meritec!clapp&bellcore.bellcore.com
Gill Pratt gill%25mit-ccc@mc.lcs.mit.edu
Grenville Armitage gja&thumper.belcore.com 1995-04
Herb Jensen hwjensen&itt.com 1995-02
Inaky Perez-Gonzalez inaky.perez-gonzalez&intel.com 2008-10-01
Jean-Michel Pittet jmp&gandalf.engr.sgi.com 1998-11
Jerome Etienne jetienne&arobas.net 2000-06
Jon Postel postel&isi.edu
Jonathan Stone jonathan&dsg.stanford.edu 1996-05
Joyce K. Reynolds jkrey&isi.edu
Kenji Fujisawa fujisawa&sm.sony.co.jp 1998-10
Marion Pitts marionp&vnet.ibm.com 1997-05
Mike Burrows burrows&src.dec.com
Mitsuru Maruyama mitsuru&ntt-20.ecl.net 1997-03
Myron Hattig Myron_Hattig&ccm.jf.intel.com 1997-02
Philip Koch Philip.Koch&dartmouth.edu
Rajiv Dhingra rajiv&ultra.com
Scott Guthery sguthery&mobile-mind.com 2000-03
Scott Guthery sguthery&hidcorp.com 2008-09-25
Tom Unger tom&citi.umich
Tseng-Hui Lin tsenglin&us.ibm.com
Wei Pan tarzan.pan&huawei.com 2023-05-19