Dynamic Host Configuration Protocol (DHCP) Authentication Option Name Spaces

Created

  • 2001-05-15

Last Updated

  • 2026-02-02

Available Formats


Protocol Name Space Values

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 3118: Authentication for DHCP Messages

Available Formats

Value Description Reference
0 configuration token RFC 3118
1 delayed authentication RFC 3118
2 Delayed Authentication (Obsolete) RFC 9915
3 Reconfigure Key RFC 9915
4 Split-horizon DNS RFC 9704

Algorithm Name Space Values

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 3118: Authentication for DHCP Messages

configuration token (0) Algorithms

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 3118: Authentication for DHCP Messages

Available Formats

Value Description Reference
0 configuration token RFC 3118

delayed authentication (1) Algorithms, Delayed Authentication (2) Algorithms, and Reconfigure Key (3) Algorithms

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 3118: Authentication for DHCP Messages

Available Formats

Value Description Reference
1 HMAC-MD5 RFC 3118; RFC 9915

RDM Name Space Values

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 3118: Authentication for DHCP Messages

Available Formats

Value Description Reference
0 use of a monotonically increasing value RFC 3118; RFC 9915