Babel TLV Types
Expert(s)
- Juliusz Chroboczek, Donald Eastlake
Reference
- RFC 8966: The Babel Routing Protocol
Available Formats
| Range | Registration Procedures |
|---|---|
| 0-223 | Specification Required |
| 224-254 | Experimental Use |
| Type | Name | Reference |
|---|---|---|
| 0 | Pad1 | RFC 8966 |
| 1 | PadN | RFC 8966 |
| 2 | Acknowledgment Request | RFC 8966 |
| 3 | Acknowledgment | RFC 8966 |
| 4 | Hello | RFC 8966 |
| 5 | IHU | RFC 8966 |
| 6 | Router-Id | RFC 8966 |
| 7 | Next Hop | RFC 8966 |
| 8 | Update | RFC 8966 |
| 9 | Route Request | RFC 8966 |
| 10 | Seqno Request | RFC 8966 |
| 11 | TS/PC | RFC 7298 |
| 12 | HMAC | RFC 7298 |
| 13 | Reserved | previously used in an early version of draft-ietf-babel-source-specific |
| 14 | Reserved | previously used in an early version of draft-ietf-babel-source-specific |
| 15 | Reserved | previously used in an early version of draft-ietf-babel-source-specific |
| 16 | MAC | RFC 8967 |
| 17 | PC | RFC 8967 |
| 18 | Challenge Request | RFC 8967 |
| 19 | Challenge Reply | RFC 8967 |
| 20-223 | Unassigned | |
| 224-254 | Reserved for Experimental Use | RFC 8966 |
| 255 | Reserved for expansion of the type space | RFC 8966 |
Babel Sub-TLV Types
Expert(s)
- Juliusz Chroboczek, Donald Eastlake
Reference
- RFC 8966: The Babel Routing Protocol
Available Formats
| Range | Registration Procedures |
|---|---|
| 0-111 | Specification Required |
| 112-126 | Experimental Use |
| 128-239 | Specification Required |
| 240-254 | Experimental Use |
| Type | Name | Reference |
|---|---|---|
| 0 | Pad1 | RFC 8966 |
| 1 | PadN | RFC 8966 |
| 2 | Diversity | draft-chroboczek-babel-diversity-routing-00 |
| 3 | Timestamp | RFC 9616 |
| 4-111 | Unassigned | |
| 112-126 | Reserved for Experimental Use | RFC 8966 |
| 127 | Reserved for expansion of the type space | RFC 8966 |
| 128 | Source Prefix | RFC 9079 |
| 129-239 | Unassigned | |
| 240-254 | Reserved for Experimental Use | RFC 8966 |
| 255 | Reserved for expansion of the type space | RFC 8966 |
Babel Update Flags Values
Registration Procedure(s)
- Specification Required
Expert(s)
- Juliusz Chroboczek, Donald Eastlake
Reference
- RFC 8966: The Babel Routing Protocol
Available Formats
Babel Address Encodings
Expert(s)
- Juliusz Chroboczek, Donald Eastlake
Reference
- RFC 8966: The Babel Routing Protocol
Available Formats
| Range | Registration Procedures |
|---|---|
| 0-223 | Specification Required |
| 224-254 | Experimental Use |