Border Gateway Protocol (BGP) Extended Communities
BGP Transitive Extended Community Types
- RFC 7153: IANA Registries for BGP Extended Communities
- RFC 9184: BGP Extended Community Registries Update
This registry contains values of the high-order octet (the "Type"
field) of a Transitive Extended Community.
When an Extended Community requests allocation for a code point of
both transitive and non-transitive variants for the same type/sub-type,
it is recommended that the same value be assigned to them.
| Range |
Registration Procedures |
Note |
| 0x00-0x3f |
First Come First Served |
|
| 0x80-0x82 |
First Come First Served |
see RFC 9184 |
| 0x83-0x8f |
Reserved for Experimental Use |
see RFC 3692 |
| 0x90-0xbf |
Standards Action |
|
| Type Value |
Name |
Reference |
Date |
| 0x00 |
Transitive Two-Octet AS-Specific Extended Community
(Sub-Types are defined in the "Transitive Two-octet AS-Specific Extended
Community Sub-Types" registry) |
RFC 7153; RFC-ietf-idr-rfc4360-bis-09 |
|
| 0x01 |
Transitive IPv4-Address-Specific Extended Community
(Sub-Types are defined in the "Transitive IPv4-Address-Specific Extended
Community Sub-Types" registry) |
RFC 7153; RFC-ietf-idr-rfc4360-bis-09 |
|
| 0x02 |
Transitive Four-Octet AS-Specific Extended Community
(Sub-Types are defined in the "Transitive Four-octet AS-Specific Extended
Community Sub-Types" registry) |
RFC 7153 |
|
| 0x03 |
Transitive Opaque Extended Community
(Sub-Types are defined in the "Transitive Opaque Extended
Community Sub-Types" registry) |
RFC 7153; RFC-ietf-idr-rfc4360-bis-09 |
|
| 0x04 |
QoS Marking |
Thomas Martin Knoll |
2008-12-30 |
| 0x05 |
CoS Capability |
Thomas Martin Knoll |
2009-05-18 |
| 0x06 |
EVPN (Sub-Types are defined in the "EVPN Extended
Community Sub-Types" registry) |
RFC 7153 |
|
| 0x07 |
FlowSpec Transitive Extended Communities |
draft-ietf-idr-flowspec-interfaceset-03 |
2017-03-16 |
| 0x08 |
Flow spec redirect/mirror to IP next-hop |
draft-simpson-idr-flowspec-redirect-01 |
2012-09-28 |
| 0x09 |
FlowSpec Redirect to indirection-id Extended Community |
draft-ietf-idr-flowspec-path-redirect-05 |
2018-05-18 |
| 0x0a |
Transport Class |
RFC 9832 |
2020-07-01 |
| 0x0b |
SFC (Sub-Types are defined in the "SFC Extended Community Sub-Types" registry) |
RFC 9015 |
2020-09-02 |
| 0x0c |
SRv6 MUP Extended Community |
draft-mpmz-bess-mup-safi-00 |
2022-08-10 |
| 0x0d |
Source PE Extended Community |
RFC-ietf-idr-vpn-prefix-orf-45 |
2026-07-18 |
| 0x0e-0x3f |
Unassigned |
|
|
| 0x80 |
Generic Transitive Extended Community (Sub-Types
are defined in the "Generic Transitive Extended Community
Sub-Types" registry) |
RFC 7153; RFC 9184 |
|
| 0x81 |
Generic Transitive Extended Community Part 2
(Sub-Types are defined in the "Generic Transitive
Extended Community Part 2 Sub-Types" registry) |
RFC 8955; RFC 9184 |
2015-08-28 |
| 0x82 |
Generic Transitive Extended Community Part 3
(Sub-Types are defined in the "Generic Transitive
Extended Community Part 3 Sub-Types" registry) |
RFC 8955; RFC 9184 |
2015-08-28 |
| 0x83-0x8f |
Reserved for Experimental Use |
RFC 7153 |
2012-09-28 |
| 0x90-0xbf |
Unassigned |
|
|
BGP Non-Transitive Extended Community Types
- RFC 7153: IANA Registries for BGP Extended Communities
This registry contains values of the high-order octet (the "Type"
field) of a Non-transitive Extended Community.
When an Extended Community requests allocation for a code point of
both transitive and non-transitive variants for the same type/sub-type,
it is recommended that the same value be assigned to them.
| Range |
Registration Procedures |
Note |
| 0x40-0x7f |
First Come First Served |
|
| 0xc0-0xcf |
Reserved for Experimental Use |
see RFC 3692 |
| 0xd0-0xff |
Standards Action |
|
| Type Value |
Name |
Reference |
Date |
| 0x40 |
Non-Transitive Two-Octet AS-Specific Extended Community
(Sub-Types are defined in the "Non-Transitive Two-octet AS-Specific Extended
Community Sub-Types" registry) |
RFC 7153; RFC-ietf-idr-rfc4360-bis-09 |
|
| 0x41 |
Non-Transitive IPv4-Address-Specific Extended Community
(Sub-Types are defined in the "Non-Transitive IPv4-Address-Specific Extended
Community Sub-Types" registry) |
RFC 7153; RFC-ietf-idr-rfc4360-bis-09 |
|
| 0x42 |
Non-Transitive Four-Octet AS-Specific Extended Community
(Sub-Types are defined in the "Non-Transitive Four-octet AS-Specific Extended
Community Sub-Types" registry) |
RFC 7153 |
|
| 0x43 |
Non-Transitive Opaque Extended Community
(Sub-Types are defined in the "Non-Transitive Opaque Extended
Community Sub-Types" registry) |
RFC 7153; RFC-ietf-idr-rfc4360-bis-09 |
|
| 0x44 |
QoS Marking |
Thomas Martin Knoll |
2008-12-30 |
| 0x45-0x46 |
Unassigned |
|
|
| 0x47 |
FlowSpec Non-Transitive Extended Communities |
draft-ietf-idr-flowspec-interfaceset-03 |
2016-03-16 |
| 0x48-0x49 |
Unassigned |
|
|
| 0x4a |
Non-Transitive Transport Class |
RFC 9832 |
2020-07-01 |
| 0x4b-0x7f |
Unassigned |
|
|
| 0xc0-0xcf |
Reserved for Experimental Use |
RFC 7153 |
2012-09-28 |
| 0xd0-0xff |
Unassigned |
|
|
EVPN Extended Community Sub-Types
- RFC 7153: IANA Registries for BGP Extended Communities
This registry contains values of the second octet (the "Sub-Type"
field) of an extended community when the value of the first
octet (the "Type" field) is 0x06.
| Range |
Registration Procedures |
| 0x00-0xbf |
First Come First Served |
| 0xc0-0xff |
IETF Review |
Transitive Two-Octet AS-Specific Extended Community Sub-Types
- RFC 7153: IANA Registries for BGP Extended Communities
This registry contains values of the second octet (the "Sub-Type"
field) of an extended community when the value of the first
octet (the "Type" field) is 0x00.
When an Extended Community requests allocation for a code point of
both transitive and non-transitive variants for the same type/sub-type,
it is recommended that the same value be assigned to them.
| Range |
Registration Procedures |
| 0x00-0xbf |
First Come First Served |
| 0xc0-0xff |
IETF Review |
Non-Transitive Two-Octet AS-Specific Extended Community Sub-Types
- RFC 7153: IANA Registries for BGP Extended Communities
This registry contains values of the second octet (the "Sub-Type"
field) of an extended community when the value of the first
octet (the "Type" field) is 0x40.
When an Extended Community requests allocation for a code point of
both transitive and non-transitive variants for the same type/sub-type,
it is recommended that the same value be assigned to them.
| Range |
Registration Procedures |
| 0x00-0xbf |
First Come First Served |
| 0xc0-0xff |
IETF Review |
Transitive Four-Octet AS-Specific Extended Community Sub-Types
- RFC 7153: IANA Registries for BGP Extended Communities
This registry contains values of the second octet (the "Sub-Type"
field) of an extended community when the value of the first
octet (the "Type" field) is 0x02.
When an Extended Community requests allocation for a code point of
both transitive and non-transitive variants for the same type/sub-type,
it is recommended that the same value be assigned to them.
| Range |
Registration Procedures |
| 0x00-0xbf |
First Come First Served |
| 0xc0-0xff |
IETF Review |
Non-Transitive Four-Octet AS-Specific Extended Community Sub-Types
- RFC 7153: IANA Registries for BGP Extended Communities
This registry contains values of the second octet (the "Sub-Type"
field) of an extended community when the value of the first
octet (the "Type" field) is 0x42.
When an Extended Community requests allocation for a code point of
both transitive and non-transitive variants for the same type/sub-type,
it is recommended that the same value be assigned to them.
| Range |
Registration Procedures |
| 0x00-0xbf |
First Come First Served |
| 0xc0-0xff |
IETF Review |
Transitive IPv4-Address-Specific Extended Community Sub-Types
- RFC 7153: IANA Registries for BGP Extended Communities
This registry contains values of the second octet (the "Sub-Type"
field) of an extended community when the value of the first
octet (the "Type" field) is 0x01.
When an Extended Community requests allocation for a code point of
both transitive and non-transitive variants for the same type/sub-type,
it is recommended that the same value be assigned to them.
| Range |
Registration Procedures |
| 0x00-0xbf |
First Come First Served |
| 0xc0-0xff |
IETF Review |
Non-Transitive IPv4-Address-Specific Extended Community Sub-Types
- RFC 7153: IANA Registries for BGP Extended Communities
This registry contains values of the second octet (the "Sub-Type"
field) of an extended community when the value of the first
octet (the "Type" field) is 0x41.
When an Extended Community requests allocation for a code point of
both transitive and non-transitive variants for the same type/sub-type,
it is recommended that the same value be assigned to them.
| Range |
Registration Procedures |
| 0x00-0xbf |
First Come First Served |
| 0xc0-0xff |
IETF Review |
Transitive Opaque Extended Community Sub-Types
- RFC 7153: IANA Registries for BGP Extended Communities
This registry contains values of the second octet (the "Sub-Type"
field) of an extended community when the value of the first
octet (the "Type" field) is 0x03.
When an Extended Community requests allocation for a code point of
both transitive and non-transitive variants for the same type/sub-type,
it is recommended that the same value be assigned to them.
| Range |
Registration Procedures |
| 0x00-0xbf |
First Come First Served |
| 0xc0-0xff |
IETF Review |
Non-Transitive Opaque Extended Community Sub-Types
- RFC 7153: IANA Registries for BGP Extended Communities
This registry contains values of the second octet (the "Sub-Type"
field) of an extended community when the value of the first
octet (the "Type" field) is 0x43.
When an Extended Community requests allocation for a code point of
both transitive and non-transitive variants for the same type/sub-type,
it is recommended that the same value be assigned to them.
| Range |
Registration Procedures |
| 0x00-0xbf |
First Come First Served |
| 0xc0-0xff |
IETF Review |
Generic Transitive Extended Community Sub-Types
- RFC 7153: IANA Registries for BGP Extended Communities
- RFC 9184: BGP Extended Community Registries Update
This registry contains values of the second octet (the "Sub-Type"
field) of an extended community when the value of the first
octet (the "Type" field) is 0x80.
| Range |
Registration Procedures |
| 0x00-0xbf |
First Come First Served |
| 0xc0-0xff |
IETF Review |
Generic Transitive Extended Community Part 2 Sub-Types
- RFC 8955: Dissemination of Flow Specification Rules
- RFC 9184: BGP Extended Community Registries Update
This registry contains values of the second octet (the "Sub-Type"
field) of an extended community when the value of the first
octet (the "Type" field) is 0x81.
| Range |
Registration Procedures |
| 0x00-0xbf |
First Come First Served |
| 0xc0-0xff |
IETF Review |
| Sub-Type Value |
Name |
Reference |
Date |
| 0x00-0x07 |
Unassigned |
|
|
| 0x08 |
Flow spec rt-redirect IPv4 format |
RFC 8955 |
2015-08-28 |
| 0x09-0xff |
Unassigned |
|
|
Generic Transitive Extended Community Part 3 Sub-Types
- RFC 8955: Dissemination of Flow Specification Rules
- RFC 9184: BGP Extended Community Registries Update
This registry contains values of the second octet (the "Sub-Type"
field) of an extended community when the value of the first
octet (the "Type" field) is 0x82.
| Range |
Registration Procedures |
| 0x00-0xbf |
First Come First Served |
| 0xc0-0xff |
IETF Review |
Traffic Action Fields
- RFC 8955: Dissemination of Flow Specification Rules
Bit 0 is the most significant, or leftmost bit of the six-byte
field; bit 47 is the least significant, or rightmost bit.
| Bit |
Name |
Reference |
Date |
| 47 |
Terminal Action |
RFC 8955 |
|
| 46 |
Sample |
RFC 8955 |
|
| 0-45 |
Unassigned |
|
|
Transitive IPv6-Address-Specific Extended Community Types
- RFC 7153: IANA Registries for BGP Extended Communities
This registry contains values of the two high-order octets of an
IPv6-Address-Specific Extended Community.
When an Extended Community requests allocation for a code point of
both transitive and non-transitive variants for the same type/sub-type,
it is recommended that the same value be assigned to them.
Non-Transitive IPv6-Address-Specific Extended Community Types
- RFC 7153: IANA Registries for BGP Extended Communities
This registry contains values of the two high-order octets of an
IPv6-Address-Specific Extended Community.
When an Extended Community requests allocation for a code point of
both transitive and non-transitive variants for the same type/sub-type,
it is recommended that the same value be assigned to them.
| Type Value |
Name |
Reference |
Date |
| 0x4000-0x40ff |
Unassigned |
|
|
Additional PMSI Tunnel Attribute Flags
- RFC 7902: Registry and Extensions for P-Multicast Service Interface Tunnel Attribute Flags
| Bit Flag |
Name |
Reference |
Date |
| 0-46 |
Unassigned |
|
|
| 47 |
DCB |
RFC 9573 |
2019-01-23 |
EVPN Layer 2 Attributes Control Flags
- RFC 8214: Virtual Private Wire Service Support in Ethernet VPN
| Sub-Type Value |
Name |
Reference |
Date |
| P |
Advertising PE is the primary PE. |
RFC 8214 |
2017-06-15 |
| B |
Advertising PE is the backup PE. |
RFC 8214 |
2017-06-15 |
| C |
Control word RFC 4448 MUST be present. |
RFC 8214 |
2017-06-15 |
| M |
Signaling mode of operation (bits 10-11) |
RFC 9744 |
2024-12-20 |
| V |
VLAN-ID normalization (bits 8-9) |
RFC 9744 |
2024-12-20 |
E-Tree Flags
- RFC 8317: Ethernet-Tree (E-Tree) Support in Ethernet VPN (EVPN) and Provider Backbone Bridging EVPN (PBB-EVPN)
| Bit |
Name |
Reference |
Date |
| 0-6 |
Unassigned |
|
|
| 7 |
Leaf-Indication |
RFC 8317 |
2017-12-05 |
DF Alg
- RFC 8584: Framework for Ethernet VPN Designated Forwarder Election Extensibility
| Alg |
Name |
Reference |
Date |
| 0 |
Default DF Election |
RFC 8584 |
2019-02-01 |
| 1 |
HRW Algorithm |
RFC 8584 |
2019-02-01 |
| 2 |
Highest-Preference Algorithm |
RFC 9785 |
2023-11-05 |
| 3 |
Lowest-Preference Algorithm |
RFC 9785 |
2023-11-05 |
| 4-30 |
Unassigned |
|
|
| 31 |
Reserved for Experimental Use |
RFC 8584 |
2019-02-01 |
DF Election Capabilities
- RFC 8584: Framework for Ethernet VPN Designated Forwarder Election Extensibility
| Bit |
Name |
Reference |
Date |
| 0 |
D (Don't Preempt) Capability |
RFC 9785 |
2023-11-05 |
| 1 |
AC-DF Capability |
RFC 8584 |
2019-02-01 |
| 2 |
Unassigned |
|
|
| 3 |
Time Synchronization |
RFC 9722 |
2024-11-27 |
| 4 |
BW (Bandwidth Weighted DF Election) |
RFC-ietf-bess-evpn-unequal-lb-35 |
2026-03-19 |
| 5 |
Port Mode Designated Forwarder Election |
RFC 9786 |
2024-12-12 |
| 6-15 |
Unassigned |
|
|
Multicast Flags Extended Community
- RFC 9251: Internet Group Management Protocol (IGMP) and Multicast Listener Discovery (MLD) Proxies for Ethernet VPN (EVPN)
Context-Specific Label Space ID Type
- RFC 9573: MVPN/EVPN Tunnel Aggregation with Common Labels
| Type Value |
Name |
Reference |
Change Controller |
Date |
| 0 |
MPLS Label |
RFC 9573 |
IETF |
2023-10-09 |
| 1-254 |
Unassigned |
|
|
|
| 255 |
Reserved |
RFC 9573 |
|
|
Multihoming Redundancy Mode
- RFC 9746: BGP EVPN Multihoming Extensions for Split-Horizon Filtering
| Value |
Multihoming Redundancy Mode |
Reference |
Date |
| 00 |
All-Active |
RFC 7432 |
2024-09-09 |
| 01 |
Single-Active |
RFC 7432 |
2024-09-09 |
| 10 |
Unassigned |
|
|
| 11 |
Unassigned |
|
|
Split-Horizon Type
- RFC 9746: BGP EVPN Multihoming Extensions for Split-Horizon Filtering
| Value |
Split-Horizon Type Value |
Reference |
Date |
| 00 |
Default SHT |
RFC 9746 |
2024-09-09 |
| 01 |
Local Bias |
RFC 9746 |
2024-09-09 |
| 10 |
ESI Label-based filtering |
RFC 9746 |
2024-09-09 |
| 11 |
Unassigned |
|
|
Transitive Transport Class Extended Community Sub-Types
This registry contains values of the second octet (the
"Sub-Type" field) of an extended community when the value
of the first octet (the "Type" field) is 0x0a.
| Range |
Registration Procedures |
| 0x00-0xbf |
First Come First Served |
| 0xc0-0xff |
IETF Review |
| Sub-Type Value |
Name |
Reference |
Date |
| 0x00-0x01 |
Unassigned |
|
|
| 0x02 |
Route Target |
RFC 9832 |
2025-03-10 |
| 0x03-0xff |
Unassigned |
|
|
Non-Transitive Transport Class Extended Community Sub-Types
This registry contains values of the second octet (the
"Sub-Type" field) of an extended community when the value
of the first octet (the "Type" field) is 0x4a.
| Range |
Registration Procedures |
| 0x00-0xbf |
First Come First Served |
| 0xc0-0xff |
IETF Review |
| Sub-Type Value |
Name |
Reference |
Date |
| 0x00-0x01 |
Unassigned |
|
|
| 0x02 |
Route Target |
RFC 9832 |
2025-03-10 |
| 0x03-0xff |
Unassigned |
|
|
EVPN Link Bandwidth Value Units
Contact Information