Border Gateway Protocol (BGP) Parameters
BGP Message Types
- RFC 4271: A Border Gateway Protocol 4 (BGP-4)
BGP Path Attributes
- RFC 4271: A Border Gateway Protocol 4 (BGP-4)
| Value |
Code |
Reference |
| 0 |
Reserved |
|
| 1 |
ORIGIN |
RFC 4271 |
| 2 |
AS_PATH |
RFC 4271 |
| 3 |
NEXT_HOP |
RFC 4271 |
| 4 |
MULTI_EXIT_DISC |
RFC 4271 |
| 5 |
LOCAL_PREF |
RFC 4271 |
| 6 |
ATOMIC_AGGREGATE |
RFC 4271 |
| 7 |
AGGREGATOR |
RFC 4271 |
| 8 |
COMMUNITIES |
RFC 1997 |
| 9 |
ORIGINATOR_ID |
RFC 4456 |
| 10 |
CLUSTER_LIST |
RFC 4456 |
| 11 |
DPA (deprecated) |
Chen, E., Bates, T., "Destination Preference Attribute for BGP",
Work in progress, March 1996.; RFC 6938 |
| 12 |
ADVERTISER (historic) (deprecated) |
RFC 1863; RFC 4223; RFC 6938 |
| 13 |
RCID_PATH / CLUSTER_ID (Historic) (deprecated) |
RFC 1863; RFC 4223; RFC 6938 |
| 14 |
MP_REACH_NLRI |
RFC 4760 |
| 15 |
MP_UNREACH_NLRI |
RFC 4760 |
| 16 |
EXTENDED COMMUNITIES |
Eric Rosen; draft-ramachandra-bgp-ext-communities-00; RFC-ietf-idr-rfc4360-bis-09 |
| 17 |
AS4_PATH |
RFC 6793 |
| 18 |
AS4_AGGREGATOR |
RFC 6793 |
| 19 |
SAFI Specific Attribute (SSA) (deprecated) |
Gargi Nalawade; draft-kapoor-nalawade-idr-bgp-ssa-00; draft-nalawade-idr-mdt-safi-00; draft-wijnands-mt-discovery-00 |
| 20 |
Connector Attribute (deprecated) |
RFC 6037 |
| 21 |
AS_PATHLIMIT (deprecated) |
draft-ietf-idr-as-pathlimit-02 |
| 22 |
PMSI_TUNNEL |
RFC 6514 |
| 23 |
Tunnel Encapsulation |
RFC 9012 |
| 24 |
Traffic Engineering |
RFC 5543 |
| 25 |
IPv6 Address Specific Extended Community |
RFC 5701 |
| 26 |
AIGP |
RFC 7311 |
| 27 |
PE Distinguisher Labels |
RFC 6514 |
| 28 |
BGP Entropy Label Capability Attribute (deprecated) |
RFC 6790; RFC 7447 |
| 29 |
BGP-LS Attribute |
RFC 9552 |
| 30 |
Deprecated |
RFC 8093 |
| 31 |
Deprecated |
RFC 8093 |
| 32 |
LARGE_COMMUNITY |
RFC 8092 |
| 33 |
BGPsec_Path |
RFC 8205 |
| 34 |
BGP Community Container Attribute
(TEMPORARY - registered 2017-07-28, extension registered 2024-08-22, expires 2025-07-28) |
draft-ietf-idr-wide-bgp-communities-11 |
| 35 |
Only to Customer (OTC) |
RFC 9234 |
| 36 |
BGP Domain Path (D-PATH) |
RFC 10039 |
| 37 |
SFP attribute |
RFC 9015 |
| 38 |
BFD Discriminator |
RFC 9026 |
| 39 |
Next Hop Dependent Characteristic (NHC) |
RFC-ietf-idr-nhc-07 |
| 40 |
BGP Prefix-SID |
RFC 8669 |
| 41 |
BIER |
RFC 9793 |
| 42 |
Edge Metadata Path Attribute (TEMPORARY - registered 2025-04-23, extension registered 2026-04-03, expires 2027-04-23) |
draft-ietf-idr-5g-edge-service-metadata-27 |
| 43-127 |
Unassigned |
|
| 128 |
ATTR_SET |
RFC 6368 |
| 129 |
Deprecated |
RFC 8093 |
| 130-240 |
Unassigned |
|
| 241 |
Deprecated |
RFC 8093 |
| 242 |
Deprecated |
RFC 8093 |
| 243 |
Deprecated |
RFC 8093 |
| 244-254 |
Unassigned |
|
| 255 |
Reserved for development |
RFC 2042 |
BGP Error (Notification) Codes
- RFC 4271: A Border Gateway Protocol 4 (BGP-4)
- RFC 7313: Enhanced Route Refresh Capability for BGP-4
BGP Error Subcodes
- RFC 4271: A Border Gateway Protocol 4 (BGP-4)
Message Header Error subcodes
- RFC 4271: A Border Gateway Protocol 4 (BGP-4)
OPEN Message Error subcodes
- RFC 4271: A Border Gateway Protocol 4 (BGP-4)
UPDATE Message Error subcodes
- RFC 4271: A Border Gateway Protocol 4 (BGP-4)
BGP Finite State Machine Error Subcodes
- RFC 6608: Subcodes for BGP Finite State Machine Error
| Value |
Name |
Reference |
| 0 |
Unspecified Error |
RFC 6608 |
| 1 |
Receive Unexpected Message in OpenSent State |
RFC 6608 |
| 2 |
Receive Unexpected Message in OpenConfirm State |
RFC 6608 |
| 3 |
Receive Unexpected Message in Established State |
RFC 6608 |
| 4-255 |
Unassigned |
|
BGP Cease NOTIFICATION message subcodes
- Standards Action or Early IANA Allocation process
- RFC 4486: Subcodes for BGP Cease Notification Message
BGP ROUTE-REFRESH Message Error subcodes
- RFC 7313: Enhanced Route Refresh Capability for BGP-4
| Range |
Registration Procedures |
| 0-127 |
Standards Action |
| 128-255 |
First Come First Served |
| Value |
Name |
Reference |
| 0 |
Reserved |
RFC 7313 |
| 1 |
Invalid Message Length |
RFC 7313 |
| 2-255 |
Unassigned |
|
BGP Outbound Route Filtering (ORF) Types
- RFC 5291: Outbound Route Filtering Capability for BGP-4
| Range |
Registration Procedures |
Note |
| 0-63 |
Standards Action |
|
| 64-127 |
First Come First Served |
|
| 128-255 |
Vendor-Specific |
IANA does not assign |
BGP OPEN Optional Parameter Types
- RFC 5492: Capabilities Advertisement with BGP-4
BGP Layer 2 Encapsulation Types
- RFC 6624: Layer 2 Virtual Private Networks Using BGP for Auto-Discovery and Signaling
When this registry is modified, the YANG module iana-bgp-l2-encaps must be updated
as defined in RFC 9291.
| Range |
Registration Procedures |
| 0-127 |
Expert Review |
| 128-251 |
First Come First Served |
| 252-255 |
Experimental Use |
| Value |
Description |
Reference |
| 0 |
Reserved |
RFC 6624 |
| 1 |
Frame Relay |
RFC 4446 |
| 2 |
ATM AAL5 SDU VCC transport |
RFC 4446 |
| 3 |
ATM transparent cell transport |
RFC 4816 |
| 4 |
Ethernet (VLAN) Tagged Mode |
RFC 4448 |
| 5 |
Ethernet Raw Mode |
RFC 4448 |
| 6 |
Cisco HDLC |
RFC 4618 |
| 7 |
PPP |
RFC 4618 |
| 8 |
SONET/SDH Circuit Emulation Service |
RFC 4842 |
| 9 |
ATM n-to-one VCC cell transport |
RFC 4717 |
| 10 |
ATM n-to-one VPC cell transport |
RFC 4717 |
| 11 |
IP Layer 2 Transport |
RFC 3032 |
| 12-14 |
Unassigned |
|
| 15 |
Frame Relay Port mode |
RFC 4619 |
| 16 |
Unassigned |
|
| 17 |
Structure-agnostic E1 over packet |
RFC 4553 |
| 18 |
Structure-agnostic T1 (DS1) over packet |
RFC 4553 |
| 19 |
VPLS |
RFC 4761 |
| 20 |
Structure-agnostic T3 (DS3) over packet |
RFC 4553 |
| 21 |
Nx64kbit/s Basic Service using Structure-aware |
RFC 5086 |
| 22-24 |
Unassigned |
|
| 25 |
Frame Relay DLCI |
RFC 4619 |
| 25-39 |
Unassigned |
|
| 40 |
Structure-agnostic E3 over packet |
RFC 4553 |
| 41 |
Octet-aligned payload for Structure-agnostic DS1 circuits |
RFC 4553 |
| 42 |
E1 Nx64kbit/s with CAS using Structure-aware |
RFC 5086 |
| 43 |
DS1 (ESF) Nx64kbit/s with CAS using Structure-aware |
RFC 5086 |
| 44 |
DS1 (SF) Nx64kbit/s with CAS using Structure-aware |
RFC 5086 |
| 45-251 |
Unassigned |
|
| 252-255 |
Experimental Use |
RFC 6624 |
BGP Layer 2 TLV Types
- RFC 6624: Layer 2 Virtual Private Networks Using BGP for Auto-Discovery and Signaling
| Range |
Registration Procedures |
| 0-127 |
Expert Review |
| 128-251 |
First Come First Served |
| 252-255 |
Experimental Use |
| Value |
Description |
Reference |
| 0 |
Reserved |
RFC 6624 |
| 1 |
Circuit Status Vector |
RFC 6624 |
| 2-127 |
Unassigned |
|
| 128-251 |
Unassigned |
|
| 252-255 |
Experimental Use |
RFC 6624 |
BGP AIGP Attribute Types
- RFC 7311: The Accumulated IGP Metric Attribute for BGP
| Value |
Description |
Reference |
| 0 |
Reserved |
RFC 7311 |
| 1 |
AIGP |
RFC 7311 |
| 2-255 |
Unassigned |
|
BGP Route Refresh Subcodes
- RFC 7313: Enhanced Route Refresh Capability for BGP-4
| Range |
Registration Procedures |
| 0-127 |
Standards Action |
| 128-254 |
First Come First Served |
P-Multicast Service Interface Tunnel (PMSI Tunnel) Tunnel Types
- RFC 7385: IANA Registry for P-Multicast Service Interface (PMSI) Tunnel Type Code Points
- RFC 8317: Ethernet-Tree (E-Tree) Support in Ethernet VPN (EVPN) and Provider Backbone Bridging EVPN (PBB-EVPN)
The status of value 0xFF may only be changed through Standards Action RFC 8126.
| Range |
Registration Procedures |
| 0x00-0x7A |
IETF Review |
| 0x7B-0x7E |
Experimental Use |
| 0x80-0xFA |
Composite Tunnel |
| 0xFB-0xFE |
Experimental Use |
| 0xFF |
Standards Action |
P-Multicast Service Interface (PMSI) Tunnel Attribute Flags
- RFC 7902: Registry and Extensions for P-Multicast Service Interface Tunnel Attribute Flags
| Value |
Name |
Reference |
| 0 |
Unassigned |
|
| 1 |
Extension |
RFC 7902 |
| 2 |
Leaf Information Required per-Flow (LIR-pF) |
RFC 8534 |
| 3-4 |
Assisted Replication Type (T) |
RFC 9574 |
| 5 |
Broadcast and Multicast (BM) |
RFC 9574 |
| 6 |
Unknown (U) |
RFC 9574 |
| 7 |
Leaf Information Required (L) |
RFC 6514 |
BGP MCAST-VPN Route Types
- RFC 7441: Encoding Multipoint LDP (mLDP) Forwarding Equivalence Classes (FECs) in the NLRI of BGP MCAST-VPN Routes
- RFC 6514: BGP Encodings and Procedures for Multicast in MPLS/BGP IP VPNs
Values may be assigned from one of several ranges:
-
Range 0x01-0x3f: Generic/PIM Range. Values are assigned from
this range when the NLRI format associated with the route type
presupposes that PIM or IGMP is the C-multicast control protocol,
or when the NLRI format associated with the route type is
independent of the C-multicast control protocol.
-
Range 0x43-0x7f: mLDP Range. Values are assigned from this range
when the NLRI format associated with the route type presupposes
that mLDP is the C-multicast control protocol.
-
Range 0x80-0xff: This range is reserved; values should not be
assigned from this range.
In general, whenever an assignment is requested from this registry,
two codepoints should be requested at the same time: one from the
Generic/PIM range (0x01-0x3f) and one from the mLDP range (0x43-0x7f).
The two codepoints should have the same low-order 6 bits. If one of
the two codepoints is not actually needed, it should be registered
anyway, and marked as "Reserved."
BGP Prefix-SID TLV Types
- Acee Lindem, Hannes Gredler
- RFC 8669: Segment Routing Prefix Segment Identifier Extensions for BGP
BGP Prefix-SID Label-Index TLV Flags
- Acee Lindem, Hannes Gredler
- RFC 8669: Segment Routing Prefix Segment Identifier Extensions for BGP
| Value |
Name |
Reference |
| 0x0001-0x8000 |
Unassigned |
|
BGP Prefix-SID Originator SRGB TLV Flags
- Acee Lindem, Hannes Gredler
- RFC 8669: Segment Routing Prefix Segment Identifier Extensions for BGP
| Value |
Name |
Reference |
| 0x0001-0x8000 |
Unassigned |
|
BGP Graceful Restart Flags
- RFC 4724: Graceful Restart Mechanism for BGP
- RFC 8538: Notification Message Support for BGP Graceful Restart
| Bit Position |
Name |
Short Name |
Reference |
| 0 |
Restart State |
R |
RFC 4724 |
| 1 |
Notification |
N |
RFC 8538 |
| 2-3 |
Unassigned |
|
|
BGP Graceful Restart Flags for Address Family
- RFC 4724: Graceful Restart Mechanism for BGP
- RFC 8538: Notification Message Support for BGP Graceful Restart
| Bit Position |
Name |
Short Name |
Reference |
| 0 |
Forwarding State |
F |
RFC 4724 |
| 1-7 |
Unassigned |
|
|
SFP Attribute TLVs
- RFC 9015: BGP Control Plane for the Network Service Header in Service Function Chaining
| Type |
Name |
Reference |
Registration Date |
| 0 |
Reserved |
RFC 9015 |
|
| 1 |
Association TLV |
RFC 9015 |
2020-09-02 |
| 2 |
Hop TLV |
RFC 9015 |
2020-09-02 |
| 3 |
SFT TLV |
RFC 9015 |
2020-09-02 |
| 4 |
MPLS Swapping/Stacking |
RFC 9015 |
2020-09-02 |
| 5 |
SFP Traversal With MPLS |
RFC 9015 |
2020-09-02 |
| 6-65534 |
Unassigned |
|
|
| 65535 |
Reserved |
RFC 9015 |
|
SFP Association Type
- RFC 9015: BGP Control Plane for the Network Service Header in Service Function Chaining
| Association Type |
Name |
Reference |
Registration Date |
| 0 |
Reserved |
RFC 9015 |
|
| 1 |
Bidirectional SFP |
RFC 9015 |
2020-09-02 |
| 2-65534 |
Unassigned |
|
|
| 65535 |
Reserved |
RFC 9015 |
|
SFC SPI/SI Representation Flags
- RFC 9015: BGP Control Plane for the Network Service Header in Service Function Chaining
| Value |
Name |
Reference |
| 0 |
NSH data plane |
RFC 9015 |
| 1 |
MPLS data plane |
RFC 9015 |
| 2-15 |
Unassigned |
|
BFD Mode
- RFC 9026: Multicast VPN Fast Upstream Failover
| Range |
Registration Procedures |
| 0-175 |
IETF Review |
| 176-249 |
First Come First Served |
| 250-254 |
Experimental Use |
| 255 |
IETF Review |
BFD Discriminator Optional TLV Type
- RFC 9026: Multicast VPN Fast Upstream Failover
| Range |
Registration Procedures |
| 0-175 |
IETF Review |
| 176-249 |
First Come First Served |
| 250-254 |
Experimental Use |
| 255 |
IETF Review |
| Value |
Description |
Reference |
| 0 |
Reserved |
RFC 9026 |
| 1 |
Source IP Address |
RFC 9026 |
| 2-175 |
Unassigned |
|
| 176-249 |
Unassigned |
|
| 250-254 |
Experimental Use |
RFC 9026 |
| 255 |
Reserved |
RFC 9026 |
SRv6 Service Sub-TLV Types
- RFC 9252: BGP Overlay Services Based on Segment Routing over IPv6 (SRv6)
| Range |
Registration Procedures |
| 0-127 |
IETF Review |
| 128-254 |
First Come First Served |
| 255 |
IETF Review |
SRv6 Service Data Sub-Sub-TLV Types
- RFC 9252: BGP Overlay Services Based on Segment Routing over IPv6 (SRv6)
| Range |
Registration Procedures |
| 0-127 |
IETF Review |
| 128-254 |
First Come First Served |
| 255 |
IETF Review |
| Value |
Type |
Reference |
| 0 |
Reserved |
RFC 9252 |
| 1 |
SRv6 SID Structure Sub-Sub-TLV |
RFC 9252 |
| 2-254 |
Unassigned |
|
| 255 |
Reserved |
RFC 9252 |
BGP SRv6 Service SID Flags
- RFC 9252: BGP Overlay Services Based on Segment Routing over IPv6 (SRv6)
| Bit Position |
Name |
Reference |
| 0-7 |
Unassigned |
|
Long-Lived Graceful Restart Flags for Address Family
- RFC 9494: Long-Lived Graceful Restart for BGP
| Bit Position |
Name |
Short Name |
Reference |
| 0 |
Preservation of state |
F |
RFC 9494 |
| 1-7 |
Unassigned |
|
|
BGP BIER TLV and Sub-TLV Types
- RFC 9793: BGP Extensions for Bit Index Explicit Replication (BIER)
BGP CAR NLRI Types
- Bruno Decraene, Swadesh Agrawal
BGP CAR NLRI TLV Types
- Bruno Decraene, Swadesh Agrawal
Next Hop Dependent Characteristic Codes
| Range |
Registration Procedures |
| 0 |
Reserved |
| 1-65399 |
First Come First Served |
| 65400-65499 |
Private Use |
| 65500-65534 |
Experimental Use |
| 65535 |
Reserved |
VPN Prefix ORF TLV Type
| Range |
Registration Procedures |
| 0-127 |
IETF Review |
| 128-255 |
First Come First Served |
ORF Entry Bits
| Bit Position |
Name |
Description |
Reference |
| 0-1 |
Action |
The value of this field is 0 for ADD, 1 for REMOVE,
and 2 for REMOVE-ALL. |
RFC 5291 |
| 2 |
Match |
The value of this field is 0 for PERMIT and 1 for
DENY. |
RFC 5291 |
| 3 |
Overload VPN routes process method |
The value of this field is 0 for withdrawn all
overload VPN routes, and 1 for refusing to receive VPN routes
matching the overload criteria. |
RFC-ietf-idr-vpn-prefix-orf-45 |
| 4-7 |
Unassigned |
|
|
Contact Information