Border Gateway Protocol (BGP) Well-known Communities

Created

  • 2004-01-16

Last Updated

  • 2026-09-22

Available Formats


BGP Well-known Communities

Reference

  • RFC 1997: BGP Communities Attribute
  • RFC 8642: Policy Behavior for Well-Known BGP Communities

Note

Out of the total community space defined by RFC 1997 of 0x00000000 - 0xFFFFFFFF, the following ranges and values are reserved for communities that have global significance and their operations shall be implemented in any community-attribute-aware BGP speaker. The remainder of the space, specifically 0x00010000 - 0xFFFEFFFF, is for Private Use, with the first two octets encoding the autonomous system value as described by the RFC.

Available Formats

Range Registration Procedures
0x00000000-0x0000FFFF Reserved
0x00010000-0xFFFEFFFF Private Use
0xFFFF0000-0xFFFF8000 First Come First Served
0xFFFF8001-0xFFFFFFFF Standards Action
Attribute Value Attribute Reference
0x00000000-0x0000FFFF Reserved RFC 1997
0x00010000-0xFFFEFFFF Reserved for Private Use RFC 1997
0xFFFF0000 GRACEFUL_SHUTDOWN RFC 8326
0xFFFF0001 ACCEPT_OWN RFC 7611
0xFFFF0002 ROUTE_FILTER_TRANSLATED_v4 draft-l3vpn-legacy-rtc-00
0xFFFF0003 ROUTE_FILTER_v4 draft-l3vpn-legacy-rtc-00
0xFFFF0004 ROUTE_FILTER_TRANSLATED_v6 draft-l3vpn-legacy-rtc-00
0xFFFF0005 ROUTE_FILTER_v6 draft-l3vpn-legacy-rtc-00
0xFFFF0006 LLGR_STALE RFC 9494
0xFFFF0007 NO_LLGR RFC 9494
0xFFFF0008 accept-own-nexthop draft-agrewal-idr-accept-own-nexthop-00
0xFFFF0009 Standby PE RFC 9026
0xFFFF000A DOWNGRADE draft-ietf-grow-downgrade-bgp-community-00
0xFFFF000B-0xFFFF0299 Unassigned
0xFFFF029A BLACKHOLE RFC 7999
0xFFFF029B-0xFFFFFF00 Unassigned
0xFFFFFF01 NO_EXPORT RFC 1997
0xFFFFFF02 NO_ADVERTISE RFC 1997
0xFFFFFF03 NO_EXPORT_SUBCONFED RFC 1997
0xFFFFFF04 NOPEER RFC 3765
0xFFFFFF05-0xFFFFFFFF Unassigned