Bit Index Explicit Replication (BIER)

Created

  • 2017-10-31

Last Updated

  • 2024-12-24

Available Formats


BIER Next Protocol Identifiers

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8296: Encapsulation for Bit Index Explicit Replication (BIER) in MPLS and Non-MPLS Networks

Available Formats

Value Description Reference
0 Reserved RFC 8296
1 MPLS packet with downstream-assigned label at top of stack RFC 8296
2 MPLS packet with upstream-assigned label at top of stack RFC 8296
3 Ethernet frame RFC 8296
4 IPv4 packet RFC 8296
5 OAM packet draft-ietf-bier-ping-02
6 IPv6 packet RFC 8296
7 Payload is VXLAN encapsulated (no IP/UDP header) RFC 9624
8 Payload is NVGRE encapsulated (no IP header) RFC 9624
9 Payload is GENEVE encapsulated (no IP/UDP header) RFC 9624
10-62 Unassigned
63 Reserved RFC 8296

BIER Algorithm

Expert(s)

  • Les Ginsberg, Chris Hopps

Reference

  • RFC 8401: Bit Index Explicit Replication (BIER) Support via IS-IS
  • RFC 9272: Underlay Path Calculation Algorithm and Constraints for Bit Index Explicit Replication (BIER)

Available Formats

Range Registration Procedures
0-127 Standards Action
128-239 Specification Required
240-254 Private or Experimental Use
Value Description Reference
0 No BIER specific algorithm is used RFC 8401
1-239 Unassigned
240-254 Reserved for Private or Experimental Use RFC 8401; RFC 9272
255 Reserved RFC 8401