Concise Binary Object Representation (CBOR) Tags

Created

  • 2013-09-19

Last Updated

  • 2026-10-08

Available Formats


CBOR Tags

Expert(s)

  • Christian Amsüss, Thomas Fossati, Francesca Palombini, Carsten Bormann (backup)

Reference

  • RFC 8949: Concise Binary Object Representation (CBOR)

Note

All registration requests must include the template from RFC 8949.

Available Formats

Range Registration Procedures
0-23 Standards Action
24-32767 Specification Required
32768-18446744073709551615 First Come First Served
Tag Data Item Semantics Reference Template
0 text string Standard date/time string; see Section 3.4.1 RFC 8949
1 integer or float Epoch-based date/time; see Section 3.4.2 RFC 8949
2 byte string Unsigned bignum; see Section 3.4.3 RFC 8949
3 byte string Negative bignum; see Section 3.4.3 RFC 8949
4 array Decimal fraction; see Section 3.4.4 RFC 8949
5 array Bigfloat; see Section 3.4.4 RFC 8949
6-15 Unassigned
16 COSE_Encrypt0 COSE Single Recipient Encrypted Data Object RFC 9052
17 COSE_Mac0 COSE Mac w/o Recipients Object RFC 9052
18 COSE_Sign1 COSE Single Signer Data Object RFC 9052
19 COSE_Countersignature COSE standalone V2 countersignature RFC 9338
20 Unassigned
21 (any) Expected conversion to base64url encoding; see Section 3.4.5.2 RFC 8949
22 (any) Expected conversion to base64 encoding; see Section 3.4.5.2 RFC 8949
23 (any) Expected conversion to base16 encoding; see Section 3.4.5.2 RFC 8949
24 byte string Encoded CBOR data item; see Section 3.4.5.1 RFC 8949
25 unsigned integer reference the nth previously seen string http://cbor.schmorp.de/stringref; Marc A. Lehmann
26 array Serialised Perl object with classname and constructor arguments http://cbor.schmorp.de/perl-object; Marc A. Lehmann
27 array Serialised language-independent object with type name and constructor arguments http://cbor.schmorp.de/generic-object; Marc A. Lehmann
28 multiple mark value as (potentially) shared http://cbor.schmorp.de/value-sharing; Marc A. Lehmann
29 unsigned integer reference nth marked value http://cbor.schmorp.de/value-sharing; Marc A. Lehmann
30 array Rational number http://peteroupc.github.io/CBOR/rational.html; Peter Occil
31 Undefined (0xf7) Absent value in a CBOR Array https://github.com/svaarala/cbor-specs/blob/master/cbor-absent-tag.rst; Sami Vaarala
32 text string URI; see Section 3.4.5.3 RFC 8949
33 text string base64url; see Section 3.4.5.3 RFC 8949
34 text string base64; see Section 3.4.5.3 RFC 8949
35 UTF-8 string Regular expression; see Section 2.4.4.3 RFC 7049
36 text string MIME message; see Section 3.4.5.3 RFC 8949
37 byte string Binary UUID (RFC 9562, Section 4) https://github.com/lucas-clemente/cbor-specs/blob/master/uuid.md; Lucas Clemente
38 array Language-tagged string RFC 9290, Appendix A
39 multiple Identifier https://github.com/lucas-clemente/cbor-specs/blob/master/id.md; Lucas Clemente
40 array of two arrays [1] Multi-dimensional Array, row-major order RFC 8746
41 array Homogeneous Array RFC 8746
42 byte string IPLD content identifier https://github.com/ipld/cid-cbor/; Volker Mische
43 text string YANG bits datatype; see Section 6.7. RFC 9254
44 text string YANG enumeration datatype; see Section 6.6. RFC 9254
45 unsigned integer or text string YANG identityref datatype; see Section 6.10. RFC 9254
46 unsigned integer or text string or array YANG instance-identifier datatype; see Section 6.13. RFC 9254
47 unsigned integer YANG Schema Item iDentifier (sid); see Section 3.2. RFC 9254
48 byte string IEEE MAC Address RFC 9542
49-51 Unassigned
52 byte string or array IPv4, [prefixlen,IPv4], [IPv4,prefixpart] RFC 9164
53 Unassigned
54 byte string or array IPv6, [prefixlen,IPv6], [IPv6,prefixpart] RFC 9164
55-57 Unassigned
58 (any) An array claim element intended to be redacted, or a map key whose key and value are intended to be redacted. (TEMPORARY - registered 2025-12-09, expires 2026-12-09) draft-ietf-spice-sd-cwt-06, Section 11.1
59 Unassigned
60 byte string A selective disclosure redacted (array) claim element. (TEMPORARY - registered 2025-12-09, expires 2026-12-09) draft-ietf-spice-sd-cwt-06, Section 5.1
61 CBOR Web Token (CWT) CBOR Web Token (CWT) RFC 8392; Michael B. Jones
62 uint .gt 0 A marker of a location in a map or an array where a decoy is intended to be inserted. (TEMPORARY - registered 2026-01-27, expires 2027-01-27) draft-ietf-spice-sd-cwt-06, Section 11.2
63 byte string Encoded CBOR Sequence RFC 8742 draft-bormann-cbor-notable-tags-02, Section 2.1
64 byte string uint8 Typed Array RFC 8746
65 byte string uint16, big endian, Typed Array RFC 8746
66 byte string uint32, big endian, Typed Array RFC 8746
67 byte string uint64, big endian, Typed Array RFC 8746
68 byte string uint8 Typed Array, clamped arithmetic RFC 8746
69 byte string uint16, little endian, Typed Array RFC 8746
70 byte string uint32, little endian, Typed Array RFC 8746
71 byte string uint64, little endian, Typed Array RFC 8746
72 byte string sint8 Typed Array RFC 8746
73 byte string sint16, big endian, Typed Array RFC 8746
74 byte string sint32, big endian, Typed Array RFC 8746
75 byte string sint64, big endian, Typed Array RFC 8746
76 byte string (reserved) RFC 8746
77 byte string sint16, little endian, Typed Array RFC 8746
78 byte string sint32, little endian, Typed Array RFC 8746
79 byte string sint64, little endian, Typed Array RFC 8746
80 byte string IEEE 754 binary16, big endian, Typed Array RFC 8746
81 byte string IEEE 754 binary32, big endian, Typed Array RFC 8746
82 byte string IEEE 754 binary64, big endian, Typed Array RFC 8746
83 byte string IEEE 754 binary128, big endian, Typed Array RFC 8746
84 byte string IEEE 754 binary16, little endian, Typed Array RFC 8746
85 byte string IEEE 754 binary32, little endian, Typed Array RFC 8746
86 byte string IEEE 754 binary64, little endian, Typed Array RFC 8746
87 byte string IEEE 754 binary128, little endian, Typed Array RFC 8746
88-95 Unassigned
96 COSE_Encrypt COSE Encrypted Data Object RFC 9052
97 COSE_Mac COSE MACed Data Object RFC 9052
98 COSE_Sign COSE Signed Data Object RFC 9052
99 array CRI Reference RFC-ietf-core-href-29
100 Unsigned or negative integer Number of days since the epoch date 1970-01-01 RFC 8943
101 array [uint, any] alternatives as given by the uint + 128; see Section 9.1 draft-bormann-cbor-notable-tags-07
102 Unassigned
103 array Geographic Coordinates https://github.com/allthingstalk/cbor/blob/master/CBOR-Tag103-Geographic-Coordinates.md; Danilo Vidovic
104 multiple Geographic Coordinate Reference System WKT or EPSG number draft-clarke-cbor-crs-01
105-106 Unassigned
107 map SUIT_Envelope as defined in Appendix A of RFC-ietf-suit-manifest-34 RFC-ietf-suit-manifest-34
108 byte string Expected conversion to base16 encoding (lowercase) draft-bormann-cbor-notable-tags-12, Section 2.1, Paragraph 2, Item 2
109 Unassigned
110 byte string, array, or map relative object identifier (BER encoding); SDNV RFC 6256 sequence RFC 9090
111 byte string, array, or map object identifier (BER encoding) RFC 9090
112 byte string, array, or map object identifier (BER encoding), relative to 1.3.6.1.4.1 RFC 9090
113-119 Unassigned
120 multiple Internet of Things Data Point https://github.com/allthingstalk/cbor/blob/master/CBOR-Tag120-Internet-of-Things-Data-Points.md; Danilo Vidovic
121-127 any alternatives 0..6, 1+1 encoding; see Section 9.1 draft-bormann-cbor-notable-tags-07
128-199 Unassigned
200 multiple Gordian Envelope draft-mcnally-envelope-05
201 any enclosed dCBOR draft-mcnally-deterministic-cbor-10
202-255 Unassigned
256 multiple mark value as having string references http://cbor.schmorp.de/stringref; Marc A. Lehmann
257 byte string Binary MIME message http://peteroupc.github.io/CBOR/binarymime.html; Peter Occil
258 array Mathematical finite set https://github.com/input-output-hk/cbor-sets-spec/blob/master/CBOR_SETS.md; Alfredo Di Napoli
259 map Map datatype with key-value operations (e.g. `.get()/.set()/.delete()`) https://github.com/shanewholloway/js-cbor-codec/blob/master/docs/CBOR-259-spec--explicit-maps.md; Shane Holloway
260 byte string Network Address (IPv4 or IPv6 or MAC Address) (DEPRECATED in favor of 52 and 54 for IP addresses) http://www.employees.org/~ravir/cbor-network.txt; Ravi Raju; RFC 9164
261 map (IPAddress + Mask Length) Network Address Prefix (IPv4 or IPv6 Address + Mask Length) (DEPRECATED in favor of 52 and 54 for IP addresses) https://github.com/toravir/CBOR-Tag-Specs/blob/master/networkPrefix.md; Ravi Raju; RFC 9164
262 byte string Embedded JSON Object https://github.com/toravir/CBOR-Tag-Specs/blob/master/embeddedJSON.md; Ravi Raju
263 byte string Hexadecimal string https://github.com/toravir/CBOR-Tag-Specs/blob/master/hexString.md; Ravi Raju
264 array Decimal fraction with arbitrary exponent http://peteroupc.github.io/CBOR/bigfrac.html; Peter Occil
265 array Bigfloat with arbitrary exponent http://peteroupc.github.io/CBOR/bigfrac.html; Peter Occil
266 text string Internationalized resource identifier (IRI) https://peteroupc.github.io/CBOR/iri.html; Peter Occil
267 text string Internationalized resource identifier reference (IRI reference) https://peteroupc.github.io/CBOR/iri.html; Peter Occil
268 array Extended decimal fraction https://peteroupc.github.io/CBOR/extended.html; Peter Occil
269 array Extended bigfloat https://peteroupc.github.io/CBOR/extended.html; Peter Occil
270 array Extended rational number https://peteroupc.github.io/CBOR/extended.html; Peter Occil
271 DDoS Open Threat Signaling (DOTS) signal channel object DDoS Open Threat Signaling (DOTS) signal channel object, as defined in RFC 9132 RFC 9132
272 byte string Non-UTF-8 CESU-8 string https://github.com/svaarala/cbor-specs/blob/master/cbor-nonutf8-string-tags.rst; Sami Vaarala
273 byte string Non-UTF-8 WTF-8 string https://github.com/svaarala/cbor-specs/blob/master/cbor-nonutf8-string-tags.rst; Sami Vaarala
274 byte string Non-UTF-8 MUTF-8 string https://github.com/svaarala/cbor-specs/blob/master/cbor-nonutf8-string-tags.rst; Sami Vaarala
275 map (major type 5) Map contains only keys that are of type Text String (major type 3) https://github.com/ecorm/cbor-tag-text-key-map; Emile Cormier
276 byte string ERIS binary read capability http://purl.org/eris
277 byte string Universal Geographical Area Description (GAD) shape; see Section 5 TS 23.032; Mathew Meins
278 byte string Universal Geographical Area Description (GAD) description of velocity; see Section 8 TS 23.032; Mathew Meins
279 array Coordinate Reference System Wrapper Fast and Readable Geographical Hashing (CTA-5009-A); Consumer Technology Association
280 string or array Symbol https://github.com/mishoo/cbor.lisp/blob/e1428a5/clext-spec.txt; Mihai Bazon
281 array Linked list https://github.com/mishoo/cbor.lisp/blob/e1428a5/clext-spec.txt; Mihai Bazon
282 unsigned integer Character https://github.com/mishoo/cbor.lisp/blob/e1428a5/clext-spec.txt; Mihai Bazon
283 array Object https://github.com/mishoo/cbor.lisp/blob/e1428a5/clext-spec.txt; Mihai Bazon
284 text string or byte string JSON Numeric Value, Represented as its JSON Text https://gist.github.com/theory/ef667af1c725240e6e30d525786d58e6; David_Wheeler
285 array SUIT_Report_Protected RFC-ietf-suit-report-19
286 array SUIT_Reference RFC-ietf-suit-report-19
287 map SUIT_Capability_Report RFC-ietf-suit-report-19
288-295 Unassigned
296 any isolate shared values within this scope https://cbor.is4.site/sharedref-namespace; IS4
297-300 Unassigned
301 text string or array Geohash String Fast and Readable Geographical Hashing (CTA-5009-A); Consumer Technology Association
302-499 Unassigned
500 any Earmarked for CoRIM draft-ietf-rats-corim-07
501 map A CBOR tag that contains a corim-map. TCG DICE Endorsement Architecture for Devices; TCG Errata for DICE Endorsement Architecture for Devices Version 1.1; Trusted Computing Group
502-504 any Earmarked for CoRIM draft-ietf-rats-corim-07
505 bytes A CBOR tag that contains a conciseswid-tag-map. TCG DICE Endorsement Architecture for Devices; TCG Errata for DICE Endorsement Architecture for Devices Version 1.1; Trusted Computing Group
506 bytes A CBOR tag that contains a concisemid-tag-map. TCG DICE Endorsement Architecture for Devices; TCG Errata for DICE Endorsement Architecture for Devices Version 1.1; Trusted Computing Group
507-525 any Earmarked for CoRIM draft-ietf-rats-corim-07
526 map A CBOR tag that contains an xcorim-map. TCG DICE Endorsement Architecture for Devices; TCG Errata for DICE Endorsement Architecture for Devices Version 1.1; Trusted Computing Group
527 tagged signature block A CBOR tag that contains either: xcorimmap, or signed-xcorim. TCG DICE Endorsement Architecture for Devices; TCG Errata for DICE Endorsement Architecture for Devices Version 1.1; Trusted Computing Group
528-549 any Earmarked for CoRIM draft-ietf-rats-corim-07
550 bytes A CBOR tag that contains a UEID between 7 and 33 bytes. TCG DICE Endorsement Architecture for Devices; TCG Errata for DICE Endorsement Architecture for Devices Version 1.1; Trusted Computing Group
551 any Earmarked for CoRIM draft-ietf-rats-corim-07
552 unsigned integer A CBOR tag that contains a security version number that is evaluated with equivalence semantics. TCG DICE Endorsement Architecture for Devices; TCG Errata for DICE Endorsement Architecture for Devices Version 1.1; Trusted Computing Group
553 unsigned integer A CBOR tag that contains min-svn that identifies a security version number that is evaluated with greater than or equals semantics TCG DICE Endorsement Architecture for Devices; TCG Errata for DICE Endorsement Architecture for Devices Version 1.1; Trusted Computing Group
554 string A CBOR tag that contains a PEM encoded SubjectPublicKeyInfo. See Section 13 of RFC 7468. TCG DICE Endorsement Architecture for Devices; TCG Errata for DICE Endorsement Architecture for Devices Version 1.1; Trusted Computing Group
555 string A CBOR tag that contains a PEM encoded SubjectPublicKeyInfo. See Section 13 of RFC 7468. TCG DICE Endorsement Architecture for Devices; TCG Errata for DICE Endorsement Architecture for Devices Version 1.1; Trusted Computing Group
556 string A CBOR tag that contains an X.509 certificate chain created by the concatenation of as many PEM encoded X.509 certificates as needed. The certificates MUST be concatenated in order that each directly certifies the one preceding. TCG DICE Endorsement Architecture for Devices; TCG Errata for DICE Endorsement Architecture for Devices Version 1.1; Trusted Computing Group
557-559 any Earmarked for CoRIM draft-ietf-rats-corim-07
560 bytes A CBOR tag that contains a byte string interpreted as an array of bits. TCG DICE Endorsement Architecture for Devices; TCG Errata for DICE Endorsement Architecture for Devices Version 1.1; Trusted Computing Group
561-569 any Earmarked for CoRIM draft-ietf-rats-corim-07
570 map (spdm-toc-map, see CDDL) spdm-toc-map TCG DICE Concise Evidence Binding for SPDM; Trusted Computing Group
571 map (concise-evidence-map, see CDDL) concise-evidence-map TCG DICE Concise Evidence Binding for SPDM; Trusted Computing Group
572-599 any Earmarked for CoRIM draft-ietf-rats-corim-07
600 Unassigned
601 map (Claims-Set as per Appendix A of RFC 9781) Unprotected CWT Claims Set RFC 9781 RFC 9781
602 array Detached EAT Bundle RFC 9711, Section 5
603-1000 Unassigned
1001 map extended time RFC 9581, Section 3
1002 map duration RFC 9581, Section 4
1003 array period RFC 9581, Section 5
1004 UTF-8 text string RFC 3339 full-date string RFC 8943
1005-1009 Unassigned
1010 array: [id: text string, obj: any] Object type identifier draft-rundgren-cotx-04
1011-1039 Unassigned
1040 array of two arrays [1] Multi-dimensional Array, column-major order RFC 8746
1041-1047 Unassigned
1048 byte string IEEE OUI/CID RFC 9542
1049-1069 Unassigned
1070 map SUIT_Manifest as defined in Appendix A of RFC-ietf-suit-manifest-34 RFC-ietf-suit-manifest-34
1071-1279 Unassigned
1280-1400 any alternatives 7..127, 1+2 encoding; see Section 9.1 draft-bormann-cbor-notable-tags-07
1401-18299 Unassigned
18300-18555 byte string Bare Hash value (COSE algorithm -256 to -1) draft-bormann-cbor-notable-tags-09, Section 3.1.1
18556 array [COSE algorithm identifier, Base Hash value] draft-bormann-cbor-notable-tags-09, Section 3.1.1
18557-18811 byte string Bare Hash value (COSE algorithm 1 to 255) draft-bormann-cbor-notable-tags-09, Section 3.1.1
18812-20852 Unassigned
20853 any description of the value instead of the value itself https://cbor.is4.site/quoted; IS4
20854-21064 Unassigned
21065 text string I-Regexp draft-bormann-cbor-notable-tags-11, Section 2.1; RFC 9485
21066 Array[UTF8string, UTF8string?] ECMAScript RegExp https://262.ecma-international.org/14.0/#sec-regexp-regular-expression-objects https://github.com/hildjj/cbor-specs/blob/main/regexp.md; Joe Hildebrand
21067-21333 Unassigned
21334 uint (always invalid in interchange) programming aid for simple values draft-bormann-cbor-notable-tags-12, Section 10.2
21335-21606 Unassigned
21607 unsigned integer a CBOR Tag identifier https://cbor.is4.site/cbor-tag; IS4
21608-22097 Unassigned
22098 multiple hint that indicates an additional level of indirection http://cbor.schmorp.de/indirection; Marc A. Lehmann
22099-25440 Unassigned
25441 Array containing at most one array followed by at most one map Capture [3] https://github.com/japhb/cbor-specs/blob/main/capture.md; Geoffrey Broadwell
25442-32767 Unassigned
32768 unsigned integer Identifier for a FHIR constant Stefan Genchev template/32768
32769 multiple External reference https://gitlab.com/Hawk777/cbor-specs/-/blob/main/external-reference.md; Christopher Head
32770-32869 unsigned integer Used to mark pointers in PSA Crypto API IPC implementation Ole Saether template/32770-32869
32870 multiple Logical operator: NONE / NOT. Encodes the logical operation (!item1&&!item2&&!item3&&..., if array), otherwise (!item). Jon Caruana template/32870
32871 array Logical operator: ANY. Encodes the logical operation (item1||item2||item3||...). Jon Caruana template/32871
32872 array Logical operator: ALL. Encodes the logical operation (item1&&item2&&item3&&...). Jon Caruana template/32872
32873-32999 Unassigned
33000 array TLA+ function as an array of [argument, value] pairs Markus Alexander Kuppe; Younes Akhouayri; https://gist.github.com/younes-io/8bbc63cffd4811f6aa2776c7301eb360 template/33000
33001-39999 Unassigned
40000 unsigned integer ur:known-value, Semantic signifier https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40001 byte string ur:digest, 32-byte SHA-256 digest https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40002 array ur:encrypted, IETF ChaCha20-Poly1305 (RFC 8439) encrypted message https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40003 array ur:compressed, RFC 1951 DEFLATE-compressed message https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40004 multiple ur:request, Transaction Request identifier https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40005 multiple ur:response, Transaction response identifier https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40006 unsigned integer or text string ur:function, Envelope expression function identifier https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40007 unsigned integer or text string ur:parameter, Envelope expression parameter identifier https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40008 unsigned integer or text string ur:placeholder, Envelope expression placeholder identifier https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40009 unsigned integer or text string ur:replacement, Envelope expression replacement identifier https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40010 byte string ur:agreement-private-key, Curve25519 private key for X25519 key agreement https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40011 byte string ur:agreement-public-key, Curve25519 public key for X25519 key agreement https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40012 byte string ur:arid, Apparently Random Identifier https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40013 array ur:crypto-prvkeys, Private keys for cryptographic operations https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40014 byte string ur:nonce, Cryptographic nonce https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40015 array ur:password, Scrypt-hashed password https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40016 byte string ur:crypto-prvkeys, Private key base (key material) https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40017 array ur:crypto-pubkeys, Public key base (signing and agreement public key bundle) https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40018 byte string ur:salt, Random salt used for hash tree decorrelation https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40019 array ur:crypto-sealed, Encrypted message and ephemeral public key https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40020 multiple ur:signature, Cryptographic signature https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40021 byte string ur:signing-private-key, Cryptographic private key used for signing https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40022 multiple ur:signing-public-key, Cryptographic public key used for signing https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40023 byte string ur:crypto-key, Cryptographic key used for symmetric encryption https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40024 multiple ur:xid, Extensible identifier or XID Document https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40025 byte string ur:reference, Cryptographically secure reference to an object https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40026 unsigned integer or text string ur:event, Event identifier https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40027 tagged array ur:encrypted-key, Content key encrypted with a derivation function https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40028-40099 Unassigned
40100 array ur:mlkem-private-key, Private key for MLKEM key encapsulation https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40101 array ur:mlkem-public-key, Public key for MLKEM key encapsulation https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40102 array ur:mlkem-ciphertext, Ciphertext for MLKEM key encapsulation https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40103 array ur:mldsa-private-key, Private key for MLDSA signature generation https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40104 array ur:mldsa-public-key, Public key for MLDSA signature verification https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40105 array ur:mldsa-signature, MLDSA signature https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40106-40299 Unassigned
40300 map ur:seed, Cryptographic seed https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40301-40302 Unassigned
40303 map ur:hdkey, Bitcoin BIP-32 HD key https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40304 map ur:keypath, Bitcoin BIP-32 key derivation path https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40305 map ur:coin-info, Cryptographic asset and network specifier https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40306 map ur:eckey, Bitcoin elliptic curve key (private or public) https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40307 map ur:address, Cryptocurrency address https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40308 map ur:output-descriptor, Bitcoin output descriptor https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40309 byte string ur:sskr, Sharded Secret Key Reconstruction (SSKR) share https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40310 byte string ur:psbt, Partially Signed Bitcoin Transaction https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40311 map ur:account-descriptor, Bitcoin account descriptor https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40312-40799 Unassigned
40800 text string ur:ssh-private, Text format SSH private key https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40801 text string ur:ssh-public, Text format SSH public key https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40802 text string ur:ssh-signature, Text format SSH signature https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40803 text string ur:ssh-certificate, Text format SSH certificate https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
40804-40918 Unassigned
40919 multiple (uint or array [uint, uint]) Concordium smart contract address https://proposals.concordium.com/CIS/cis-7.html#smart-contract-address; Thomas Dinsdale-Young template/40919
40920-41727 Unassigned
41728 array, unsigned integer or unsigned bignum Fraction https://medyro.eu/specification/IANA/CBOR%20Tags/Fraction/; Medyro template/41728
41729 array, unsigned integer or unsigned bignum Fraction (-NaN signals) https://medyro.eu/specification/IANA/CBOR%20Tags/Fraction/; Medyro template/41729
41730 array, unsigned integer or unsigned bignum Fraction (+NaN signals) https://medyro.eu/specification/IANA/CBOR%20Tags/Fraction/; Medyro template/41730
41731 array, unsigned integer or unsigned bignum Fraction (Both NaNs signal) https://medyro.eu/specification/IANA/CBOR%20Tags/Fraction/; Medyro template/41731
41732-42599 Unassigned
42600 map A confidentiality clearance. The key value pairs of the map are defined in ADatP-4774.8 Aidan Murdock template/42600
42601 array A metadata binding. The elements of the array are defined in AdatP-4778.8. The tag is also used as part of the magic number in on-disk detached and encapsulating bindings. Aidan Murdock template/42601
42602 map A collection of NCMS metadata elements. The key value pairs of the map are defined in AdatP-5636.8 Aidan Murdock template/42602
42603-42999 Unassigned
43000 array Single complex number: array elements are real (I) and imaginary (Q) components Saajan Chana template/43000
43001 array Array of complex numbers in interleaved form: complex value k is stored with real (I) part at array index 2k and imaginary (Q) part at index (2k + 1) Saajan Chana template/43001
43002-44251 Unassigned
44252 array Metrological value (quantity value with unit of measure, SI prefix and GUM measurement uncertainty) https://github.com/OpenChargingTechnology/Whitepapers/blob/master/MetrologicalCBOR/README.md; Achim Friedland template/44252
44253-46009 Unassigned
46010 byte string, exactly 4 bytes CRC-32/ISO-HDLC digest Hans Larsen template/46010
46011 byte string, exactly 16 bytes MD5 digest Hans Larsen template/46011
46012-49999 Unassigned
50000 integer PlatformV_IS_ID https://github.com/arthurwangtz/platformv-cbor; Wang Tongzhou
50001 text string PlatformV_IS_NAME https://github.com/arthurwangtz/platformv-cbor; Wang Tongzhou
50002 any PlatformV_IS_VALUE https://github.com/arthurwangtz/platformv-cbor; Wang Tongzhou
50003 array PlatformV_HAS_COMPOSITE_VALUE https://github.com/arthurwangtz/platformv-cbor; Wang Tongzhou
50004 array PlatformV_HAS_MAPPED_VALUE https://github.com/arthurwangtz/platformv-cbor; Wang Tongzhou
50005 array PlatformV_HAS_OBJ_ID https://github.com/arthurwangtz/platformv-cbor; Wang Tongzhou
50006 array PlatformV_HAS_OBJ_TAG https://github.com/arthurwangtz/platformv-cbor; Wang Tongzhou
50007 array PlatformV_HAS_CHILD https://github.com/arthurwangtz/platformv-cbor; Wang Tongzhou
50008 array PlatformV_HAS_PROPERTY https://github.com/arthurwangtz/platformv-cbor; Wang Tongzhou
50009 array PlatformV_HAS_META https://github.com/arthurwangtz/platformv-cbor; Wang Tongzhou
50010 array PlatformV_HAS_EVENT https://github.com/arthurwangtz/platformv-cbor; Wang Tongzhou
50011 array PlatformV_HAS_ACTION https://github.com/arthurwangtz/platformv-cbor; Wang Tongzhou
50012 integer PlatformV_IS_TYPE https://github.com/arthurwangtz/platformv-cbor; Wang Tongzhou
50013-51996 Unassigned
51997 array A tag value of 51997 indicates that the payload is CBOR-LD. https://json-ld.github.io/cbor-ld-spec/#cbor-tags-for-cbor-ld; Wesley Smith template/51997
51998-55798 Unassigned
55799 (any) Self-described CBOR; see Section 3.4.6 RFC 8949
55800 tagged byte string indicates that the file contains CBOR Sequences RFC 9277
55801 tagged byte string indicates that the file starts with a CBOR-Labeled Non-CBOR Data label. RFC 9277
55802-56499 Unassigned
56500 array (major type 4) Compressed byte string https://github.com/dectris/documentation/blob/main/cbor/dectris-compression-tag.md; Dirk Boye
56501-57341 Unassigned
57342 array Identify and define a set of record structures (each a sequence of property names) that can be referenced as tags in the included value (and the scope for the record tag definitions) https://github.com/kriszyp/cbor-records; Kris Zyp
57343 array Identify and define a record structure (a sequence of property names), and use that record structure definition to interpret the included values. https://github.com/kriszyp/cbor-records; Kris Zyp
57344-57599 array References a defined record structure, using that referenced record definition to interpret the included values. https://github.com/kriszyp/cbor-records; Kris Zyp
57600-59999 Unassigned
60000 array The tagged CBOR array contains attestation evidence data with an Intel TEE quote. Shanwei Cen template/60000
60001 array The tagged CBOR array contains attestation evidence data with an Intel TEE report. Shanwei Cen template/60001
60002 array The tagged CBOR array contains attestation evidence data with an Intel SGX report. Shanwei Cen template/60002
60003-60009 Unassigned
60010 array The tagged CBOR array containing a numeric expression. https://github.com/nedmsmith/draft-cds-rats-intel-corim-profile/blob/main/draft-cds-rats-intel-corim-profile.md; Ned Smith
60011-60019 Unassigned
60020 array The tagged CBOR array containing a set of digests expression. https://github.com/nedmsmith/draft-cds-rats-intel-corim-profile/blob/main/draft-cds-rats-intel-corim-profile.md; Ned Smith
60021 array The tagged CBOR array containing a set of strings expression. https://github.com/nedmsmith/draft-cds-rats-intel-corim-profile/blob/main/draft-cds-rats-intel-corim-profile.md; Ned Smith
60022-65534 Unassigned
65535 (none valid) always invalid; see Section 10.1 draft-bormann-cbor-notable-tags-02
65536-79999 Unassigned
80000-80099 byte string, array or map Private tags as suggested in https://mailarchive.ietf.org/arch/msg/cbor/NJlskB63pjXFt5a6S37tiwJBbCM. Tony Putman template/80000-80099
80100-80149 byte string, array or map Private tags as suggested in https://mailarchive.ietf.org/arch/msg/cbor/NJlskB63pjXFt5a6S37tiwJBbCM/. Infra Ops template/80100-80149
80150-80199 byte string, array or map Private tags as suggested in https://mailarchive.ietf.org/arch/msg/cbor/NJlskB63pjXFt5a6S37tiwJBbCM/. Janis Danisevskis template/80150-80199
80200-133132 Unassigned
133133 array ZeWIF (Zcash Wallet Interchange Format) document; the tag encloses a two-element array [version, payload] whose payload is a CBOR map conforming to the version's ZeWIF schema. In a stored document this tag is enclosed in tag 55799 (Self-Described CBOR). Kris Nuttycombe; ZeWIF: Zcash Wallet Interchange Format template/133133
133134-14245119 Unassigned
14245120-14245220 array or map A tag within this range will indicate that a CBOR-encoded payload contains a W3C verifiable credential, data integrity proof value. The additional specificity of the tag in this range is use to identify a particular cryptographic suite, cryptographic feature, or proof role (base or derived). Greg Bernstein template/14245120-14245220
14245221-15309735 Unassigned
15309736 map (major type 5) RAINS Message https://britram.github.io/rains-prototype; Brian Trammell
15309737-827539797 Unassigned
827539798 array Universal Saves Format bundle Hans Larsen template/827539798
827539799-1146111422 Unassigned
1146111423 map TCG DICE Protection Environment profile descriptor TCG DICE Protection Environment; Trusted Computing Group template/1146111423
1146111424-1298360422 Unassigned
1298360423 map MoaT change-of-status marker https://github.com/M-o-a-T/moat/blob/main/doc/common/cbor.rst; Matthias Urlichs
1298360424-1298493253 Unassigned
1298493254 map MoaT end-of-file marker https://github.com/M-o-a-T/moat-util/; Matthias Urlichs
1298493255-1299145043 Unassigned
1299145044 array MoaT file identifier / details https://github.com/M-o-a-T/moat-util/; Matthias Urlichs
1299145045-1330664269 Unassigned
1330664270 byte-string A CBOR encoded Openswan configuration file, as stored on disk for unit test cases. Michael Richardson; Samir Hussain template/1330664270
1330664271-1347571279 Unassigned
1347571280 Proof of Process Packet (PPPP) A cryptographically anchored data structure used for digital authorship attestation, capturing the authorship process through entangled Verifiable Delay Functions (VDFs) and behavioral biometrics. witnessd Proof of Process Evidence Format, Version 1.3.0; David Lee Condrey template/1347571280
1347571281 Compact Evidence Reference A cryptographic pointer to a full Proof of Process Evidence Packet, used for embedding authorship claims in space-constrained contexts (e.g., metadata, QR codes). witnessd Proof of Process Evidence Format, Version 1.3.0; David Lee Condrey template/1347571281
1347571282-1347571541 Unassigned
1347571542 array ur:provenance, Provenance Mark https://github.com/BlockchainCommons/Research/blob/master/papers/bcr-2020-006-urtypes.md; Wolf McNally
1347571543-1398229315 Unassigned
1398229316 map Concise Software Identifier (CoSWID) RFC 9393
1398229317-1413829459 Unassigned
1413829460 any Explicitly none. draft-bormann-cbor-notable-tags-15, Section 10.3; Joe Hildebrand template/1413829460
1413829461-1463894559 Unassigned
1463894560 Writers Authenticity Report (WAR) An Attestation Result structure produced by Verifiers appraising Proof of Process Evidence, conveying verification verdicts, confidence scores, and forensic assessments per the IETF RATS architecture. witnessd Proof of Process Evidence Format, Version 1.3.0; David Lee Condrey template/1463894560
1463894561-1482048303 Unassigned
1482048304-1482048346 integer or map Xbox Virtual Container identifiers for use with RFC 9277 Jon Caruana template/1482048304-1482048346
1482048347-1668546816 Unassigned
1668546817-1668612095 byte string or any CBOR data item (see Appendix B of RFC 9277) the representation of content-format ct < 65025 is indicated by tag number TN(ct) = 0x63740101 + (ct / 255) * 256 + ct % 255 RFC 9277
1668612096-1701996914 Unassigned
1701996915 array Array of content-addressed blocks and ERIS read capabilities Endo Renberg template/1701996915
1701996916 array ERIS-FS image header Endo Renberg template/1701996916
1701996917-1735551331 Unassigned
1735551332 array PromiseGrid message envelope Steve Traugott template/1735551332
1735551333-4294967294 Unassigned
4294967295 (none valid) always invalid; see Section 10.1 draft-bormann-cbor-notable-tags-02
4294967296 map Intel FPGA SPDM Manifest Andrew Draper template/4294967296
4294967297-18446744073709551614 Unassigned
18446744073709551615 (none valid) always invalid; Section 10.1 draft-bormann-cbor-notable-tags-02

Timescales

Registration Procedure(s)

  • RFC and Expert Review Required

Expert(s)

  • Henk Birkholz, Esko Dijk

Reference

  • RFC 9581: Concise Binary Object Representation (CBOR) Tags for Time, Duration, and Period

Available Formats

Timescale Value Semantics Reference
UTC 0 UTC with POSIX Epoch RFC 9581
TAI 1 TAI with PTP Epoch RFC 9581
Unassigned 2-18446744073709551615

Time Tag Map Keys

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Henk Birkholz, Esko Dijk

Reference

  • RFC 9581: Concise Binary Object Representation (CBOR) Tags for Time, Duration, and Period

Available Formats

Value Semantics Reference
-18446744073709551616..-19 Unassigned
-18 attoseconds RFC 9581
-17..-16 Unassigned
-15 femtoseconds RFC 9581
-14 Unassigned
-13 timescale (elective) RFC 9581
-12 picoseconds RFC 9581
-11 IXDTF Suffix Information (elective) RFC 9581; RFC 9557
-10 IXDTF Time Zone Hint (elective) RFC 9581; RFC 9557
-9 nanoseconds RFC 9581
-8 Guarantee RFC 9581
-7 Uncertainty RFC 9581
-6 microseconds RFC 9581
-5 Offset-Scaled Log Variance RFC 9581
-4 Clock Accuracy RFC 9581
-3 milliseconds RFC 9581
-2 Clock Class RFC 9581
-1 timescale (elective) legacy RFC 9581
0 Unassigned
1 base time value as in CBOR Tag 1 RFC 8949; RFC 9581
2-3 Unassigned
4 base time value as in CBOR Tag 4 RFC 8949; RFC 9581
5 base time value as in CBOR Tag 5 RFC 8949; RFC 9581
6-9 Unassigned
10 IXDTF Time Zone Hint (critical) RFC 9581; RFC 9557
11 IXDTF Suffix Information (critical) RFC 9581; RFC 9557
12 Unassigned
13 timescale (critical) RFC 9581
14-18446744073709551615 Unassigned

Contact Information

Name Contact URI Last Updated
Achim Friedland achim.friedland&graphdefined.com 2026-08-19
Aidan Murdock aidan.murdock&ncia.nato.int 2022-05-24
Alfredo Di Napoli alfredo.dinapoli&iohk.io 2017-08-25
Andrew Draper andrew.draper&intel.com 2021-12-10
Brian Trammell ietf&trammell.ch 2016-08-17
Christopher Head chead&chead.ca 2022-12-28
Consumer Technology Association standards&cta.tech 2024-06-11
Danilo Vidovic cbor&allthingstalk.com 2018-04-17
David Lee Condrey david&writerslogic.com 2026-02-06
David_Wheeler david&justatheory.com 2025-05-16
Dirk Boye dirk.boye&dectris.com 2024-02-12
Emile Cormier emile.cormier.jr&gmail.com 2020-03-30
Endo Renberg pukkamustard&posteo.net 2023-07-31
Geoffrey Broadwell gjb&sonic.net 2021-11-09
Greg Bernstein gregb&grotto-networking.com 2024-08-28
Hans Larsen spec&1retro.com 2026-09-18
IS4 is4.site&gmail.com 2025-03-06
Janis Danisevskis jdanisevskis&aurora.tech 2025-09-04
Joe Hildebrand joe-ietf&cursive.net 2026-02-11
Jon Caruana joncar&xbox.com 2025-09-08
Kris Nuttycombe kris&zodl.com 2026-07-20
Kris Zyp kriszyp&gmail.com 2022-05-23
Lucas Clemente lucas&clemente.io 2014-07-01
Marc A. Lehmann cbor&schmorp.de 2013-11-26
Markus Alexander Kuppe markus&tlapl.us 2026-10-08
Mathew Meins mm&blackhelicopters.net 2021-02-01
Matthias Urlichs matthias&urlichs.de 2025-02-13
Medyro Curious.Charr&web.de 2026-04-02
Michael B. Jones mbj&microsoft.com 2018-05-04
Michael Richardson mcr&xelerance.com 2021-01-25
Mihai Bazon mihai.bazon&gmail.com 2025-04-03
Ned Smith ned.smith&intel.com 2025-05-12
Ole Saether ole.saether&nordicsemi.no 2024-06-28
Peter Occil poccil14&gmail.com 2018-11-09
Ravi Raju ravir&employees.org 2018-03-06
Saajan Chana saajan.chana&cambridgeconsultants.com 2022-07-20
Sami Vaarala sami.vaarala&iki.fi 2020-03-18
Samir Hussain shussain&xelerance.com 2021-01-25
Shane Holloway shane.holloway&ieee.org 2018-10-25
Shanwei Cen shanwei.cen&intel.com 2023-01-12
Stefan Genchev stefan.genchev&tum.de 2022-12-09
Steve Traugott ietf-poc&t7a.org 2026-07-20
Trusted Computing Group iana-requests&trustedcomputinggroup.org 2024-03-20
Thomas Dinsdale-Young ty&concordium.com 2025-08-18
Tony Putman anthony.putman&dyson.com 2023-04-26
Infra Ops cbor&unchained.com 2025-09-29
Volker Mische volker.mische&gmail.com 2024-03-05
Wang Tongzhou tongzhou.wang&siemens.com 2022-10-20
Wesley Smith wsmith&digitalbazaar.com 2025-05-05
Wolf McNally wolf&wolfmcnally.com 2025-04-28
Younes Akhouayri git&younes.io 2026-10-08

Footnote

[1]

second element of outer array in data item is native CBOR array (major type 4) or Typed Array (one of Tag 64..87)