Concise Data Definition Language (CDDL)
Created
- 2019-03-28
Last Updated
- 2025-03-06
Available Formats
CDDL Control Operators
Expert(s)
- Jeffrey Yasskin, Henk Birkholz
Reference
- RFC 8610, Section 6.1: Concise Data Definition Language (CDDL): A Notational Convention to Express Concise Binary Object Representation (CBOR) and JSON Data Structures
Note
Requests to register names that don't include an internal dot can be submitted here: https://www.iana.org/form/protocol-assignment
Available Formats
| Range | Registration Procedures |
|---|---|
| name includes internal dot | IETF Review |
| name does not include internal dot | Specification Required |
| Name | Reference |
|---|---|
| .size | RFC 8610 |
| .bits | RFC 8610 |
| .regexp | RFC 8610 |
| .cbor | RFC 8610 |
| .cborseq | RFC 8610 |
| .within | RFC 8610 |
| .and | RFC 8610 |
| .lt | RFC 8610 |
| .le | RFC 8610 |
| .gt | RFC 8610 |
| .ge | RFC 8610 |
| .eq | RFC 8610 |
| .ne | RFC 8610 |
| .default | RFC 8610 |
| .sdnv | RFC 9090 |
| .sdnvseq | RFC 9090 |
| .oid | RFC 9090 |
| .plus | RFC 9165 |
| .cat | RFC 9165 |
| .det | RFC 9165 |
| .abnf | RFC 9165 |
| .abnfb | RFC 9165 |
| .feature | RFC 9165 |
| .b64u | RFC 9741 |
| .b64u-sloppy | RFC 9741 |
| .b64c | RFC 9741 |
| .b64c-sloppy | RFC 9741 |
| .b45 | RFC 9741 |
| .b32 | RFC 9741 |
| .h32 | RFC 9741 |
| .hex | RFC 9741 |
| .hexlc | RFC 9741 |
| .hexuc | RFC 9741 |
| .base10 | RFC 9741 |
| .printf | RFC 9741 |
| .json | RFC 9741 |
| .join | RFC 9741 |