Channel-Binding Types
Last Updated
- 2026-07-13
Registration Procedure(s)
- Expert Review
Expert(s)
- Nicolas Williams
Reference
- RFC 5056: On the Use of Channel Bindings to Secure Channels
Available Formats
| Channel-binding unique prefix | Channel-binding type | Channel type | Published specification | Channel-binding is secret | Description | Intended usage | Person and email address to contact for further information | Owner/Change controller name and email address | Expert reviewer name and contact information | Registration Date | Last Updated | Note |
|---|---|---|---|---|---|---|---|---|---|---|---|---|
| tls-server-end-point | end-point | TLS RFC 5246 | RFC 5929 | no | <See specification> | COMMON | Larry Zhu; Nicolas Williams | IESG | IETF TLS WG | 2008-06-26 | 2010-05-13 | see the published specification for advice on the applicability of this channel binding type. |
| tls-unique | unique | TLS RFC 5246 | RFC 5929 | no | <See specification> | COMMON | Larry Zhu; Nicolas Williams | IESG | IETF TLS WG | 2008-06-26 | 2010-05-13 | see the published specification for advice on the applicability of this channel binding type. |
| tls-unique-for-telnet | unique | TLS RFC 5246 | RFC 5929 | no | <See specification> | COMMON | Jeff Altman; Nicolas Williams | IESG | IETF TLS WG | 2008-06-26 | 2010-05-13 | see the published specification for advice on the applicability of this channel binding type. |
| tls-exporter | unique | TLS RFC 9846 | RFC 9266 | no | The EKM value obtained from the current TLS connection. | COMMON | Sam Whited | IESG | IETF TLS WG; IETF KITTEN WG | 2022-05-31 | 2025-08-12 | See the published specification for advice on the applicability of this channel binding type. |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| IESG | |||
| IETF KITTEN WG | kitten&ietf.org
ietf&ietf.org |
||
| IETF TLS WG | tls&ietf.org
ietf&ietf.org |
||
| Jeff Altman | jaltman&secure-endpoints.com | ||
| Larry Zhu | larry.zhuµsoft.com | ||
| Nicolas Williams | Nicolas.Williams&oracle.com | ||
| Sam Whited | sam&samwhited.com | 2022-05-31 |