Character Sets

Last Updated

  • 2026-10-02

Available Formats


Character Sets

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Martin Dürst

Reference

  • RFC 2978: IANA Charset Registration Procedures

Note

Registration requests must be sent to the subscriber-only ietf-charsets@iana.org mailing list. The designated expert will forward approved requests to IANA.

Subscribe by email: mailto:ietf-charsets-join@iana.org View the archive or subscribe online: Mailing list interface

If you have any questions, please contact iana@iana.org.

Note

These are the official names for character sets that may be used in the Internet and may be referred to in Internet documentation. These names are expressed in ANSI_X3.4-1968 which is commonly called US-ASCII or simply ASCII. The character set most commonly use in the Internet and used especially in protocol standards is US-ASCII, this is strongly encouraged. The use of the name US-ASCII is also encouraged.

The character set names may be up to 40 characters taken from the printable characters of US-ASCII. However, no distinction is made between use of upper and lower case letters.

The MIBenum value is a unique value for use in MIBs to identify coded character sets.

The value space for MIBenum values has been divided into three regions. The first region (3-999) consists of coded character sets that have been standardized by some standard setting organization. This region is intended for standards that do not have subset implementations. The second region (1000-1999) is for the Unicode and ISO/IEC 10646 coded character sets together with a specification of a (set of) sub-repertoires that may occur. The third region (>1999) is intended for vendor specific coded character sets.

    Assigned MIB enum Numbers
    -------------------------
    0-2             Reserved
    3-999           Set By Standards Organizations
    1000-1999       Unicode / 10646
    2000-2999       Vendor

The aliases that start with "cs" have been added for use with the IANA-CHARSET-MIB as originally defined in RFC 3808, and as currently maintained by IANA at IANA-CHARSET-MIB. Note that the ianacharset-mib needs to be kept in sync with this registry. These aliases that start with "cs" contain the standard numbers along with suggestive names in order to facilitate applications that want to display the names in user interfaces. The "cs" stands for character set and is provided for applications that need a lower case first letter but want to use mixed case thereafter that cannot contain any special characters, such as underbar ("_") and dash ("-").

If the character set is from an ISO standard, its cs alias is the ISO standard number or name. If the character set is not from an ISO standard, but is registered with ISO (IPSJ/ITSCJ is the current ISO Registration Authority), the ISO Registry number is specified as ISOnnn followed by letters suggestive of the name or standards number of the code set. When a national or international standard is revised, the year of revision is added to the cs alias of the new character set entry in the IANA Registry in order to distinguish the revised character set from the original character set.

Available Formats

Preferred MIME Name Name MIBenum Source Reference Aliases Note
US-ASCII US-ASCII 3 ANSI X3.4-1986 RFC 2046 iso-ir-6
ANSI_X3.4-1968
ANSI_X3.4-1986
ISO_646.irv:1991
ISO646-US
US-ASCII
us
IBM367
cp367
csASCII
ISO-8859-1 ISO_8859-1:1987 4 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-100
ISO_8859-1
ISO-8859-1
latin1
l1
IBM819
CP819
csISOLatin1
ISO-8859-2 ISO_8859-2:1987 5 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-101
ISO_8859-2
ISO-8859-2
latin2
l2
csISOLatin2
ISO-8859-3 ISO_8859-3:1988 6 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-109
ISO_8859-3
ISO-8859-3
latin3
l3
csISOLatin3
ISO-8859-4 ISO_8859-4:1988 7 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-110
ISO_8859-4
ISO-8859-4
latin4
l4
csISOLatin4
ISO-8859-5 ISO_8859-5:1988 8 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-144
ISO_8859-5
ISO-8859-5
cyrillic
csISOLatinCyrillic
ISO-8859-6 ISO_8859-6:1987 9 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-127
ISO_8859-6
ISO-8859-6
ECMA-114
ASMO-708
arabic
csISOLatinArabic
ISO-8859-7 ISO_8859-7:1987 10 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1947; RFC 1345; Keld Simonsen iso-ir-126
ISO_8859-7
ISO-8859-7
ELOT_928
ECMA-118
greek
greek8
csISOLatinGreek
ISO-8859-8 ISO_8859-8:1988 11 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-138
ISO_8859-8
ISO-8859-8
hebrew
csISOLatinHebrew
ISO-8859-9 ISO_8859-9:1989 12 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-148
ISO_8859-9
ISO-8859-9
latin5
l5
csISOLatin5
ISO-8859-10 ISO-8859-10 13 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-157
l6
ISO_8859-10:1992
csISOLatin6
latin6
ISO_6937-2-add 14 ISO-IR: International Register of Escape Sequences and ISO 6937-2:1983
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-142
csISOTextComm
JIS_X0201 15 JIS X 0201-1976. One byte only, this is equivalent to JIS/Roman (similar to ASCII) plus eight-bit half-width Katakana RFC 1345; Keld Simonsen X0201
csHalfWidthKatakana
JIS_Encoding 16 JIS X 0202-1991. Uses ISO 2022 escape sequences to shift code sets as documented in JIS X 0202-1991. csJISEncoding
Shift_JIS Shift_JIS 17 This charset is an extension of csHalfWidthKatakana by adding graphic characters in JIS X 0208. The CCS's are JIS X0201:1997 and JIS X0208:1997. The complete definition is shown in Appendix 1 of JIS X0208:1997. This charset can be used for the top-level media type "text". MS_Kanji
csShiftJIS
EUC-JP Extended_UNIX_Code_Packed_Format_for_Japanese 18 Standardized by OSF, UNIX International, and UNIX Systems Laboratories Pacific. Uses ISO 2022 rules to select code set 0: US-ASCII (a single 7-bit byte set) code set 1: JIS X0208-1990 (a double 8-bit byte set) restricted to A0-FF in both bytes code set 2: Half Width Katakana (a single 7-bit byte set) requiring SS2 as the character prefix code set 3: JIS X0212-1990 (a double 7-bit byte set) restricted to A0-FF in both bytes requiring SS3 as the character prefix csEUCPkdFmtJapanese
EUC-JP
Extended_UNIX_Code_Fixed_Width_for_Japanese 19 Used in Japan. Each character is 2 octets. code set 0: US-ASCII (a single 7-bit byte set) 1st byte = 00 2nd byte = 20-7E code set 1: JIS X0208-1990 (a double 7-bit byte set) restricted to A0-FF in both bytes code set 2: Half Width Katakana (a single 7-bit byte set) 1st byte = 00 2nd byte = A0-FF code set 3: JIS X0212-1990 (a double 7-bit byte set) restricted to A0-FF in the first byte and 21-7E in the second byte csEUCFixWidJapanese
BS_4730 20 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-4
ISO646-GB
gb
uk
csISO4UnitedKingdom
SEN_850200_C 21 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-11
ISO646-SE2
se2
csISO11SwedishForNames
IT 22 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-15
ISO646-IT
csISO15Italian
ES 23 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-17
ISO646-ES
csISO17Spanish
DIN_66003 24 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-21
de
ISO646-DE
csISO21German
NS_4551-1 25 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-60
ISO646-NO
no
csISO60DanishNorwegian
csISO60Norwegian1
NF_Z_62-010 26 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-69
ISO646-FR
fr
csISO69French
ISO-10646-UTF-1 27 Universal Transfer Format (1), this is the multibyte encoding, that subsets ASCII-7. It does not have byte ordering issues. csISO10646UTF1
ISO_646.basic:1983 28 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen ref
csISO646basic1983
INVARIANT 29 RFC 1345; Keld Simonsen csINVARIANT
ISO_646.irv:1983 30 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-2
irv
csISO2IntlRefVersion
NATS-SEFI 31 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-8-1
csNATSSEFI
NATS-SEFI-ADD 32 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-8-2
csNATSSEFIADD
NATS-DANO 33 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-9-1
csNATSDANO
NATS-DANO-ADD 34 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-9-2
csNATSDANOADD
SEN_850200_B 35 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-10
FI
ISO646-FI
ISO646-SE
se
csISO10Swedish
KS_C_5601-1987 36 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-149
KS_C_5601-1989
KSC_5601
korean
csKSC56011987
ISO-2022-KR ISO-2022-KR 37 RFC 1557 (see also KS_C_5601-1987) RFC 1557; Woohyong Choi csISO2022KR
EUC-KR EUC-KR 38 RFC 1557 (see also KS_C_5861-1992) RFC 1557; Woohyong Choi csEUCKR
ISO-2022-JP ISO-2022-JP 39 RFC 1468 (see also RFC 2237) RFC 1468; Jun Murai csISO2022JP
ISO-2022-JP-2 ISO-2022-JP-2 40 RFC 1554 RFC 1554; Masataka Ohta csISO2022JP2
JIS_C6220-1969-jp 41 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen JIS_C6220-1969
iso-ir-13
katakana
x0201-7
csISO13JISC6220jp
JIS_C6220-1969-ro 42 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-14
jp
ISO646-JP
csISO14JISC6220ro
PT 43 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-16
ISO646-PT
csISO16Portuguese
greek7-old 44 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-18
csISO18Greek7Old
latin-greek 45 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-19
csISO19LatinGreek
NF_Z_62-010_(1973) 46 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-25
ISO646-FR1
csISO25French
Latin-greek-1 47 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-27
csISO27LatinGreek1
ISO_5427 48 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-37
csISO5427Cyrillic
JIS_C6226-1978 49 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-42
csISO42JISC62261978
BS_viewdata 50 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-47
csISO47BSViewdata
INIS 51 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-49
csISO49INIS
INIS-8 52 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-50
csISO50INIS8
INIS-cyrillic 53 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-51
csISO51INISCyrillic
ISO_5427:1981 54 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-54
ISO5427Cyrillic1981
csISO54271981
ISO_5428:1980 55 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-55
csISO5428Greek
GB_1988-80 56 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-57
cn
ISO646-CN
csISO57GB1988
GB_2312-80 57 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-58
chinese
csISO58GB231280
NS_4551-2 58 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen ISO646-NO2
iso-ir-61
no2
csISO61Norwegian2
videotex-suppl 59 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-70
csISO70VideotexSupp1
PT2 60 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-84
ISO646-PT2
csISO84Portuguese2
ES2 61 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-85
ISO646-ES2
csISO85Spanish2
MSZ_7795.3 62 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-86
ISO646-HU
hu
csISO86Hungarian
JIS_C6226-1983 63 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-87
x0208
JIS_X0208-1983
csISO87JISX0208
greek7 64 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-88
csISO88Greek7
ASMO_449 65 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen ISO_9036
arabic7
iso-ir-89
csISO89ASMO449
iso-ir-90 66 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen csISO90
JIS_C6229-1984-a 67 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-91
jp-ocr-a
csISO91JISC62291984a
JIS_C6229-1984-b 68 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-92
ISO646-JP-OCR-B
jp-ocr-b
csISO92JISC62991984b
JIS_C6229-1984-b-add 69 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-93
jp-ocr-b-add
csISO93JIS62291984badd
JIS_C6229-1984-hand 70 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-94
jp-ocr-hand
csISO94JIS62291984hand
JIS_C6229-1984-hand-add 71 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-95
jp-ocr-hand-add
csISO95JIS62291984handadd
JIS_C6229-1984-kana 72 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-96
csISO96JISC62291984kana
ISO_2033-1983 73 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-98
e13b
csISO2033
ANSI_X3.110-1983 74 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-99
CSA_T500-1983
NAPLPS
csISO99NAPLPS
T.61-7bit 75 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-102
csISO102T617bit
T.61-8bit 76 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen T.61
iso-ir-103
csISO103T618bit
ECMA-cyrillic 77 ISO registry iso-ir-111
KOI8-E
csISO111ECMACyrillic
CSA_Z243.4-1985-1 78 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-121
ISO646-CA
csa7-1
csa71
ca
csISO121Canadian1
CSA_Z243.4-1985-2 79 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-122
ISO646-CA2
csa7-2
csa72
csISO122Canadian2
CSA_Z243.4-1985-gr 80 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-123
csISO123CSAZ24341985gr
ISO-8859-6-E ISO_8859-6-E 81 RFC 1556 RFC 1556; Internet Assigned Numbers Authority csISO88596E
ISO-8859-6-E
ISO-8859-6-I ISO_8859-6-I 82 RFC 1556 RFC 1556; Internet Assigned Numbers Authority csISO88596I
ISO-8859-6-I
T.101-G2 83 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-128
csISO128T101G2
ISO-8859-8-E ISO_8859-8-E 84 RFC 1556 RFC 1556; Hank Nussbacher csISO88598E
ISO-8859-8-E
ISO-8859-8-I ISO_8859-8-I 85 RFC 1556 RFC 1556; Hank Nussbacher csISO88598I
ISO-8859-8-I
CSN_369103 86 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-139
csISO139CSN369103
JUS_I.B1.002 87 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-141
ISO646-YU
js
yu
csISO141JUSIB1002
IEC_P27-1 88 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-143
csISO143IECP271
JUS_I.B1.003-serb 89 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-146
serbian
csISO146Serbian
JUS_I.B1.003-mac 90 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen macedonian
iso-ir-147
csISO147Macedonian
greek-ccitt 91 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-150
csISO150
csISO150GreekCCITT
NC_NC00-10:81 92 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen cuba
iso-ir-151
ISO646-CU
csISO151Cuba
ISO_6937-2-25 93 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-152
csISO6937Add
GOST_19768-74 94 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen ST_SEV_358-88
iso-ir-153
csISO153GOST1976874
ISO_8859-supp 95 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-154
latin1-2-5
csISO8859Supp
ISO_10367-box 96 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen iso-ir-155
csISO10367Box
latin-lap 97 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen lap
iso-ir-158
csISO158Lap
JIS_X0212-1990 98 ISO-IR: International Register of Escape Sequences
Note: The current registration authority is IPSJ/ITSCJ, Japan.
RFC 1345; Keld Simonsen x0212
iso-ir-159
csISO159JISX02121990
DS_2089 99 Danish Standard, DS 2089, February 1974 RFC 1345; Keld Simonsen DS2089
ISO646-DK
dk
csISO646Danish
us-dk 100 RFC 1345; Keld Simonsen csUSDK
dk-us 101 RFC 1345; Keld Simonsen csDKUS
KSC5636 102 RFC 1345; Keld Simonsen ISO646-KR
csKSC5636
UNICODE-1-1-UTF-7 103 RFC 1642 RFC 1642 csUnicode11UTF7
ISO-2022-CN 104 RFC 1922 RFC 1922 csISO2022CN
ISO-2022-CN-EXT 105 RFC 1922 RFC 1922 csISO2022CNEXT
UTF-8 106 RFC 3629 RFC 3629 csUTF8
ISO-8859-13 109 ISO See https://www.iana.org/assignments/charset-reg/ISO-8859-13; Vladas Tumasonis csISO885913
ISO-8859-14 110 ISO See https://www.iana.org/assignments/charset-reg/ISO-8859-14; Keld Simonsen iso-ir-199
ISO_8859-14:1998
ISO_8859-14
latin8
iso-celtic
l8
csISO885914
ISO-8859-15 111 ISO Please see: https://www.iana.org/assignments/charset-reg/ISO-8859-15 ISO_8859-15
Latin-9
csISO885915
ISO-8859-16 112 ISO iso-ir-226
ISO_8859-16:2001
ISO_8859-16
latin10
l10
csISO885916
GBK 113 Chinese IT Standardization Technical Committee Please see: https://www.iana.org/assignments/charset-reg/GBK CP936
MS936
windows-936
csGBK
GB18030 114 Chinese IT Standardization Technical Committee Please see: https://www.iana.org/assignments/charset-reg/GB18030 csGB18030
OSD_EBCDIC_DF04_15 115 Fujitsu-Siemens standard mainframe EBCDIC encoding Please see: https://www.iana.org/assignments/charset-reg/OSD-EBCDIC-DF04-15 csOSDEBCDICDF0415
OSD_EBCDIC_DF03_IRV 116 Fujitsu-Siemens standard mainframe EBCDIC encoding Please see: https://www.iana.org/assignments/charset-reg/OSD-EBCDIC-DF03-IRV csOSDEBCDICDF03IRV
OSD_EBCDIC_DF04_1 117 Fujitsu-Siemens standard mainframe EBCDIC encoding Please see: https://www.iana.org/assignments/charset-reg/OSD-EBCDIC-DF04-1 csOSDEBCDICDF041
ISO-11548-1 118 See https://www.iana.org/assignments/charset-reg/ISO-11548-1; Samuel Thibault ISO_11548-1
ISO_TR_11548-1
csISO115481
KZ-1048 119 See https://www.iana.org/assignments/charset-reg/KZ-1048; Sairan M. Kikkarin; Alexei Veremeev STRK1048-2002
RK1048
csKZ1048
ISO-10646-UCS-2 1000 the 2-octet Basic Multilingual Plane, aka Unicode this needs to specify network byte order: the standard does not specify (it is a 16-bit integer space) csUnicode
ISO-10646-UCS-4 1001 the full code space. (same comment about byte order, these are 31-bit numbers. csUCS4
ISO-10646-UCS-Basic 1002 ASCII subset of Unicode. Basic Latin = collection 1 See ISO 10646, Appendix A csUnicodeASCII
ISO-10646-Unicode-Latin1 1003 ISO Latin-1 subset of Unicode. Basic Latin and Latin-1 Supplement = collections 1 and 2. See ISO 10646, Appendix A. See RFC 1815. csUnicodeLatin1
ISO-10646
ISO-10646-J-1 1004 ISO 10646 Japanese, see RFC 1815. csUnicodeJapanese
ISO-Unicode-IBM-1261 1005 IBM Latin-2, -3, -5, Extended Presentation Set, GCSGID: 1261 csUnicodeIBM1261
ISO-Unicode-IBM-1268 1006 IBM Latin-4 Extended Presentation Set, GCSGID: 1268 csUnicodeIBM1268
ISO-Unicode-IBM-1276 1007 IBM Cyrillic Greek Extended Presentation Set, GCSGID: 1276 csUnicodeIBM1276
ISO-Unicode-IBM-1264 1008 IBM Arabic Presentation Set, GCSGID: 1264 csUnicodeIBM1264
ISO-Unicode-IBM-1265 1009 IBM Hebrew Presentation Set, GCSGID: 1265 csUnicodeIBM1265
UNICODE-1-1 1010 RFC 1641 RFC 1641 csUnicode11
SCSU 1011 SCSU See https://www.iana.org/assignments/charset-reg/SCSU; Markus Scherer csSCSU
UTF-7 1012 RFC 2152 RFC 2152 csUTF7
UTF-16BE 1013 RFC 2781 RFC 2781 csUTF16BE
UTF-16LE 1014 RFC 2781 RFC 2781 csUTF16LE
UTF-16 1015 RFC 2781 RFC 2781 csUTF16
CESU-8 1016 http://www.unicode.org/unicode/reports/tr26 Toby Phipps csCESU8
csCESU-8
UTF-32 1017 http://www.unicode.org/unicode/reports/tr19/ Mark Davis csUTF32
UTF-32BE 1018 http://www.unicode.org/unicode/reports/tr19/ Mark Davis csUTF32BE
UTF-32LE 1019 http://www.unicode.org/unicode/reports/tr19/ Mark Davis csUTF32LE
BOCU-1 1020 http://www.unicode.org/notes/tn6/ Markus Scherer csBOCU1
csBOCU-1
UTF-7-IMAP 1021 Note: This charset is used to encode Unicode in IMAP mailbox names; see Section 5.1.3 of RFC 3501. It should never be used outside this context. A name has been assigned so that charset processing implementations can refer to it in a consistent way. Florian Weimer csUTF7IMAP
ISO-8859-1-Windows-3.0-Latin-1 2000 Extended ISO 8859-1 Latin-1 for Windows 3.0. PCL Symbol Set id: 9U Hewlett-Packard Company, "HP PCL 5 Comparison Guide", (P/N 5021-0329) pp B-13, 1996. csWindows30Latin1
ISO-8859-1-Windows-3.1-Latin-1 2001 Extended ISO 8859-1 Latin-1 for Windows 3.1. PCL Symbol Set id: 19U Hewlett-Packard Company, "HP PCL 5 Comparison Guide", (P/N 5021-0329) pp B-13, 1996. csWindows31Latin1
ISO-8859-2-Windows-Latin-2 2002 Extended ISO 8859-2. Latin-2 for Windows 3.1. PCL Symbol Set id: 9E Hewlett-Packard Company, "HP PCL 5 Comparison Guide", (P/N 5021-0329) pp B-13, 1996. csWindows31Latin2
ISO-8859-9-Windows-Latin-5 2003 Extended ISO 8859-9. Latin-5 for Windows 3.1 PCL Symbol Set id: 5T Hewlett-Packard Company, "HP PCL 5 Comparison Guide", (P/N 5021-0329) pp B-13, 1996. csWindows31Latin5
hp-roman8 2004 LaserJet IIP Printer User's Manual, HP part no 33471-90901, Hewlet-Packard, June 1989. Hewlett-Packard Company, "HP PCL 5 Comparison Guide", (P/N 5021-0329) pp B-13, 1996.; RFC 1345; Keld Simonsen roman8
r8
csHPRoman8
Adobe-Standard-Encoding 2005 PostScript Language Reference Manual PCL Symbol Set id: 10J Adobe Systems Incorporated, PostScript Language Reference Manual, second edition, Addison-Wesley Publishing Company, Inc., 1990. csAdobeStandardEncoding
Ventura-US 2006 Ventura US. ASCII plus characters typically used in publishing, like pilcrow, copyright, registered, trade mark, section, dagger, and double dagger in the range A0 (hex) to FF (hex). PCL Symbol Set id: 14J Hewlett-Packard Company, "HP PCL 5 Comparison Guide", (P/N 5021-0329) pp B-13, 1996. csVenturaUS
Ventura-International 2007 Ventura International. ASCII plus coded characters similar to Roman8. PCL Symbol Set id: 13J Hewlett-Packard Company, "HP PCL 5 Comparison Guide", (P/N 5021-0329) pp B-13, 1996. csVenturaInternational
DEC-MCS 2008 VAX/VMS User's Manual, Order Number: AI-Y517A-TE, April 1986. RFC 1345; Keld Simonsen dec
csDECMCS
IBM850 2009 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen cp850
850
csPC850Multilingual
PC8-Danish-Norwegian 2012 PC Danish Norwegian 8-bit PC set for Danish Norwegian PCL Symbol Set id: 11U Hewlett-Packard Company, "HP PCL 5 Comparison Guide", (P/N 5021-0329) pp B-13, 1996. csPC8DanishNorwegian
IBM862 2013 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen cp862
862
csPC862LatinHebrew
PC8-Turkish 2014 PC Latin Turkish. PCL Symbol Set id: 9T Hewlett-Packard Company, "HP PCL 5 Comparison Guide", (P/N 5021-0329) pp B-13, 1996. csPC8Turkish
IBM-Symbols 2015 Presentation Set, CPGID: 259 IBM Corporation, "ABOUT TYPE: IBM's Technical Reference for Core Interchange Digitized Type", Publication number S544-3708-01 csIBMSymbols
IBM-Thai 2016 Presentation Set, CPGID: 838 IBM Corporation, "ABOUT TYPE: IBM's Technical Reference for Core Interchange Digitized Type", Publication number S544-3708-01 csIBMThai
HP-Legal 2017 PCL 5 Comparison Guide, Hewlett-Packard, HP part number 5961-0510, October 1992 PCL Symbol Set id: 1U Hewlett-Packard Company, "HP PCL 5 Comparison Guide", (P/N 5021-0329) pp B-13, 1996. csHPLegal
HP-Pi-font 2018 PCL 5 Comparison Guide, Hewlett-Packard, HP part number 5961-0510, October 1992 PCL Symbol Set id: 15U Hewlett-Packard Company, "HP PCL 5 Comparison Guide", (P/N 5021-0329) pp B-13, 1996. csHPPiFont
HP-Math8 2019 PCL 5 Comparison Guide, Hewlett-Packard, HP part number 5961-0510, October 1992 PCL Symbol Set id: 8M Hewlett-Packard Company, "HP PCL 5 Comparison Guide", (P/N 5021-0329) pp B-13, 1996. csHPMath8
Adobe-Symbol-Encoding 2020 PostScript Language Reference Manual PCL Symbol Set id: 5M Adobe Systems Incorporated, PostScript Language Reference Manual, second edition, Addison-Wesley Publishing Company, Inc., 1990. csHPPSMath
HP-DeskTop 2021 PCL 5 Comparison Guide, Hewlett-Packard, HP part number 5961-0510, October 1992 PCL Symbol Set id: 7J Hewlett-Packard Company, "HP PCL 5 Comparison Guide", (P/N 5021-0329) pp B-13, 1996. csHPDesktop
Ventura-Math 2022 PCL 5 Comparison Guide, Hewlett-Packard, HP part number 5961-0510, October 1992 PCL Symbol Set id: 6M Hewlett-Packard Company, "HP PCL 5 Comparison Guide", (P/N 5021-0329) pp B-13, 1996. csVenturaMath
Microsoft-Publishing 2023 PCL 5 Comparison Guide, Hewlett-Packard, HP part number 5961-0510, October 1992 PCL Symbol Set id: 6J Hewlett-Packard Company, "HP PCL 5 Comparison Guide", (P/N 5021-0329) pp B-13, 1996. csMicrosoftPublishing
Windows-31J 2024 Windows Japanese. A further extension of Shift_JIS to include NEC special characters (Row 13), NEC selection of IBM extensions (Rows 89 to 92), and IBM extensions (Rows 115 to 119). The CCS's are JIS X0201:1997, JIS X0208:1997, and these extensions. This charset can be used for the top-level media type "text", but it is of limited or specialized use (see RFC 2278). PCL Symbol Set id: 19K csWindows31J
GB2312 GB2312 2025 Chinese for People's Republic of China (PRC) mixed one byte, two byte set: 20-7E = one byte ASCII A1-FE = two byte PRC Kanji See GB 2312-80 PCL Symbol Set Id: 18C csGB2312
Big5 Big5 2026 Chinese for Taiwan Multi-byte set. PCL Symbol Set Id: 18T csBig5
macintosh 2027 The Unicode Standard ver1.0, ISBN 0-201-56788-1, Oct 1991 RFC 1345; Keld Simonsen mac
csMacintosh
IBM037 2028 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen cp037
ebcdic-cp-us
ebcdic-cp-ca
ebcdic-cp-wt
ebcdic-cp-nl
csIBM037
IBM038 2029 IBM 3174 Character Set Ref, GA27-3831-02, March 1990 RFC 1345; Keld Simonsen EBCDIC-INT
cp038
csIBM038
IBM273 2030 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen CP273
csIBM273
IBM274 2031 IBM 3174 Character Set Ref, GA27-3831-02, March 1990 RFC 1345; Keld Simonsen EBCDIC-BE
CP274
csIBM274
IBM275 2032 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen EBCDIC-BR
cp275
csIBM275
IBM277 2033 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen EBCDIC-CP-DK
EBCDIC-CP-NO
csIBM277
IBM278 2034 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen CP278
ebcdic-cp-fi
ebcdic-cp-se
csIBM278
IBM280 2035 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen CP280
ebcdic-cp-it
csIBM280
IBM281 2036 IBM 3174 Character Set Ref, GA27-3831-02, March 1990 RFC 1345; Keld Simonsen EBCDIC-JP-E
cp281
csIBM281
IBM284 2037 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen CP284
ebcdic-cp-es
csIBM284
IBM285 2038 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen CP285
ebcdic-cp-gb
csIBM285
IBM290 2039 IBM 3174 Character Set Ref, GA27-3831-02, March 1990 RFC 1345; Keld Simonsen cp290
EBCDIC-JP-kana
csIBM290
IBM297 2040 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen cp297
ebcdic-cp-fr
csIBM297
IBM420 2041 IBM NLS RM Vol2 SE09-8002-01, March 1990, IBM NLS RM p 11-11 RFC 1345; Keld Simonsen cp420
ebcdic-cp-ar1
csIBM420
IBM423 2042 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen cp423
ebcdic-cp-gr
csIBM423
IBM424 2043 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen cp424
ebcdic-cp-he
csIBM424
IBM437 2011 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen cp437
437
csPC8CodePage437
IBM500 2044 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen CP500
ebcdic-cp-be
ebcdic-cp-ch
csIBM500
IBM851 2045 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen cp851
851
csIBM851
IBM852 2010 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen cp852
852
csPCp852
IBM855 2046 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen cp855
855
csIBM855
IBM857 2047 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen cp857
857
csIBM857
IBM860 2048 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen cp860
860
csIBM860
IBM861 2049 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen cp861
861
cp-is
csIBM861
IBM863 2050 IBM Keyboard layouts and code pages, PN 07G4586 June 1991 RFC 1345; Keld Simonsen cp863
863
csIBM863
IBM864 2051 IBM Keyboard layouts and code pages, PN 07G4586 June 1991 RFC 1345; Keld Simonsen cp864
csIBM864
IBM865 2052 IBM DOS 3.3 Ref (Abridged), 94X9575 (Feb 1987) RFC 1345; Keld Simonsen cp865
865
csIBM865
IBM868 2053 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen CP868
cp-ar
csIBM868
IBM869 2054 IBM Keyboard layouts and code pages, PN 07G4586 June 1991 RFC 1345; Keld Simonsen cp869
869
cp-gr
csIBM869
IBM870 2055 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen CP870
ebcdic-cp-roece
ebcdic-cp-yu
csIBM870
IBM871 2056 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen CP871
ebcdic-cp-is
csIBM871
IBM880 2057 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen cp880
EBCDIC-Cyrillic
csIBM880
IBM891 2058 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen cp891
csIBM891
IBM903 2059 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen cp903
csIBM903
IBM904 2060 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen cp904
904
csIBBM904
IBM905 2061 IBM 3174 Character Set Ref, GA27-3831-02, March 1990 RFC 1345; Keld Simonsen CP905
ebcdic-cp-tr
csIBM905
IBM918 2062 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen CP918
ebcdic-cp-ar2
csIBM918
IBM1026 2063 IBM NLS RM Vol2 SE09-8002-01, March 1990 RFC 1345; Keld Simonsen CP1026
csIBM1026
EBCDIC-AT-DE 2064 IBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987 RFC 1345; Keld Simonsen csIBMEBCDICATDE
EBCDIC-AT-DE-A 2065 IBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987 RFC 1345; Keld Simonsen csEBCDICATDEA
EBCDIC-CA-FR 2066 IBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987 RFC 1345; Keld Simonsen csEBCDICCAFR
EBCDIC-DK-NO 2067 IBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987 RFC 1345; Keld Simonsen csEBCDICDKNO
EBCDIC-DK-NO-A 2068 IBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987 RFC 1345; Keld Simonsen csEBCDICDKNOA
EBCDIC-FI-SE 2069 IBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987 RFC 1345; Keld Simonsen csEBCDICFISE
EBCDIC-FI-SE-A 2070 IBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987 RFC 1345; Keld Simonsen csEBCDICFISEA
EBCDIC-FR 2071 IBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987 RFC 1345; Keld Simonsen csEBCDICFR
EBCDIC-IT 2072 IBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987 RFC 1345; Keld Simonsen csEBCDICIT
EBCDIC-PT 2073 IBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987 RFC 1345; Keld Simonsen csEBCDICPT
EBCDIC-ES 2074 IBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987 RFC 1345; Keld Simonsen csEBCDICES
EBCDIC-ES-A 2075 IBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987 RFC 1345; Keld Simonsen csEBCDICESA
EBCDIC-ES-S 2076 IBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987 RFC 1345; Keld Simonsen csEBCDICESS
EBCDIC-UK 2077 IBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987 RFC 1345; Keld Simonsen csEBCDICUK
EBCDIC-US 2078 IBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987 RFC 1345; Keld Simonsen csEBCDICUS
UNKNOWN-8BIT 2079 RFC 1428 csUnknown8BiT
MNEMONIC 2080 RFC 1345, also known as "mnemonic+ascii+38" RFC 1345; Keld Simonsen csMnemonic
MNEM 2081 RFC 1345, also known as "mnemonic+ascii+8200" RFC 1345; Keld Simonsen csMnem
VISCII 2082 RFC 1456 RFC 1456 csVISCII
VIQR 2083 RFC 1456 RFC 1456 csVIQR
KOI8-R KOI8-R 2084 RFC 1489, based on GOST-19768-74, ISO-6937/8, INIS-Cyrillic, ISO-5427. RFC 1489 csKOI8R
HZ-GB-2312 2085 RFC 1842, RFC 1843; RFC 1843; RFC 1842
IBM866 2086 IBM NLDG Volume 2 (SE09-8002-03) August 1994 Rick Pond cp866
866
csIBM866
IBM775 2087 HP PCL 5 Comparison Guide (P/N 5021-0329) pp B-13, 1996 Hewlett-Packard Company, "HP PCL 5 Comparison Guide", (P/N 5021-0329) pp B-13, 1996. cp775
csPC775Baltic
KOI8-U 2088 RFC 2319 RFC 2319 csKOI8U
IBM00858 2089 IBM See https://www.iana.org/assignments/charset-reg/IBM00858; Tamer Mahdi CCSID00858
CP00858
PC-Multilingual-850+euro
csIBM00858
IBM00924 2090 IBM See https://www.iana.org/assignments/charset-reg/IBM00924; Tamer Mahdi CCSID00924
CP00924
ebcdic-Latin9--euro
csIBM00924
IBM01140 2091 IBM See https://www.iana.org/assignments/charset-reg/IBM01140; Tamer Mahdi CCSID01140
CP01140
ebcdic-us-37+euro
csIBM01140
IBM01141 2092 IBM See https://www.iana.org/assignments/charset-reg/IBM01141; Tamer Mahdi CCSID01141
CP01141
ebcdic-de-273+euro
csIBM01141
IBM01142 2093 IBM See https://www.iana.org/assignments/charset-reg/IBM01142; Tamer Mahdi CCSID01142
CP01142
ebcdic-dk-277+euro
ebcdic-no-277+euro
csIBM01142
IBM01143 2094 IBM See https://www.iana.org/assignments/charset-reg/IBM01143; Tamer Mahdi CCSID01143
CP01143
ebcdic-fi-278+euro
ebcdic-se-278+euro
csIBM01143
IBM01144 2095 IBM See https://www.iana.org/assignments/charset-reg/IBM01144; Tamer Mahdi CCSID01144
CP01144
ebcdic-it-280+euro
csIBM01144
IBM01145 2096 IBM See https://www.iana.org/assignments/charset-reg/IBM01145; Tamer Mahdi CCSID01145
CP01145
ebcdic-es-284+euro
csIBM01145
IBM01146 2097 IBM See https://www.iana.org/assignments/charset-reg/IBM01146; Tamer Mahdi CCSID01146
CP01146
ebcdic-gb-285+euro
csIBM01146
IBM01147 2098 IBM See https://www.iana.org/assignments/charset-reg/IBM01147; Tamer Mahdi CCSID01147
CP01147
ebcdic-fr-297+euro
csIBM01147
IBM01148 2099 IBM See https://www.iana.org/assignments/charset-reg/IBM01148; Tamer Mahdi CCSID01148
CP01148
ebcdic-international-500+euro
csIBM01148
IBM01149 2100 IBM See https://www.iana.org/assignments/charset-reg/IBM01149; Tamer Mahdi CCSID01149
CP01149
ebcdic-is-871+euro
csIBM01149
Big5-HKSCS 2101 See https://www.iana.org/assignments/charset-reg/Big5-HKSCS Nicky Yick csBig5HKSCS
IBM1047 2102 IBM1047 (EBCDIC Latin 1/Open Systems) http://www-1.ibm.com/servers/eserver/iseries/software/globalization/pdf/cp01047z.pdf Reuel Robrigado IBM-1047
csIBM1047
PTCP154 2103 See https://www.iana.org/assignments/charset-reg/PTCP154 Alexander Uskov csPTCP154
PT154
CP154
Cyrillic-Asian
Amiga-1251 2104 See http://www.amiga.ultranet.ru/Amiga-1251.html Ami1251
Amiga1251
Ami-1251
csAmiga1251 (Aliases are provided for historical reasons and should not be used) [Malyshev]
KOI7-switched 2105 See https://www.iana.org/assignments/charset-reg/KOI7-switched csKOI7switched
BRF 2106 See https://www.iana.org/assignments/charset-reg/BRF; Samuel Thibault csBRF
TSCII 2107 See https://www.iana.org/assignments/charset-reg/TSCII; Kuppuswamy Kalyanasundaram csTSCII
CP51932 2108 See https://www.iana.org/assignments/charset-reg/CP51932; Yui Naruse csCP51932
windows-874 2109 See https://www.iana.org/assignments/charset-reg/windows-874; Shawn Steele cswindows874
windows-1250 2250 Microsoft https://www.iana.org/assignments/charset-reg/windows-1250; Katya Lazhintseva cswindows1250
windows-1251 2251 Microsoft https://www.iana.org/assignments/charset-reg/windows-1251; Katya Lazhintseva cswindows1251
windows-1252 2252 Microsoft https://www.iana.org/assignments/charset-reg/windows-1252; Chris Wendt cswindows1252
windows-1253 2253 Microsoft https://www.iana.org/assignments/charset-reg/windows-1253; Katya Lazhintseva cswindows1253
windows-1254 2254 Microsoft https://www.iana.org/assignments/charset-reg/windows-1254; Katya Lazhintseva cswindows1254
windows-1255 2255 Microsoft https://www.iana.org/assignments/charset-reg/windows-1255; Katya Lazhintseva cswindows1255
windows-1256 2256 Microsoft https://www.iana.org/assignments/charset-reg/windows-1256; Katya Lazhintseva cswindows1256
windows-1257 2257 Microsoft https://www.iana.org/assignments/charset-reg/windows-1257; Katya Lazhintseva cswindows1257
windows-1258 2258 Microsoft https://www.iana.org/assignments/charset-reg/windows-1258; Katya Lazhintseva cswindows1258
TIS-620 2259 Thai Industrial Standards Institute (TISI) Trin Tantsetthi csTIS620
ISO-8859-11
CP50220 2260 See https://www.iana.org/assignments/charset-reg/CP50220; Yui Naruse csCP50220

Contact Information

Name Contact URI Last Updated
Alexander Uskov auskov&idc.kz 2002-09
Alexei Veremeev Alexey.Veremeev&oracle.com 2006-12-07
Chris Wendt christw&microsoft.com 1999-12
Florian Weimer fw&deneb.enyo.de 2021-01-04
Hank Nussbacher hank&vm.tau.ac.il
Internet Assigned Numbers Authority iana&iana.org
Jun Murai jun&wide.ad.jp
Katya Lazhintseva katyal&microsoft.com 1996-05
Keld Simonsen Keld&keldix.com 2018-10-19
Keld Simonsen Keld.Simonsen&rap.dk 2000-08
Kuppuswamy Kalyanasundaram kalyan.geo&yahoo.com 2007-05-14
Mark Davis mark&unicode.org 2002-04
Markus Scherer markus.scherer&jtcsv.com 2002-09
Masataka Ohta mohta&cc.titech.ac.jp 1995-07
Nicky Yick cliac&itsd.gcn.gov.hk 2000-10
Reuel Robrigado reuelr&ca.ibm.com 2002-09
Rick Pond rickpond&vnet.ibm.com 1997-03
Sairan M. Kikkarin sairan&sci.kz 2006-12-07
Samuel Thibault samuel.thibault&ens-lyon.org 2006-12-07
Shawn Steele Shawn.Steele&microsoft.com 2010-11-04
Tamer Mahdi tamer&ca.ibm.com 2000-08
Toby Phipps tphipps&peoplesoft.com 2002-03
Trin Tantsetthi trin&mozart.inet.co.th 1998-09
Vladas Tumasonis vladas.tumasonis&maf.vu.lt 2000-08
Woohyong Choi whchoi&cosmos.kaist.ac.kr
Yui Naruse naruse&airemix.jp 2011-09-23