Civic Address Types Registry

Created

  • 2006-04-11

Last Updated

  • 2014-04-11

Available Formats


Civic Address Types (CAtypes)

Expert(s)

  • Martin Thomson

Reference

  • RFC 4776: Dynamic Host Configuration Protocol (DHCPv4 and DHCPv6) Option for Civic Addresses Configuration Information
  • RFC 6848: Specifying Civic Address Extensions in the Presence Information Data Format Location Object (PIDF-LO)

Note

No registrations of new CAtype numbers in the Civic Address Types Registry are permitted, except by IESG Approval under unusual circumstances. As specified in RFC 6848, new registrations are accepted only for CAtype 40, using the template specified in Section 8.3.

Note

The registration of new values should be accompanied by a corresponding reservation in the Relative Location Parameters registry.

Available Formats

Range Registration Procedures
Type=A IETF Review
Type=B Expert Review
CAtype Local Name Description Example Namespace URI Contact Schema Type Reference
0 language i-default urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776; RFC 2277
1 A1 national subdivisions (state, canton, region, province, prefecture) urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776
2 A2 county, parish, gun (JP), district (IN) urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776
3 A3 city, township, shi (JP) urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776
4 A4 city division, borough, city district, ward, chou (JP) urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776
5 A5 neighborhood, block urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776
6 A6 group of streets below the neighborhood level urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776
7-10 Unassigned
11-15 RESERVED by Relative Location Parameters registry RFC 7035
16 PRD leading street direction N urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776
17 POD trailing street suffix SW urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776
18 STS street suffix or type Ave, Platz urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776
19 HNO house number 123 urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776
20 HNS house number suffix A, 1/2 urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776
21 LMK landmark or vanity address Columbia University urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776
22 LOC additional location information South Wing urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776
23 NAM name (residence and office occupant) Joe's Barbershop urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776
24 PC postal/zip code 10027-1234 urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776
25 BLD building (structure) Low Library urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776; RFC 5139
26 UNIT unit (apartment, suite) Apt 42 urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776; RFC 5139
27 FLR floor 4 urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776
28 ROOM room number 450F urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776; RFC 5139
29 PLC type of place office urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4589; RFC 5139
30 PCN postal community name Leonia urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776; RFC 5139
31 POBOX post office box (P.O. Box) 12345 urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776; RFC 5139
32 ADDCODE additional code 13203000003 urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776; RFC 5139
33 SEAT seat (desk, cubicle, workstation) WS 181 urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776; RFC 5139
34 RD Primary road or street Broadway urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776; RFC 5139
35 RDSEC Road section 14 urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776; RFC 5139
36 RDBR Road branch Lane 7 urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776; RFC 5139
37 RDSUBBR Road sub-branch Alley 8 urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776; RFC 5139
38 PRM Street name pre-modifier Old urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776; RFC 5139
39 POM Street name post-modifier Service urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776; RFC 5139
40 PN Post number that is attributed to a lamp post or utility pole. urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr:ext The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr:ext A RFC 6848
40 MP Milepost: a marker indicating distance to or from a place (often a town). urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr:ext The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr:ext A RFC 6848
40 STP Street Type Prefix. urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr:ext The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr:ext A RFC 6848
40 HNP House Number Prefix. urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr:ext The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr:ext A RFC 6848
40 STPS Separator between the existing Street Type Prefix (STP) and the Road Name (RD) elements. urn:nena:xml:ns:pidf:nenaCivicAddr The NENA Registry System urn:nena:xml:schema:pidf:nenaCivicAddr B NENA-STA-004
40 LMKP Component part of a Complete Landmark Name. urn:nena:xml:ns:pidf:nenaCivicAddr The NENA Registry System urn:nena:xml:schema:pidf:nenaCivicAddr B NENA-STA-004
41-127 RESERVED by Relative Location Parameters registry RFC 7035
128 script Latn urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr The IESG (iesg@ietf.org); the GEOPRIV working group (geopriv@ietf.org) urn:ietf:params:xml:schema:pidf:geopriv10:civicAddr A RFC 4776
129-131 RESERVED by Relative Location Parameters registry RFC 7035
132-254 Unassigned
255 Reserved RFC 4776

Relative Location Parameters

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 7035: Relative Location Representation

Note

The registration of a new value should be accompanied by a corresponding reservation in the Civic Address Types (CAtypes) registry.

Available Formats

RLtype Description Reference
0-40 RESERVED by CAtypes registry RFC 4776; RFC 7035
41-110 Unassigned
111 relative location reference RFC 7035
112 Unassigned
113 relative location shape 2D point RFC 7035
114 relative location shape 3D point RFC 7035
115 relative location shape circular RFC 7035
116 relative location shape spherical RFC 7035
117 relative location shape elliptical RFC 7035
118 relative location shape ellipsoid RFC 7035
119 relative location shape 2D polygon RFC 7035
120 relative location shape 3D polygon RFC 7035
121 relative location shape prism RFC 7035
122 relative location shape arc-band RFC 7035
123 relative location dynamic orientation RFC 7035
124 relative location dynamic speed RFC 7035
125 relative location dynamic heading RFC 7035
126 relative location map type RFC 7035
127 relative location map URI RFC 7035
128 RESERVED by CAtypes registry RFC 4776; RFC 7035
129 relative location map coordinates RFC 7035
130 relative location map angle RFC 7035
131 relative location map scale RFC 7035
132-255 Unassigned

Contact Information

Name Contact URI Last Updated
The NENA Registry System nrs-admin&nena.org 2014-04-11