Common Name Resolution Protocol (CNRP) Parameters
Created
- 2002-08-15
Last Updated
- 2002-08-21
Available Formats
Properties
Registration Procedure(s)
- First Come First Served
Reference
- RFC 3367: Common Name Resolution Protocol (CNRP)
Available Formats
| Property Name | Default Type | Description | Reference |
|---|---|---|---|
| geography | iso3166-1 | A geographic location | RFC 3367 |
| language | rfc1766 | A language specification | RFC 3367 |
| category | freeform | A node in some system of semantic relationships that is considered relevant to the common-name. | RFC 3367 |
| range | range | A range given in the format "x,y" where x is the starting point and y is the length. This property is used by the client to tell the server that is is requesting a subrange of the results. | RFC 3367 |
| dataseturi | uri | A URI used to disambiguate between two Datasets offered by the same Service. | RFC 3367 |
Property Types
Registration Procedure(s)
- First Come First Served
Reference
- RFC 3367: Common Name Resolution Protocol (CNRP)
Available Formats
| Type | Property | Description | Reference |
|---|---|---|---|
| freeform | category | The value is to be interpreted by the server the best way it knows how. This value has no defined structure. | RFC 3367 |
| freeform | geography | The value is to be interpreted by the server the best way it knows how. This value has no defined structure. | RFC 3367 |
| freeform | language | The value is to be interpreted by the server the best way it knows how. This value has no defined structure. | RFC 3367 |
| iso3166-2 | geography | The combination of country and sub-region codes found in ISO 3166-2. | RFC 3367 |
| iso3166-1 | Geography | Country Codes found in ISO 3166-1. | RFC 3367 |
| postalcode | Geography | A postal code that is valid for some region. A good example is the Zip code system used in the US. | RFC 3367 |
| lat-long | Geography | The latitude and longitude of a geographical location in the form specified in Department of Commerce, 1986, Representation of geographic point locations for information interchange (Federal Information Processing Standard 70-1): Washington, Department of Commerce, National Institute of Standards and Technology. | RFC 3367 |
| rfc1766 | Language | Language codes as defined by RFC 1766. | RFC 3367 |
| naics | Category | North American Industry Code System. | RFC 3367 |
| uri | dataseturi | A URI adhering to the 'absoluteURI' production of the Collected ABNF found in RFC 2396. | RFC 3367 |
Status Messages
Registration Procedure(s)
- First Come First Served
Reference
- RFC 3367: Common Name Resolution Protocol (CNRP)
Status Messages Level 1 - (Informative) Codes
Registration Procedure(s)
- First Come First Served
Reference
- RFC 3367: Common Name Resolution Protocol (CNRP)
Available Formats
Status Messages Level 2 - (Success) Codes
Registration Procedure(s)
- First Come First Served
Reference
- RFC 3367: Common Name Resolution Protocol (CNRP)
Available Formats
Status Messages Level 3 - (Partial Success) Codes
Registration Procedure(s)
- First Come First Served
Reference
- RFC 3367: Common Name Resolution Protocol (CNRP)
Available Formats
| Code | Description | Reference |
|---|---|---|
| 3.0.0 | Something undefined was only partially successful | RFC 3367 |
| 3.1.0 | The query was only partially successful | RFC 3367 |
| 3.1.1 | The query contained invalid or unsupported properties | RFC 3367 |
| 3.1.2 | The XML was well formed but invalid | RFC 3367 |
| 3.1.3 | Server does not support datasets | RFC 3367 |
| 3.1.4 | The first dataset in the list of datasets you gave in the query was the only one used | RFC 3367 |
| 3.1.5 | This dataset not supported | RFC 3367 |
| 3.2.0 | The server caused a partially successful event | RFC 3367 |
| 3.2.1 | Some referral server was unavailable | RFC 3367 |
Status Messages Level 4 - (Transient Failure) Codes
Registration Procedure(s)
- First Come First Served
Reference
- RFC 3367: Common Name Resolution Protocol (CNRP)
Available Formats
| Code | Description | Reference |
|---|---|---|
| 4.0.0 | Something undefined caused a persistent transient failure | RFC 3367 |
| 4.1.0 | There was an error in the query that made it unable to be interpreted | RFC 3367 |
| 4.2.0 | The query was to complex | RFC 3367 |
| 4.2.1 | The Service was too busy | RFC 3367 |
| 4.2.2 | The Server is in maintenance | RFC 3367 |
| 4.2.3 | The Server had an internal error | RFC 3367 |
Status Messages Level 5 - (Permanent Failures) Codes
Registration Procedure(s)
- First Come First Served
Reference
- RFC 3367: Common Name Resolution Protocol (CNRP)