Common Open Policy Service (COPS) Protocol
Client Types Values
- RFC 2748: The COPS (Common Open Policy Service) Protocol
Client-type values in the range 0x4000 - 0x7FFF are reserved for
Private Use as defined in RFC 8126. These Client-types
are not tracked by IANA and are not to be used in standards or
general-release products, as their uniqueness cannot be assured.
| Range |
Registration Procedures |
Notes |
| 0x0 |
IETF Review |
Defined by RFC4261 |
| 0x001-0x3FF |
Specification Required |
COPS extension document required |
| 0x4000-0x7FFF |
Reserved |
Private Use |
| 0x8000-0xFFFF |
First Come First Served |
|
Client-type Values (0x0001-0x3FFF)
| Value |
Name |
PIB Module |
Description |
Reference |
| 1 |
|
|
COPS Usage for RSVP |
RFC 2749 |
| 2 |
diffServ |
dsPolicyPib |
DiffServ QoS, DIFFSERV-PIB |
RFC 3317 |
Client-Type Values (0x8000-0xFFFF)
| Value |
Name |
PIB Module |
Description |
Reference |
| 0x8001 |
|
|
IP Highway |
Shai Herzog |
| 0x8002 |
|
|
IP Highway |
Shai Herzog |
| 0x8003 |
|
|
IP Highway |
Shai Herzog |
| 0x8004 |
|
|
IP Highway |
Shai Herzog |
| 0x8005 |
|
|
Fujitsu Application Server Software Division |
Tetsuharu Hanada |
| 0x8006 |
|
|
HP OpenView PolicyXpert |
Brian O'Keefe |
| 0x8007 |
|
|
HP OpenView PolicyXpert COPS-PR PXPIB |
Brian O'Keefe |
| 0x8008 |
|
|
PacketCable Dynamic Quality of Service |
Jason Gaedtke |
| 0x8009 |
go3gppPib |
go3gppPib |
COPS usage for 3GPP GO interface |
ftp://ftp.3gpp.org/specs/Specs/archive/29_series/29.207/ |
| 0x800a |
|
|
PacketCable Multimedia
[http://www.packetcable.com/specifications/multimedia.html] |
|
| 0x800b |
|
|
Juniper Networks |
John Scano |
| 0x800c |
ITUT-RwPIB |
ITUT-RwPIB |
Q.3303.1 (Rw interface) COPS alternative |
ITU-T Recommendation Q.3303.1 |
| 0x800d |
ITUT-RcPIB |
ITUT-RcPIB |
Q.3304.1 (Rc interface) COPS alternative |
ITU-T Recommendation Q.3304.1 |
C-Num and C-Type Values
- RFC 2748: The COPS (Common Open Policy Service) Protocol
| c-num |
c-type |
Description |
Reference |
| 0x01 |
0x01 |
Handle |
RFC 2748 |
| 0x02 |
0x01 |
Context |
RFC 2748 |
| 0x03 |
0x01 |
In-Interface, IPv4 |
RFC 2748 |
| 0x03 |
0x02 |
In-Interface, IPv6 |
RFC 2748 |
| 0x04 |
0x01 |
Out-Interface, IPv4 |
RFC 2748 |
| 0x04 |
0x02 |
Out-Interface, IPv6 |
RFC 2748 |
| 0x05 |
0x01 |
Reason |
RFC 2748 |
| 0x06 |
0x01 |
Decision, Flags |
RFC 2748 |
| 0x06 |
0x02 |
Decision, Stateless Data |
RFC 2748 |
| 0x06 |
0x03 |
Decision, Replacement Data |
RFC 2748 |
| 0x06 |
0x04 |
Decision, Client Specific Decision Data |
RFC 2748 |
| 0x06 |
0x05 |
Decision, Named Decision Data |
RFC 2748 |
| 0x07 |
0x01 |
LPDP Decision, Flags |
RFC 2748 |
| 0x07 |
0x02 |
LPDP Decision, Stateless Data |
RFC 2748 |
| 0x07 |
0x03 |
LPDP Decision, Replacement Data |
RFC 2748 |
| 0x07 |
0x04 |
LPDP Decision, Client Specific Decision Data |
RFC 2748 |
| 0x07 |
0x05 |
LPDP Decision, Named Decision Data |
RFC 2748 |
| 0x08 |
0x01 |
Error |
RFC 2748 |
| 0x09 |
0x01 |
Client Specific Information, Signaled |
RFC 2748 |
| 0x09 |
0x02 |
Client Specific Information, Named |
RFC 2748 |
| 0x0A |
0x01 |
Keep-Alive Timer |
RFC 2748 |
| 0x0B |
0x01 |
PEP Identification |
RFC 2748 |
| 0x0C |
0x01 |
Report-Type |
RFC 2748 |
| 0x0D |
0x01 |
PDP Redirect Address, IPv4 + TCP Port |
RFC 2748 |
| 0x0D |
0x02 |
PDP Redirect Address, IPv6 + TCP Port |
RFC 2748 |
| 0x0E |
0x01 |
Last PDP Address, IPv4 + TCP Port |
RFC 2748 |
| 0x0E |
0x02 |
Last PDP Address, IPv6 + TCP Port |
RFC 2748 |
| 0x0F |
0x01 |
Accounting Timer |
RFC 2748 |
| 0x10 |
0x01 |
Message Integrity |
RFC 2748 |
| 0x10 |
0x02 |
Message Integrity, Integrity-TLS |
RFC 4261 |
R-Types, Reason-Codes, Report-Types, Decision Object Command-Codes/Flags, and Error-Codes
- RFC 2748: The COPS (Common Open Policy Service) Protocol
R-Types
| R-Type |
Description |
Reference |
| 0x01 |
Incoming-Message/Admission Control request |
RFC 2748 |
| 0x02 |
Resource-Allocation request |
RFC 2748 |
| 0x04 |
Outgoing-Message request |
RFC 2748 |
| 0x08 |
Configuration request |
RFC 2748 |
Decision Object Command-Codes
Decision Object Flags
| Decision-Flag |
Description |
Reference |
| 0x01 |
Trigger Error |
RFC 2748 |
| 0x02 |
Request-State |
RFC 3084 |
M-Types, Reason Sub-Codes, and Error Sub-codes
- Values are assigned relative to the respective Client-type
- RFC 2748: The COPS (Common Open Policy Service) Protocol
| No registrations at this time. |
Client-type = 0 Flags and Error-SubCodes
- RFC 4261: Common Open Policy Service (COPS) Over Transport Layer Security (TLS)
| Error-Code |
Error-SubCode Octet 2 |
Error-SubCode Octet 3 |
Description |
Reference |
| 15 |
16 |
0 |
No security |
RFC 4261 |
| 15 |
16 |
2 |
Integrity-TLS supported/preferred |
RFC 4261 |
Flags
- RFC 4261: Common Open Policy Service (COPS) Over Transport Layer Security (TLS)
| Value |
Flag |
Reference |
| 0x01 |
StartTLS |
RFC 4261 |
COPS-PR Object S-Num, S-Types, and Error-Codes
- RFC 3084: COPS Usage for Policy Provisioning (COPS-PR)
Additional COPS-PR RFC 3084 Object S-Num, S-Types, and Error-Codes
MAY be defined for use with future COPS-PR Client-types, but such
additions require IETF Review as defined in RFC 8126.
| s-num |
s-type val |
Description (s-num, s-type) |
Reference |
| 0x01 |
0x01 |
Complete PRID, BER |
RFC 3084 |
| 0x02 |
0x01 |
Prefix PRID, BER |
RFC 3084 |
| 0x03 |
0x01 |
EPD, BER |
RFC 3084 |
| 0x04 |
0x01 |
GPERR, BER |
RFC 3084 |
| 0x05 |
0x01 |
CPERR, BER |
RFC 3084 |
| 0x06 |
0x01 |
ErrorPRID, BER |
RFC 3084 |
|
0x02 |
Reserved for transport of XML encoded data |
RFC 3084 |
Global Provisioning Error (GPERR) (s-num=4, s-type=1)
- RFC 3084: COPS Usage for Policy Provisioning (COPS-PR)
Class-Specific Provisioning Error (CPERR) (s-num=5, s-type=1)
- RFC 3084: COPS Usage for Policy Provisioning (COPS-PR)
P-types
- RFC 2750: RSVP Extensions for Policy Control
| Range |
Registration Procedures |
Note |
| 0-49151 |
IETF Review |
|
| 49152-53247 |
First Come First Served |
Vendor-specific |
| 53248-65535 |
Reserved for Private Use |
|
AUTH_SESSION X-Types (0x04)
- RFC 3520: Session Authorization Policy Element
| Range |
Registration Procedures |
| 0-127 |
IETF Review |
| 128-255 |
Private Use |
AUTH_ENT_ID (X-Type 1) SubType values
- RFC 3520: Session Authorization Policy Element
| Range |
Registration Procedures |
| 0-127 |
IETF Review |
| 128-255 |
Private Use |
SOURCE_ADDR (X-Type 3) SubType values
- RFC 3520: Session Authorization Policy Element
| Range |
Registration Procedures |
| 0-127 |
IETF Review |
| 128-255 |
Private Use |
| SubType |
Description |
Reference |
| 0 |
Reserved |
|
| 1 |
IPV4_ADDRESS |
RFC 3520 |
| 2 |
IPV6_ADDRESS |
RFC 3520 |
| 3 |
UDP_PORT_LIST |
RFC 3520 |
| 4 |
TCP_PORT_LIST |
RFC 3520 |
| 5-127 |
Unassigned |
|
| 128-255 |
Reserved |
|
DEST_ADDR (X-Type 4) SubType values
- RFC 3520: Session Authorization Policy Element
| Range |
Registration Procedures |
| 0-127 |
IETF Review |
| 128-255 |
Private Use |
| SubType |
Description |
Reference |
| 0 |
Reserved |
|
| 1 |
IPV4_ADDRESS |
RFC 3520 |
| 2 |
IPV6_ADDRESS |
RFC 3520 |
| 3 |
UDP_PORT_LIST |
RFC 3520 |
| 4 |
TCP_PORT_LIST |
RFC 3520 |
| 5-127 |
Unassigned |
|
| 128-255 |
Reserved |
|
START_TIME (X-Type 5) SubType values
- RFC 3520: Session Authorization Policy Element
| Range |
Registration Procedures |
| 0-127 |
IETF Review |
| 128-255 |
Private Use |
| SubType |
Description |
Reference |
| 0 |
Reserved |
|
| 1 |
NTP_TIMESTAMP |
RFC 3520 |
| 2-127 |
Unassigned |
|
| 128-255 |
Reserved |
|
END_TIME (X-Type 6) SubType values
- RFC 3520: Session Authorization Policy Element
| Range |
Registration Procedures |
| 0-127 |
IETF Review |
| 128-255 |
Private Use |
| SubType |
Description |
Reference |
| 0 |
Reserved |
|
| 1 |
NTP_TIMESTAMP |
RFC 3520 |
| 2-127 |
Unassigned |
|
| 128-255 |
Reserved |
|
RESOURCES (X-Type 7) SubType values
- RFC 3520: Session Authorization Policy Element
| Range |
Registration Procedures |
| 0-127 |
IETF Review |
| 128-255 |
Private Use |
A-types
- RFC 3182: Identity Representation for RSVP
| Range |
Registration Procedures |
| 0-127 |
IETF Review |
| 128-255 |
Private Use |
| A-Type |
Description |
Reference |
| 0 |
Reserved |
|
| 1 |
POLICY_LOCATOR |
RFC 3182 |
| 2 |
CREDENTIAL |
RFC 3182 |
| 3 |
DIGITAL_SIGNATURE |
RFC 3182 |
| 4 |
POLICY_ERROR_OBJECT |
RFC 3182 |
| 5-127 |
Unassigned |
|
| 128-255 |
Reserved |
|
POLICY_LOCATOR (A-Type 1) SubType values
- RFC 3182: Identity Representation for RSVP
| Range |
Registration Procedures |
| 0-127 |
IETF Review |
| 128-255 |
Private Use |
| SubType |
Description |
Reference |
| 0 |
Reserved |
|
| 1 |
ASCII_DN |
RFC 3182 |
| 2 |
UNICODE_DN |
RFC 3182 |
| 3 |
ASCII_DN_ENCRYPT |
RFC 3182 |
| 4 |
UNICODE_DN_ENCRYPT |
RFC 3182 |
| 5-127 |
Unassigned |
|
| 128-255 |
Reserved |
|
CREDENTIAL (A-Type 2) SubType values
- RFC 3182: Identity Representation for RSVP
| Range |
Registration Procedures |
| 0-127 |
IETF Review |
| 128-255 |
Private Use |
POLICY_ERROR_CODE ErrorValues (A-Type 4)
- RFC 3182: Identity Representation for RSVP
| Range |
Registration Procedures |
| 0-32767 |
IETF Review |
| 32768-65535 |
Private Use |
| ErrorValue |
Description |
Reference |
| 0 |
Reserved |
|
| 1 |
ErrorValue ERROR_NO_MORE_INFO |
RFC 3182 |
| 2 |
UNSUPPORTED_CREDENTIAL_TYPE |
RFC 3182 |
| 3 |
INSUFFICIENT_PRIVILEGES |
RFC 3182 |
| 4 |
EXPIRED_CREDENTIAL |
RFC 3182 |
| 5 |
IDENTITY_CHANGED |
RFC 3182 |
| 6-32767 |
Unassigned |
|
| 32768-65535 |
Reserved |
|
Merge Strategies
- RFC 6401: RSVP Extensions for Admission Priority
| Range |
Registration Procedures |
| 0-127 |
IETF Review |
| 128-240 |
First Come First Served |
ADMISSION_PRI (P-Type 0x05) Error Codes
- RFC 6401: RSVP Extensions for Admission Priority
| Range |
Registration Procedures |
| 0-127 |
IETF Review |
| 128-240 |
First Come First Served |
| Value |
Description |
Reference |
| 0 |
NO_ERROR Value used for regular ADMISSION_PRI elements |
RFC 6401 |
| 1 |
Reserved |
RFC 6401 |
| 2 |
HETEROGENEOUS This element encountered heterogeneous merge |
RFC 6401 |
| 3-240 |
Unassigned |
|
| 241-255 |
Reserved for Private Use |
RFC 6401 |
Receiver Proxy Control Policy Element (P-Type 0x07) Control-Value field
- RFC 5946: Resource Reservation Protocol (RSVP) Extensions for Path-Triggered RSVP Receiver Proxy
| Range |
Registration Procedures |
| 0-127 |
IETF Review |
| 128-240 |
First Come First Served |
| Value |
Description |
Reference |
| 0 |
Reserved |
RFC 5946 |
| 1 |
Receiver-Proxy-Needed |
RFC 5946 |
| 2 |
Receiver-Proxy-Not-Needed |
RFC 5946 |
| 3-240 |
Unassigned |
|
| 241-255 |
Reserved for Private Use |
RFC 5946 |
Contact Information