| core.gp |
Group Configuration resource. This resource is used to
query/manage the group membership of a CoAP server. |
RFC 7390, Section 2.6.2 |
|
| core.hc |
HTTP-to-CoAP mapping base resource. |
RFC 8075, Section 5.5 |
|
| core.rd |
Directory resource of an RD |
RFC 9176, Section 4.3 |
|
| core.rd-ep |
Endpoint resource of an RD |
RFC 9176, Section 6 |
|
| core.rd-lookup-ep |
Endpoint lookup of an RD |
RFC 9176, Section 4.3 |
|
| core.rd-lookup-res |
Resource lookup of an RD |
RFC 9176, Section 4.3 |
|
| oic.d.airconditioner |
Air Conditioner device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.airpurifier |
Air Purifier device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.blind |
Blind device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.camera |
Camera device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.dishwasher |
Dishwasher device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.door |
Door device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.dryer |
Dryer device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.fan |
Fan device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.garagedoor |
Garage Door device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.light |
Light device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.multifunctionprinter |
Printer Multi-Function device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.oven |
Oven device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.printer |
Printer device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.receiver |
Receiver device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.refrigerator |
Refrigerator device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.robotcleaner |
Robot Cleaner device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.scanner |
Scanner device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.securitypanel |
Security Panel device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.sensor |
Generic Sensor device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.smartlock |
Smart Lock device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.smartplug |
Smart Plug device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.switch |
Switch device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.thermostat |
Thermostat device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.tv |
Television device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.washer |
Washer device. This is a clothes washer device. |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.d.watervalve |
Water Valve device |
OIC_SmartHomeDevice_Specification_v1.1.0 section 10.1 |
|
| oic.r.airflow |
Air Flow resource. This resource describes the properties associated with air flow. |
OIC_Resource_Type_Specification_v1.1.0 section 6.1 |
|
| oic.r.airflowcontrol |
Air Flow Control resource. This resource describes the attributes associated with control of air flow, for example as modelled by a Thermostat (fan), Room A/C or other device. |
OIC_Resource_Type_Specification_v1.1.0 section 6.2 |
|
| oic.r.altimeter |
Altimeter resource. This resource describes properties associated with the height of the position. |
OIC_Resource_Type_Specification_v1.1.0 section 6.58 |
|
| oic.r.audio |
Audio Controls resource. This resource defines basic audio control functions. |
OIC_Resource_Type_Specification_v1.1.0 section 6.25 |
|
| oic.r.autofocus |
Auto Focus resource. This resource describes whether an auto focus feature is on or off. |
OIC_Resource_Type_Specification_v1.1.0 section 6.26 |
|
| oic.r.automaticdocumentfeeder |
Automatic Document Feeder resource. This resource describes the state of an automatic document feeder, typically used with a scanner. |
OIC_Resource_Type_Specification_v1.1.0 section 6.27 |
|
| oic.r.button |
Button Switch resource. This resource describes the operation of a button style switch. |
OIC_Resource_Type_Specification_v1.1.0 section 6.28 |
|
| oic.r.clock |
Clock resource. This resource describes the properties associated with clock and time. |
OIC_Resource_Type_Specification_v1.1.0 section 6.59 |
|
| oic.r.colour.autowhitebalance |
Auto White Balance resource. This resource describes whether an auto balance feature is on or off. |
OIC_Resource_Type_Specification_v1.1.0 section 6.31 |
|
| oic.r.colour.chroma |
Colour Chroma resource. This resource describes the colour using chroma conventions. |
OIC_Resource_Type_Specification_v1.1.0 section 6.6 |
|
| oic.r.colour.rgb |
Colour RGB resource. This resource specifies the actual colour in the RGB space. |
OIC_Resource_Type_Specification_v1.1.0 section 6.7 |
|
| oic.r.colour.saturation |
Colour Saturation resource. This resource describes a Colour saturation value. |
OIC_Resource_Type_Specification_v1.1.0 section 6.32 |
|
| oic.r.door |
Door resource. This resource describes the open state of a door. |
OIC_Resource_Type_Specification_v1.1.0 section 6.9 |
|
| oic.r.energy.battery |
Battery resource. This resource represents the charge state of a battery. |
OIC_Resource_Type_Specification_v1.1.0 section 6.3 |
|
| oic.r.energy.consumption |
Energy Consumption resource. This resource describes the energy consumed by the device since power up and the instantaneous power draw of the device at the time the resource was queried. |
OIC_Resource_Type_Specification_v1.1.0 section 6.10 |
|
| oic.r.energy.drlc |
Demand Response Load Control (DRLC) resource. This resource describes any to be applied or currently being applied DRLC signal. |
OIC_Resource_Type_Specification_v1.1.0 section 6.34 |
|
| oic.r.energy.overload |
Energy Overload/Circuit Breaker resource. This resource describes whether an energy overload detector/circuit breaker has been tripped. |
OIC_Resource_Type_Specification_v1.1.0 section 6.35 |
|
| oic.r.energy.usage |
Energy Usage resource. This resource describes a cumulative time-based energy usage query. |
OIC_Resource_Type_Specification_v1.1.0 section 6.11 |
|
| oic.r.height |
Height resource. This resource describes the properties associated with height of an object's physical size. |
OIC_Resource_Type_Specification_v1.1.0 section 6.61 |
|
| oic.r.humidity |
Humidity resource. This resource describes a sensed or desired humidity. |
OIC_Resource_Type_Specification_v1.1.0 section 6.12 |
|
| oic.r.icemaker |
Ice Maker resource. This resource describes the operational state of an ice maker. |
OIC_Resource_Type_Specification_v1.1.0 section 6.13 |
|
| oic.r.light.brightness |
Brightness resource. This resource describes the brightness of a light or lamp. |
OIC_Resource_Type_Specification_v1.1.0 section 6.5 |
|
| oic.r.light.dimming |
Dimming resource. This resource describes a dimming function. |
OIC_Resource_Type_Specification_v1.1.0 section 6.8 |
|
| oic.r.light.ramptime |
Ramp Time resource. This resource describes the Ramp Time of a dimming function. |
OIC_Resource_Type_Specification_v1.1.0 section 6.19 |
|
| oic.r.lock.code |
Lock Code resource. This resource describes a lock code. |
OIC_Resource_Type_Specification_v1.1.0 section 6.15 |
|
| oic.r.lock.status |
Lock resource. This resource describes whether a lock is locked or unlocked. |
OIC_Resource_Type_Specification_v1.1.0 section 6.14 |
|
| oic.r.media |
Media resource. This resource specifies the media that a server supports. |
OIC_Resource_Type_Specification_v1.1.0 section 6.41 |
|
| oic.r.media.input |
Media Source Input resource. This resource provides the list of input media sources available on the device. |
OIC_Resource_Type_Specification_v1.1.0 section 6.42 |
|
| oic.r.media.output |
Media Source Output resource. This resource provides the list of output media sources available on the device. |
OIC_Resource_Type_Specification_v1.1.0 section 6.43 |
|
| oic.r.mode |
Mode resource. This resource describes the modes of operation that a device can provide. |
OIC_Resource_Type_Specification_v1.1.0 section 6.16 |
|
| oic.r.movement.linear |
Movement resource. This resource describes linear movement. |
OIC_Resource_Type_Specification_v1.1.0 section 6.54 |
|
| oic.r.nightmode |
Night Mode resource. This resource describes whether a night mode feature is on or off. |
OIC_Resource_Type_Specification_v1.1.0 section 6.45 |
|
| oic.r.openlevel |
Open Level resource. This resource describes how open or ajar an entity such as a window, door, blind or shutter is. |
OIC_Resource_Type_Specification_v1.1.0 section 6.17 |
|
| oic.r.operational.state |
Operational State resource. This resource describes the operational and job states on a device. |
OIC_Resource_Type_Specification_v1.1.0 section 6.18 |
|
| oic.r.ptz |
Pan Tilt Zoom Movement resource. This resource specifies the pan tilt and zoom capabilities of a device. |
OIC_Resource_Type_Specification_v1.1.0 section 6.47 |
|
| oic.r.refrigeration |
Refrigeration resource. This resource describes a refrigeration function. |
OIC_Resource_Type_Specification_v1.1.0 section 6.20 |
|
| oic.r.sensor |
Generic Sensor resource. This resource describes whether some value or property or entity has been sensed or not. |
OIC_Resource_Type_Specification_v1.1.0 section 6.36 |
|
| oic.r.sensor.acceleration |
Acceleration Sensor resource. This resource provides a measure of proper acceleration (g force). |
OIC_Resource_Type_Specification_v1.1.0 section 6.53 |
|
| oic.r.sensor.activity.count |
Activity Count resource. This resource specifies an activity count. |
OIC_Resource_Type_Specification_v1.1.0 section 6.23 |
|
| oic.r.sensor.atmosphericpressure |
Atmospheric Pressure resource. This resource provides a measurement of Mean Sea Level Pressure experienced at the measuring point expressed in millibars. |
OIC_Resource_Type_Specification_v1.1.0 section 6.24 |
|
| oic.r.sensor.carbondioxide |
Carbon Dioxide Sensor resource. This resource describes whether carbon dioxide has been sensed or not. |
OIC_Resource_Type_Specification_v1.1.0 section 6.29 |
|
| oic.r.sensor.carbonmonoxide |
Carbon Monoxide Sensor resource. This resource describes whether carbon monoxide has been sensed or not. |
OIC_Resource_Type_Specification_v1.1.0 section 6.30 |
|
| oic.r.sensor.contact |
Contact Sensor resource. This resource describes whether a contact sensor has been tripped or not. |
OIC_Resource_Type_Specification_v1.1.0 section 6.33 |
|
| oic.r.sensor.geolocation |
Geolocation Sensor resource. This resource describes the properties associated with the current geolocation coordinate. |
OIC_Resource_Type_Specification_v1.1.0 section 6.60 |
|
| oic.r.sensor.glassbreak |
Glass Break Sensor resource. This resource describes a glass break sensor. |
OIC_Resource_Type_Specification_v1.1.0 section 6.37 |
|
| oic.r.sensor.heart.zone |
Heart Rate Zone Sensor resource. This resource describes a measured heart rate by the current Zone using the Zoladz method. |
OIC_Resource_Type_Specification_v1.1.0 section 6.38 |
|
| oic.r.sensor.illuminance |
Illuminance Sensor resource. This resource describes an illuminance sensor. |
OIC_Resource_Type_Specification_v1.1.0 section 6.39 |
|
| oic.r.sensor.magneticfielddirection |
Magnetic Field Direction resource. This resource describes the direction of the Earth's magnetic field at the observer's current point in space. |
OIC_Resource_Type_Specification_v1.1.0 section 6.40 |
|
| oic.r.sensor.motion |
Motion Sensor resource. This resource describes whether motion has been sensed or not. |
OIC_Resource_Type_Specification_v1.1.0 section 6.43 |
|
| oic.r.sensor.presence |
Presence Sensor resource. This resource describes whether presence has been sensed or not. |
OIC_Resource_Type_Specification_v1.1.0 section 6.45 |
|
| oic.r.sensor.radiation.uv |
UV Radiation resource. This resource describes an ultraviolet radiation measurement. |
OIC_Resource_Type_Specification_v1.1.0 section 6.51 |
|
| oic.r.sensor.sleep |
Sleep Sensor resource. This resource describes whether human sleep has been sensed or not. |
OIC_Resource_Type_Specification_v1.1.0 section 6.55 |
|
| oic.r.sensor.smoke |
Smoke Sensor resource. This resource describes whether smoke has been sensed or not. |
OIC_Resource_Type_Specification_v1.1.0 section 6.56 |
|
| oic.r.sensor.threeaxis |
Three Axis Sensor resource. This resource provides a representation of the measurement from a three-axis sensor. |
OIC_Resource_Type_Specification_v1.1.0 section 6.57 |
|
| oic.r.sensor.touch |
Touch Sensor resource. This resource describes whether touch has been sensed or not. |
OIC_Resource_Type_Specification_v1.1.0 section 6.50 |
|
| oic.r.sensor.water |
Water Sensor resource. This resource describes whether water has been sensed or not. |
OIC_Resource_Type_Specification_v1.1.0 section 6.52 |
|
| oic.r.signalstrength |
Signal Strength resource. This resource describes the strength of a signal by means of Link Quality Indicator and Received Signal Strength Indicator. |
OIC_Resource_Type_Specification_v1.1.0 section 6.48 |
|
| oic.r.speech.tts |
Speech Synthesis resource. This resource is capable of rendering speech and allows a client to provide an SSML document with text to render. |
OIC_Resource_Type_Specification_v1.1.0 section 6.49 |
|
| oic.r.switch.binary |
Binary switch resource. This resource describes a binary switch (on/off). |
OIC_Resource_Type_Specification_v1.1.0 section 6.4 |
|
| oic.r.temperature |
Temperature resource. This resource describes a sensed or actuated Temperature value. |
OIC_Resource_Type_Specification_v1.1.0 section 6.21 |
|
| oic.r.time.period |
Time Period resource. This resource describes the time period over which any additionally provided information is derived or bounded. |
OIC_Resource_Type_Specification_v1.1.0 section 6.22 |
|
| oic.r.weight |
Weight resource. This resource describes the properties associated with weight of an object. |
OIC_Resource_Type_Specification_v1.1.0 section 6.62 |
|
| oma.lwm2m |
OMA LwM2M Resource. This Resource type indicates that
the resource and all of its sub-resources support the OMA Lightweight
M2M protocol, i.e. contain OMA LwM2M objects and resources. |
OMA-TS-LightweightM2M-V1_0 |
|
| bbf.usp.endpoint |
Endpoint of the Broadband Forum USP protocol |
https://usp.technology/specification/mtp/coap/ |
|
| oic.wk.col |
Collection resource. |
OCF_Core_Specification_v1.0.0 section D.2 |
|
| oic.wk.con |
Device Configuration resource. |
OCF_Core_Specification_v1.0.0 section D.3 |
|
| oic.wk.con.p |
Platform Configuration resource. |
OCF_Core_Specification_v1.0.0 section D.4 |
|
| oic.wk.d |
Device resource. |
OCF_Core_Specification_v1.0.0 section D.5 |
|
| oic.wk.mnt |
Maintenance resource. |
OCF_Core_Specification_v1.0.0 section D.6 |
|
| oic.wk.p |
Platform resource. |
OCF_Core_Specification_v1.0.0 section D.7 |
|
| oic.wk.res |
Discoverable Resources resource. |
OCF_Core_Specification_v1.0.0 section D.9 |
|
| oic.wk.scenelist |
Scene List resource. |
OCF_Core_Specification_v1.0.0 section D.11 |
|
| oic.wk.scenecollection |
Scene Member Collection resource. |
OCF_Core_Specification_v1.0.0 section D.12 |
|
| oic.wk.scenemember |
Scene Member resource. |
OCF_Core_Specification_v1.0.0 section D.13 |
|
| oic.wk.rd |
Resource Directory resource. |
OCF_Core_Specification_v1.0.0 section D.14 |
|
| oic.r.icon |
Icon resource. |
OCF_Core_Specification_v1.0.0 section D.15 |
|
| oic.wk.introspection |
Introspection resource. |
OCF_Core_Specification_v1.0.0 section D.16 |
|
| oic.r.airquality |
Air Quality resource. |
OCF_ResourceType_Specification_v1.0.0 section 6.65 |
|
| oic.r.airqualitycollection |
Air Quality Collection resource. |
OCF_ResourceType_Specification_v1.0.0 section 6.66 |
|
| oic.r.consumable |
Consumable resource. |
OCF_ResourceType_Specification_v1.0.0 section 6.67 |
|
| oic.r.consumablecollection |
Consumable Collection resource. |
OCF_ResourceType_Specification_v1.0.0 section 6.68 |
|
| oic.r.delaydefrost |
Delay Defrost resource. |
OCF_ResourceType_Specification_v1.0.0 section 6.69 |
|
| oic.r.ecomode |
Ecomode resource. |
OCF_ResourceType_Specification_v1.0.0 section 6.70 |
|
| oic.r.heatingzone |
Heating Zone resource. |
OCF_ResourceType_Specification_v1.0.0 section 6.71 |
|
| oic.r.heatingzonecollection |
Heating Zone Collection resource. |
OCF_ResourceType_Specification_v1.0.0 section 6.72 |
|
| oic.r.mediasourcelist |
Media Source List resource. |
OCF_ResourceType_Specification_v1.0.0 section 6.43 |
|
| oic.r.media.input |
Input Media Source List resource. |
OCF_ResourceType_Specification_v1.0.0 section 6.44 |
|
| oic.r.media.output |
Output Media Source List resource. |
OCF_ResourceType_Specification_v1.0.0 section 6.45 |
|
| oic.r.movement.ptz |
Physical Pan Tilt Zoom resource. |
OCF_ResourceType_Specification_v1.0.0 section 6.49 |
|
| oic.r.image.ptz |
Image Pan Tilt Zoom resource. |
OCF_ResourceType_Specification_v1.0.0 section 6.49 |
|
| oic.r.selectablelevels |
Selectable Levels resource. |
OCF_ResourceType_Specification_v1.0.0 section 6.73 |
|
| oic.r.value.conditional |
Value Conditional resource. |
OCF_ResourceType_Specification_v1.0.0 section 6.74 |
|
| oic.d.airqualitymonitor |
Air Quality Monitor device |
OCF_SmartHome_Device_Specification_v1.0.0 section 9.1 |
|
| oic.d.washerdryer |
Washer Dryer (Laundry) device |
OCF_SmartHome_Device_Specification_v1.0.0 section 9.1 |
|
| oic.d.cookerhood |
Cooker Hood device |
OCF_SmartHome_Device_Specification_v1.0.0 section 9.1 |
|
| oic.d.cooktop |
Cooktop device |
OCF_SmartHome_Device_Specification_v1.0.0 section 9.1 |
|
| oic.d.dehumidifier |
Dehumidifier device |
OCF_SmartHome_Device_Specification_v1.0.0 section 9.1 |
|
| oic.d.freezer |
Freezer device |
OCF_SmartHome_Device_Specification_v1.0.0 section 9.1 |
|
| oic.d.foodprobe |
Food Probe device |
OCF_SmartHome_Device_Specification_v1.0.0 section 9.1 |
|
| oic.d.humidifier |
Humidifier device |
OCF_SmartHome_Device_Specification_v1.0.0 section 9.1 |
|
| oic.d.stb |
Set Top Box device |
OCF_SmartHome_Device_Specification_v1.0.0 section 9.1 |
|
| oic.wk.nmon |
Network Monitoring resource. |
OCF_Core_Specification_v2.0.1 section D.16 |
|
| oic.wk.atomicmeasurement |
Atomic Measurement resource. |
OCF_Core_Specification_v2.0.1 section D.17 |
|
| oic.d.bridge |
Bridge device. |
OCF_Bridging_Specification_v2.0.1 section 8 |
|
| oic.d.virtual |
Virtual device. |
OCF_Bridging_Specification_v2.0.1 section 8 |
|
| oic.r.securemode |
Secure Mode resource. |
OCF_Bridging_Specification_v2.0.1 section 9.2 |
|
| oic.r.alljoynobject |
Alljoyn Object resource. |
OCF_Bridging_Specification_v2.0.1 section 9.3 |
|
| oic.r.easysetup |
Easy Setup resource. |
OCF_Core_Specification_Extension_Wi-Fi_Easy_Setup_v2.0.1 section A.2 |
|
| oic.r.wificonf |
Wi-Fi Configuration resource. |
OCF_Core_Specification_Extension_Wi-Fi_Easy_Setup_v2.0.1 section A.3 |
|
| oic.r.devconf |
Device Configuration resource. |
OCF_Core_Specification_Extension_Wi-Fi_Easy_Setup_v2.0.1 section A.4 |
|
| oic.r.coapcloudconf |
CoAP Cloud Configuration. |
OCF_Core_Specification_Extension_CoAP_Native_Cloud_v2.0.1 section A.2 |
|
| oic.r.colour.csc |
Colour Space Coordinates resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.75 |
|
| oic.r.colour.colourtemperature |
Colour Temperature resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.76 |
|
| oic.r.colour.hs |
Colour Hue Saturation resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.77 |
|
| oic.r.batterymaterial |
Battery Material resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.78 |
|
| oic.r.brewing |
Brewing resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.79 |
|
| oic.r.energy.electrical |
Electrical Energy resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.80 |
|
| oic.r.energy.generation |
Energy Generation resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.81 |
|
| oic.r.foaming |
Foaming resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.82 |
|
| oic.r.grinder |
Grinder resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.83 |
|
| oic.r.liquid.level |
Liquid Level resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.84 |
|
| oic.r.vehicle.connector |
Electric Vehicle Connector resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.85 |
|
| oic.r.time.stamp |
Time Stamp resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.86 |
|
| oic.r.printer.3d |
3D Printer resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.87 |
|
| oic.r.blood.pressure |
Blood Pressure resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.88 |
|
| oic.r.bloodpressuremonitor-am |
Blood Pressure Monitor Atomic Measurement resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.89 |
|
| oic.r.bmi |
Body Mass Index (BMI) resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.90 |
|
| oic.r.body.fat |
Body Fat resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.91 |
|
| oic.r.body.ffm |
Body Fat Free Mass resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.92 |
|
| oic.r.body.location |
Body Location resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.93 |
|
| oic.r.body.location.temperature |
Body Location Temperature resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.94 |
|
| oic.r.bodyscale-am |
Body Scale Atomic Measurement resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.95 |
|
| oic.r.body.slm |
Body Soft Lean Mass resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.96 |
|
| oic.r.bodythermometer-am |
Body Thermometer Atomic Measurement resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.97 |
|
| oic.r.body.water |
Body Water resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.98 |
|
| oic.r.glucose |
Glucose resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.99 |
|
| oic.r.glucose.carb |
Glucose Meter Complex Carbohydrates resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.100 |
|
| oic.r.glucose.exercise |
Glucose Meter Exercise resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.101 |
|
| oic.r.glucose.hba1c |
Glucose Meter HbA1c resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.102 |
|
| oic.r.glucose.health |
Glucose Meter Context Health resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.103 |
|
| oic.r.glucose.meal |
Glucose Meter Context Meal resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.104 |
|
| oic.r.glucose.medication |
Glucose Meter Context Medication resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.105 |
|
| oic.r.glucosemeter-am |
Glucose Meter Atomic Measurement resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.106 |
|
| oic.r.glucose.samplelocation |
Glucose Meter Context Sample Location resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.107 |
|
| oic.r.glucose.tester |
Glucose Meter Context Tester resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.108 |
|
| oic.r.orfid.station |
Optical RFID Station resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.109 |
|
| oic.r.orfid.tag |
Optical RFID Tag resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.110 |
|
| oic.r.powersource |
Power Source resource |
OCF_Resource_Type_Specification_v2.0.1 section 6.111 |
|
| oic.r.printer.queue |
Print Queue resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.112 |
|
| oic.r.pulserate |
Pulse Rate resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.113 |
|
| oic.r.sensor.props |
Sensor Properties resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.114 |
|
| oic.r.userid |
User ID resource. |
OCF_Resource_Type_Specification_v2.0.1 section 6.115 |
|
| oic.d.waterheater |
Water Heater device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.furnace |
Furnace device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.pump |
Pump device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.condensingunit |
Condensing Unit device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.condenser |
Condenser device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.hvac |
HVAC device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.lightingcontrol |
Lighting Controls device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.icemachine |
Ice Machine device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.range |
Range device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.steamcloset |
Steam Closet device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.audiosystem |
Audio System device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.avplayer |
AV Player device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.desktoppc |
Desktop PC device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.notebookpc |
Notebook PC device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.server |
Server device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.pc |
Computer device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.datastorageunit |
Data Storage Unit device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.display |
Display device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.portableelectronics |
Portable Electronics device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.gameconsole |
Game Console device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.3dprinter |
3D Printer device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.musicalinstrument |
Musical Instrument device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.networking |
Networking Equipment device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.handset |
Handset device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.telephonydevice |
Telephony device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.speaker |
Active Speaker device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.smallelectrical |
Electronics device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.aircompressor |
Air Compressor device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.bathroomdevice |
Bathroom General device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.batterycharger |
Battery Charger device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.businessequipment |
Business Equipment device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.portablestove |
Portable Stove device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.exercisemachine |
Exercise Machine device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.hvacportable |
Portable HVAC device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.orfid |
Optical Augmented RFID Reader device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.coffeemachine |
Coffee Machine device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.grinder |
Grinder device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.kettle |
Kettle device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.lightdecorative |
Decorative Lighting device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.lightemergency |
Emergency Lighting device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.microwave |
Microwave Oven device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.vendingmachine |
Vending Machine device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.waterdispenser |
Water Dispenser device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.battery |
Battery device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.window |
Window device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.fireplace |
Fireplace device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.energygenerator |
Energy Generator device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.electricmeter |
Electric Meter device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.electricvehiclecharger |
Electric Vehicle Charger device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.fitnessdevice |
Fitness device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.bloodpressuremonitor |
Blood Pressure Monitor device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.bodythermometer |
Body Thermometer device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.medicaldevice |
Media device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.glucosemeter |
Glucose Meter device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.bodyscale |
Body Scale device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.personalhealthdevice |
Personal Health device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.d.unknown |
Other device. |
OCF_Device_Specification_v2.0.1 section A.2 |
|
| oic.r.doxm |
Device Owner Transfer resource |
OCF_Security_Specification_v2.0.1 section 13.1 |
|
| oic.r.cred |
Credential resource |
OCF_Security_Specification_v2.0.1 section 13.2 |
|
| oic.r.crl |
Certificate Revocation List resource |
OCF_Security_Specification_v2.0.1 section 13.3 |
|
| oic.r.acl |
Access Control List resource |
OCF_Security_Specification_v2.0.1 section 13.4 |
|
| oic.r.acl2 |
Access Control List 2 resource |
OCF_Security_Specification_v2.0.1 section 13.4 |
|
| oic.r.amacl |
Access Manager ACL resource |
OCF_Security_Specification_v2.0.1 section 13.5 |
|
| oic.r.sacl |
Signed ACL resource |
OCF_Security_Specification_v2.0.1 section 13.6 |
|
| oic.r.pstat |
Provisioning Status resource |
OCF_Security_Specification_v2.0.1 section 13.7 |
|
| oic.r.csr |
Certificate Signing Request resource |
OCF_Security_Specification_v2.0.1 section 13.8 |
|
| oic.r.roles |
Roles resource |
OCF_Security_Specification_v2.0.1 section 13.9 |
|
| oic.r.account |
Account resource |
OCF_Security_Specification_v2.0.1 section 13.10 |
|
| oic.r.session |
Account Session resource |
OCF_Security_Specification_v2.0.1 section 13.11 |
|
| oic.r.tokenrefresh |
Account Token Refresh resource |
OCF_Security_Specification_v2.0.1 section 13.12 |
|
| fa.cs |
Resource type for the Fairhair common services |
Fairhair Alliance specification section 5.2.2 |
|
| fa.rd-conf |
Resource type for the Fairhair resource that configures and manages information about RDs on FA devices |
Fairhair Alliance specification section 4.6.1.4 |
|
| fa.lnk |
Resource type for the Fairhair Linkage resource |
Fairhair Alliance specification section 5.5.2 |
|
| fa.rd-id |
Resource type for the Fairhair resource that Identifies the resource which configures and manages RD identity information |
Fairhair Alliance specification section 4.6.1.5 |
|
| oic.d.activitytracker |
Activity Tracker device. |
OCF_Device_Specification_v2.0.5 clause A.2 |
|
| oic.d.ams |
Access Management Service. |
OCF_Device_Specification_v2.0.5 clause A.2 |
|
| oic.d.cgm |
Continuous Glucose Meter device. |
OCF_Device_Specification_v2.0.5 clause A.2 |
|
| oic.d.circuitbreaker |
Circuit Breaker device. |
OCF_Device_Specification_v2.0.5 clause A.2 |
|
| oic.d.cms |
Credential Management Service. |
OCF_Device_Specification_v2.0.5 clause A.2 |
|
| oic.d.cyclingcadencesensor |
Cycling cadence sensor device. |
OCF_Device_Specification_v2.0.5 clause A.2 |
|
| oic.d.cyclingpowermeter |
Cycling power meter device. |
OCF_Device_Specification_v2.0.5 clause A.2 |
|
| oic.d.cyclingspeedsensor |
Cycling speed sensor device. |
OCF_Device_Specification_v2.0.5 clause A.2 |
|
| oic.d.dots |
Device Ownership Transfer Service. |
OCF_Device_Specification_v2.0.5 clause A.2 |
|
| oic.d.energymonitor |
Energy Monitor device. |
OCF_Device_Specification_v2.0.5 clause A.2 |
|
| oic.d.heartratemonitor |
Heart Rate Monitor device. |
OCF_Device_Specification_v2.0.5 clause A.2 |
|
| oic.d.inverter |
Inverter device. |
OCF_Device_Specification_v2.0.5 clause A.2 |
|
| oic.d.pulseoximeter |
Pulse Oximeter device. |
OCF_Device_Specification_v2.0.5 clause A.2 |
|
| oic.d.pvarraysystem |
Photovoltaic Array System device. |
OCF_Device_Specification_v2.0.5 clause A.2 |
|
| oic.d.sleepmonitor |
Sleep Monitor device. |
OCF_Device_Specification_v2.0.5 clause A.2 |
|
| oic.d.waterpurifier |
Water Purifier device. |
OCF_Device_Specification_v2.0.5 clause A.2 |
|
| oic.r.activity |
Activity resource. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.127 |
|
| oic.r.activitytracker-am |
Activity tracker measurement with activity, heart rate, etc. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.128 |
|
| oic.r.alarm |
Alarm resource. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.129 |
|
| oic.r.alert |
Alerts resource type |
OCF_Core_Optional_Specification_v2.0.5 clause A.10 |
|
| oic.r.alertcollection |
Alerts Collection resource type |
OCF_Core_Optional_Specification_v2.0.5 clause A.11 |
|
| oic.r.cadence |
Cadence resource. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.144 |
|
| oic.r.calorificvalue |
Energy associated with the consumption of various fuels. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.116 |
|
| oic.r.cgm.calibrate |
Continuous Glucose Meter calibration resource. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.131 |
|
| oic.r.cgm.samplinginterval |
Continuous Glucose Meter sampling interval resource. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.132 |
|
| oic.r.cgm.sensor |
Continuous Glucose Meter sensor resource. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.133 |
|
| oic.r.cgm.status |
Continuous Glucose Meter status resource. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.134 |
|
| oic.r.cgm.threshold |
Continuous Glucose Meter threshold resource. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.135 |
|
| oic.r.cgm-am |
Resource for glucose, sensor, time, and user data. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.130 |
|
| oic.r.circuitbreaker |
Circuit Breaker resource. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.145 |
|
| oic.r.conversionfactor |
Property used in calculating conversions. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.117 |
|
| oic.r.cyclingpower |
Cycling power resource. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.146 |
|
| oic.r.gas.consumption |
Energy values associated with gas consumption. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.118 |
|
| oic.r.gas.usage |
Cumulative time-based gas usage query. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.119 |
|
| oic.r.heartrate |
Heart rate resource. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.136 |
|
| oic.r.heartratemonitor-am |
Resource for heart rate, time, and user data. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.137 |
|
| oic.r.iaszone |
Resource that includes iaszoneinfo, battery, and power source information |
OCF_Resource_Type_Specification_v2.0.5 clause 6.125 |
|
| oic.r.iaszoneinfo |
Intruder Alert System (IAS) Zone information resource |
OCF_Resource_Type_Specification_v2.0.5 clause 6.124 |
|
| oic.r.impactsensor |
Impact sensor resource. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.120 |
|
| oic.r.inverter |
Inverter resource. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.147 |
|
| oic.r.keypadchar |
Character keypad resource. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.121 |
|
| oic.r.opaquedata |
Opaque data transferred and uninterpretable at endpoints. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.122 |
|
| oic.r.pulsatilecharacteristic |
Pulsatile characteristic of the pulsative wave of a pulse oximeter. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.138 |
|
| oic.r.pulsatileoccurrence |
Pulsatile occurrence of a pulse oximeter. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.139 |
|
| oic.r.pulseoximeter-am |
Resource for SpO2, pulse data, observed time, and user data. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.140 |
|
| oic.r.pvconnectionterminal |
Photovoltaic connection terminal resource. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.148 |
|
| oic.r.sleep |
Sleep resource. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.141 |
|
| oic.r.sleepmonitor-am |
Resource for sleep stages and sleep score data. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.142 |
|
| oic.r.softwareupdate |
Software Update resource type |
OCF_Core_Optional_Specification_v2.0.5 clause A.12 |
|
| oic.r.sp |
Security Profile |
OCF_Security_Specification_v2.0.5 clause 14.8 |
|
| oic.r.speed |
Speed resource. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.149 |
|
| oic.r.spo2 |
Blood oxygen saturation level resource. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.143 |
|
| oic.r.torque |
Torque resource. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.150 |
|
| oic.r.userid |
User identification resource. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.123 |
|
| oic.r.vodlist |
Virtual OCF Device resource. |
OCF_Bridging_Specification_v2.0.5 clause 5.5 |
|
| oic.r.waterinfo |
Water information resource. |
OCF_Resource_Type_Specification_v2.0.5 clause 6.151 |
|
| oic.r.windowcovering |
Configurable window covering resource |
OCF_Resource_Type_Specification_v2.0.5 clause 6.126 |
|
| ace.est.crts |
This resource depicts the support of EST GET cacerts. |
RFC 9148 |
|
| ace.est.sen |
This resource depicts the support of EST simple enroll. |
RFC 9148 |
|
| ace.est.sren |
This resource depicts the support of EST simple reenroll. |
RFC 9148 |
|
| ace.est.att |
This resource depicts the support of EST GET CSR attributes. |
RFC 9148 |
|
| ace.est.skg |
This resource depicts the support of EST server-side key
generation with the returned certificate in a PKCS #7 container. |
RFC 9148 |
|
| ace.est.skc |
This resource depicts the support of EST
server-side key generation with the returned certificate in application/pkix-cert format. |
RFC 9148 |
|
| oic.d.bodycompositionanalyser |
Body Composition Analyser device |
OCF Device Specification v2.1.2 clause A.2 |
|
| oic.d.indoorgarden |
Indoor Garden device |
OCF Device Specification v2.1.2 clause A.2 |
|
| oic.d.mattress |
Mattress device |
OCF Device Specification v2.1.2 clause A.2 |
|
| oic.d.muscleoxygenmonitor |
Muscle Oxygen Monitor device |
OCF Device Specification v2.1.2 clause A.2 |
|
| oic.r.ael |
Auditable Event List |
OCF Security Specification v2.1.2 clause C.9 |
|
| oic.r.bodycompositionanalyser-am |
Body Composition Analyser resource |
OCF Resource Type Specification v2.1.2 clause 6.155 |
|
| oic.r.deodorization |
Deodorization resource |
OCF Resource Type Specification v2.1.2 clause 6.152 |
|
| oic.r.hvac.capacity |
HVAC Capacity resource |
OCF Resource Type Specification v2.1.2 clause 6.157 |
|
| oic.r.keycardswitch |
Keycard Switch resource |
OCF Resource Type Specification v2.1.2 clause 6.153 |
|
| oic.r.media.audio |
Media (Audio) resource |
OCF Resource Type Specification v2.1.2 clause 6.158 |
|
| oic.r.media.core |
Media (Core) resource |
OCF Resource Type Specification v2.1.2 clause 6.159 |
|
| oic.r.media.image |
Media (Image) resource |
OCF Resource Type Specification v2.1.2 clause 6.160 |
|
| oic.r.media.text |
Media (Text) resource |
OCF Resource Type Specification v2.1.2 clause 6.161 |
|
| oic.r.media.video |
Media (Video) resource |
OCF Resource Type Specification v2.1.2 clause 6.162 |
|
| oic.r.muscleoxygensaturation |
Muscle Oxygen Saturation resource |
OCF Resource Type Specification v2.1.2 clause 6.154 |
|
| oic.r.switch.fault |
Fault Interrupter resource |
OCF Resource Type Specification v2.1.2 clause 6.156 |
|
| oic.r.switch.restricted |
Restricted Switch resource |
OCF Resource Type Specification v2.1.2 clause 6.163 |
|
| oic.d.afci |
Arc Fault Circuit Interrupter |
OCF Device Specification v2.2.0 clause A.2 |
|
| oic.d.airer |
Airer |
OCF Device Specification v2.2.0 clause A.2 |
|
| oic.d.gfci |
Ground Fault Circuit Interrupter |
OCF Device Specification v2.2.0 clause A.2 |
|
| oic.r.sdi |
Security Domain Information |
OCF Security Specification v2.2.0 clause C.10 |
|
| oic.r.settings.accessibility |
Device Settings - Accessibility |
OCF Resource Type Specification v2.2.0 clause 6.164 |
|
| oic.r.settings.broadcasting |
Device Settings - Broadcasting |
OCF Resource Type Specification v2.2.0 clause 6.165 |
|
| oic.r.settings.picture |
Device Settings - Picture |
OCF Resource Type Specification v2.2.0 clause 6.166 |
|
| oic.r.settings.sound |
Device Settings - Sound |
OCF Resource Type Specification v2.2.0 clause 6.167 |
|
| oic.r.settings.support |
Device Settings - Support |
OCF Resource Type Specification v2.2.0 clause 6.168 |
|
| oic.r.settings.system |
Device Settings - System |
OCF Resource Type Specification v2.2.0 clause 6.169 |
|
| oic.r.sensor.measurement |
Generic Measurement Sensor |
OCF_Resource_Type_Specification_v2.2.2 clause 6.170 |
|
| oic.r.sensor.radiation.uva |
UVA Radiation |
OCF_Resource_Type_Specification_v2.2.2 clause 6.171 |
|
| oic.r.sensor.radiation.uvb |
UVB Radiation |
OCF_Resource_Type_Specification_v2.2.2 clause 6.172 |
|
| oic.r.colour.renderingindex |
Colour Rendering Index |
OCF_Resource_Type_Specification_v2.2.2 clause 6.173 |
|
| oic.r.sound.pressure |
Sound Pressure in Pascal |
OCF_Resource_Type_Specification_v2.2.2 clause 6.174 |
|
| oic.r.sound.pressurelevel |
Sound Pressure Level in dB |
OCF_Resource_Type_Specification_v2.2.2 clause 6.175 |
|
| oic.r.location.civic |
Civic Location |
OCF_Resource_Type_Specification_v2.2.2 clause 6.176 |
|
| ace.ai |
ACE-OAuth authz-info endpoint resource. |
RFC 9200 |
|
| oic.d.acassistant |
A/C Assistant |
OCF_Device_Specification_v2.2.4 clause A.2 |
|
| oic.d.dali |
Light (DALI) Device |
OCF_Device_Specification_v2.2.4 clause A.2 |
|
| oic.d.dali.ac |
Light (DALI) Application Controller |
OCF_Device_Specification_v2.2.4 clause A.2 |
|
| oic.d.dali.bus |
Light (DALI) Bus |
OCF_Device_Specification_v2.2.4 clause A.2 |
|
| oic.d.light.smart |
Smart Light |
OCF_Device_Specification_v2.2.4 clause A.2 |
|
| oic.d.wallpad |
Wallpad |
OCF_Device_Specification_v2.2.4 clause A.2 |
|
| oic.r.remotecontrol |
Remote Control |
OCF_Resource_Type_Specification_v2.2.4 clause 7.177 |
|
| oic.r.tv.apps |
TV Apps |
OCF_Resource_Type_Specification_v2.2.4 clause 7.178 |
|
| oic.r.vendorlist |
Vendor List |
OCF_Resource_Type_Specification_v2.2.4 clause 7.179 |
|
| oic.r.dali |
DALI |
OCF_Resource_Type_Specification_v2.2.4 clause 7.180 |
|
| oic.r.dali.conf |
DALI Configuration |
OCF_Resource_Type_Specification_v2.2.4 clause 7.181 |
|
| wot.directory |
link to WoT Thing Description of a Thing Description Directory |
Web of Things (WoT) Discovery, Section 6.4 |
|
| wot.thing |
link to WoT Thing Description of a Thing |
Web of Things (WoT) Discovery, Section 6.4 |
|
| core.edhoc |
EDHOC resource |
RFC 9528 |
|
| core.coap-eap |
CoAP-EAP resource |
RFC 9820 |
|
| core.dns |
DNS over CoAP resource |
RFC 9953, Section 3 |
|
| core.osc.gm |
Group-membership resource of an OSCORE Group Manager |
RFC-ietf-ace-key-groupcomm-oscore-21 |
|
| core.osc.gcoll |
Group-collection resource of an OSCORE Group Manager |
RFC-ietf-ace-oscore-gm-admin-17 |
|
| core.osc.gconf |
Group-configuration resource of an OSCORE Group Manager |
RFC-ietf-ace-oscore-gm-admin-17 |
|