Datagram Congestion Control Protocol (DCCP) Parameters

Created

  • 2005-08-25

Last Updated

  • 2026-01-12

Available Formats


Packet Types

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 4340: Datagram Congestion Control Protocol (DCCP)

Available Formats

Type Description/Meaning Reference
0 DCCP-Request RFC 4340
1 DCCP-Response RFC 4340
2 DCCP-Data RFC 4340
3 DCCP-Ack RFC 4340
4 DCCP-DataAck RFC 4340
5 DCCP-CloseReq RFC 4340
6 DCCP-Close RFC 4340
7 DCCP-Reset RFC 4340
8 DCCP-Sync RFC 4340
9 DCCP-SyncAck RFC 4340
10 DCCP-Listen RFC 5596
11-13 Unassigned RFC 4340
14 Reserved for experimental and testing use RFC 4340
15 Unassigned RFC 4340

Reset Codes

Reference

  • RFC 4340: Datagram Congestion Control Protocol (DCCP)

Available Formats

Range Registration Procedures Note
12-119 IETF Review (IETF RFC publication)
120-126 Reserved For experimental and testing use
127 IETF Review (IETF RFC publication)
128-255 CCID-specific codes [1]
Reset Code Name Reference
0 Unspecified RFC 4340
1 Closed RFC 4340
2 Aborted RFC 4340
3 No Connection RFC 4340
4 Packet Error RFC 4340
5 Option Error RFC 4340
6 Mandatory Error RFC 4340
7 Connection Refused RFC 4340
8 Bad Service Code RFC 4340
9 Too Busy RFC 4340
10 Bad Init Cookie RFC 4340
11 Aggression Penalty RFC 4340
12 Encapsulated Port Reuse RFC 6773
13 Abrupt MP termination RFC 9897
14-119 Unassigned RFC 4340
120-126 Reserved RFC 4340
127 Unassigned RFC 4340
128-255 CCID-specific codes RFC 4340

Option Types

Reference

  • RFC 4340: Datagram Congestion Control Protocol (DCCP)

Available Formats

Range Registration Procedures Note
3-30 IETF Review (IETF RFC publication)
45-119 IETF Review (IETF RFC publication)
120-126 Reserved For experimental and testing use
127 IETF Review (IETF RFC publication)
128-255 CCID-specific codes [1]
Type Description/Meaning Reference
0 Padding RFC 4340
1 Mandatory RFC 4340
2 Slow Receiver RFC 4340
3-30 Unassigned RFC 4340
31 Reserved for experimental and testing use RFC 4340
32 Change L RFC 4340
33 Confirm L RFC 4340
34 Change R RFC 4340
35 Confirm R RFC 4340
36 Init Cookie RFC 4340
37 NDP Count RFC 4340
38 Ack Vector [Nonce 0] RFC 4340
39 Ack Vector [Nonce 1] RFC 4340
40 Data Dropped RFC 4340
41 Timestamp RFC 4340
42 Timestamp Echo RFC 4340
43 Elapsed Time RFC 4340
44 Data Checksum RFC 4340
45 Quick-Start Response RFC 5634
46 Multipath RFC 9897
47-119 Unassigned RFC 4340
120-126 Reserved RFC 4340
127 Unassigned RFC 4340
128-255 CCID-specific codes RFC 4340

Feature Numbers

Reference

  • RFC 4340: Datagram Congestion Control Protocol (DCCP)

Available Formats

Range Registration Procedures Note
10-119 IETF Review (IETF RFC publication)
120-126 Reserved For experimental and testing use
127 IETF Review (IETF RFC publication)
128-255 CCID-specific codes [1]
Number Description/Meaning Reference
0 Reserved RFC 4340
1 Congestion Control ID (CCID) RFC 4340
2 Allow Short Seqnos RFC 4340
3 Sequence Window RFC 4340
4 ECN Incapable RFC 4340
5 Ack Ratio RFC 4340
6 Send Ack Vector RFC 4340
7 Send NDP Count RFC 4340
8 Minimum Checksum Coverage RFC 4340
9 Check Data Checksum RFC 4340
10 Multipath Capable RFC 9897
11-119 Unassigned RFC 4340
120-126 Reserved RFC 4340
127 Unassigned RFC 4340
128-255 CCID-specific codes RFC 4340

Congestion Control Identifiers

Reference

  • RFC 4340: Datagram Congestion Control Protocol (DCCP)

Available Formats

Range Registration Procedures Note
0-1 IETF Review (IETF RFC publication)
4-247 IETF Review (IETF RFC publication)
248-254 Reserved For experimental and testing use
255 IETF Review (IETF RFC publication)
CCID Description/Meaning Reference
0-1 Unassigned RFC 4340
2 TCP-like Congestion Control RFC 4341
3 TFRC Congestion Control RFC 4342
4 TCP-Friendly Rate Control for Small Packets RFC 5622
5-247 Unassigned RFC 4340
248-254 Reserved RFC 4340
255 Unassigned RFC 4340

Ack Vector States

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 4340: Datagram Congestion Control Protocol (DCCP)

Available Formats

State Description/Meaning Reference
0 Received RFC 4340
1 Received ECN Marked RFC 4340
2 Unassigned RFC 4340
3 Not Yet Received RFC 4340

Drop Codes

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 4340: Datagram Congestion Control Protocol (DCCP)

Available Formats

Drop Code Description/Meaning Reference
0 Protocol Constraints RFC 4340
1 Application Not Listening RFC 4340
2 Receive Buffer RFC 4340
3 Corrupt RFC 4340
4-6 Unassigned RFC 4340
7 Delivered Corrupt RFC 4340

Service Codes

Reference

  • RFC 4340: Datagram Congestion Control Protocol (DCCP)

Note

Service Codes can be found at the following: http://www.iana.org/assignments/service-codes


MP-DCCP Versions

Registration Procedure(s)

  • RFC Required

Reference

  • RFC 9897: Datagram Congestion Control Protocol (DCCP) Extensions for Multipath Operation with Multiple Addresses

Available Formats

Version Value Reference
0 0000 RFC 9897
1-15 Unassigned

Multipath Options

Registration Procedure(s)

  • RFC Required

Reference

  • RFC 9897: Datagram Congestion Control Protocol (DCCP) Extensions for Multipath Operation with Multiple Addresses

Available Formats

Multipath Option Name Description Reference
MP_OPT=0 MP_CONFIRM Confirm reception/processing of an MP_OPT option RFC 9897, Section 3.2.1
MP_OPT=1 MP_JOIN Join subflow to an existing MP-DCCP connection RFC 9897, Section 3.2.2
MP_OPT=2 MP_FAST_CLOSE Close an MP-DCCP connection unconditionally RFC 9897, Section 3.2.3
MP_OPT=3 MP_KEY Exchange key material for MP_HMAC RFC 9897, Section 3.2.4
MP_OPT=4 MP_SEQ Multipath sequence number RFC 9897, Section 3.2.5
MP_OPT=5 MP_HMAC Hash-based message authentication code for MP-DCCP RFC 9897, Section 3.2.6
MP_OPT=6 MP_RTT Transmit RTT values and calculation parameters RFC 9897, Section 3.2.7
MP_OPT=7 MP_ADDADDR Advertise one or more additional addresses/ports RFC 9897, Section 3.2.8
MP_OPT=8 MP_REMOVEADDR Remove one or more addresses/ports RFC 9897, Section 3.2.9
MP_OPT=9 MP_PRIO Change subflow priority RFC 9897, Section 3.2.10
MP_OPT=10 MP_CLOSE Close an MP-DCCP connection RFC 9897, Section 3.2.11
MP_OPT=11 MP_EXP Experimental option for private use RFC 9897, Section 3.2.12
MP_OPT=12-255 Unassigned

Multipath Key Type

Registration Procedure(s)

  • RFC Required

Reference

  • RFC 9897: Datagram Congestion Control Protocol (DCCP) Extensions for Multipath Operation with Multiple Addresses

Available Formats

Type Name Meaning Reference
0 Plain Text Plain text Key RFC 9897, Section 3.2.4
1-254 Unassigned
255 Experimental For private use only RFC 9897, Section 3.2.4

Footnote

[1]

Note for CCID-specific codes: DCCP Reset Codes 128-255, Option Types 128-255, and Feature Numbers 128-255 are reserved for CCID-specific use. Each DCCP CCID (that is, each entry in the DCCP Congestion Control Identifiers registry) may create registries for its CCID-specific Reset Code, Option Type, and Feature Number ranges. These CCID-specific registries are independent: different CCIDs can allocate the same value (such as Feature Number 128) for different purposes. RFC 4340, Section 10.3, describes how DCCP decides which registry applies for a given CCID-specific Reset Code, Option Type, or Feature Number. In each case, CCID-specific registries may only register values 128-255; values 0-127 are registered here. For examples, see the following:

Profile for Datagram Congestion Control Protocol (DCCP) Congestion Control ID 2: TCP-like Congestion Control Parameters;

Profile for Datagram Congestion Control Protocol (DCCP) Congestion Control ID 3: TFRC Congestion Control Parameters;

Profile for Datagram Congestion Control Protocol (DCCP) Congestion Control ID 4: TCP-Friendly Rate Control for Small Packets (TFRC-SP)