Dynamic Host Configuration Protocol for IPv6 (DHCPv6)
Created
- 2003-11-03
Last Updated
- 2026-09-01
Note
For the Civic Address Types Registry RFC 4776, please see: http://www.iana.org/assignments/civic-address-types-registry
Available Formats
Message Types
Registration Procedure(s)
- Standards Action
Reference
- RFC 9915: Dynamic Host Configuration Protocol for IPv6 (DHCPv6)
Available Formats
| Value | Description | Status | Reference |
|---|---|---|---|
| 0 | Reserved | ||
| 1 | SOLICIT | RFC 9915 | |
| 2 | ADVERTISE | RFC 9915 | |
| 3 | REQUEST | RFC 9915 | |
| 4 | CONFIRM | RFC 9915 | |
| 5 | RENEW | RFC 9915 | |
| 6 | REBIND | RFC 9915 | |
| 7 | REPLY | RFC 9915 | |
| 8 | RELEASE | RFC 9915 | |
| 9 | DECLINE | RFC 9915 | |
| 10 | RECONFIGURE | RFC 9915 | |
| 11 | INFORMATION-REQUEST | RFC 9915 | |
| 12 | RELAY-FORW | RFC 9915 | |
| 13 | RELAY-REPL | RFC 9915 | |
| 14 | LEASEQUERY | RFC 5007 | |
| 15 | LEASEQUERY-REPLY | RFC 5007 | |
| 16 | LEASEQUERY-DONE | RFC 5460 | |
| 17 | LEASEQUERY-DATA | RFC 5460 | |
| 18 | RECONFIGURE-REQUEST | RFC 6977 | |
| 19 | RECONFIGURE-REPLY | RFC 6977 | |
| 20 | DHCPV4-QUERY | RFC 7341 | |
| 21 | DHCPV4-RESPONSE | RFC 7341 | |
| 22 | ACTIVELEASEQUERY | RFC 7653 | |
| 23 | STARTTLS | RFC 7653 | |
| 24 | BNDUPD | RFC 8156 | |
| 25 | BNDREPLY | RFC 8156 | |
| 26 | POOLREQ | RFC 8156 | |
| 27 | POOLRESP | RFC 8156 | |
| 28 | UPDREQ | RFC 8156 | |
| 29 | UPDREQALL | RFC 8156 | |
| 30 | UPDDONE | RFC 8156 | |
| 31 | CONNECT | RFC 8156 | |
| 32 | CONNECTREPLY | RFC 8156 | |
| 33 | DISCONNECT | RFC 8156 | |
| 34 | STATE | RFC 8156 | |
| 35 | CONTACT | RFC 8156 | |
| 36 | ADDR-REG-INFORM | RFC 9686 | |
| 37 | ADDR-REG-REPLY | RFC 9686 | |
| 38-255 | Unassigned |
Option Codes
Registration Procedure(s)
- Expert Review and Standards Action
Expert(s)
- Ted Lemon, Bernie Volz, Tomek Mrugalski
Reference
- RFC 9915: Dynamic Host Configuration Protocol for IPv6 (DHCPv6)
Note
For the "Client ORO" column: a "Yes" for an option means that the client includes this option code in the Option Request option (see Section 21.7 of RFC 9915) if it desires that configuration information; a "No" means that the option MUST NOT be included (and servers SHOULD silently ignore that option code if it appears in a client's Option Request option).
Available Formats
| Value | Description | Client ORO | Singleton Option | Status | Reference |
|---|---|---|---|---|---|
| 0 | Reserved | ||||
| 1 | OPTION_CLIENTID | No | Yes | RFC 9915 | |
| 2 | OPTION_SERVERID | No | Yes | RFC 9915 | |
| 3 | OPTION_IA_NA | No | No | RFC 9915 | |
| 4 | OPTION_IA_TA | No | No | Obsolete | RFC 9915 |
| 5 | OPTION_IAADDR | No | No | RFC 9915 | |
| 6 | OPTION_ORO | No | Yes | RFC 9915 | |
| 7 | OPTION_PREFERENCE | No | Yes | RFC 9915 | |
| 8 | OPTION_ELAPSED_TIME | No | Yes | RFC 9915 | |
| 9 | OPTION_RELAY_MSG | No | Yes | RFC 9915 | |
| 10 | Unassigned | No | Yes | ||
| 11 | OPTION_AUTH | No | Yes | RFC 9915 | |
| 12 | OPTION_UNICAST | No | Yes | Obsolete | RFC 9915 |
| 13 | OPTION_STATUS_CODE | No | Yes | RFC 9915 | |
| 14 | OPTION_RAPID_COMMIT | No | Yes | RFC 9915 | |
| 15 | OPTION_USER_CLASS | No | Yes | RFC 9915 | |
| 16 | OPTION_VENDOR_CLASS | No | No[1] | RFC 9915 | |
| 17 | OPTION_VENDOR_OPTS | Optional | No[1] | RFC 9915 | |
| 18 | OPTION_INTERFACE_ID | No | Yes | RFC 9915 | |
| 19 | OPTION_RECONF_MSG | No | Yes | RFC 9915 | |
| 20 | OPTION_RECONF_ACCEPT | No | Yes | RFC 9915 | |
| 21 | OPTION_SIP_SERVER_D | Yes | Yes | RFC 3319 | |
| 22 | OPTION_SIP_SERVER_A | Yes | Yes | RFC 3319 | |
| 23 | OPTION_DNS_SERVERS | Yes | Yes | RFC 3646 | |
| 24 | OPTION_DOMAIN_LIST | Yes | Yes | RFC 3646 | |
| 25 | OPTION_IA_PD | No | No | RFC 3633; RFC 9915 | |
| 26 | OPTION_IAPREFIX | No | No | RFC 3633; RFC 9915 | |
| 27 | OPTION_NIS_SERVERS | Yes | Yes | RFC 3898 | |
| 28 | OPTION_NISP_SERVERS | Yes | Yes | RFC 3898 | |
| 29 | OPTION_NIS_DOMAIN_NAME | Yes | Yes | RFC 3898 | |
| 30 | OPTION_NISP_DOMAIN_NAME | Yes | Yes | RFC 3898 | |
| 31 | OPTION_SNTP_SERVERS | Yes | Yes | RFC 4075 | |
| 32 | OPTION_INFORMATION_REFRESH_TIME | Required for Information-request | Yes | RFC 4242; RFC 9915 | |
| 33 | OPTION_BCMCS_SERVER_D | Yes | Yes | RFC 4280 | |
| 34 | OPTION_BCMCS_SERVER_A | Yes | Yes | RFC 4280 | |
| 35 | Unassigned | Yes | Yes | ||
| 36 | OPTION_GEOCONF_CIVIC | Yes | Yes | RFC 4776 | |
| 37 | OPTION_REMOTE_ID | No | Yes | RFC 4649 | |
| 38 | OPTION_SUBSCRIBER_ID | No | Yes | RFC 4580 | |
| 39 | OPTION_CLIENT_FQDN | Yes | Yes | RFC 4704 | |
| 40 | OPTION_PANA_AGENT | Yes | Yes | RFC 5192 | |
| 41 | OPTION_NEW_POSIX_TIMEZONE | Yes | Yes | RFC 4833 | |
| 42 | OPTION_NEW_TZDB_TIMEZONE | Yes | Yes | RFC 4833 | |
| 43 | OPTION_ERO | No | Yes | RFC 4994 | |
| 44 | OPTION_LQ_QUERY | No | Yes | RFC 5007 | |
| 45 | OPTION_CLIENT_DATA | No | Yes | RFC 5007 | |
| 46 | OPTION_CLT_TIME | No | Yes | RFC 5007 | |
| 47 | OPTION_LQ_RELAY_DATA | No | Yes | RFC 5007 | |
| 48 | OPTION_LQ_CLIENT_LINK | No | Yes | RFC 5007 | |
| 49 | OPTION_MIP6_HNIDF | Yes | Yes | RFC 6610 | |
| 50 | OPTION_MIP6_VDINF | Yes | Yes | RFC 6610 | |
| 51 | OPTION_V6_LOST | Yes | Yes | RFC 5223 | |
| 52 | OPTION_CAPWAP_AC_V6 | Yes | Yes | RFC 5417 | |
| 53 | OPTION_RELAY_ID | No | Yes | RFC 5460 | |
| 54 | OPTION-IPv6_Address-MoS | Yes | Yes | RFC 5678 | |
| 55 | OPTION-IPv6_FQDN-MoS | Yes | Yes | RFC 5678 | |
| 56 | OPTION_NTP_SERVER | Yes | Yes | RFC 5908 | |
| 57 | OPTION_V6_ACCESS_DOMAIN | Yes | Yes | RFC 5986 | |
| 58 | OPTION_SIP_UA_CS_LIST | Yes | Yes | RFC 6011 | |
| 59 | OPT_BOOTFILE_URL | Yes | Yes | RFC 5970 | |
| 60 | OPT_BOOTFILE_PARAM | Yes | Yes | RFC 5970 | |
| 61 | OPTION_CLIENT_ARCH_TYPE | No | Yes | RFC 5970 | |
| 62 | OPTION_NII | Yes | Yes | RFC 5970 | |
| 63 | OPTION_GEOLOCATION | Yes | Yes | RFC 6225 | |
| 64 | OPTION_AFTR_NAME | Yes | Yes | RFC 6334 | |
| 65 | OPTION_ERP_LOCAL_DOMAIN_NAME | Yes | Yes | RFC 6440 | |
| 66 | OPTION_RSOO | No | Yes | RFC 6422 | |
| 67 | OPTION_PD_EXCLUDE | Yes | Yes | RFC 6603 | |
| 68 | OPTION_VSS | No | Yes | RFC 6607 | |
| 69 | OPTION_MIP6_IDINF | Yes | Yes | RFC 6610 | |
| 70 | OPTION_MIP6_UDINF | Yes | Yes | RFC 6610 | |
| 71 | OPTION_MIP6_HNP | Yes | Yes | RFC 6610 | |
| 72 | OPTION_MIP6_HAA | Yes | Yes | RFC 6610 | |
| 73 | OPTION_MIP6_HAF | Yes | Yes | RFC 6610 | |
| 74 | OPTION_RDNSS_SELECTION | Yes | Yes | RFC 6731 | |
| 75 | OPTION_KRB_PRINCIPAL_NAME | Yes | Yes | RFC 6784 | |
| 76 | OPTION_KRB_REALM_NAME | Yes | Yes | RFC 6784 | |
| 77 | OPTION_KRB_DEFAULT_REALM_NAME | Yes | Yes | RFC 6784 | |
| 78 | OPTION_KRB_KDC | Yes | Yes | RFC 6784 | |
| 79 | OPTION_CLIENT_LINKLAYER_ADDR | No | Yes | RFC 6939 | |
| 80 | OPTION_LINK_ADDRESS | No | Yes | RFC 6977 | |
| 81 | OPTION_RADIUS | No | Yes | RFC 7037 | |
| 82 | OPTION_SOL_MAX_RT | Required for Solicit | Yes | RFC 7083; RFC 9915 | |
| 83 | OPTION_INF_MAX_RT | Required for Information-request | Yes | RFC 7083; RFC 9915 | |
| 84 | OPTION_ADDRSEL | Yes | Yes | RFC 7078 | |
| 85 | OPTION_ADDRSEL_TABLE | Yes | Yes | RFC 7078 | |
| 86 | OPTION_V6_PCP_SERVER | Yes | No | RFC 7291 | |
| 87 | OPTION_DHCPV4_MSG | No | Yes | RFC 7341 | |
| 88 | OPTION_DHCP4_O_DHCP6_SERVER | Yes | Yes | RFC 7341 | |
| 89 | OPTION_S46_RULE | No | No[2] | RFC 7598 | |
| 90 | OPTION_S46_BR | Yes | No | RFC 7598; RFC 8539 | |
| 91 | OPTION_S46_DMR | No | Yes | RFC 7598 | |
| 92 | OPTION_S46_V4V6BIND | No | Yes | RFC 7598 | |
| 93 | OPTION_S46_PORTPARAMS | No | Yes | RFC 7598 | |
| 94 | OPTION_S46_CONT_MAPE | Yes | No | RFC 7598 | |
| 95 | OPTION_S46_CONT_MAPT | Yes | Yes | RFC 7598 | |
| 96 | OPTION_S46_CONT_LW | Yes | Yes | RFC 7598 | |
| 97 | OPTION_4RD | Yes | Yes | RFC 7600 | |
| 98 | OPTION_4RD_MAP_RULE | Yes | Yes | RFC 7600 | |
| 99 | OPTION_4RD_NON_MAP_RULE | Yes | Yes | RFC 7600 | |
| 100 | OPTION_LQ_BASE_TIME | No | Yes | RFC 7653 | |
| 101 | OPTION_LQ_START_TIME | No | Yes | RFC 7653 | |
| 102 | OPTION_LQ_END_TIME | No | Yes | RFC 7653 | |
| 103 | DHCP Captive-Portal | Yes | Yes | RFC 8910 | |
| 104 | OPTION_MPL_PARAMETERS | Yes | No | RFC 7774 | |
| 105 | OPTION_ANI_ATT | No | Yes | RFC 7839 | |
| 106 | OPTION_ANI_NETWORK_NAME | No | Yes | RFC 7839 | |
| 107 | OPTION_ANI_AP_NAME | No | Yes | RFC 7839 | |
| 108 | OPTION_ANI_AP_BSSID | No | Yes | RFC 7839 | |
| 109 | OPTION_ANI_OPERATOR_ID | No | Yes | RFC 7839 | |
| 110 | OPTION_ANI_OPERATOR_REALM | No | Yes | RFC 7839 | |
| 111 | OPTION_S46_PRIORITY | Yes | Yes | RFC 8026 | |
| 112 | OPTION_MUD_URL_V6 | No | Yes | RFC 8520 | |
| 113 | OPTION_V6_PREFIX64 | Yes | No | RFC 8115 | |
| 114 | OPTION_F_BINDING_STATUS | No | Yes | RFC 8156 | |
| 115 | OPTION_F_CONNECT_FLAGS | No | Yes | RFC 8156 | |
| 116 | OPTION_F_DNS_REMOVAL_INFO | No | Yes | RFC 8156 | |
| 117 | OPTION_F_DNS_HOST_NAME | No | Yes | RFC 8156 | |
| 118 | OPTION_F_DNS_ZONE_NAME | No | Yes | RFC 8156 | |
| 119 | OPTION_F_DNS_FLAGS | No | Yes | RFC 8156 | |
| 120 | OPTION_F_EXPIRATION_TIME | No | Yes | RFC 8156 | |
| 121 | OPTION_F_MAX_UNACKED_BNDUPD | No | Yes | RFC 8156 | |
| 122 | OPTION_F_MCLT | No | Yes | RFC 8156 | |
| 123 | OPTION_F_PARTNER_LIFETIME | No | Yes | RFC 8156 | |
| 124 | OPTION_F_PARTNER_LIFETIME_SENT | No | Yes | RFC 8156 | |
| 125 | OPTION_F_PARTNER_DOWN_TIME | No | Yes | RFC 8156 | |
| 126 | OPTION_F_PARTNER_RAW_CLT_TIME | No | Yes | RFC 8156 | |
| 127 | OPTION_F_PROTOCOL_VERSION | No | Yes | RFC 8156 | |
| 128 | OPTION_F_KEEPALIVE_TIME | No | Yes | RFC 8156 | |
| 129 | OPTION_F_RECONFIGURE_DATA | No | Yes | RFC 8156 | |
| 130 | OPTION_F_RELATIONSHIP_NAME | No | Yes | RFC 8156 | |
| 131 | OPTION_F_SERVER_FLAGS | No | Yes | RFC 8156 | |
| 132 | OPTION_F_SERVER_STATE | No | Yes | RFC 8156 | |
| 133 | OPTION_F_START_TIME_OF_STATE | No | Yes | RFC 8156 | |
| 134 | OPTION_F_STATE_EXPIRATION_TIME | No | Yes | RFC 8156 | |
| 135 | OPTION_RELAY_PORT | No | Yes | RFC 8357 | |
| 136 | OPTION_V6_SZTP_REDIRECT | Yes | Yes | RFC 8572 | |
| 137 | OPTION_S46_BIND_IPV6_PREFIX | Yes | Yes | RFC 8539 | |
| 138 | OPTION_IA_LL | No | No | RFC 8947 | |
| 139 | OPTION_LLADDR | No | No | RFC 8947 | |
| 140 | OPTION_SLAP_QUAD | No | Yes | RFC 8948 | |
| 141 | OPTION_V6_DOTS_RI | Yes | Yes | RFC 8973 | |
| 142 | OPTION_V6_DOTS_ADDRESS | Yes | Yes | RFC 8973 | |
| 143 | OPTION-IPv6_Address-ANDSF | Yes | Yes | RFC 6153 | |
| 144 | OPTION_V6_DNR | Yes | No | RFC 9463 | |
| 145 | OPTION_REGISTERED_DOMAIN | Yes | No | RFC 9527, Section 4.1 | |
| 146 | OPTION_FORWARD_DIST_MANAGER | Yes | Yes | RFC 9527, Section 4.2 | |
| 147 | OPTION_REVERSE_DIST_MANAGER | Yes | Yes | RFC 9527, Section 4.3 | |
| 148 | OPTION_ADDR_REG_ENABLE | Yes | Yes | RFC 9686 | |
| 149 | OPTION_IA_SRV6_LOCATOR | No | No | RFC 10038 | |
| 150 | OPTION_IALOCATOR | No | No | RFC 10038 | |
| 151-65535 | Unassigned |
Status Codes
Registration Procedure(s)
- Standards Action
Reference
- RFC 9915: Dynamic Host Configuration Protocol for IPv6 (DHCPv6)
Available Formats
| Code | Name | Status | Reference |
|---|---|---|---|
| 0 | Success | RFC 9915 | |
| 1 | UnspecFail | RFC 9915 | |
| 2 | NoAddrsAvail | RFC 9915 | |
| 3 | NoBinding | RFC 9915 | |
| 4 | NotOnLink | RFC 9915 | |
| 5 | UseMulticast | Obsolete | RFC 9915 |
| 6 | NoPrefixAvail | RFC 3633; RFC 9915 | |
| 7 | UnknownQueryType | RFC 5007 | |
| 8 | MalformedQuery | RFC 5007 | |
| 9 | NotConfigured | RFC 5007 | |
| 10 | NotAllowed | RFC 5007 | |
| 11 | QueryTerminated | RFC 5460 | |
| 12 | DataMissing | RFC 7653 | |
| 13 | CatchUpComplete | RFC 7653 | |
| 14 | NotSupported | RFC 7653 | |
| 15 | TLSConnectionRefused | RFC 7653 | |
| 16 | AddressInUse | RFC 8156 | |
| 17 | ConfigurationConflict | RFC 8156 | |
| 18 | MissingBindingInformation | RFC 8156 | |
| 19 | OutdatedBindingInformation | RFC 8156 | |
| 20 | ServerShuttingDown | RFC 8156 | |
| 21 | DNSUpdateNotSupported | RFC 8156 | |
| 22 | ExcessiveTimeSkew | RFC 8156 | |
| 23 | NoSRv6LocatorAvail | RFC 10038 | |
| 24-65535 | Unassigned |
DUIDs
Registration Procedure(s)
- Standards Action
Reference
- RFC 9915: Dynamic Host Configuration Protocol for IPv6 (DHCPv6)
Available Formats
OPTION_LQ_QUERY option
Registration Procedure(s)
- Standards Action
Reference
Available Formats
IEEE 802.21 Service Type (MoS DHCPv6 Address and FQDN Sub-Options)
Registration Procedure(s)
- Standards Action
Reference
- RFC 5678: Dynamic Host Configuration Protocol (DHCPv4 and DHCPv6) Options for IEEE 802.21 Mobility Services (MoS) Discovery
- RFC 9915: Dynamic Host Configuration Protocol for IPv6 (DHCPv6)
Available Formats
Processor Architecture Types
Registration Procedure(s)
- Expert Review
Expert(s)
- Vincent Zimmer, Bernie Volz, Tomek Mrugalski
Reference
- RFC 5970: DHCPv6 Options for Network Boot
- RFC 9915: Dynamic Host Configuration Protocol for IPv6 (DHCPv6)
Available Formats
| Type | Architecture Name | Status | Reference |
|---|---|---|---|
| 0x00 0x00 | x86 BIOS | RFC 5970; RFC 4578 | |
| 0x00 0x01 | NEC/PC98 (DEPRECATED) | RFC 5970; RFC 4578 | |
| 0x00 0x02 | Itanium | RFC 5970; RFC 4578 | |
| 0x00 0x03 | DEC Alpha (DEPRECATED) | RFC 5970; RFC 4578 | |
| 0x00 0x04 | Arc x86 (DEPRECATED) | RFC 5970; RFC 4578 | |
| 0x00 0x05 | Intel Lean Client (DEPRECATED) | RFC 5970; RFC 4578 | |
| 0x00 0x06 | x86 UEFI | RFC 5970; RFC 4578 | |
| 0x00 0x07 | x64 UEFI | RFC 5970; RFC 4578 | |
| 0x00 0x08 | EFI Xscale (DEPRECATED) | RFC 5970; RFC 4578 | |
| 0x00 0x09 | EBC | RFC 5970; RFC 4578 | |
| 0x00 0x0a | ARM 32-bit UEFI | RFC 5970 | |
| 0x00 0x0b | ARM 64-bit UEFI | RFC 5970 | |
| 0x00 0x0c | PowerPC Open Firmware | Thomas Huth | |
| 0x00 0x0d | PowerPC ePAPR | Thomas Huth | |
| 0x00 0x0e | POWER OPAL v3 | Jeremy Kerr | |
| 0x00 0x0f | x86 uefi boot from http | Samer El-Haj-Mahmoud | |
| 0x00 0x10 | x64 uefi boot from http | Samer El-Haj-Mahmoud | |
| 0x00 0x11 | ebc boot from http | Samer El-Haj-Mahmoud | |
| 0x00 0x12 | arm uefi 32 boot from http | Samer El-Haj-Mahmoud | |
| 0x00 0x13 | arm uefi 64 boot from http | Samer El-Haj-Mahmoud | |
| 0x00 0x14 | pc/at bios boot from http | Samer El-Haj-Mahmoud | |
| 0x00 0x15 | arm 32 uboot | Joseph Shifflett | |
| 0x00 0x16 | arm 64 uboot | Joseph Shifflett | |
| 0x00 0x17 | arm uboot 32 boot from http | Joseph Shifflett | |
| 0x00 0x18 | arm uboot 64 boot from http | Joseph Shifflett | |
| 0x00 0x19 | RISC-V 32-bit UEFI | Dong Wei | |
| 0x00 0x1a | RISC-V 32-bit UEFI boot from http | Dong Wei | |
| 0x00 0x1b | RISC-V 64-bit UEFI | Dong Wei | |
| 0x00 0x1c | RISC-V 64-bit UEFI boot from http | Dong Wei | |
| 0x00 0x1d | RISC-V 128-bit UEFI | Dong Wei | |
| 0x00 0x1e | RISC-V 128-bit UEFI boot from http | Dong Wei | |
| 0x00 0x1f | s390 Basic | Hendrik Brueckner | |
| 0x00 0x20 | s390 Extended | Hendrik Brueckner | |
| 0x00 0x21 | MIPS 32-bit UEFI | Jiading Zhang | |
| 0x00 0x22 | MIPS 64-bit UEFI | Jiading Zhang | |
| 0x00 0x23 | Sunway 32-bit UEFI | Jiading Zhang | |
| 0x00 0x24 | Sunway 64-bit UEFI | Jiading Zhang | |
| 0x00 0x25 | LoongArch 32-bit UEFI | LI Chao; https://loongson.github.io/LoongArch-Documentation/README-EN.html; https://github.com/loongson/LoongArch-Documentation | |
| 0x00 0x26 | LoongArch 32-bit UEFI boot from http | LI Chao; https://loongson.github.io/LoongArch-Documentation/README-EN.html; https://github.com/loongson/LoongArch-Documentation | |
| 0x00 0x27 | LoongArch 64-bit UEFI | LI Chao; https://loongson.github.io/LoongArch-Documentation/README-EN.html; https://github.com/loongson/LoongArch-Documentation | |
| 0x00 0x28 | LoongArch 64-bit UEFI boot from http | LI Chao; https://loongson.github.io/LoongArch-Documentation/README-EN.html; https://github.com/loongson/LoongArch-Documentation | |
| 0x00 0x29 | arm rpiboot | Peter Harper; https://www.raspberrypi.com/documentation/computers/remote-access.html#network-booting-using-ipv6 | |
| 0x00 0x2a-0xff 0xff | Unassigned |
Options Permitted in the Relay-Supplied Options Option
Registration Procedure(s)
- IETF Review
Reference
- RFC 6422: Relay-Supplied DHCP Options
- RFC 9915: Dynamic Host Configuration Protocol for IPv6 (DHCPv6)
Available Formats
| Value | Description | Status | Reference |
|---|---|---|---|
| 65 | OPTION_ERP_LOCAL_DOMAIN_NAME | RFC 6440 |
VSS Type Options
Registration Procedure(s)
- IETF Review
Reference
- RFC 6607: Virtual Subnet Selection Options for DHCPv4 and DHCPv6
Note
See the VSS Type Options registry at Dynamic Host Configuration Protocol (DHCP) and Bootstrap Protocol (BOOTP) Parameters
NTP Time Source Suboptions
Registration Procedure(s)
- IETF Review
Reference
- RFC 5908: Network Time Protocol (NTP) Server Option for DHCPv6
- RFC 9915: Dynamic Host Configuration Protocol for IPv6 (DHCPv6)
Available Formats
RADIUS Attributes Permitted in DHCPv6 RADIUS Option
Registration Procedure(s)
- Expert Review
Expert(s)
- Bernie Volz, Tomek Mrugalski
Reference
- RFC 7037: RADIUS Option for the DHCPv6 Relay Agent
- RFC 9915: Dynamic Host Configuration Protocol for IPv6 (DHCPv6)
Available Formats
| Type Code | Attribute | Status | Reference |
|---|---|---|---|
| 26 | Vendor-Specific | RFC 2865 | |
| 123 | Delegated-IPv6-Prefix | RFC 4818 | |
| 144 | DS-Lite-Tunnel-Name | RFC 6519 | |
| 168 | Framed-IPv6-Address | RFC 6911 | |
| 169 | DNS-Server-IPv6-Address | RFC 6911 | |
| 171 | Delegated-IPv6-Prefix-Pool | RFC 6911 | |
| 172 | Stateful-IPv6-Address-Pool | RFC 6911 | |
| 245.3 | DHCPv6-Options | RFC 9445 |
Option Codes Permitted in the S46 Priority Option
Registration Procedure(s)
- IETF Review
Reference
- RFC 8026: Unified IPv4-in-IPv6 Softwire Customer Premises Equipment (CPE): A DHCPv6-Based Prioritization Mechanism
- RFC 9915: Dynamic Host Configuration Protocol for IPv6 (DHCPv6)
Available Formats
Supported Transport
Registration Procedure(s)
- RFC Required
Reference
- RFC 9527: DHCPv6 Options for the Homenet Naming Authority
- RFC 9915: Dynamic Host Configuration Protocol for IPv6 (DHCPv6)
Available Formats
| Bit Position (least to most significant) | Transport Protocol Description | Mnemonic | Status | Reference |
|---|---|---|---|---|
| 0 | DNS over mutually authenticated TLS | DomTLS | RFC 9527 | |
| 1-15 | Unassigned |
DHCPv6 Options Permitted in the RADIUS DHCPv6-Options Attribute
Registration Procedure(s)
- Expert Review
Expert(s)
- Alan DeKok, Mohamed Boucadair
Reference
- RFC 9445: RADIUS Extensions for DHCP-Configured Services
- RFC 9915: Dynamic Host Configuration Protocol for IPv6 (DHCPv6)
Available Formats
| Value | Description | Status | Reference |
|---|---|---|---|
| 144 | OPTION_V6_DNR | RFC 9445 |
Contact Information
| Name | Contact URI | Last Updated |
|---|---|---|
| Dong Wei | dong.wei&arm.com | 2022-06-24 |
| Hendrik Brueckner | brueckner&de.ibm.com | 2023-07-25 |
| Jeremy Kerr | jeremy.kerr&au.ibm.com | 2014-04-04 |
| Jiading Zhang | jdzhang&zd-tech.com.cn | 2020-03-12 |
| Joseph Shifflett | joseph.shifflett&hp.com | 2015-04-03 |
| LI Chao | lichao&loongson.cn | 2021-10-26 |
| Peter Harper | peter.harper&raspberrypi.com | 2021-12-23 |
| Samer El-Haj-Mahmoud | elhaj&hp.com | 2014-06-04 |
| Thomas Huth | thuth&de.ibm.com | 2012-06-06 |