DomainKeys Identified Mail (DKIM) Parameters
Created
- 2007-03-08
Last Updated
- 2018-07-06
Available Formats
DKIM Signature Tag Specifications
Registration Procedure(s)
- IETF Review
Reference
- RFC 6376: DomainKeys Identified Mail (DKIM) Signatures
Available Formats
| Type | Reference | Status |
|---|---|---|
| v | RFC 6376 | active |
| a | RFC 6376 | active |
| b | RFC 6376 | active |
| bh | RFC 6376 | active |
| c | RFC 6376 | active |
| d | RFC 6376 | active |
| h | RFC 6376 | active |
| i | RFC 6376 | active |
| l | RFC 6376 | active |
| q | RFC 6376 | active |
| s | RFC 6376 | active |
| t | RFC 6376 | active |
| x | RFC 6376 | active |
| z | RFC 6376 | active |
| atps | RFC 6541 | active |
| atpsh | RFC 6541 | active |
| r | RFC 6651 | active |
DKIM-Signature Query Method
Registration Procedure(s)
- IETF Review
Reference
- RFC 6376: DomainKeys Identified Mail (DKIM) Signatures
Available Formats
| Type | Option | Reference | Status |
|---|---|---|---|
| dns | txt | RFC 6376 | active |
DKIM-Signature Canonicalization Header
Registration Procedure(s)
- IETF Review
Reference
- RFC 6376: DomainKeys Identified Mail (DKIM) Signatures
Available Formats
DKIM-Signature Canonicalization Body
Registration Procedure(s)
- IETF Review
Reference
- RFC 6376: DomainKeys Identified Mail (DKIM) Signatures
Available Formats
_domainkey DNS TXT Record Tag Specifications
Registration Procedure(s)
- IETF Review
Reference
- RFC 6376: DomainKeys Identified Mail (DKIM) Signatures
Available Formats
DKIM Key Type
Registration Procedure(s)
- IETF Review
Reference
- RFC 6376: DomainKeys Identified Mail (DKIM) Signatures
Available Formats
DKIM Hash Algorithms
Registration Procedure(s)
- IETF Review
Reference
- RFC 6376: DomainKeys Identified Mail (DKIM) Signatures
Available Formats
| Type | Reference | Status |
|---|---|---|
| sha1 | RFC 6376; RFC 8301 | historic |
| sha256 | FIPS-180-3-2008 | active |
DKIM Service Types
Registration Procedure(s)
- IETF Review
Reference
- RFC 6376: DomainKeys Identified Mail (DKIM) Signatures
Available Formats
DKIM Selector Flags
Registration Procedure(s)
- IETF Review
Reference
- RFC 6376: DomainKeys Identified Mail (DKIM) Signatures
Available Formats
Authorized Third-Party Signature (ATPS) Tag Registry
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 6541: DomainKeys Identified Mail (DKIM) Authorized Third-Party Signatures