DNS SSHFP Resource Record Parameters

Created

  • 2003-09-19

Last Updated

  • 2020-02-25

Available Formats


SSHFP RR Types for public key algorithms

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 4255: Using DNS to Securely Publish Secure Shell (SSH) Key Fingerprints

Available Formats

Value Description Reference
0 Reserved RFC 4255
1 RSA RFC 4255
2 DSA RFC 4255
3 ECDSA RFC 6594
4 Ed25519 RFC 7479
5 Unassigned
6 Ed448 RFC 8709

SSHFP RR types for fingerprint types

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 4255: Using DNS to Securely Publish Secure Shell (SSH) Key Fingerprints

Available Formats

Value Description Reference
0 Reserved RFC 4255
1 SHA-1 RFC 4255
2 SHA-256 RFC 6594