DNS Service Bindings (SVCB)

Created

  • 2022-05-26

Last Updated

  • 2026-06-25

Available Formats


DNS SVCB Service Parameter Keys (SvcParamKeys)

Expert(s)

  • Benjamin Schwartz, David Lawrence

Reference

  • RFC 9460: Service Binding and Parameter Specification via the DNS (SVCB and HTTPS Resource Records)

Available Formats

Range Registration Procedures
0-65279 Expert Review
65280-65534 Private Use
Number Name Meaning Change Controller Reference
0 mandatory Mandatory keys in this RR IETF RFC 9460, Section 8
1 alpn Additional supported protocols IETF RFC 9460, Section 7.1
2 no-default-alpn No support for default protocol IETF RFC 9460, Section 7.1
3 port Port for alternative endpoint IETF RFC 9460, Section 7.2
4 ipv4hint IPv4 address hints IETF RFC 9460, Section 7.3
5 ech TLS Encrypted ClientHello Config IETF RFC 9848
6 ipv6hint IPv6 address hints IETF RFC 9460, Section 7.3
7 dohpath DNS over HTTPS path template IETF RFC 9461
8 ohttp Denotes that a service operates an Oblivious HTTP target IETF RFC 9540, Section 4
9 tls-supported-groups Supported groups in TLS IETF draft-ietf-tls-key-share-prediction-01, Section 3.1
10 docpath DNS over CoAP resource path IETF RFC 9953, Section 3
11 pvd PvD configuration is available at the well-known path IETF RFC-ietf-intarea-proxy-config-13, Section 2.1
12 oots Per-transport operator confidence in serving the nameserver's query load over that transport, as a percentage IETF draft-johani-dnsop-svcb-oots-00, Section 5
13-65279 Unassigned
65280-65534 N/A Reserved for Private Use IETF RFC 9460
65535 N/A Reserved ("Invalid key") IETF RFC 9460