DNSKEY FLAGS

Created

  • 2004-02-04

Last Updated

  • 2026-07-20

Available Formats


DNSKEY RR Flags

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 3755: Legacy Resolver Compatibility for Delegation Signer (DS)
  • RFC 4034: Resource Records for the DNS Security Extensions

Note

The DNSKEY RR contains a 16-bit flags field. The KEY RR may have different flag assignments -- those assignments are not recorded in this registry.

Available Formats

Number Description Reference
0-6 Unassigned RFC 3755; RFC 4034
7 ZONE RFC 3755; RFC 4034
8 REVOKE RFC 5011
9-13 Unassigned RFC 3755; RFC 4034
14 Authoritative Delegation Types (TEMPORARY - registered 2026-07-20, expires 2027-07-20) draft-ietf-dnsop-delext-08
15 Secure Entry Point (SEP) RFC 3757; RFC 4034