Differentiated Services Field Codepoints (DSCP)

Last Updated

  • 2026-05-13

Note

The Differentiated Services (Diffserv) architecture specifies use of the DS field in the IPv4 and IPv6 packet headers to carry one of 64 distict differentiated services field codepoint (DSCP) values. The codepoint space is divided into three pools for the purpose of codepoint assignment and management: a pool of 32 codepoints (Pool 1) to be assigned by Standards Action as defined in RFC 8126, a pool of 16 codepoints (Pool 2) to be reserved for experimental or Local Use (EXP/LU) as defined in RFC 8126, and a pool of 16 codepoints (Pool 3) which are initially available for experimental or local use, but which should be preferentially utilized for standardized assignments if Pool 1 is ever exhausted. Pool 3 codepoints are now utilized for standardized assignments and are no longer available for experimental or local use, as specified by RFC 8436. The pools are defined in the following table (where 'x' refers to either '0' or '1').

Available Formats


Differentiated Services Field Codepoints (DSCP)

Reference

  • RFC 2474: Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 Headers
  • RFC 3260, Section 4: New Terminology and Clarifications for Diffserv

Note

See RFC 9435 for considerations when assigning a new codepoint from the DSCP registry.

Available Formats

Pool Codepoint Space Registration Procedure Note
1 xxxxx0 Standards Action
2 xxxx11 Experimental or Local Use Reserved for experimental or Local Use
3 xxxx01 Standards Action

DSCP Pool 1 Codepoints

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 2474: Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 Headers
  • RFC 3260, Section 4: New Terminology and Clarifications for Diffserv

Available Formats

Name Value (Binary) Value (Decimal) Reference
CS0 000000 0 RFC 2474
CS1 001000 8 RFC 2474
CS2 010000 16 RFC 2474
CS3 011000 24 RFC 2474
CS4 100000 32 RFC 2474
CS5 101000 40 RFC 2474
CS6 110000 48 RFC 2474
CS7 111000 56 RFC 2474
AF11 001010 10 RFC 2597
AF12 001100 12 RFC 2597
AF13 001110 14 RFC 2597
AF21 010010 18 RFC 2597
AF22 010100 20 RFC 2597
AF23 010110 22 RFC 2597
AF31 011010 26 RFC 2597
AF32 011100 28 RFC 2597
AF33 011110 30 RFC 2597
AF41 100010 34 RFC 2597
AF42 100100 36 RFC 2597
AF43 100110 38 RFC 2597
EF 101110 46 RFC 3246
VOICE-ADMIT 101100 44 RFC 5865

DSCP Pool 3 Codepoints

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 2474: Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 Headers
  • RFC 3260, Section 4: New Terminology and Clarifications for Diffserv
  • RFC 8436: Update to IANA Registration Procedures for Pool 3 Values in the Differentiated Services Field Codepoints (DSCP) Registry

Available Formats

Name Value (Binary) Value (Decimal) Reference
LE 000001 1 RFC 8622
NQB 101101 45 RFC 9956

ECN Field (Bits 6-7)

Registration Procedure(s)

  • RFC Required

Reference

  • RFC 3168: The Addition of Explicit Congestion Notification (ECN) to IP

Note

The registrations are identical for IPv4 and IPv6.

Available Formats

Binary Keyword Reference
00 Not-ECT (Not ECN-Capable Transport) RFC 3168
01 ECT(1) (ECN-Capable Transport(1))[1] RFC 8311; RFC Errata 5399; RFC 9331
10 ECT(0) (ECN-Capable Transport(0)) RFC 3168
11 CE (Congestion Experienced) RFC 3168

Footnote

[1]

ECT(1) is for experimental use only RFC 8311, Section 4.2