Dynamic Symmetric Key Provisioning Protocol (DSKPP)
Created
- 2010-09-21
Last Updated
- 2015-06-08
Available Formats
Status Codes
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 6063: Dynamic Symmetric Key Provisioning Protocol (DSKPP)
Available Formats
| Status Code | Reference |
|---|---|
| Continue | RFC 6063 |
| Success | RFC 6063 |
| Abort | RFC 6063 |
| AccessDenied | RFC 6063 |
| MalformedRequest | RFC 6063 |
| UnknownRequest | RFC 6063 |
| UnknownCriticalExtension | RFC 6063 |
| UnsupportedVersion | RFC 6063 |
| NoSupportedKeyTypes | RFC 6063 |
| NoSupportedEncryptionAlgorithms | RFC 6063 |
| NoSupportedMacAlgorithms | RFC 6063 |
| NoProtocolVariants | RFC 6063 |
| NoSupportedKeyPackages | RFC 6063 |
| AuthenticationDataMissing | RFC 6063 |
| AuthenticationDataInvalid | RFC 6063 |
| InitializationFailed | RFC 6063 |
| ProvisioningPeriodExpired | RFC 6063 |
DSKPP Version Registry
Registration Procedure(s)
- Standards Action
Reference
- RFC 6063: Dynamic Symmetric Key Provisioning Protocol (DSKPP)
Available Formats
| DSKPP Version | Reference |
|---|---|
| 1.0 | RFC 6063 |
PRF Algorithm ID Registry
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 6063: Dynamic Symmetric Key Provisioning Protocol (DSKPP)
Available Formats
Key Container Registry
Registration Procedure(s)
- Specification Required
Expert(s)
- Unassigned
Reference
- RFC 6063: Dynamic Symmetric Key Provisioning Protocol (DSKPP)
Available Formats
| Name | URI | Deprecated | Reference |
|---|---|---|---|
| PSKC Key Container | urn:ietf:params:xml:ns:keyprov:dskpp:pskc-key-container | FALSE | RFC 6030; RFC 6063 |
| SKPC Key Container | urn:ietf:params:xml:ns:keyprov:dskpp:skpc-key-container | FALSE | RFC 6031; RFC 6063 |
| PKCS12 Key Container | urn:ietf:params:xml:ns:keyprov:dskpp:pkcs12-key-container | FALSE | 'Personal Information Exchange Syntax Standard', PKCS 12 Version 1.0; ftp://ftp.rsasecurity.com/pub/pkcs/pkcs-12/pkcs-12v1.pdf; RFC 6063 |
| PKCS5-XML Key Container | urn:ietf:params:xml:ns:keyprov:dskpp:pkcs5-xml-key-container | FALSE | 'XML Schema for PKCS 5 Version 2.0', PKCS 5 Version 2.0 Amd.1 (FINAL DRAFT), October 2006; http://www.rsasecurity.com/rsalabs/pkcs/; RFC 6063 |