Nimble Out-of-Band Authentication for EAP Parameters (EAP-NOOB)

Created

  • 2021-09-21

Last Updated

  • 2022-01-07

Available Formats


EAP-NOOB Cryptosuites

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Tuomas Aura, Mohit Sethi

Reference

  • RFC 9140: Nimble Out-of-Band Authentication for EAP (EAP-NOOB)

Available Formats

Cryptosuite Algorithms Reference
0 Reserved RFC 9140
1 ECDHE curve Curve25519 RFC 7748, public-key format RFC 7517, hash function SHA-256 RFC 6234. The JWK encoding of Curve25519 public key is defined in RFC 8037. For clarity, the "crv" parameter is "X25519", the "kty" parameter is "OKP", and the public-key encoding contains only an x-coordinate. RFC 9140
2 ECDHE curve NIST P-256 FIPS186-4, public-key format RFC 7517, hash function SHA-256 RFC 6234. The JWK encoding of NIST P-256 public key is defined in RFC 7518. For clarity, the "crv" parameter is "P-256", the "kty" parameter is "EC", and the public-key encoding has both an x and y coordinate, as defined in Section 6.2.1 of RFC 7518. RFC 9140
3-65535 Unassigned

EAP-NOOB Message Types

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Tuomas Aura, Mohit Sethi

Reference

  • RFC 9140: Nimble Out-of-Band Authentication for EAP (EAP-NOOB)

Available Formats

Message Type Used in Exchange Purpose Reference
0 Error Error notification RFC 9140
1 All exchanges PeerId and PeerState discovery RFC 9140
2 Initial Version, cryptosuite, and parameter negotiation RFC 9140
3 Initial Exchange of ECDHE keys and nonces RFC 9140
4 Waiting Indication to the peer that the server has not yet received an OOB message RFC 9140
5 Completion NoobId discovery RFC 9140
6 Completion Authentication and key confirmation with HMAC RFC 9140
7 Reconnect Version, cryptosuite, and parameter negotiation RFC 9140
8 Reconnect Exchange of ECDHE keys and nonces RFC 9140
9 Reconnect Authentication and key confirmation with HMAC RFC 9140
10-65535 Unassigned

EAP-NOOB Error Codes

Expert(s)

  • Tuomas Aura, Mohit Sethi

Reference

  • RFC 9140: Nimble Out-of-Band Authentication for EAP (EAP-NOOB)

Available Formats

Range Registration Procedures
6001-6999 Private and Experimental Use
All other values Specification Required
Error Code Purpose Reference
1001 Invalid NAI RFC 9140
1002 Invalid message structure RFC 9140
1003 Invalid data RFC 9140
1004 Unexpected message type RFC 9140
1005 Invalid ECDHE key RFC 9140
2001 Unwanted peer RFC 9140
2002 State mismatch, user action required RFC 9140
2003 Unrecognized OOB message identifier RFC 9140
2004 Unexpected peer identifier RFC 9140
3001 No mutually supported protocol version RFC 9140
3002 No mutually supported cryptosuite RFC 9140
3003 No mutually supported OOB direction RFC 9140
4001 HMAC verification failure RFC 9140
5001 Application-specific error RFC 9140
5002 Invalid server info RFC 9140
5003 Invalid server URL RFC 9140
5004 Invalid peer info RFC 9140
6001-6999 Reserved for Private and Experimental Use RFC 9140

EAP-NOOB ServerInfo Data Fields

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Tuomas Aura, Mohit Sethi

Reference

  • RFC 9140: Nimble Out-of-Band Authentication for EAP (EAP-NOOB)

Available Formats

Data Field Reference
Type RFC 9140, Section 4
ServerName RFC 9140, Section 4
ServerURL RFC 9140, Section 4
SSIDList RFC 9140, Section 4
Base64SSIDList RFC 9140, Section 4

EAP-NOOB PeerInfo Data Fields

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Tuomas Aura, Mohit Sethi

Reference

  • RFC 9140: Nimble Out-of-Band Authentication for EAP (EAP-NOOB)

Available Formats