Extensible Authentication Protocol (EAP) Registry
Created
- 2004-04-09
Last Updated
- 2026-08-31
Available Formats
Packet Codes
Registration Procedure(s)
- Standards Action
Reference
- RFC 3748: Extensible Authentication Protocol (EAP)
Available Formats
EAP Initiate and Finish Attributes
Registration Procedure(s)
- IETF Review
Reference
- RFC 6696: EAP Extensions for the EAP Re-authentication Protocol (ERP)
Available Formats
| Type | Description | Payload Type | Reference |
|---|---|---|---|
| 0 | Reserved | RFC 6696 | |
| 1 | keyName-NAI | TLV | RFC 6696 |
| 2 | rRK Lifetime | TV | RFC 6696 |
| 3 | rMSK Lifetime | TV | RFC 6696 |
| 4 | Domain name | TLV | RFC 6696 |
| 5 | Cryptosuite list | TLV | RFC 6696 |
| 6 | Authorization Indication | TLV | RFC 6696 |
| 7 | Sequence number | TV | RFC 6630 |
| 8 | ERP/AAK-Key | TLV | RFC 6630 |
| 9 | pRK Lifetime | TLV | RFC 6630 |
| 10 | pMSK Lifetime | TLV | RFC 6630 |
| 11 | CAP-Identifier | TLV | RFC 6630 |
| 12-127 | Unassigned | ||
| 128 | Called-Station-Id | TLV | RFC 6696 |
| 129 | Calling-Station-Id | TLV | RFC 6696 |
| 130 | NAS-Identifier | TLV | RFC 6696 |
| 131 | NAS-IP-Address | TLV | RFC 6696 |
| 132 | NAS-IPv6-Address | TLV | RFC 6696 |
| 133-191 | Unassigned | ||
| 192-255 | Reserved for Private Use | RFC 6696 |
Method Types
Expert(s)
- Joseph Salowey
Reference
- RFC 3748: Extensible Authentication Protocol (EAP)
Available Formats
| Range | Registration Procedures |
|---|---|
| 1-191 | Specification Required |
| 192-253 | Standards Action |
| 254 | Expanded Type |
| 255 | Experimental |
| 256-4294967295 | Specification Required |
| Value | Description | Reference |
|---|---|---|
| 0 | Reserved | |
| 1 | Identity | RFC 3748 |
| 2 | Notification | RFC 3748 |
| 3 | Legacy Nak | RFC 3748 |
| 4 | MD5-Challenge | RFC 3748 |
| 5 | One-Time Password (OTP) | RFC 3748 |
| 6 | Generic Token Card (GTC) | RFC 3748 |
| 7 | Allocated | RFC 3748 |
| 8 | Allocated | RFC 3748 |
| 9 | RSA Public Key Authentication | William Whelan |
| 10 | DSS Unilateral | William Nace |
| 11 | KEA | William Nace |
| 12 | KEA-VALIDATE | William Nace |
| 13 | EAP-TLS | RFC 5216 |
| 14 | Defender Token (AXENT) | Michael Rosselli |
| 15 | RSA Security SecurID EAP | Magnus Nyström |
| 16 | Arcot Systems EAP | Rob Jerdonek |
| 17 | EAP-Cisco Wireless | Stuart Norman |
| 18 | GSM Subscriber Identity Modules (EAP-SIM) | RFC 4186 |
| 19 | SRP-SHA1 | James Carlson |
| 20 | Unassigned | |
| 21 | EAP-TTLS | RFC 5281 |
| 22 | Remote Access Service | Steven Fields |
| 23 | EAP-AKA Authentication | RFC 4187 |
| 24 | EAP-3Com Wireless | Albert Young |
| 25 | PEAP | Ashwin Palekar |
| 26 | MS-EAP-Authentication | Ashwin Palekar |
| 27 | Mutual Authentication w/Key Exchange (MAKE) | Romain Berrendonner |
| 28 | CRYPTOCard | Stephen M. Webb |
| 29 | EAP-MSCHAP-V2 | Darran Potter |
| 30 | DynamID | Pascal Merlin |
| 31 | Rob EAP | Sana Ullah |
| 32 | Protected One-Time Password | RFC 4793; Magnus Nyström |
| 33 | MS-Authentication-TLV | Ashwin Palekar |
| 34 | SentriNET | Joe Kelleher |
| 35 | EAP-Actiontec Wireless | Victor Chang |
| 36 | Cogent Systems Biometrics Authentication EAP | John Xiong |
| 37 | AirFortress EAP | Richard Hibbard |
| 38 | EAP-HTTP Digest | Oliver K. Tavakoli |
| 39 | SecureSuite EAP | Matt Clements |
| 40 | DeviceConnect EAP | David Pitard |
| 41 | EAP-SPEKE | Don Zick |
| 42 | EAP-MOBAC | Tom Rixom |
| 43 | EAP-FAST | RFC 4851 |
| 44 | ZoneLabs EAP (ZLXEAP) | Darrin Bogue |
| 45 | EAP-Link | Don Zick |
| 46 | EAP-PAX | T. Charles Clancy |
| 47 | EAP-PSK | RFC 4764 |
| 48 | EAP-SAKE | RFC 4763 |
| 49 | EAP-IKEv2 | RFC 5106 |
| 50 | EAP-AKA' | RFC 9048 |
| 51 | EAP-GPSK | RFC 5433 |
| 52 | EAP-pwd | RFC 5931 |
| 53 | EAP-EKE Version 1 | RFC 6124 |
| 54 | EAP Method Type for PT-EAP | RFC 7171 |
| 55 | TEAP | RFC 9930 |
| 56 | EAP-NOOB | RFC 9140 |
| 57 | EAP-EDHOC | RFC-ietf-emu-eap-edhoc-12 |
| 58-191 | Unassigned | |
| 192-253 | Unassigned | |
| 254 | Reserved for the Expanded Type | RFC 3748 |
| 255 | Experimental | RFC 3748 |
| 256-4294967295 | Unassigned |
EAP-FAST TLV Types (Value 43)
Note
EAP-FAST (value 43) Error-TLV (value 5) Error-Codes
Note
EAP-FAST (value 43) Request-Action TLV (value 19) Action Codes
Note
Message Types
Registration Procedure(s)
- IETF Review
Reference
- RFC 6696: EAP Extensions for the EAP Re-authentication Protocol (ERP)
Available Formats
Re-authentication Cryptosuites
Registration Procedure(s)
- IETF Review
Reference
- RFC 6696: EAP Extensions for the EAP Re-authentication Protocol (ERP)
Available Formats
EAP-TTLS AVP Usage
Registration Procedure(s)
- IETF Review
Reference
- RFC 5281: Extensible Authentication Protocol Tunneled Transport Layer Security Authenticated Protocol Version 0 (EAP-TTLSv0)
Note
The following table lists whether the AVP may appear in a packet from server to client ("Request") and/or in a packet from client to server ("Response"), and whether the AVP MUST be implemented ("MI").
Available Formats
| Name | Request | Response | MI | Reference |
|---|---|---|---|---|
| User-Name | X | RFC 5281 | ||
| User-Password | X | RFC 5281 | ||
| CHAP-Password | X | RFC 5281 | ||
| Reply-Message | X | RFC 5281 | ||
| CHAP-Challenge | X | RFC 5281 | ||
| EAP-Message | X | X | X | RFC 5281 |
| MS-CHAP-Response | X | RFC 5281 | ||
| MS-CHAP-Error | X | RFC 5281 | ||
| MS-CHAP-NT-Enc-PW | X | RFC 5281 | ||
| MS-CHAP-Domain | X | RFC 5281 | ||
| MS-CHAP-Challenge | X | RFC 5281 | ||
| MS-CHAP2-Response | X | RFC 5281 | ||
| MS-CHAP2-Success | X | RFC 5281 | ||
| MS-CHAP2-CPW | X | RFC 5281 |
EAP Initiate/Re-auth-Start Flags
Registration Procedure(s)
- Standards Action or IESG Approval
Reference
- RFC 6630: EAP Re-authentication Protocol Extensions for Authenticated Anticipatory Keying (ERP/AAK)
Available Formats
| Flag | Value | Reference |
|---|---|---|
| (E) | 0x80 | RFC 6630 |
EAP Initiate/Re-auth Flags
Registration Procedure(s)
- Standards Action or IESG Approval
Reference
- RFC 6630: EAP Re-authentication Protocol Extensions for Authenticated Anticipatory Keying (ERP/AAK)
Available Formats
EAP Finish/Re-auth Flags
Registration Procedure(s)
- Standards Action or IESG Approval
Reference
- RFC 6630: EAP Re-authentication Protocol Extensions for Authenticated Anticipatory Keying (ERP/AAK)
Available Formats
EAP Lower Layers
Registration Procedure(s)
- Expert Review
Expert(s)
- Joseph Salowey
Reference
- RFC 6677: Channel-Binding Support for Extensible Authentication Protocol (EAP) Methods
Available Formats
| Value | Lower Layer | Reference |
|---|---|---|
| 0 | Reserved | RFC 6677 |
| 1 | Wired IEEE 802.1X | RFC 6677 |
| 2 | IEEE 802.11 (no-pre-auth) | RFC 6677 |
| 3 | IEEE 802.11 (pre-authentication) | RFC 6677 |
| 4 | IEEE 802.16e | RFC 6677 |
| 5 | IKEv2 | RFC 6677 |
| 6 | PPP | RFC 6677 |
| 7 | PANA (no pre-authentication) | RFC 5191; RFC 6677 |
| 8 | GSS-API | RFC 7055; RFC 6677 |
| 9 | PANA (pre-authentication) | RFC 5873; RFC 6677 |
| 10 | CoAP-EAP | RFC 9820 |
| 11-255 | Unassigned |
EAP Provisioning Identifiers
Registration Procedure(s)
- Expert Review
Expert(s)
- Unassigned
Reference
- RFC 9965: The eap.arpa. Domain and Extensible Authentication Protocol (EAP) Provisioning
Available Formats
EAP-NOOB ServerInfo Data Fields
Note
See Nimble Out-of-Band Authentication for EAP Parameters (EAP-NOOB)
EAP-NOOB PeerInfo Data Fields
Note
See Nimble Out-of-Band Authentication for EAP Parameters (EAP-NOOB)
TEAP Identity-Type TLV (value 2) Registry
Note
See Tunnel Extensible Authentication Protocol (TEAP) Parameters
TEAP Error TLV (value 5) Error Codes
Note
See Tunnel Extensible Authentication Protocol (TEAP) Parameters
TEAP Request-Action TLV (value 8) Registry
Note
See Tunnel Extensible Authentication Protocol (TEAP) Parameters
TEAP PAC TLV (value 11) PAC Attribute Type Codes
Note
See Tunnel Extensible Authentication Protocol (TEAP) Parameters
TEAP PAC TLV (value 11) PAC-Type Type Codes
Note
See Tunnel Extensible Authentication Protocol (TEAP) Parameters
TEAP Trusted-Server-Root TLV (value 17) Credential-Format Codes
Note
See Tunnel Extensible Authentication Protocol (TEAP) Parameters
Contact Information
| Name | Contact URI | Last Updated |
|---|---|---|
| Albert Young | albert_young&3com.com | 2001-12 |
| Ashwin Palekar | ashwinpµsoft.com | 2002-04 |
| Darran Potter | dpotter&cisco.com | 2002-01 |
| Darrin Bogue | dbogue&zonelabs.com | 2004-02 |
| David Pitard | david_pitard&phoenix.com | 2003-02 |
| Don Zick | dzick&interlinknetworks.com | 2004-04 |
| James Carlson | james.d.carlson&east.sun.com | 2001-02 |
| Joe Kelleher | joe.kelleher&informer.co.uk | 2002-04 |
| John Xiong | johnxiong&cogentsystems.com | 2002-06 |
| Magnus Nyström | mnystromµsoft.com | 2006-04-11 |
| Matt Clements | matt&iosoftware.com | 2003-02 |
| Michael Rosselli | mrosselli&axent.com | 1998-01 |
| Oliver K. Tavakoli | radagast&funk.com | 2003-02 |
| Pascal Merlin | pmerlin&scrypto.fr | 2002-01 |
| Richard Hibbard | rhibbard&fortresstech.com | 2003-02 |
| Rob Jerdonek | rob&arcot.com | 2000-05 |
| Romain Berrendonner | romain.berrendonner&sagem.com | 2001-12 |
| Sana Ullah | palash78&globalctg.net | 2002-02 |
| Stephen M. Webb | stephenw&cryptocard.com | 2002-01 |
| Steven Fields | sfields&identix.com | 2001-11 |
| Stuart Norman | snorm&cisco.com | 2000-11 |
| T. Charles Clancy | clancy&cs.umd.edu | 2005-06 |
| Tom Rixom | tom.rixom&alfa-ariss.com | 2003-05 |
| Victor Chang | vchang&actiontec.com | 2002-06 |
| William Nace | wanace&missi.ncsc.mil | 1997-12 |
| William Whelan | bwhelan&nei.com | 1997-12 |