Provider ID Series
Registration Procedure(s)
- Expert Review
Expert(s)
- Brian Rosen
Reference
- RFC 7852: Additional Data Related to an Emergency Call
Available Formats
| Name | Source | URL | Reference |
|---|---|---|---|
| NENA | National Emergency Number Association | http://www.nena.org | RFC 7852 |
| EENA | European Emergency Number Association | http://www.eena.org | RFC 7852 |
| domain | (The ID is a fully qualified domain name) | (not applicable) | RFC 7852 |
Service Environment
Registration Procedure(s)
- Expert Review
Expert(s)
- Brian Rosen
Reference
- RFC 7852: Additional Data Related to an Emergency Call
Available Formats
Service Type
Registration Procedure(s)
- Expert Review
Expert(s)
- Brian Rosen
Reference
- RFC 7852: Additional Data Related to an Emergency Call
Available Formats
| Token | Description | Reference |
|---|---|---|
| wireless | Wireless Telephone Service: Includes CDMA, GSM, Wi-Fi, WiMAX, and LTE (but not satellite) | RFC 7852 |
| coin | Fixed public pay/coin telephones: Any device operated by coin or credit card | RFC 7852 |
| one-way | One-way outbound service | RFC 7852 |
| temp | Soft dial tone/quick service/warm disconnect/suspended | RFC 7852 |
| MLTS-hosted | Hosted multi-line telephone system such as Centrex | RFC 7852 |
| MLTS-local | Local multi-line telephone system, including all PBXs, key systems, and Shared Tenant Services | RFC 7852 |
| sensor-unattended | These are devices that generate DATA ONLY. This is a one-way information transmit without interactive media. | RFC 7852 |
| sensor-attended | Devices that are supported by a monitoring service provider or that are capable of supporting interactive media | RFC 7852 |
| POTS | Wireline: Plain Old Telephone Service | RFC 7852 |
| OTT | An over-the-top service that provides communication over arbitrary Internet access (fixed, nomadic, mobile) | RFC 7852 |
| digital | Wireline non-OTT digital phone service | RFC 7852 |
| OPX | Off-premise extension | RFC 7852 |
| relay | A service where a human third-party agent provides additional assistance. This includes sign language relay/interpretation, telematics services that provide a human on the call, and similar services. | RFC 7852 |
Service Mobility
Registration Procedure(s)
- Expert Review
Expert(s)
- Brian Rosen
Reference
- RFC 7852: Additional Data Related to an Emergency Call
Available Formats
| Token | Description | Reference |
|---|---|---|
| Mobile | The device is able to move at any time | RFC 7852 |
| Fixed | The device is not expected to move unless the service is relocated | RFC 7852 |
| Nomadic | The device is not expected to change its point of attachment while on a call | RFC 7852 |
| Unknown | No information is known about the service mobility environment for the device | RFC 7852 |
Type of Provider
Registration Procedure(s)
- Expert Review
Expert(s)
- Brian Rosen
Reference
- RFC 7852: Additional Data Related to an Emergency Call
Available Formats
| Token | Description | Reference |
|---|---|---|
| Client | Originating client/device | RFC 7852 |
| Access Network Provider | Access network service provider | RFC 7852 |
| Telecom Provider | Telecom service provider (including native and over-the-top VoIP services) | RFC 7852 |
| Telematics Provider | A sensor-based service provider, especially vehicle based | RFC 7852 |
| Language Translation Provider | A spoken language translation service | RFC 7852 |
| Emergency Service Provider | An emergency service provider conveying information to another emergency service provider | RFC 7852 |
| Emergency Modality Translation | An emergency-call-specific modality translation service, e.g., for sign language | RFC 7852 |
| Relay Provider | An interpretation service, e.g., video relay for sign language interpretation | RFC 7852 |
| Gateway | An element translating/interworking between SIP-based emergency calling and another protocol (e.g., Signaling System 7) | NENA-STA-034.1-2022; Randall Gellens |
| Other | Any other type of service provider | RFC 7852 |
Device Classification
Registration Procedure(s)
- Expert Review
Expert(s)
- Brian Rosen
Reference
- RFC 7852: Additional Data Related to an Emergency Call
Available Formats
| Token | Description | Reference |
|---|---|---|
| cordless | Cordless handset | RFC 7852 |
| fixed | Fixed phone | RFC 7852 |
| satellite | Satellite phone | RFC 7852 |
| sensor-fixed | Fixed (non-mobile) sensor/alarm device | RFC 7852 |
| desktop | Soft client on desktop PC | RFC 7852 |
| laptop | Soft client on laptop-type device | RFC 7852 |
| tablet | Soft client on tablet-type device | RFC 7852 |
| alarm-monitored | Alarm system | RFC 7852 |
| sensor-mobile | Mobile sensor device | RFC 7852 |
| aircraft | Aircraft telematics device | RFC 7852 |
| automobile | Automobile/cycle/off-road telematics | RFC 7852 |
| truck | Truck/construction telematics | RFC 7852 |
| farm | Farm equipment telematics | RFC 7852 |
| marine | Marine telematics | RFC 7852 |
| personal | Personal telematics device | RFC 7852 |
| feature-phone | Cellular feature phone (not smartphone) | RFC 7852 |
| smart-phone | Cellular smartphone (native) | RFC 7852 |
| smart-phone-app | Soft client app on smartphone | RFC 7852 |
| unknown-device | Soft client on unknown device type | RFC 7852 |
| game | Gaming console | RFC 7852 |
| text-only | Other text device | RFC 7852 |
| NA | Not Available | RFC 7852 |
Device ID Type
Registration Procedure(s)
- Expert Review
Expert(s)
- Brian Rosen
Reference
- RFC 7852: Additional Data Related to an Emergency Call
Available Formats
| Token | Description | Reference |
|---|---|---|
| MEID | Mobile Equipment Identifier (CDMA) | RFC 7852 |
| ESN | Electronic Serial Number (GSM) | RFC 7852 |
| MAC | Media Access Control Address (IEEE) | RFC 7852 |
| WiMAX | Device Certificate Unique ID | RFC 7852 |
| IMEI | International Mobile Equipment ID (GSM) | RFC 7852 |
| IMSI | International Mobile Subscriber ID (GSM) | RFC 7852 |
| UDI | Unique Device Identifier | RFC 7852 |
| RFID | Radio Frequency Identification | RFC 7852 |
| SN | Manufacturer Serial Number | RFC 7852 |
Device/Service Data Type
Registration Procedure(s)
- Specification Required
Expert(s)
- Brian Rosen
Reference
- RFC 7852: Additional Data Related to an Emergency Call
Available Formats
| Name | Source | Specification | Reference |
|---|---|---|---|
| IEEE1512 | Common Incident Management Message Set (USDoT model for traffic incidents) | IEEE 1512-2006 | RFC 7852 |
Emergency Call Data Types
Registration Procedure(s)
- Specification Required
Expert(s)
- Brian Rosen (primary), Henning Schulzrinne (secondary)
Reference
- RFC 7852: Additional Data Related to an Emergency Call
Available Formats
| Token | Data About | Reference |
|---|---|---|
| ProviderInfo | The Call | RFC 7852 |
| ServiceInfo | The Call | RFC 7852 |
| DeviceInfo | The Call | RFC 7852 |
| SubscriberInfo | The Call | RFC 7852 |
| Comment | The Call | RFC 7852 |
| eCall.MSD | The Call | RFC 8147 |
| Control | The Call | RFC 8147 |
| VEDS | The Call | RFC 8148 |
| cap | The Call | RFC 8876 |
| LegacyESN | The Location | NENA-STA-034.1-2022; Randall Gellens |
Contact Information
| Name | Contact URI | Last Updated |
|---|---|---|
| Randall Gellens | rg+ietf+iana&randy.pensive.org | 2022-09-20 |