FCAST Parameters

Created

  • 2013-05-07

Last Updated

  • 2013-07-09

Available Formats


FCAST Object Metadata Format

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 6968: FCAST: Object Delivery for the Asynchronous Layered Coding (ALC) and NACK-Oriented Reliable Multicast (NORM) Protocols

Available Formats

Value Format Name Format Reference Reference
0 (default) HTTP/1.1 metainformation format RFC 2616, Section 7.1 RFC 6968
1-15 Unassigned

FCAST Object Metadata Encoding

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Unassigned

Reference

  • RFC 6968: FCAST: Object Delivery for the Asynchronous Layered Coding (ALC) and NACK-Oriented Reliable Multicast (NORM) Protocols

Available Formats

Value Encoding Name Encoding Reference Reference
0 UTF-8 encoded text RFC 3629 RFC 6968
1 GZIP'ed UTF-8 encoded text RFC 1952; RFC 3629 RFC 6968
2-15 Unassigned

FCAST Object Metadata Types

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Unassigned

Reference

  • RFC 6968: FCAST: Object Delivery for the Asynchronous Layered Coding (ALC) and NACK-Oriented Reliable Multicast (NORM) Protocols

Available Formats

Meta-Data Type Description Reference
Fcast-Obj-Digest-SHA1 a string that contains the "base64" encoding of the SHA-1 message digest of the object before any content encoding is applied (if any) and without considering the FCAST Header RFC 6968
Fcast-Obj-Digest-SHA256 a string that contains the "base64" encoding of the SHA-256 message digest of the object before any content encoding is applied (if any) and without considering the FCAST Header RFC 6968
Fcast-Obj-Slice-Nb Unsigned 32-bit integer that contains the total number of slices. A value greater than 1 indicates that this object is the result of a split of the original object RFC 6968
Fcast-Obj-Slice-Idx Unsigned 32-bit integer that contains the slice index (in the {0 .. SliceNb - 1} interval) RFC 6968
Fcast-Obj-Slice-Offset Unsigned 64-bit integer that contains the byte offset at which this slice starts within the original object RFC 6968