General Internet Signalling Transport (GIST) Parameters

Created

  • 2009-07-30

Last Updated

  • 2011-01-20

Available Formats


NSIS Signaling Layer Protocol (NSLP) Identifiers

Registration Procedure(s)

  • IESG Approval

Reference

  • RFC 5971: GIST: General Internet Signalling Transport

Available Formats

NSLPID Description Reference
0 Used for GIST messages not related to any signalling application. RFC 5971
1-32 QoS NSLP Aggregation Levels 0-31 RFC 5974
33 NATFW RFC 5973
34-32703 Unassigned
32704-32767 Reserved for Private/Experimental Use RFC 5971
32768-65535 Reserved RFC 5971

GIST Message Types

Expert(s)

  • Martin Stiemerling

Reference

  • RFC 5971: GIST: General Internet Signalling Transport

Available Formats

Range Registration Procedures
0-31 IETF Review
32-55 Expert Review
Value Description Reference
0 Query RFC 5971
1 Response RFC 5971
2 Confirm RFC 5971
3 Data RFC 5971
4 Error RFC 5971
5 MA-Hello RFC 5971
6-55 Unassigned
56-63 Reserved for Private/Experimental Use RFC 5971
64-127 Reserved RFC 5971

GIST Object Types

Expert(s)

  • Martin Stiemerling

Reference

  • RFC 5971: GIST: General Internet Signalling Transport

Available Formats

Range Registration Procedures
0-1023 IETF Review
1024-1999 Specification Required
Value Description Reference
0 Message Routing Information RFC 5971
1 Session ID RFC 5971
2 Network Layer Information RFC 5971
3 Stack Proposal RFC 5971
4 Stack Configuration Data RFC 5971
5 Query-Cookie RFC 5971
6 Responder-Cookie RFC 5971
7 NAT Traversal RFC 5971
8 NSLP Data RFC 5971
9 Error RFC 5971
10 Hello ID RFC 5971
11-1999 Unassigned
2000-2047 Reserved for Private/Experimental Use RFC 5971
2048-4095 Reserved RFC 5971

GIST Message Routing Methods

Expert(s)

  • Martin Stiemerling

Reference

  • RFC 5971: GIST: General Internet Signalling Transport

Available Formats

Range Registration Procedures
0-63 IETF Review
64-119 Specification Required
Value Description Reference
0 Path-Coupled MRM RFC 5971
1 Loose-End MRM RFC 5971
2-119 Unassigned
120-127 Reserved for Private/Experimental Use RFC 5971
128-255 Reserved RFC 5971

GIST MA-Protocol-IDs

Expert(s)

  • Martin Stiemerling

Reference

  • RFC 5971: GIST: General Internet Signalling Transport

Available Formats

Range Registration Procedures
0-63 IETF Review
64-119 Expert Review
Value Description Reference
0 Reserved RFC 5971
1 TCP opened in the forwards direction RFC 5971
2 TLS initiated in the forwards direction RFC 5971
3 SCTP opened in the forwards direction RFC 6084
4 DTLS initiated in the forwards direction RFC 6084
5-119 Unassigned
120-127 Reserved for Private/Experimental Use RFC 5971
128-255 Reserved RFC 5971

GIST Error Codes

Registration Procedure(s)

  • First Come First Served

Reference

  • RFC 5971: GIST: General Internet Signalling Transport

Available Formats

Error Code Error Case Class Additional Information Reference
1 Common Header Parse Error Protocol-Error For subcode 3 only, Message Length Info carries the calculated message length. RFC 5971
2 Hop Limit Exceeded Permanent-Failure RFC 5971
3 Incorrect Encapsulation Protocol-Error RFC 5971
4 Incorrectly Delivered Message Protocol-Error RFC 5971
5 No Routing State Protocol-Error RFC 5971
6 Unknown NSLPID Permanent-Failure RFC 5971
7 Endpoint Found Permanent-Failure RFC 5971
8 Message Too Large Permanent-Failure MTU Info RFC 5971
9 Object Type Error Protocol-Error Object Type Info RFC 5971
10 Object Value Error Protocol-Error 1 or 2 Object Value Info fields; see appendix A.4.4.10 RFC 5971
11 Invalid IP-Layer TTL Permanent-Failure RFC 5971
12 MRI Validation Failure Permanent-Failure Object Value Info RFC 5971

Error Code 1 Subcodes

Registration Procedure(s)

  • First Come First Served

Reference

  • RFC 5971: GIST: General Internet Signalling Transport

Available Formats

Value Description Reference
0 Unknown Version RFC 5971
1 Unknown Type RFC 5971
2 Invalid R-flag RFC 5971
3 Incorrect Message Length RFC 5971
4 Invalid E-flag RFC 5971
5 Invalid C-flag RFC 5971

Error Code 9 Subcodes

Registration Procedure(s)

  • First Come First Served

Reference

  • RFC 5971: GIST: General Internet Signalling Transport

Available Formats

Value Description Reference
0 Duplicate Object RFC 5971
1 Unrecognized Object RFC 5971
2 Missing Object RFC 5971
3 Invalid Object Type RFC 5971
4 Untranslated Object RFC 5971
5 Invalid Extensibility Flags RFC 5971

Error Code 10 Subcodes

Registration Procedure(s)

  • First Come First Served

Reference

  • RFC 5971: GIST: General Internet Signalling Transport

Available Formats

Value Description Reference
0 Incorrect Length RFC 5971
1 Value Not Supported RFC 5971
2 Invalid Flag-Field Combination RFC 5971
3 Empty List RFC 5971
4 Invalid Cookie RFC 5971
5 Stack-Proposal RFC 5971

Error Code 12 Subcodes

Registration Procedure(s)

  • First Come First Served

Reference

  • RFC 5971: GIST: General Internet Signalling Transport

Available Formats

Value Description Reference
0 MRI Too Wild RFC 5971
1 IP Version Mismatch RFC 5971
2 Ingress Filter Failure RFC 5971

Additional Information Types

Registration Procedure(s)

  • First Come First Served

Reference

  • RFC 5971: GIST: General Internet Signalling Transport

Available Formats

Value Description Reference
1 Message Length Info RFC 5971
2 MTU Info RFC 5971
3 Object Type Info RFC 5971
4 Object Value Info RFC 5971