Generalized Multi-Protocol Label Switching (GMPLS) Signaling Parameters

Created

  • 2002-11-08

Last Updated

  • 2020-07-23

Available Formats


LSP Encoding Types

Reference

  • RFC 3471: Generalized Multi-Protocol Label Switching (GMPLS) Signaling Functional Description
  • RFC 4328: Generalized Multi-Protocol Label Switching (GMPLS) Signaling Extensions for G.709 Optical Transport Networks Control

Available Formats

Range Registration Procedures Note
0-239 Standards Action
240-255 Assigned temporarily for Experimental Usage Not registered with IANA
Value Name Reference
0 Unassigned
1 Packet RFC 3471
2 Ethernet RFC 3471
3 ANSI/ETSI PDH RFC 3471
4 Reserved RFC 3471
5 SDH ITU-T G.707 / SONET ANSI T1.105 RFC 3471
6 Reserved RFC 3471
7 Digital Wrapper RFC 3471
8 Lambda (photonic) RFC 3471
9 Fiber RFC 3471
10 Reserved RFC 3471
11 FiberChannel RFC 3471
12 G.709 ODUk (Digital Path) RFC 4328
13 G.709 Optical Channel RFC 4328
14 Line (e.g., 8B/10B) RFC 6004
15-239 Unassigned
240-255 Experimental Usage/temporarily

Switching Types

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 3471: Generalized Multi-Protocol Label Switching (GMPLS) Signaling Functional Description
  • RFC 4328: Generalized Multi-Protocol Label Switching (GMPLS) Signaling Extensions for G.709 Optical Transport Networks Control
  • RFC 7074: Revised Definition of the GMPLS Switching Capability and Type Fields

Available Formats

Value Name Reference
0 Unassigned
1 Packet-Switch Capable-1 (PSC-1) RFC 3471
2 Deprecated RFC 7074
3 Deprecated RFC 7074
4 Deprecated RFC 7074
5 PSC with GSCSI support RFC 8330
6-29 Unassigned
30 Ethernet Virtual Private Line (EVPL) RFC 6004
31-39 Unassigned
40 802_1 PBB-TE RFC 6060
41-50 Unassigned
51 Layer-2 Switch Capable (L2SC) RFC 3471
52 L2SC with GSCSI support RFC 8330
53-99 Unassigned
100 Time-Division-Multiplex Capable (TDM) RFC 3471
101-109 Unassigned
110 OTN-TDM capable RFC 7138
111-124 Unassigned
125 Data Channel Switching Capable (DCSC) RFC 6002
126-149 Unassigned
150 Lambda-Switch Capable (LSC) RFC 3471
151 WSON-LSC RFC 7688
152 Flexi-Grid-LSC RFC 8363
153-199 Unassigned
200 Fiber-Switch Capable (FSC) RFC 3471
201-255 Unassigned

Generalized PIDs (G-PID)

Reference

  • RFC 3471: Generalized Multi-Protocol Label Switching (GMPLS) Signaling Functional Description
  • RFC 4328: Generalized Multi-Protocol Label Switching (GMPLS) Signaling Extensions for G.709 Optical Transport Networks Control

Available Formats

Range Registration Procedures References
0-31743 Standards Action RFC 4328
31744-32767 Assigned Temporarily for Experimental Usage RFC 4328
32768-65535 Standards Action RFC 4328
Value Type Technology Reference
0 Unknown All RFC 3471
1 Reserved RFC 3471
2 Reserved RFC 3471
3 Reserved RFC 3471
4 Reserved RFC 3471
5 Asynchronous mapping of E4 SDH RFC 3471
6 Asynchronous mapping of DS3/T3 SDH RFC 3471
7 Asynchronous mapping of E3 SDH RFC 3471
8 Bit synchronous mapping of E3 SDH RFC 3471
9 Byte synchronous mapping of E3 SDH RFC 3471
10 Asynchronous mapping of DS2/T2 SDH RFC 3471
11 Bit synchronous mapping of DS2/T2 SDH RFC 3471
12 Reserved RFC 3471
13 Asynchronous mapping of E1 SDH RFC 3471
14 Byte synchronous mapping of E1 SDH RFC 3471
15 Byte synchronous mapping of 31 * DS0 SDH RFC 3471
16 Asynchronous mapping of DS1/T1 SDH RFC 3471
17 Bit synchronous mapping of DS1/T1 SDH RFC 3471
18 Byte synchronous mapping of DS1/T1 SDH RFC 3471
19 VC-11 in VC-12 SDH RFC 3471
20 Reserved RFC 3471
21 Reserved RFC 3471
22 DS1 SF Asynchronous SONET RFC 3471
23 DS1 ESF Asynchronous SONET RFC 3471
24 DS3 M23 Asynchronous SONET RFC 3471
25 DS3 C-Bit Parity Asynchronous SONET RFC 3471
26 VT/LOVC SDH RFC 3471
27 STS SPE/HOVC SDH RFC 3471
28 POS - No Scrambling, 16 bit CRC SDH RFC 3471
29 POS - No Scrambling, 32 bit CRC SDH RFC 3471
30 POS - Scrambling, 16 bit CRC SDH RFC 3471
31 POS - Scrambling, 32 bit CRC SDH RFC 3471
32 ATM mapping SDH, G.709 ODUk RFC 3471; RFC 4328
33 Ethernet PHY SDH, G.709 OCh, Lambda, Fiber RFC 3471; RFC 4328
34 SONET/SDH G.709 OCh, Lambda, Fiber RFC 3471; RFC 4328
35 Reserved (SONET deprecated) G.709 OCh, Lambda, Fiber RFC 3471; RFC 4328
36 Digital Wrapper Lambda, Fiber RFC 3471
37 Lambda Fiber RFC 3471
38 ANSI/ETSI PDH SDH RFC 3471
39 Reserved SDH RFC 3471
40 Link Access Protocol SDH (LAPS - X.85 and X.86) SDH RFC 3471
41 FDDI SDH, Lambda, Fiber RFC 3471
42 DQDB (ETSI ETS 300 216) SDH RFC 3471
43 FiberChannel-3 (Services) FiberChannel RFC 3471
44 HDLC SDH RFC 3471
45 Ethernet V2/DIX (only) SDH, Lambda, Fiber RFC 3471
46 Ethernet 802.3 (only) SDH, Lambda, Fiber RFC 3471
47 G.709 ODU-2.5G G.709 ODUk RFC 4328; RFC 7139
48 G.709 OTUk(v) G.709 OCh ODUk mapped into OTUk(v) RFC 4328
49 CBR/CBRa G.709 ODUk, G.709 OCh RFC 4328
50 CBRb G.709 ODUk RFC 4328
51 BSOT G.709 ODUk RFC 4328
52 BSNT G.709 ODUk RFC 4328
53 IP/PPP (GFP) G.709 ODUk (and SDH) RFC 4328
54 Ethernet MAC (framed GFP) G.709 ODUk (and SDH) RFC 4328
55 Ethernet PHY (transparent GFP) G.709 ODUk (and SDH) RFC 4328
56 SBCON/ESCON G.709 ODUk, Lambda, Fiber RFC 4328; RFC 7139
57 FICON G.709 ODUk, Lambda, Fiber RFC 4328
58 Fiber Channel G.709 ODUk, Lambda, Fiber RFC 4328
59 Framed GFP G.709 ODUk RFC 7139
60 STM-1 G.709 ODUk RFC 7139
61 STM-4 G.709 ODUk RFC 7139
62 InfiniBand G.709 ODUflex RFC 7139
63 SDI (Serial Digital Interface) G.709 ODUk RFC 7139
64 SDI/1.001 G.709 ODUk RFC 7139
65 DVB_ASI G.709 ODUk RFC 7139
66 G.709 ODU-1.25G G.709 ODUk RFC 7139
67 G.709 ODU-Any G.709 ODUk RFC 7139
68 Null Test G.709 ODUk RFC 7139
69 Random Test G.709 ODUk RFC 7139
70 64B/66B GFP-F Ethernet G.709 ODUk RFC 7139
71-31743 Unassigned
31744-32767 Experimental Usage/temporarily
32768-65535 Reserved RFC 4328

Actions

Registration Procedure(s)

  • IETF Review or Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 3471: Generalized Multi-Protocol Label Switching (GMPLS) Signaling Functional Description

Available Formats

Value Description Reference
0 Inclusive List Indicates that the object/TLV contains one or more subchannel elements that are included in the Label Set. RFC 3471
1 Exclusive List Indicates that the object/TLV contains one or more subchannel elements that are excluded from the Label Set. RFC 3471
2 Inclusive Range Indicates that the object/TLV contains a range of labels. The object/TLV contains two subchannel elements. The first element indicates the start of the range. The second element indicates the end of the range. A value of zero indicates that there is no bound on the corresponding portion of the range. RFC 3471
3 Exclusive Range Indicates that the object/TLV contains a range of labels that are excluded from the Label Set. The object/TLV contains two subchannel elements. The first element indicates the start of the range. The second element indicates the end of the range. A value of zero indicates that there is no bound on the corresponding portion of the range. RFC 3471
4-255 Unassigned

Interface_ID Types

Registration Procedure(s)

  • IETF Review or Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 3471: Generalized Multi-Protocol Label Switching (GMPLS) Signaling Functional Description

Available Formats

Type Length Format Description Reference
0 Unassigned
1 8 IPv4 Addr. IPv4 RFC 3471
2 20 IPv6 Addr. IPv6 RFC 3471
3 12 Compound IF_INDEX (Interface Index) RFC 3471
4 12 Compound COMPONENT_IF_DOWNSTREAM (Component interface) - DEPRECATED RFC 3471; RFC 4201
5 12 Compound COMPONENT_IF_UPSTREAM (Component interface) - DEPRECATED RFC 3471; RFC 4201
6 varies See RFC 4920, Section 6.2 DOWNSTREAM_LABEL (GMPLS label) RFC 4920
7 varies See RFC 4920, Section 6.2 UPSTREAM_LABEL (GMPLS label) RFC 4920
8 8 See RFC 4920, Section 6.2 NODE_ID (TE Router ID) RFC 4920
9 x See RFC 4920, Section 6.2 OSPF_AREA (Area ID) RFC 4920
10 x See RFC 4920, Section 6.2 ISIS_AREA (Area ID) RFC 4920
11 8 See RFC 4920, Section 6.2 AUTONOMOUS_SYSTEM (Autonomous system) RFC 4920
12 varies See RFC 4920, Section 6.2 ERO_CONTEXT (ERO subobject) RFC 4920
13 varies See RFC 4920, Section 6.2 ERO_NEXT_CONTEXT (ERO subobjects) RFC 4920
14 8 IPv4 Addr. PREVIOUS_HOP_IPv4 (Node address) RFC 4920
15 20 IPv6 Addr. PREVIOUS_HOP_IPv6 (Node address) RFC 4920
16 8 IPv4 Addr. INCOMING_IPv4 (Interface address) RFC 4920
17 20 IPv6 Addr. INCOMING_IPv6 (Interface address) RFC 4920
18 12 Compound INCOMING_IF_INDEX (Interface index) RFC 4920
19 varies See RFC 4920, Section 6.2 INCOMING_DOWN_LABEL (GMPLS label) RFC 4920
20 varies See RFC 4920, Section 6.2 INCOMING_UP_LABEL (GMPLS label) RFC 4920
21 8 See RFC 4920, Section 6.2 REPORTING_NODE_ID (Router ID) RFC 4920
22 x See RFC 4920, Section 6.2 REPORTING_OSPF_AREA (Area ID) RFC 4920
23 x See RFC 4920, Section 6.2 REPORTING_ISIS_AREA (Area ID) RFC 4920
24 8 See RFC 4920, Section 6.2 REPORTING_AS (Autonomous system) RFC 4920
25 varies See RFC 4920, Section 6.2 PROPOSED_ERO (ERO subobjects) RFC 4920
26 varies See RFC 4920, Section 6.2 NODE_EXCLUSIONS (List of nodes) RFC 4920
27 varies See RFC 4920, Section 6.2 LINK_EXCLUSIONS (List of interfaces) RFC 4920
28 varies See RFC 6389, Section 5 RSVP-TE P2MP LSP TLV RFC 6389
29 varies See RFC 6389, Section 5 LDP P2MP LSP TLV RFC 6389
30 varies See RFC 6389, Section 5 IP Multicast Tunnel TLV RFC 6389
31 varies See RFC 6389, Section 5 MPLS Context Label TLV RFC 6389
32-511 Unassigned
512 8 See RFC 4783 REFERENCE_COUNT RFC 4783
513 8 See RFC 4783 SEVERITY RFC 4783
514 8 See RFC 4783 GLOBAL_TIMESTAMP RFC 4783
515 8 See RFC 4783 LOCAL_TIMESTAMP RFC 4783
516 varies See RFC 4783 ERROR_STRING RFC 4783
517-65535 Unassigned

Administrative Status Information Flags

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 4783: GMPLS - Communication of Alarm Information

Available Formats

Bit Number Hex Value Name Reference
0 0x80000000 Reflect (R) RFC 3473; RFC 3471
1-22 Unassigned
23 0x00000100 OAM Flows Enabled (M) RFC 7260
24 0x00000080 OAM Alarms Enabled (O) RFC 7260
25 0x00000040 Handover (H) RFC 5852
26 0x00000020 Lockout (L) RFC 4872
27 0x00000010 Inhibit Alarm Communication (I) RFC 4783
28 0x00000008 Call control (C) RFC 4974
29 0x00000004 Testing (T) RFC 3473; RFC 3471
30 0x00000002 Administratively down (A) RFC 3473; RFC 3471
31 0x00000001 Deletion in progress (D) RFC 3473; RFC 3471

Association Type

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 4872: RSVP-TE Extensions in Support of End-to-End Generalized Multi-Protocol Label Switching (GMPLS) Recovery

Available Formats

Value Name Reference
0 Reserved RFC 4872
1 Recovery (R) RFC 4872
2 Resource Sharing (S) RFC 4873; RFC 6780
3 Double-Sided Associated Bidirectional LSP (D) RFC 7551
4 Single-Sided Associated Bidirectional LSP (A) RFC 7551
5 Bypass Summary FRR Ready Association (B-SFRR-Ready) RFC 8796, Section 3.1
6 Bypass Summary FRR Active Association (B-SFRR-Active) RFC 8796, Section 3.2
7-65535 Unassigned

Ethernet Switching Granularities

Registration Procedure(s)

  • Standards Action

Reference

Available Formats

Value Switching Granularity Reference
0 Provided in signaling. RFC 6004; RFC 6003
1 Ethernet Port (for port-based service) RFC 6003
2 Ethernet Frame (for EVC-based service) RFC 6003
3-239 Unassigned
240-254 Reserved for Vendor-Specific Use RFC 6003
255 Reserved RFC 6003
256-65535 Not assigned at this time RFC 6003

Ethernet Sender TSpec TLVs/Ethernet Flowspec TLVs

Registration Procedure(s)

  • Standards Action

Reference

Available Formats

Type Description Reference
0 Reserved RFC 6003
1 Reserved RFC 6003
2 Ethernet Bandwidth Profile RFC 6003
3 Layer 2 Control Protocol (L2CP) RFC 6003
4 Bandwidth Availability RFC 8625
5-239 Unassigned
240-254 Reserved for Vendor-Specific Use RFC 6003
255 Reserved RFC 6003
256-65535 Not assigned at this time RFC 6003

Ethernet Bandwidth Profiles

Registration Procedure(s)

  • Standards Action

Reference

Available Formats

Bit Number Hex Value Name Reference
0 0x01 Coupling Flag (CF) RFC 6003
1 0x02 Color Mode (CM) RFC 6003

Hierarchy Actions

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 6107: Procedures for Dynamically Signaled Hierarchical Label Switched Paths

Available Formats

Bit Number Hex Value Name Reference
0-2 Unassigned
3 0x10 Hierarchy/stitching (H) RFC 6107
4 0x08 Bundle (B) RFC 6107
5 0x04 Routing adjacency (R) RFC 6107
6 0x02 TE link (T) RFC 6107
7 0x01 Private (P) RFC 6107

Grid Subregistry

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 6205: Generalized Labels for Lambda-Switch-Capable (LSC) Label Switching Routers

Available Formats

Value Grid Reference
0 Reserved RFC 6205
1 ITU-T DWDM RFC 6205
2 ITU-T CWDM RFC 6205
3 ITU-T Flex RFC 7699
4-7 Unassigned

DWDM Channel Spacing Subregistry

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 6205: Generalized Labels for Lambda-Switch-Capable (LSC) Label Switching Routers

Available Formats

Value Channel Spacing (GHz) Reference
0 Reserved RFC 6205
1 100 RFC 6205
2 50 RFC 6205
3 25 RFC 6205
4 12.5 RFC 6205
5 6.25 RFC 7699
6-15 Unassigned

CWDM Channel Spacing Subregistry

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 6205: Generalized Labels for Lambda-Switch-Capable (LSC) Label Switching Routers

Available Formats

Value Channel Spacing (nm) Reference
0 Reserved RFC 6205
1 20 RFC 6205
2-15 Unassigned

OTN Signal Type

Expert(s)

  • Daniele Ceccarelli, Fatai Zhang

Reference

  • RFC 7139: GMPLS Signaling Extensions for Control of Evolving G.709 Optical Transport Networks
  • RFC 7892: IANA Allocation Procedures for the GMPLS OTN Signal Type Registry

Available Formats

Range Registration Procedures Note
0-255 Standards Action standards-track documents
0-255 Specification Required other documents
Value Name Reference
0 Not significant RFC 4328
1 ODU1 (i.e., 2.5Gbps) RFC 4328
2 ODU2 (i.e., 10Gbps) RFC 4328
3 ODU3 (i.e., 40Gbps) RFC 4328
4 ODU4 (i.e., 100Gbps) RFC 7139
5 Unassigned RFC 4328
6 OCh at 2.5Gbps RFC 4328
7 OCh at 10Gbps RFC 4328
8 OCh at 40Gbps RFC 4328
9 OCh at 100Gbps RFC 7139
10 ODU0 (i.e., 1.25Gbps) RFC 7139
11 ODU2e (i.e., 10Gbps for FC1200 and GE LAN) RFC 7139
12-19 Unassigned
20 ODUflex(CBR) (i.e., 1.25*N Gbps) RFC 7139
21 ODUflex(GFP-F), resizable (i.e., 1.25*N Gbps) RFC 7139
22 ODUflex(GFP-F), non resizable (i.e., 1.25*N Gbps) RFC 7139
23 ODU1e (10Gbps Ethernet [G.Sup43]) RFC 7963
24-25 Unassigned
26 ODU3e1 (40Gbps Ethernet [G.Sup43]) RFC 7963
27 ODU3e2 (40Gbps Ethernet [G.Sup43]) RFC 7963
28-255 Unassigned

Generalized SCSI (Switching Capability Specific Information) TLV Types

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Lou Berger, Vishnu Beeram

Reference

  • RFC 8258: Generalized SCSI: A Generic Structure for Interface Switching Capability Descriptor (ISCD) Switching Capability Specific Information (SCSI)

Available Formats

Value SCSI-TLV Switching Type Reference
0 Reserved RFC 8258
1-9 Unassigned
10 Availability 5, 52 RFC 8330
11 Frequency Availability Bitmap 152 RFC 8363
12-65535 Unassigned

Special Purpose Generalized Label Values

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 8359: Network-Assigned Upstream Label

Available Formats

Pattern/Value Label Name Applicable Objects Reference
all-ones Unassigned Upstream Label UPSTREAM_LABEL RFC 8359