GeneRic Autonomic Signaling Protocol (GRASP) Parameters
Created
- 2017-07-20
Last Updated
- 2023-11-30
Available Formats
GRASP Messages and Options
Registration Procedure(s)
- Standards Action
Reference
- RFC 8990: GeneRic Autonomic Signaling Protocol (GRASP)
Available Formats
| Value | Message/Option | Reference |
|---|---|---|
| 0 | M_NOOP | RFC 8990 |
| 1 | M_DISCOVERY | RFC 8990 |
| 2 | M_RESPONSE | RFC 8990 |
| 3 | M_REQ_NEG | RFC 8990 |
| 4 | M_REQ_SYN | RFC 8990 |
| 5 | M_NEGOTIATE | RFC 8990 |
| 6 | M_END | RFC 8990 |
| 7 | M_WAIT | RFC 8990 |
| 8 | M_SYNCH | RFC 8990 |
| 9 | M_FLOOD | RFC 8990 |
| 10-98 | Unassigned | |
| 99 | M_INVALID | RFC 8990 |
| 100 | O_DIVERT | RFC 8990 |
| 101 | O_ACCEPT | RFC 8990 |
| 102 | O_DECLINE | RFC 8990 |
| 103 | O_IPv6_LOCATOR | RFC 8990 |
| 104 | O_IPv4_LOCATOR | RFC 8990 |
| 105 | O_FQDN_LOCATOR | RFC 8990 |
| 106 | O_URI_LOCATOR | RFC 8990 |
| 107-255 | Unassigned |
GRASP Objective Names
Registration Procedure(s)
- Specification Required
Expert(s)
- Michael Richardson
Reference
- RFC 8990: GeneRic Autonomic Signaling Protocol (GRASP)
Available Formats
| Objective Name | Reference |
|---|---|
| EX0 | RFC 8990 |
| EX1 | RFC 8990 |
| EX2 | RFC 8990 |
| EX3 | RFC 8990 |
| EX4 | RFC 8990 |
| EX5 | RFC 8990 |
| EX6 | RFC 8990 |
| EX7 | RFC 8990 |
| EX8 | RFC 8990 |
| EX9 | RFC 8990 |
| PrefixManager | RFC 8992 |
| PrefixManager.Params | RFC 8992 |
| AN_ACP | RFC 8994 |
| SRV.est | RFC 8994 |
| AN_Proxy | RFC 8995 |
| AN_join_registrar | RFC 8995; RFC Errata 7576 |