Group Secure Association Group Management Protocol (GSAKMP) Parameters
Created
- 2005-07-27
Last Updated
- 2018-09-12
Reference
- RFC 4535: GSAKMP: Group Secure Association Key Management Protocol
Available Formats
GSAKMP Group Identification Types
Registration Procedure(s)
- Standards Action
Reference
- RFC 4535: GSAKMP: Group Secure Association Key Management Protocol
Available Formats
| Grp ID Type | Value | Description/Defined In | Reference |
|---|---|---|---|
| Reserved | 0 | RFC 4535 | |
| UTF-8 | 1 | Format defined in Section 7.1.1.1.1 of RFC 4535. | RFC 4535 |
| Octet String | 2 | This type MUST be implemented. Format defined in Section 7.1.1.1.2 of RFC 4535. | RFC 4535 |
| IPv4 | 3 | Format defined in Section 7.1.1.1.3 of RFC 4535. | RFC 4535 |
| IPv6 | 4 | Format defined in Section 7.1.1.1.4 of RFC 4535. | RFC 4535 |
| Reserved to IANA | 5-192 | RFC 4535 | |
| Private Use | 193-255 | RFC 4535 |
GSAKMP Payload Types
Registration Procedure(s)
- Standards Action
Reference
- RFC 4535: GSAKMP: Group Secure Association Key Management Protocol
Available Formats
| Next_Payload_Type | Value | Reference |
|---|---|---|
| None | 0 | RFC 4535 |
| Policy Token | 1 | RFC 4535 |
| Key Download Packet | 2 | RFC 4535 |
| Rekey event | 3 | RFC 4535 |
| Identification | 4 | RFC 4535 |
| Reserved | 5 | RFC 4535 |
| Certificate | 6 | RFC 4535 |
| Reserved | 7 | RFC 4535 |
| Signature | 8 | RFC 4535 |
| Notification | 9 | RFC 4535 |
| Vendor ID | 10 | RFC 4535 |
| Key Creation | 11 | RFC 4535 |
| Nonce | 12 | RFC 4535 |
| Reserved to IANA | 13-192 | RFC 4535 |
| Private Use | 193-255 | RFC 4535 |
GSAKMP Exchange Types
Registration Procedure(s)
- Standards Action
Reference
- RFC 4535: GSAKMP: Group Secure Association Key Management Protocol
Available Formats
| Exchange_Type | Value | Reference |
|---|---|---|
| Reserved | 0-3 | RFC 4535 |
| Key Download Ack/Failure | 4 | RFC 4535 |
| Rekey Event | 5 | RFC 4535 |
| Reserved | 6-7 | RFC 4535 |
| Request to Join | 8 | RFC 4535 |
| Key Download | 9 | RFC 4535 |
| Cookie Download | 10 | RFC 4535 |
| Request to Join Error | 11 | RFC 4535 |
| Lack of Ack | 12 | RFC 4535 |
| Request to Depart | 13 | RFC 4535 |
| Departure Response | 14 | RFC 4535 |
| Departure Ack | 15 | RFC 4535 |
| Reserved to IANA | 16-192 | RFC 4535 |
| Private Use | 193-255 | RFC 4535 |
GSAKMP Policy Token Types
Registration Procedure(s)
- Standards Action
Reference
- RFC 4535: GSAKMP: Group Secure Association Key Management Protocol
Available Formats
GSAKMP Key Download Data Item Types
Registration Procedure(s)
- Standards Action
Reference
- RFC 4535: GSAKMP: Group Secure Association Key Management Protocol
Available Formats
GSAKMP Cryptographic Key Types
Registration Procedure(s)
- Expert Review
Expert(s)
- Unassigned
Reference
- RFC 4535: GSAKMP: Group Secure Association Key Management Protocol
Available Formats
GSAKMP Rekey Event Types
Registration Procedure(s)
- Standards Action
Reference
- RFC 4535: GSAKMP: Group Secure Association Key Management Protocol
Available Formats
| Rekey_Event_Type | Value | Description/Defined In | Reference |
|---|---|---|---|
| None | 0 | This type MUST be implemented. In this case, the size of the Rekey Event Data field will be zero bytes long. The purpose of a Rekey Event Payload with type None is when it is necessary to send out a new token with no rekey information. GSAKMP Rekey Msg requires a Rekey Event Payload, and in this instance it would have rekey data of type None. | RFC 4535 |
| GSAKMP_LKH | 1 | The rekey data will be of type LKH formatted according to GSAKMP. The format for this field is defined in Section 7.5.1.2 of RFC 4535. | RFC 4535 |
| Reserved to IANA | 2-192 | RFC 4535 | |
| Private Use | 193-255 | RFC 4535 |
GSAKMP Identification Classification
Registration Procedure(s)
- Standards Action
Reference
- RFC 4535: GSAKMP: Group Secure Association Key Management Protocol
Available Formats
GSAKMP Identification Types
Registration Procedure(s)
- Expert Review
Expert(s)
- Unassigned
Reference
- RFC 4535: GSAKMP: Group Secure Association Key Management Protocol
Available Formats
| ID_Type | Value | PKIX Cert Field | Description/Defined In | Reference |
|---|---|---|---|---|
| Reserved | 0 | RFC 4535 | ||
| ID_IPV4_ADDR | 1 | SubjAltName iPAddress | See Section 3.5 of RFC 4306. | RFC 4306 |
| ID_FQDN | 2 | SubjAltName dNSName | See Section 3.5 of RFC 4306. | RFC 4306 |
| ID_RFC822_ADDR | 3 | SubjAltName rfc822Name | See Section 3.5 of RFC 4306. | RFC 4306 |
| Reserved | 4 | RFC 4535 | ||
| ID_IPV6_ADDR | 5 | SubjAltName iPAddress | See Section 3.5 of RFC 4306. | RFC 4306 |
| Reserved | 6-8 | RFC 4535 | ||
| ID_DER_ASN1_DN | 9 | Entire Subject, bitwise Compare | See Section 3.5 of RFC 4306. | RFC 4306 |
| Reserved | 10 | RFC 4535 | ||
| ID_KEY_ID | 11 | N/A | See Section 3.5 of RFC 4306. | RFC 4306 |
| Reserved | 12-29 | |||
| Unencoded Name (ID_U_NAME) | 30 | Subject | The format for this type is defined in Section 7.6.1.1 of RFC 4535. | RFC 4535 |
| ID_DN_STRING | 31 | Subject | See RFC 4514. This type MUST be implemented. | RFC 4514 |
| Reserved to IANA | 32-192 | RFC 4535 | ||
| Private Use | 193-255 | RFC 4535 |
GSAKMP Certificate Types
Registration Procedure(s)
- Expert Review
Expert(s)
- Unassigned
Reference
- RFC 4535: GSAKMP: Group Secure Association Key Management Protocol
Available Formats
| Certificate_Type | Value | Description/Defined In | Reference |
|---|---|---|---|
| None | 0 | RFC 4535 | |
| Reserved | 1-3 | RFC 4535 | |
| X.509v3 Certificate -- Signature -- DER Encoding | 4 | This type MUST be implemented. Contains a DER encoded X.509 certificate. | RFC 4535 |
| Reserved | 5-6 | RFC 4535 | |
| Certificate Revocation List (CRL) | 7 | Contains a BER encoded X.509 CRL. | RFC 4535 |
| Reserved | 8-9 | RFC 4535 | |
| X.509 Certificate -- Attribute | 10 | See Section 3.6 of RFC 4306. | RFC 4306 |
| Raw RSA Key | 11 | See Section 3.6 of RFC 4306. | RFC 4306 |
| Hash and URL of X.509 Certificate | 12 | See Section 3.6 of RFC 4306. | RFC 4306 |
| Hash and URL of X.509 bundle | 13 | See Section 3.6 of RFC 4306. | RFC 4306 |
| Reserved to IANA | 14-49152 | RFC 4535 | |
| Private Use | 49153-65535 | RFC 4535 |
GSAKMP Signature Types
Registration Procedure(s)
- Expert Review
Expert(s)
- Unassigned
Reference
- RFC 4535: GSAKMP: Group Secure Association Key Management Protocol
Available Formats
| Signature Type | Value | Description/Defined In | Reference |
|---|---|---|---|
| DSS/SHA1 with ASN.1/DER encoding (DSS-SHA1-ASN1-DER) | 0 | This type MUST be supported. | RFC 4535 |
| RSA1024-MD5 | 1 | RFC 8017 | |
| ECDSA-P384-SHA3 | 2 | NIST, "Digital Signature Standard", FIPS PUB 186-2, National Institute of Standards and Technology, U.S. Department of Commerce, January 2000. | |
| Reserved to IANA | 3-41952 | RFC 4535 | |
| Private Use | 41953-65536 | RFC 4535 |
GSAKMP Notification Types
Registration Procedure(s)
- Standards Action
Reference
- RFC 4535: GSAKMP: Group Secure Association Key Management Protocol
Available Formats
| Notification Type | Value | Reference |
|---|---|---|
| None | 0 | RFC 4535 |
| Invalid-Payload-Type | 1 | RFC 4535 |
| Reserved | 2-3 | RFC 4535 |
| Invalid-Version | 4 | RFC 4535 |
| Invalid-Group-ID | 5 | RFC 4535 |
| Invalid-Sequence-ID | 6 | RFC 4535 |
| Payload-Malformed | 7 | RFC 4535 |
| Invalid-Key-Information | 8 | RFC 4535 |
| Invalid-ID-Information | 9 | RFC 4535 |
| Reserved | 10 | RFC 4535 |
| Invalid-Certificate | 11 | RFC 4535 |
| Cert-Type-Unsupported | 12 | RFC 4535 |
| Invalid-Cert-Authority | 13 | RFC 4535 |
| Authentication-Failed | 14 | RFC 4535 |
| Reserved | 15-16 | RFC 4535 |
| Certificate-Unavailable | 17 | RFC 4535 |
| Reserved | 18 | RFC 4535 |
| Unauthorized-Request | 19 | RFC 4535 |
| Reserved | 20-22 | RFC 4535 |
| Acknowledgment | 23 | RFC 4535 |
| Reserved | 24-25 | RFC 4535 |
| Nack | 26 | RFC 4535 |
| Cookie-Required | 27 | RFC 4535 |
| Cookie | 28 | RFC 4535 |
| Mechanism Choices | 29 | RFC 4535 |
| Leave Group | 30 | RFC 4535 |
| Departure Accepted | 31 | RFC 4535 |
| Request to Depart Error | 32 | RFC 4535 |
| Invalid Exchange Type | 33 | RFC 4535 |
| IPv4 Value | 34 | RFC 4535 |
| IPv6 Value | 35 | RFC 4535 |
| Prohibited by Group Policy | 36 | RFC 4535 |
| Prohibited by Locally Configured Policy | 37 | RFC 4535 |
| Reserved to IANA | 38-49152 | RFC 4535 |
| Private Use | 49153-65535 | RFC 4535 |
GSAKMP Acknowledgment Types
Registration Procedure(s)
- Standards Action
Reference
- RFC 4535: GSAKMP: Group Secure Association Key Management Protocol
Available Formats
| ACK_Type | Value | Definition | Reference |
|---|---|---|---|
| Simple | 0 | Data portion null. | RFC 4535 |
| Reserved to IANA | 1-192 | ||
| Private Use | 193-255 |
GSAKMP Mechanism Types
Registration Procedure(s)
- Standards Action
Reference
- RFC 4535: GSAKMP: Group Secure Association Key Management Protocol
Available Formats
| Mechanism_Type | Value | Mechanism Choice Data Value Table Reference | Reference |
|---|---|---|---|
| Key Creation Algorithm | 0 | Table 26 of RFC 4535 | RFC 4535 |
| Encryption Algorithm | 1 | Table 16 of RFC 4535 | RFC 4535 |
| Nonce Hash Algorithm | 2 | Table 25 of RFC 4535 | RFC 4535 |
| Reserved to IANA | 3-192 | RFC 4535 | |
| Private Use | 193-255 | RFC 4535 |
GSAKMP Nonce Hash Types
Registration Procedure(s)
- Expert Review
Expert(s)
- Unassigned
Reference
- RFC 4535: GSAKMP: Group Secure Association Key Management Protocol
Available Formats
GSAKMP Key Creation Types
Registration Procedure(s)
- Expert Review
Expert(s)
- Unassigned
Reference
- RFC 4535: GSAKMP: Group Secure Association Key Management Protocol
Available Formats
| Key Creation Type | Value | Definition/Defined In | Reference |
|---|---|---|---|
| Reserved | 0-1 | RFC 4535 | |
| Diffie-Hellman. 1024-bit MODP Group. Truncated | 2 | This type MUST be supported. Defined in RFC 4306 B.2. If the output of the process is longer than needed for the defined mechanism, use the first X low order bits, and truncate the remainder. | RFC 4306 |
| Reserved | 3-13 | RFC 4535 | |
| Diffie-Hellman. 2048-bit MODP Group. Truncated | 14 | If the output of the process is longer than needed for the defined mechanism, use the first X low order bits, and truncate the remainder. | RFC 3526 |
| Reserved to IANA | 15-49152 | RFC 4535 | |
| Private Use | 49153-65535 | RFC 4535 |
GSAKMP Nonce Types
Registration Procedure(s)
- Standards Action
Reference
- RFC 4535: GSAKMP: Group Secure Association Key Management Protocol
Available Formats
| Nonce_Type | Value | Definition | Reference |
|---|---|---|---|
| None | 0 | RFC 4535 | |
| Initiator (Nonce_I) | 1 | RFC 4535 | |
| Responder (Nonce_R) | 2 | RFC 4535 | |
| Combined (Nonce_C) | 3 | Hash (Append (Initiator_Value,Responder_Value)) The hash type comes from the Policy (e.g., Security Suite Definition of Policy Token). | RFC 4535 |
| Reserved to IANA | 4-192 | RFC 4535 | |
| Private Use | 192-255 | RFC 4535 |