Generic Security Service Application Program Interface (GSSAPI)/Kerberos/Simple Authentication and Security Layer (SASL) Service Names

Last Updated

  • 2021-08-26

Available Formats


GSSAPI/Kerberos/SASL Service Names

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 2743: Generic Security Service Application Program Interface Version 2, Update 1

Note

A service is a resource provided to network clients; often provided by more than one server and potentially by more than one protocol. Service names are short alphanumeric textual strings. Service names are used in the GSSAPI RFC 2743 host-service name form, are specified as part of a SASL profile RFC 4422 and are used by Kerberos service-based tickets RFC 1510. Registrations are restricted to alphanumeric characters and the characters '+', '-' and '.'

Available Formats

Service Name Usage Reference
rcmd remote command/rlogin/telnet
host generic host-based service RFC 2743
imap mailstore access/IMAP4 RFC 3501; RFC 9051
pop maildrop access/POP3 RFC 5034
acap remote configuration access/ACAP RFC 2244
nfs distributed file system protocol RFC 2623; RFC 7530; RFC 8881
ftp file transfer/FTP/TFTP RFC 2228
ldap Lightweight Directory Access Protocol (LDAP) RFC 4510; RFC 4513
smtp message transfer/SMTP RFC 4954
beep Blocks Extensible Exchange Protocol RFC 3080
mupdate Mailbox Update (MUPDATE) Protocol RFC 3656
sacred Secure Available Credentials (SACRED) Protocol RFC 3767
sieve ManageSieve Protocol RFC 5804
xmpp Extensible Messaging and Presence Protocol (XMPP) RFC 6120
nntp Network News Transfer Protocol (NNTP) RFC 4643