Hash Function Textual Names

Created

  • 2006-04-21

Last Updated

  • 2019-12-16

Available Formats


Hash Function Textual Names

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 8122: Connection-Oriented Media Transport over the Transport Layer Security (TLS) Protocol in the Session Description Protocol (SDP)

Note

Registration requires a standards-track RFC which updates or obsoletes RFC 3279.

Available Formats

Hash Function Name OID Reference
"md2" 1.2.840.113549.2.2 RFC 3279
"md5" 1.2.840.113549.2.5 RFC 3279
"sha-1" 1.3.14.3.2.26 RFC 3279
"sha-224" 2.16.840.1.101.3.4.2.4 RFC 4055
"sha-256" 2.16.840.1.101.3.4.2.1 RFC 4055
"sha-384" 2.16.840.1.101.3.4.2.2 RFC 4055
"sha-512" 2.16.840.1.101.3.4.2.3 RFC 4055
"shake128" 2.16.840.1.101.3.4.2.11 RFC 8692
"shake256" 2.16.840.1.101.3.4.2.12 RFC 8692