Hypertext Transfer Protocol (HTTP) Cache-Status

Created

  • 2021-08-19

Last Updated

  • 2022-06-21

Available Formats


HTTP Cache-Status

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Mark Nottingham

Reference

  • RFC 9211: The Cache-Status HTTP Response Header Field

Available Formats

Name Type Description Reference
hit Boolean When true, indicates that the request was satisfied by the cache; that is, it was not forwarded, and the response was obtained from the cache. RFC 9211
fwd Token When present, indicates that the request went forward towards the origin; its value indicates why. RFC 9211
fwd-status Integer Indicates which status code (see RFC 9110, Section 15) the next-hop server returned in response to the forwarded request. RFC 9211
ttl Integer Indicates the response’s remaining freshness lifetime (see RFC 9111, Section 4.2.1) as calculated by the cache, as an integer number of seconds, measured as closely as possible to when the response header section is sent by the cache. RFC 9211
stored Boolean Indicates whether the cache stored the response (see RFC 9111, Section 3); a true value indicates that it did. RFC 9211
collapsed Boolean Indicates whether this request was collapsed together with one or more other forward requests (see RFC 9111, Section 4); If true, the response was successfully reused; if not, a new request had to be made. RFC 9211
key String Conveys a representation of the cache key (see RFC 9111, Section 2) used for the response. RFC 9211
detail String or Token Allows implementations to convey additional information not captured in other parameters, such as implementation-specific states or other caching-related metrics. RFC 9211