Hypertext Transfer Protocol version 2 (HTTP/2) Parameters
Created
- 2015-02-20
Last Updated
- 2022-08-17
Available Formats
HTTP/2 Frame Type
Registration Procedure(s)
- IETF Review or IESG Approval
Reference
- RFC 9113: HTTP/2
Available Formats
| Code | Frame Type | Reference |
|---|---|---|
| 0x00 | DATA | RFC 9113, Section 6.1 |
| 0x01 | HEADERS | RFC 9113, Section 6.2 |
| 0x02 | PRIORITY | RFC 9113, Section 6.3 |
| 0x03 | RST_STREAM | RFC 9113, Section 6.4 |
| 0x04 | SETTINGS | RFC 9113, Section 6.5 |
| 0x05 | PUSH_PROMISE | RFC 9113, Section 6.6 |
| 0x06 | PING | RFC 9113, Section 6.7 |
| 0x07 | GOAWAY | RFC 9113, Section 6.8 |
| 0x08 | WINDOW_UPDATE | RFC 9113, Section 6.9 |
| 0x09 | CONTINUATION | RFC 9113, Section 6.10 |
| 0x0a | ALTSVC | RFC 7838, Section 4 |
| 0x0b | Unassigned | |
| 0x0c | ORIGIN | RFC 8336 |
| 0x0d-0x0f | Unassigned | |
| 0x10 | PRIORITY_UPDATE | RFC 9218 |
| 0x11-0xff | Unassigned |
HTTP/2 Settings
Registration Procedure(s)
- Expert Review
Expert(s)
- Martin Thomson (primary), Julian Reschke (secondary)
Reference
- RFC 9113: HTTP/2
Available Formats
| Code | Name | Initial Value | Reference |
|---|---|---|---|
| 0x00 | Reserved | RFC 9113 | |
| 0x01 | HEADER_TABLE_SIZE | 4096 | RFC 9113, Section 6.5.2 |
| 0x02 | ENABLE_PUSH | 1 | RFC 9113, Section 6.5.2 |
| 0x03 | MAX_CONCURRENT_STREAMS | (infinite) | RFC 9113, Section 6.5.2 |
| 0x04 | INITIAL_WINDOW_SIZE | 65535 | RFC 9113, Section 6.5.2 |
| 0x05 | MAX_FRAME_SIZE | 16384 | RFC 9113, Section 6.5.2 |
| 0x06 | MAX_HEADER_LIST_SIZE | (infinite) | RFC 9113, Section 6.5.2 |
| 0x07 | Unassigned | ||
| 0x08 | SETTINGS_ENABLE_CONNECT_PROTOCOL | 0 | RFC 8441 |
| 0x09 | SETTINGS_NO_RFC7540_PRIORITIES | 0 | RFC 9218 |
| 0x0a-0x0f | Unassigned | ||
| 0x10 | TLS_RENEG_PERMITTED | 0x00 | MS-HTTP2E; Gabriel_Montenegro |
| 0x11-0x4d43 | Unassigned | ||
| 0x4d44 | SETTINGS_ENABLE_METADATA | 0 | draft-beky-httpbis-metadata-02 |
| 0x4d45-0xffff | Unassigned |
HTTP/2 Error Code
Registration Procedure(s)
- Expert Review
Expert(s)
- Martin Thomson (primary), Julian Reschke (secondary)
Reference
- RFC 9113: HTTP/2
Available Formats
| Code | Name | Description | Reference |
|---|---|---|---|
| 0x00 | NO_ERROR | Graceful shutdown | RFC 9113, Section 7 |
| 0x01 | PROTOCOL_ERROR | Protocol error detected | RFC 9113, Section 7 |
| 0x02 | INTERNAL_ERROR | Implementation fault | RFC 9113, Section 7 |
| 0x03 | FLOW_CONTROL_ERROR | Flow-control limits exceeded | RFC 9113, Section 7 |
| 0x04 | SETTINGS_TIMEOUT | Settings not acknowledged | RFC 9113, Section 7 |
| 0x05 | STREAM_CLOSED | Frame received for closed stream | RFC 9113, Section 7 |
| 0x06 | FRAME_SIZE_ERROR | Frame size incorrect | RFC 9113, Section 7 |
| 0x07 | REFUSED_STREAM | Stream not processed | RFC 9113, Section 7 |
| 0x08 | CANCEL | Stream cancelled | RFC 9113, Section 7 |
| 0x09 | COMPRESSION_ERROR | Compression state not updated | RFC 9113, Section 7 |
| 0x0a | CONNECT_ERROR | TCP connection error for CONNECT method | RFC 9113, Section 7 |
| 0x0b | ENHANCE_YOUR_CALM | Processing capacity exceeded | RFC 9113, Section 7 |
| 0x0c | INADEQUATE_SECURITY | Negotiated TLS parameters not acceptable | RFC 9113, Section 7 |
| 0x0d | HTTP_1_1_REQUIRED | Use HTTP/1.1 for the request | RFC 9113, Section 7 |
| 0x0e-0xffffffff | Unassigned |
Contact Information
| Name | Contact URI | Last Updated |
|---|---|---|
| Gabriel_Montenegro | gabriel.montenegroµsoft.com | 2018-08-02 |