Hypertext Transfer Protocol version 3 (HTTP/3)
Created
- 2021-02-26
Last Updated
- 2023-06-13
Available Formats
HTTP/3 Frame Types
Expert(s)
- Mike Bishop, Alan Frindell
Reference
- RFC 9114: HTTP/3
Available Formats
| Range | Registration Procedures |
|---|---|
| provisional | Expert Review |
| provisional registration date field update | First Come First Served |
| permanent, 0x00-0x3f | Standards Action or IESG Approval |
| permanent, greater than 0x3f | Specification Required |
| values 0x1f * N + 0x21 (for non-negative integer values of N) | Reserved |
| first unassigned codepoint | Standards Action |
| Value | Frame Type | Status | Reference | Date | Change Controller | Contact | Notes |
|---|---|---|---|---|---|---|---|
| 0x00 | DATA | permanent | RFC 9114, Section 7.2.1 | 2021-02-26 | IETF | HTTP working group | |
| 0x01 | HEADERS | permanent | RFC 9114, Section 7.2.2 | 2021-02-26 | IETF | HTTP working group | |
| 0x02 | Reserved | RFC 9114 | 2021-02-26 | ||||
| 0x03 | CANCEL_PUSH | permanent | RFC 9114, Section 7.2.3 | 2021-02-26 | IETF | HTTP working group | |
| 0x04 | SETTINGS | permanent | RFC 9114, Section 7.2.4 | 2021-02-26 | IETF | HTTP working group | |
| 0x05 | PUSH_PROMISE | permanent | RFC 9114, Section 7.2.5 | 2021-02-26 | IETF | HTTP working group | |
| 0x06 | Reserved | RFC 9114 | |||||
| 0x07 | GOAWAY | permanent | RFC 9114, Section 7.2.6 | 2021-02-26 | IETF | HTTP working group | |
| 0x08-0x09 | Reserved | RFC 9114 | |||||
| 0x0a-0x0b | Unassigned | ||||||
| 0x0c | ORIGIN | permanent | RFC 9412, Section 2 | 2023-03-14 | IETF | HTTP working group | |
| 0x0d | MAX_PUSH_ID | permanent | RFC 9114, Section 7.2.7 | 2021-02-26 | IETF | HTTP working group | |
| 0x0e-0x4c | Unassigned | ||||||
| 0x4d | METADATA | provisional | draft-beky-httpbis-metadata-02 | 2022-08-26 | Bence Beky | Bence Beky | |
| 0xf0700-0xf0701 | PRIORITY_UPDATE | permanent | RFC 9218 | 2022-01-25 | IETF | HTTP working group |
HTTP/3 Settings
Expert(s)
- Mike Bishop, Alan Frindell
Reference
- RFC 9114: HTTP/3
Available Formats
| Range | Registration Procedures |
|---|---|
| provisional | Expert Review |
| provisional registration date field update | First Come First Served |
| permanent, 0x00-0x3f | Standards Action or IESG Approval |
| permanent, greater than 0x3f | Specification Required |
| values 0x1f * N + 0x21 (for non-negative integer values of N) | Reserved |
| first unassigned codepoint | Standards Action |
| Value | Setting Name | Default | Status | Reference | Date | Change Controller | Contact | Notes |
|---|---|---|---|---|---|---|---|---|
| 0x00 | Reserved | N/A | RFC 9114 | |||||
| 0x01 | SETTINGS_QPACK_MAX_TABLE_CAPACITY | 0 | permanent | RFC 9204, Section 5 | 2021-03-16 | IETF | HTTP working group | |
| 0x02 | Reserved | N/A | RFC 9114 | |||||
| 0x03 | Reserved | N/A | RFC 9114 | |||||
| 0x04 | Reserved | N/A | RFC 9114 | |||||
| 0x05 | Reserved | N/A | RFC 9114 | |||||
| 0x06 | SETTINGS_MAX_FIELD_SECTION_SIZE | Unlimited | permanent | RFC 9114, Section 7.2.4.1 | 2021-02-26 | IETF | HTTP working group | |
| 0x07 | SETTINGS_QPACK_BLOCKED_STREAMS | 0 | permanent | RFC 9204, Section 5 | 2021-03-16 | IETF | HTTP working group | |
| 0x08 | SETTINGS_ENABLE_CONNECT_PROTOCOL | 0 | permanent | RFC 9220 | 2022-02-11 | IETF | HTTP working group | |
| 0x33 | SETTINGS_H3_DATAGRAM | 0 | permanent | RFC 9297 | 2022-06-23 | IETF | HTTP working group | |
| 0x4d44 | SETTINGS_ENABLE_METADATA | 0 | provisional | draft-beky-httpbis-metadata-02 | 2022-08-26 | Bence Beky | Bence Beky |
HTTP/3 Error Codes
Expert(s)
- Mike Bishop, Alan Frindell
Reference
- RFC 9114: HTTP/3
Available Formats
| Range | Registration Procedures |
|---|---|
| provisional | Expert Review |
| provisional registration date field update | First Come First Served |
| permanent, 0x00-0x3f | Standards Action or IESG Approval |
| permanent, greater than 0x3f | Specification Required |
| values 0x1f * N + 0x21 (for non-negative integer values of N) | Reserved |
| first unassigned codepoint | Standards Action |
| Value | Name | Description | Status | Reference | Date | Change Controller | Contact | Notes |
|---|---|---|---|---|---|---|---|---|
| 0x33 | H3_DATAGRAM_ERROR | Datagram or Capsule Protocol parse error | permanent | RFC 9297 | 2022-06-23 | IETF | HTTP working group | |
| 0x0100 | H3_NO_ERROR | No error | permanent | RFC 9114, Section 8.1 | 2021-02-26 | IETF | HTTP working group | |
| 0x0101 | H3_GENERAL_PROTOCOL_ERROR | General protocol error | permanent | RFC 9114, Section 8.1 | 2021-02-26 | IETF | HTTP working group | |
| 0x0102 | H3_INTERNAL_ERROR | Internal error | permanent | RFC 9114, Section 8.1 | 2021-02-26 | IETF | HTTP working group | |
| 0x0103 | H3_STREAM_CREATION_ERROR | Stream creation error | permanent | RFC 9114, Section 8.1 | 2021-02-26 | IETF | HTTP working group | |
| 0x0104 | H3_CLOSED_CRITICAL_STREAM | Critical stream was closed | permanent | RFC 9114, Section 8.1 | 2021-02-26 | IETF | HTTP working group | |
| 0x0105 | H3_FRAME_UNEXPECTED | Frame not permitted in the current state | permanent | RFC 9114, Section 8.1 | 2021-02-26 | IETF | HTTP working group | |
| 0x0106 | H3_FRAME_ERROR | Frame violated layout or size rules | permanent | RFC 9114, Section 8.1 | 2021-02-26 | IETF | HTTP working group | |
| 0x0107 | H3_EXCESSIVE_LOAD | Peer generating excessive load | permanent | RFC 9114, Section 8.1 | 2021-02-26 | IETF | HTTP working group | |
| 0x0108 | H3_ID_ERROR | An identifier was used incorrectly | permanent | RFC 9114, Section 8.1 | 2021-02-26 | IETF | HTTP working group | |
| 0x0109 | H3_SETTINGS_ERROR | SETTINGS frame contained invalid values | permanent | RFC 9114, Section 8.1 | 2021-02-26 | IETF | HTTP working group | |
| 0x010a | H3_MISSING_SETTINGS | No SETTINGS frame received | permanent | RFC 9114, Section 8.1 | 2021-02-26 | IETF | HTTP working group | |
| 0x010b | H3_REQUEST_REJECTED | Request not processed | permanent | RFC 9114, Section 8.1 | 2021-02-26 | IETF | HTTP working group | |
| 0x010c | H3_REQUEST_CANCELLED | Data no longer needed | permanent | RFC 9114, Section 8.1 | 2021-02-26 | IETF | HTTP working group | |
| 0x010d | H3_REQUEST_INCOMPLETE | Stream terminated early | permanent | RFC 9114, Section 8.1 | 2021-02-26 | IETF | HTTP working group | |
| 0x010e | H3_MESSAGE_ERROR | Malformed message | permanent | RFC 9114, Section 8.1 | 2021-02-26 | IETF | HTTP working group | |
| 0x010f | H3_CONNECT_ERROR | TCP reset or error on CONNECT request | permanent | RFC 9114, Section 8.1 | 2021-02-26 | IETF | HTTP working group | |
| 0x0110 | H3_VERSION_FALLBACK | Retry over HTTP/1.1 | permanent | RFC 9114, Section 8.1 | 2021-02-26 | IETF | HTTP working group | |
| 0x0200 | QPACK_DECOMPRESSION_FAILED | Decoding of a field section failed | permanent | RFC 9204, Section 6 | 2021-03-16 | IETF | HTTP working group | |
| 0x0201 | QPACK_ENCODER_STREAM_ERROR | Error on the encoder stream | permanent | RFC 9204, Section 6 | 2021-03-16 | IETF | HTTP working group | |
| 0x0202 | QPACK_DECODER_STREAM_ERROR | Error on the decoder stream | permanent | RFC 9204, Section 6 | 2021-03-16 | IETF | HTTP working group |
HTTP/3 Stream Types
Expert(s)
- Mike Bishop, Alan Frindell
Reference
- RFC 9114: HTTP/3
Available Formats
| Range | Registration Procedures |
|---|---|
| provisional | Expert Review |
| provisional registration date field update | First Come First Served |
| permanent, 0x00-0x3f | Standards Action or IESG Approval |
| permanent, greater than 0x3f | Specification Required |
| values 0x1f * N + 0x21 (for non-negative integer values of N) | Reserved |
| first unassigned codepoint | Standards Action |
| Value | Stream Type | Sender | Status | Reference | Date | Change Controller | Contact | Notes |
|---|---|---|---|---|---|---|---|---|
| 0x00 | Control Stream | Both | permanent | RFC 9114, Section 6.2.1 | 2021-02-26 | IETF | HTTP working group | |
| 0x01 | Push Stream | Server | permanent | RFC 9114, Section 4.4 | 2021-02-26 | IETF | HTTP working group | |
| 0x02 | QPACK Encoder Stream | Both | permanent | RFC 9204, Section 4.2 | 2021-03-16 | IETF | HTTP working group | |
| 0x03 | QPACK Decoder Stream | Both | permanent | RFC 9204, Section 4.2 | 2021-03-16 | IETF | HTTP working group |
Contact Information
| Name | Contact URI | Last Updated |
|---|---|---|
| Bence Beky | bnc&google.com | 2022-08-26 |
| HTTP working group | ietf-http-wg&w3.org | 2023-03-14 |