iana-if-type YANG Module
Created
- 2014-01-27
Last Updated
- 2026-03-18
Registration Procedure(s)
- This is one of the available formats of the Interface Types (ifType) registry.
Description
- Interface types must not be directly added to the iana-if-type YANG module. They must instead be added to the "Interface Types (ifType)" registry at Structure of Management Information (SMI) Numbers (MIB Module Registrations).
- Module: iana-if-type@2026-03-17.yang
Reference
- RFC 1213: Management Information Base for Network Management of TCP/IP-based internets: MIB-II
- RFC 2863: The Interfaces Group MIB
- RFC 7224: IANA Interface Type YANG Module
- RFC 8892: Guidelines and Registration Procedures for Interface Types and Tunnel Types