Internet Control Message Protocol (ICMP) Parameters

Last Updated

  • 2026-01-05

Available Formats


ICMP Type Numbers

Registration Procedure(s)

  • IESG Approval or Standards Action

Reference

  • RFC 2780: IANA Allocation Guidelines For Values In the Internet Protocol and Related Headers
  • RFC 9899: Extensions to the YANG Data Model for Access Control Lists (ACLs)

Note

The Internet Control Message Protocol (ICMP) has many messages that are identified by a "type" field.

Note

When this registry is modified, the YANG module "iana-icmpv4-types" YANG Parameters must be updated as defined in RFC 9899.

Available Formats

Type Name Reference
0 Echo Reply RFC 792
1 Unassigned
2 Unassigned
3 Destination Unreachable RFC 792
4 Source Quench (Deprecated) RFC 792; RFC 6633
5 Redirect RFC 792
6 Alternate Host Address (Deprecated) RFC 6918
7 Unassigned
8 Echo RFC 792
9 Router Advertisement RFC 1256
10 Router Solicitation RFC 1256
11 Time Exceeded RFC 792
12 Parameter Problem RFC 792
13 Timestamp RFC 792
14 Timestamp Reply RFC 792
15 Information Request (Deprecated) RFC 792; RFC 6918
16 Information Reply (Deprecated) RFC 792; RFC 6918
17 Address Mask Request (Deprecated) RFC 950; RFC 6918
18 Address Mask Reply (Deprecated) RFC 950; RFC 6918
19 Reserved (for Security) Solo
20-29 Reserved (for Robustness Experiment) Zaw-Sing Su
30 Traceroute (Deprecated) RFC 1393; RFC 6918
31 Datagram Conversion Error (Deprecated) RFC 1475; RFC 6918
32 Mobile Host Redirect (Deprecated) David Johnson; RFC 6918
33 IPv6 Where-Are-You (Deprecated) Bill Simpson; RFC 6918
34 IPv6 I-Am-Here (Deprecated) Bill Simpson; RFC 6918
35 Mobile Registration Request (Deprecated) Bill Simpson; RFC 6918
36 Mobile Registration Reply (Deprecated) Bill Simpson; RFC 6918
37 Domain Name Request (Deprecated) RFC 1788; RFC 6918
38 Domain Name Reply (Deprecated) RFC 1788; RFC 6918
39 SKIP (Deprecated) Tom Markson; RFC 6918
40 Photuris RFC 2521
41 ICMP messages utilized by experimental mobility protocols such as Seamoby RFC 4065
42 Extended Echo Request RFC 8335
43 Extended Echo Reply RFC 8335
44-252 Unassigned
253 RFC3692-style Experiment 1 RFC 4727
254 RFC3692-style Experiment 2 RFC 4727
255 Reserved Jon Postel

Code Fields

Reference

  • RFC 2780: IANA Allocation Guidelines For Values In the Internet Protocol and Related Headers

Note

Many of these ICMP types have a "code" field. Here we list the types again with their assigned code fields.


Type 0 — Echo Reply

Registration Procedure(s)

  • IESG Approval or Standards Action

Reference

  • RFC 792: Internet Control Message Protocol
  • RFC 2780: IANA Allocation Guidelines For Values In the Internet Protocol and Related Headers

Available Formats

Codes Description Reference
0 No Code

Type 1 — Unassigned

Codes Description Reference
No registrations at this time.

Type 2 — Unassigned

Codes Description Reference
No registrations at this time.

Type 3 — Destination Unreachable

Registration Procedure(s)

  • IESG Approval or Standards Action

Reference

  • RFC 792: Internet Control Message Protocol
  • RFC 2780: IANA Allocation Guidelines For Values In the Internet Protocol and Related Headers

Available Formats

Codes Description Reference
0 Net Unreachable RFC 792
1 Host Unreachable RFC 792
2 Protocol Unreachable RFC 792
3 Port Unreachable RFC 792
4 Fragmentation Needed and Don't Fragment was Set RFC 792
5 Source Route Failed RFC 792
6 Destination Network Unknown RFC 1122
7 Destination Host Unknown RFC 1122
8 Source Host Isolated RFC 1122
9 Communication with Destination Network is Administratively Prohibited RFC 1122
10 Communication with Destination Host is Administratively Prohibited RFC 1122
11 Destination Network Unreachable for Type of Service RFC 1122
12 Destination Host Unreachable for Type of Service RFC 1122
13 Communication Administratively Prohibited RFC 1812
14 Host Precedence Violation RFC 1812
15 Precedence cutoff in effect RFC 1812

Type 4 — Source Quench (Deprecated)

Reference

  • RFC 792: Internet Control Message Protocol
  • RFC 6633: Deprecation of ICMP Source Quench Messages

Available Formats

Codes Description Reference
0 No Code

Type 5 — Redirect

Registration Procedure(s)

  • IESG Approval or Standards Action

Reference

  • RFC 792: Internet Control Message Protocol
  • RFC 2780: IANA Allocation Guidelines For Values In the Internet Protocol and Related Headers

Available Formats

Codes Description Reference
0 Redirect Datagram for the Network (or subnet)
1 Redirect Datagram for the Host
2 Redirect Datagram for the Type of Service and Network
3 Redirect Datagram for the Type of Service and Host

Type 6 — Alternate Host Address (Deprecated)

Reference

Available Formats

Codes Description Reference
0 Alternate Address for Host

Type 7 — Unassigned

Codes Description Reference
No registrations at this time.

Type 8 — Echo

Registration Procedure(s)

  • IESG Approval or Standards Action

Reference

  • RFC 792: Internet Control Message Protocol
  • RFC 2780: IANA Allocation Guidelines For Values In the Internet Protocol and Related Headers

Available Formats

Codes Description Reference
0 No Code

Type 9 — Router Advertisement

Registration Procedure(s)

  • IESG Approval or Standards Action

Reference

  • RFC 1256: ICMP Router Discovery Messages
  • RFC 2780: IANA Allocation Guidelines For Values In the Internet Protocol and Related Headers

Available Formats

Codes Description Reference
0 Normal router advertisement RFC 3344
16 Does not route common traffic RFC 3344

Type 10 — Router Selection

Registration Procedure(s)

  • IESG Approval or Standards Action

Reference

  • RFC 1256: ICMP Router Discovery Messages
  • RFC 2780: IANA Allocation Guidelines For Values In the Internet Protocol and Related Headers

Available Formats

Codes Description Reference
0 No Code

Type 11 — Time Exceeded

Registration Procedure(s)

  • IESG Approval or Standards Action

Reference

  • RFC 792: Internet Control Message Protocol
  • RFC 2780: IANA Allocation Guidelines For Values In the Internet Protocol and Related Headers

Available Formats

Codes Description Reference
0 Time to Live exceeded in Transit
1 Fragment Reassembly Time Exceeded

Type 12 — Parameter Problem

Registration Procedure(s)

  • IESG Approval or Standards Action

Reference

  • RFC 792: Internet Control Message Protocol
  • RFC 2780: IANA Allocation Guidelines For Values In the Internet Protocol and Related Headers

Available Formats

Codes Description Reference
0 Pointer indicates the error
1 Missing a Required Option RFC 1108
2 Bad Length

Type 13 — Timestamp

Registration Procedure(s)

  • IESG Approval or Standards Action

Reference

  • RFC 792: Internet Control Message Protocol
  • RFC 2780: IANA Allocation Guidelines For Values In the Internet Protocol and Related Headers

Available Formats

Codes Description Reference
0 No Code

Type 14 — Timestamp Reply

Registration Procedure(s)

  • IESG Approval or Standards Action

Reference

  • RFC 792: Internet Control Message Protocol
  • RFC 2780: IANA Allocation Guidelines For Values In the Internet Protocol and Related Headers

Available Formats

Codes Description Reference
0 No Code

Type 15 — Information Request (Deprecated)

Reference

  • RFC 792: Internet Control Message Protocol
  • RFC 6918: Formally Deprecating Some ICMPv4 Message Types

Available Formats

Codes Description Reference
0 No Code

Type 16 — Information Reply (Deprecated)

Reference

  • RFC 792: Internet Control Message Protocol
  • RFC 6918: Formally Deprecating Some ICMPv4 Message Types

Available Formats

Codes Description Reference
0 No Code

Type 17 — Address Mask Request (Deprecated)

Reference

  • RFC 950: Internet Standard Subnetting Procedure
  • RFC 6918: Formally Deprecating Some ICMPv4 Message Types

Available Formats

Codes Description Reference
0 No Code

Type 18 — Address Mask Reply (Deprecated)

Reference

  • RFC 950: Internet Standard Subnetting Procedure
  • RFC 6918: Formally Deprecating Some ICMPv4 Message Types

Available Formats

Codes Description Reference
0 No Code

Type 19 — Reserved (for Security)

Reference

Codes Description Reference
No registrations at this time.

Types 20-29 — Reserved (for Robustness Experiment)

Reference

Codes Description Reference
No registrations at this time.

Type 30 — Traceroute (Deprecated)

Reference

  • RFC 1393: Traceroute Using an IP Option
  • RFC 6918: Formally Deprecating Some ICMPv4 Message Types
Codes Description Reference
No registrations at this time.

Type 31 — Datagram Conversion Error (Deprecated)

Reference

  • RFC 1475: TP/IX: The Next Internet
  • RFC 6918: Formally Deprecating Some ICMPv4 Message Types
Codes Description Reference
No registrations at this time.

Type 32 — Mobile Host Redirect (Deprecated)

Reference

Codes Description Reference
No registrations at this time.

Type 33 — IPv6 Where-Are-You (Deprecated)

Reference

Codes Description Reference
No registrations at this time.

Type 34 — IPv6 I-Am-Here (Deprecated)

Reference

Codes Description Reference
No registrations at this time.

Type 35 — Mobile Registration Request (Deprecated)

Reference

Codes Description Reference
No registrations at this time.

Type 36 — Mobile Registration Reply (Deprecated)

Reference

Codes Description Reference
No registrations at this time.

Type 37 — Domain Name Request (Deprecated)

Reference

  • RFC 1788: ICMP Domain Name Messages
  • RFC 6918: Formally Deprecating Some ICMPv4 Message Types
Codes Description Reference
No registrations at this time.

Type 38 — Domain Name Reply (Deprecated)

Reference

  • RFC 1788: ICMP Domain Name Messages
  • RFC 6918: Formally Deprecating Some ICMPv4 Message Types
Codes Description Reference
No registrations at this time.

Type 39 — SKIP (Deprecated)

Reference

Codes Description Reference
No registrations at this time.

Type 40 — Photuris

Registration Procedure(s)

  • IESG Approval or Standards Action

Reference

  • RFC 2521: ICMP Security Failures Messages
  • RFC 2780: IANA Allocation Guidelines For Values In the Internet Protocol and Related Headers

Available Formats

Codes Description Reference
0 Bad SPI
1 Authentication Failed
2 Decompression Failed
3 Decryption Failed
4 Need Authentication
5 Need Authorization

Type 41 — ICMP messages utilized by experimental mobility protocols such as Seamoby

Registration Procedure(s)

  • Specification Required or IESG Approval

Expert(s)

  • Unassigned

Reference

  • RFC 4065: Instructions for Seamoby and Experimental Mobility Protocol IANA Allocations
Codes Description Reference
No registrations at this time.

Type 42 — Extended Echo Request

Registration Procedure(s)

  • First Come First Served

Reference

  • RFC 8335: PROBE: A Utility for Probing Interfaces

Available Formats

Codes Description Reference
0 No Error RFC 8335
1-255 Unassigned

Type 43 — Extended Echo Reply

Registration Procedure(s)

  • First Come First Served

Reference

  • RFC 8335: PROBE: A Utility for Probing Interfaces

Available Formats

Codes Description Reference
0 No Error RFC 8335
1 Malformed Query RFC 8335
2 No Such Interface RFC 8335
3 No Such Table Entry RFC 8335
4 Multiple Interfaces Satisfy Query RFC 8335
5-255 Unassigned

Types 44-252 — Unassigned

Codes Description Reference
No registrations at this time.

Type 253 — RFC3692-style Experiment 1 [1]

Registration Procedure(s)

  • Standards Action or IESG Approval

Reference

  • RFC 4727: Experimental Values In IPv4, IPv6, ICMPv4, ICMPv6, UDP, and TCP Headers
Codes Description Reference
No registrations at this time.

Type 254 — RFC3692-style Experiment 2 [1]

Registration Procedure(s)

  • Standards Action or IESG Approval

Reference

  • RFC 4727: Experimental Values In IPv4, IPv6, ICMPv4, ICMPv6, UDP, and TCP Headers
Codes Description Reference
No registrations at this time.

ICMP Extension Object Classes and Class Sub-types

Reference

  • RFC 4884: Extended ICMP to Support Multi-Part Messages

Available Formats

Range Registration Procedures
0-246 First Come First Served
247-255 Private Use
Class Value Class Name Reference
1 MPLS Label Stack Class RFC 4950
2 Interface Information Object RFC 5837
3 Interface Identification Object RFC 8335
4 Extended Information RFC 8883
5 Node Identification Object draft-fenner-intarea-extended-icmp-hostid-01
6 Reflect All RFC-ietf-6man-icmpv6-reflection-19
7-246 Unassigned
247-255 Reserved for Private Use RFC 4884

Sub-types — Class 1 — MPLS Label Stack Class

Registration Procedure(s)

  • First Come First Served

Reference

  • RFC 4950: ICMP Extensions for Multiprotocol Label Switching

Available Formats

C-Type (Value) Description Reference
0 Reserved RFC 4950
1 Incoming MPLS Label Stack RFC 4950
2-246 Unassigned
247-255 Reserved for private use RFC 4950

Sub-types — Class 2 — Interface Information Object

Reference

  • RFC 5837: Extending ICMP for Interface and Next-Hop Identification

Available Formats

C-Type (Value) Description Reference
0-1 Interface Role field RFC 5837
2 Unallocated - allocatable with Standards Action RFC 5837
3 Unallocated - allocatable with Standards Action RFC 5837
4 ifIndex included RFC 5837
5 IP Address Sub-object included RFC 5837
6 Name Sub-object included RFC 5837
7 MTU included RFC 5837

Sub-types — Class 2 — Interface Information Object — Interface Roles

Available Formats

Value Description Reference
0 Incoming IP Interface RFC 5837
1 Sub-IP Component of Incoming IP Interface RFC 5837
2 Outgoing IP Interface RFC 5837
3 IP Next-hop RFC 5837

Sub-types — Class 3 — Interface Identification Object

Registration Procedure(s)

  • First Come First Served

Reference

  • RFC 8335: PROBE: A Utility for Probing Interfaces

Available Formats

Codes Description Reference
0 Reserved RFC 8335
1 Identifies Interface By Name RFC 8335
2 Identifies Interface By Index RFC 8335
3 Identifies Interface By Address RFC 8335
4-255 Unassigned

Sub-types — Class 4 — Extended Information

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 8883: ICMPv6 Errors for Discarding Packets Due to Processing Limits

Available Formats

Value Description Reference
0 Reserved RFC 8883
1 Pointer RFC 8883

Sub-types — Class 6 — Reflect All

Registration Procedure(s)

  • First Come First Served

Reference

Available Formats

C-Type (Value) Description Reference
0 Request RFC-ietf-6man-icmpv6-reflection-19
1 Reply - No Error RFC-ietf-6man-icmpv6-reflection-19
2 Reply - Unsupported Object RFC-ietf-6man-icmpv6-reflection-19
3-255 Unassigned

Contact Information

Name Contact URI Last Updated
Jon Postel postel&isi.edu 1995-09
David Johnson
Tom Markson markson&osmosys.incog.com 1995-09
Bill Simpson Bill.Simpson&um.cc.umich.edu 1995-10
Zaw-Sing Su ZSu&TSCA.ISTC.SRI.COM

Footnote

[1]

It is only appropriate to use these values in explicitly- configured experiments; they MUST NOT be shipped as defaults in implementations. See RFC 3692 for details.