Internet Group Management Protocol (IGMP) Type Numbers

Created

  • 2002-02-06

Last Updated

  • 2025-03-28

Note

The Internet Group Message Protocol (IGMP) has many messages that are identified by a "type" field.

Note that the original definition of IGMP in RFC 1112 divided this field into two 4-bit values, "version" and "type". This was decided to be too restrictive, so the fields were combined into a single 8-bit type space.

Available Formats


IGMP Type Numbers

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 9778: IANA Considerations for Internet Group Management Protocols

Available Formats

Type Name Reference
0x00 Reserved
0x01-0x08 Reserved (Obsolete) RFC 988
0x09-0x10 Unassigned
0x11 IGMP Membership Query RFC 1112
0x12 IGMPv1 Membership Report RFC 1112
0x13 DVMRP draft-ietf-idmr-dvmrp-v3-11
0x14 PIM version 1 draft-ietf-idmr-pim-spec-02
0x15 Cisco Trace Messages
0x16 IGMPv2 Membership Report RFC 2236
0x17 IGMPv2 Leave Group RFC 2236
0x1e Multicast Traceroute Response Bill Fenner
0x1f Multicast Traceroute Bill Fenner
0x22 IGMPv3 Membership Report RFC 9776
0x30 Multicast Router Advertisement RFC 4286
0x31 Multicast Router Solicitation RFC 4286
0x32 Multicast Router Termination RFC 4286
0xf0-0xff Reserved for experimentation RFC 9778

"Code" Fields

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 9778: IANA Considerations for Internet Group Management Protocols

Note

Many of these IGMP types have a "code" field. Here we list the types again with their assigned code fields.


Type 0x11 - IGMP Membership Query

Reference

  • RFC 1112: Host extensions for IP multicasting

Available Formats

Code Name
0 IGMP Version 1
1-255 IGMP Version 2 or above Max Response Time

Type 0x12 - IGMPv1 Membership Report

Reference

  • RFC 1112: Host extensions for IP multicasting
Code Name
No registrations at this time.

Type 0x13 - DVMRP

Reference

Available Formats

Code Name
1 Probe
2 Route Report
3 Old Ask Neighbors
4 Old Neighbors Reply
5 Ask Neighbors
6 Neighbors Reply
7 Prune
8 Graft
9 Graft Ack

Type 0x14 - PIM version 1

Reference

Available Formats

Code Name
0 Query
1 Register
2 Register-Stop
3 Join/Prune
4 RP-Reachable
5 Assert
6 Graft
7 Graft Ack
8 Mode

Type 0x16 - IGMPv2 Membership Report

Reference

  • RFC 2236: Internet Group Management Protocol, Version 2
Code Name
No registrations at this time.

Type 0x17 - IGMPv2 Leave Group

Reference

  • RFC 2236: Internet Group Management Protocol, Version 2
Code Name
No registrations at this time.

Type 0x1e - Multicast Traceroute Response

Reference

Code Name
No registrations at this time.

Type 0x1f - Multicast Traceroute

Reference

Code Name
No registrations at this time.

Type 0x22 - IGMPv3 Membership Report

Reference

  • RFC 9776: Internet Group Management Protocol, Version 3
Code Name
No registrations at this time.

Type 0xf0-0xff - Reserved for experimentation

Reference

  • RFC 9778: IANA Considerations for Internet Group Management Protocols
Code Name
No registrations at this time.

IGMP/MLD Extension Types

Reference

  • RFC 9279: Internet Group Management Protocol Version 3 (IGMPv3) and Multicast Listener Discovery Version 2 (MLDv2) Message Extension

Available Formats

Range Registration Procedures
0-65533 IETF Review
65534-65535 Experimental Use
Extension Type Length Name Reference
0 variable No-op RFC 9279
1-65533 Unassigned
65534-65535 variable Reserved for Experimental Use RFC 9279

IGMP/MLD Query Message Flags

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 9778: IANA Considerations for Internet Group Management Protocols

Available Formats

Flags Bit Short Name Description Reference
0 E Extension RFC 9279
1-3 Unassigned

IGMP/MLD Report Message Flags

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 9778: IANA Considerations for Internet Group Management Protocols

Available Formats

Flags Bit Short Name Description Reference
0 E Extension RFC 9279
1-15 Unassigned

Contact Information

Name Contact URI Last Updated
Bill Fenner fenner&research.att.com