IMAP and JMAP Keywords

Created

  • 2009-12-22

Last Updated

  • 2026-06-01

Available Formats


IMAP and JMAP Keywords

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Arnt Gulbrandsen, Barry Leiba

Reference

  • RFC 5788: IMAP4 Keyword Registry
  • RFC 8621: The JSON Meta Application Protocol (JMAP) for Mail

Available Formats

Keyword Type Usage Scope Comments Reference
$MDNSent SHARED COMMON BOTH RFC 3503
$Forwarded BOTH COMMON BOTH RFC 5550
$SubmitPending SHARED COMMON BOTH RFC 5550
$Submitted SHARED COMMON BOTH RFC 5550
$Junk BOTH COMMON BOTH Alexey Melnikov
$NotJunk BOTH COMMON BOTH Alexey Melnikov
$Phishing SHARED COMMON BOTH Rob Mueller
$Important PRIVATE COMMON BOTH RFC 8457
$draft BOTH COMMON JMAP-only RFC 8621
$seen BOTH COMMON JMAP-only RFC 8621
$flagged BOTH COMMON JMAP-only RFC 8621
$answered BOTH COMMON JMAP-only RFC 8621
$recent Reserved RFC 8621
$autosent SHARED COMMON BOTH RFC 9979
$canunsubscribe SHARED COMMON BOTH RFC 9979
$followed SHARED COMMON BOTH RFC 9979
$hasattachment SHARED COMMON BOTH RFC 9979
$hasmemo SHARED COMMON BOTH RFC 9979
$hasnoattachment SHARED COMMON BOTH RFC 9979
$imported SHARED COMMON BOTH RFC 9979
$istrusted SHARED COMMON BOTH RFC 9979
$MailFlagBit0 SHARED COMMON BOTH RFC 9979
$MailFlagBit1 SHARED COMMON BOTH RFC 9979
$MailFlagBit2 SHARED COMMON BOTH RFC 9979
$maskedemail SHARED LIMITED USE BOTH RFC 9979
$memo SHARED COMMON BOTH RFC 9979
$muted SHARED COMMON BOTH RFC 9979
$new SHARED LIMITED USE BOTH RFC 9979
$notify SHARED COMMON BOTH RFC 9979
$unsubscribed SHARED COMMON BOTH RFC 9979

Contact Information

Name Contact URI Last Updated
Alexey Melnikov alexey.melnikov&isode.com 2010-08-26
Rob Mueller robm&fastmail.com 2017-04-03