Internet Message Access Protocol (IMAP) LIST EXTENDED Registry

Created

  • 2006-10-19

Last Updated

  • 2024-06-05

Available Formats


LIST-EXTENDED options

Registration Procedure(s)

Reference

  • RFC 5258: Internet Message Access Protocol version 4 - LIST Command Extensions

Available Formats

LIST-EXTENDED option name LIST-EXTENDED option type Implied return option(s) LIST-EXTENDED option description Published specification Security considerations Intended usage Person and email address to contact for further information Owner/Change controller
SUBSCRIBED SELECTION SUBSCRIBED Causes the LIST command to list subscribed mailboxes, rather than the actual mailboxes. RFC 5258, Section 3. RFC 5258, Section 8. COMMON Alexey Melnikov IESG
REMOTE SELECTION (none) Causes the LIST command to return remote mailboxes as well as local ones, as described in RFC 2193. RFC 5258, Section 3. RFC 5258, Section 8. COMMON Alexey Melnikov IESG
SUBSCRIBED RETURN Causes the LIST command to return subscription state. RFC 5258, Section 3. RFC 5258, Section 8. COMMON Alexey Melnikov IESG
RECURSIVEMATCH SELECTION (none) Requests that CHILDINFO extended data item (childinfo-extended-item) is to be returned. RFC 5258, Section 3. RFC 5258, Section 8. COMMON Alexey Melnikov IESG
CHILDREN RETURN Requests mailbox child information. RFC 5258, Section 3, 4. RFC 5258, Section 8. COMMON Alexey Melnikov IESG
UTF8 SELECTION UTF8 Causes the LIST response to include mailboxes that mandate the UTF8 SELECT/EXAMINE parameter. RFC 5738, Section 3.4.1 RFC 5738, Section 11 COMMON see Authors' Addresses at the end of RFC 5738 IESG
UTF8ONLY SELECTION UTF8 Causes the LIST response to include mailboxes that mandate the UTF8 SELECT/EXAMINE parameter and exclude mailboxes that do not support the UTF8 SELECT/EXAMINE parameter. RFC 5738, Section 3.4.1 RFC 5738, Section 11 COMMON see Authors' Addresses at the end of RFC 5738 IESG
UTF8 RETURN none Causes the LIST response to include \NoUTF8 and \UTF8Only mailbox attributes. RFC 5738, Section 3.4.2 RFC 5738, Section 11 COMMON see Authors' Addresses at the end of RFC 5738 IESG
STATUS RETURN Causes the LIST command to return STATUS responses in addition to LIST responses. RFC 5819 RFC 5819 COMMON Alexey Melnikov IESG
SPECIAL-USE SELECTION SPECIAL-USE Limit the list to special-use mailboxes only RFC 6154 none COMMON Authors' Addresses at the end of RFC 6154 IESG
SPECIAL-USE RETURN Request special-use mailbox information RFC 6154 none COMMON Authors' Addresses at the end of RFC 6154 IESG
MYRIGHTS RETURN Causes the LIST command to return MYRIGHTS responses in addition to LIST responses. RFC 8440, Section 3 RFC 8440, Section 6 COMMON Kenneth Murchison IESG
METADATA RETURN Causes the LIST command to return METADATA responses in addition to LIST responses. RFC 9590, Section 3 RFC 9590, Section 6 COMMON See Authors' Addresses at the end of RFC 9590 IESG

LIST-EXTENDED response

Registration Procedure(s)

Reference

  • RFC 5258: Internet Message Access Protocol version 4 - LIST Command Extensions

Available Formats

LIST-EXTENDED extended data item tag LIST-EXTENDED extended data item description Which LIST-EXTENDED option(s) (and their types) causes this extended data item to be returned (if any) Published specification Security considerations Intended usage Person and email address to contact for further information Owner/Change controller
CHILDINFO The CHILDINFO extended data item describes the selection criteria that has caused it to be returned and indicates that the mailbox has one or more child mailboxes that match the selection criteria. RECURSIVEMATCH selection option RFC 5258, Section 3.5 RFC 5258, Section 8 COMMON Alexey Melnikov IESG
OLDNAME The OLDNAME extended data item describes the old mailbox name for the mailbox identified by the LIST response. none RFC 5465, Section 5.4; RFC 9051 none COMMON Alexey Melnikov IESG

Contact Information

Name Contact URI Last Updated
Alexey Melnikov Alexey.Melnikov&isode.com
Kenneth Murchison murch&fastmailteam.com 2018-08-15
IESG iesg&ietf.org