Integrated Services Parameters

Created

  • 2002-03-05

Last Updated

  • 2002-04-09

Note

The namespace is a two-level hierarchy: <service_name>.<parameter_name>. Each of these elements is a integer numerical quantity.

Available Formats


Service Names

Reference

  • RFC 2216: Network Element Service Specification Template

Note

<Service Name> is an integer in the range 1 to 254. The number space is broken into three regions. 2-254 will be allocated to individual QoS control services.

Available Formats

Range Registration Procedures Note
2-127 RFC Required
128-254 Experimental use Service and Data Element Naming
Value Description Reference
0 (Unused to allow the direct mapping of parameter names to MIB object names) RFC 2216
1 Generic RFC 2215
2 Guaranteed service RFC 2212
3-4 Unassigned
5 Controlled-load service RFC 2211
6-127 Unassigned
128-254 Experimental or private services RFC 2216
255 Reserved for future expansion RFC 2216

Parameter Names

Reference

  • RFC 2216: Network Element Service Specification Template

Note

<Parameter_name> is a number in the range 1 to 254, allocated on a per-service basis.

Available Formats

Range Registration Procedures
1-127 Parameters defined in RFC 2215
128-254 Parameters defined by author of service specification document (Service and Data Element Naming)
Value Description Reference
0 (Unused to allow the direct mapping of parameter names to MIB object names) RFC 2216
1 NON-IS_HOP flag (local) RFC 2215
2 NON-IS_HOP flag (composed) RFC 2215
3 NUMBER_OF_IS_HOPS (local) RFC 2215
4 NUMBER_OF_IS_HOPS (composed) RFC 2215
5 AVAILABLE_PATH_BANDWIDTH (local) RFC 2215
6 AVAILABLE_PATH_BANDWIDTH (composed) RFC 2215
7 MINIMUM_PATH_LATENCY (local) RFC 2215
8 MINIMUM_PATH_LATENCY (composed) RFC 2215
9 PATH_MTU (local) RFC 2215
10 PATH_MTU (composed) RFC 2215
11-125 Reserved for assignment to parameters with a common, shared meaning across all services RFC 2215
126 Compression Hint RFC 3006
127 TOKEN_BUCKET_TSPEC RFC 2215
128-254 Unassigned RFC 2216
255 Reserved for future expansion RFC 2216

Compression Hints

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 3006: Integrated Services in the Presence of Compressible Flows

Note

Hints are represented by a 32 bit field, with the high order 16 bits being the IP-compression-protocol number as defined in RFC 1332 and RFC 3544. The low order 16 bits are a sub-option for the cases where the IP-compression-protocol number alone is not sufficient for int-serv purposes.

Available Formats

Value Description Reference
0x002d0000 Van Jacobson Compressed TCP/IP RFC 1144
0x00610000 IP Header Compression RFC 2507
0x00610100 RTP Header Compression RFC 2508
0x0003pppp ROHC profile 0xpppp RFC 3241