In Situ OAM (IOAM)

Created

  • 2021-12-20

Last Updated

  • 2026-07-31

Available Formats


IOAM Option-Type

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9197: Data Fields for In Situ Operations, Administration, and Maintenance (IOAM)

Available Formats

Code Point Name Description Reference
0 IOAM Pre-allocated Trace Option-Type See RFC 9197, Section 4.4.1 RFC 9197, Section 4.4.1
1 IOAM Incremental Trace Option-Type See RFC 9197, Section 4.4.1 RFC 9197, Section 4.4.1
2 IOAM POT Option-Type See RFC 9197, Section 4.5 RFC 9197, Section 4.5
3 IOAM E2E Option-Type See RFC 9197, Section 4.6 RFC 9197, Section 4.6
4 IOAM Direct Export (DEX) Option-Type Direct exporting RFC 9326
5-63 Unassigned
64 IOAM Integrity-Protected Pre-allocated Trace Option-Type Pre-allocated Trace with Integrity Protection RFC-ietf-ippm-ioam-data-integrity-20, Section 4
65 IOAM Integrity-Protected Incremental Trace Option-Type Incremental Trace with Integrity Protection RFC-ietf-ippm-ioam-data-integrity-20, Section 4
66 IOAM Integrity-Protected POT Option-Type POT with Integrity Protection RFC-ietf-ippm-ioam-data-integrity-20, Section 4
67 IOAM Integrity-Protected E2E Option-Type E2E with Integrity Protection RFC-ietf-ippm-ioam-data-integrity-20, Section 4
68-127 Unassigned

IOAM Trace-Type

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9197: Data Fields for In Situ Operations, Administration, and Maintenance (IOAM)

Available Formats

Bit Description Reference
0 hop_Lim and node_id in short format RFC 9197
1 ingress_if_id and egress_if_id in short format RFC 9197
2 timestamp seconds RFC 9197
3 timestamp fraction RFC 9197
4 transit delay RFC 9197
5 namespace-specific data in short format RFC 9197
6 queue depth RFC 9197
7 checksum complement RFC 9197
8 hop_Lim and node_id in wide format RFC 9197
9 ingress_if_id and egress_if_id in wide format RFC 9197
10 namespace-specific data in wide format RFC 9197
11 buffer occupancy RFC 9197
12-21 Unassigned
22 variable-length Opaque State Snapshot RFC 9197
23 Reserved RFC 9197

IOAM Trace-Flags

Registration Procedure(s)

  • IETF Review

Reference

Available Formats

Bit Description Reference
0 "Overflow" (O-bit) RFC 9197
1 "Loopback" (L-bit) RFC 9322
2 "Active" (A-bit) RFC 9322
3 Unassigned

IOAM POT-Type

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9197: Data Fields for In Situ Operations, Administration, and Maintenance (IOAM)

Available Formats

Code Point Name Description Reference
0 16-Octet POT data See RFC 9197, Section 4.5 RFC 9197, Section 4.5
1-255 Unassigned

IOAM POT-Flags

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9197: Data Fields for In Situ Operations, Administration, and Maintenance (IOAM)

Available Formats

Bit Description Reference
0-7 Unassigned

IOAM E2E-Type

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9197: Data Fields for In Situ Operations, Administration, and Maintenance (IOAM)

Available Formats

Bit Description Reference
0 64-bit sequence number RFC 9197
1 32-bit sequence number RFC 9197
2 timestamp seconds RFC 9197
3 timestamp fraction RFC 9197
4-15 Unassigned

IOAM Namespace-ID

Expert(s)

  • Unassigned

Reference

  • RFC 9197: Data Fields for In Situ Operations, Administration, and Maintenance (IOAM)

Available Formats

Range Registration Procedures
0x0000 Expert Review
0x0001-0x7FFF Private Use
0x8000-0xFFFF Expert Review
Code Point Name Description Status Reference
0x0000 default namespace (known to all IOAM nodes) See RFC 9197, Section 4.3 permanent RFC 9197, Section 4.3
0x0001-0x7FFF Reserved for Private Use See RFC 9197, Section 4.3 RFC 9197, Section 4.3
0x8000-0xFFFF Unassigned

IOAM DEX Flags

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9326: In Situ Operations, Administration, and Maintenance (IOAM) Direct Exporting

Available Formats

Bit Description Reference
0-7 Unassigned

IOAM DEX Extension-Flags

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9326: In Situ Operations, Administration, and Maintenance (IOAM) Direct Exporting

Available Formats

Bit Description Reference
0 Flow ID RFC 9326
1 Sequence Number RFC 9326
2 Multicast Branching Node ID RFC 9630
3 Multicast Branching Interface Index RFC 9630
4-7 Unassigned

IOAM Integrity Protection Methods

Registration Procedure(s)

  • IETF Review

Reference

Note

When this registry is modified, the YANG module iana-ioam-integrity-protection-methods must be updated as defined in RFC-ietf-ippm-ioam-integrity-yang-08.

Available Formats

ID Description Protected Header Fields Reference
0x00 AES-GMAC, 16-octet (full) Authentication Tag, 12-octet Initialization Vector. Pre-allocated Trace and Incremental Trace:
- Namespace-ID (mask = 0xffff)
- NodeLen + Flags + RemainingLen (mask = 0xfb00)
- IOAM Trace-Type (mask = 0xffffff)
- Reserved (mask = 0x00)

POT:
- Namespace-ID (mask = 0xffff)
- IOAM-POT-Type (mask = 0xff)
- IOAM-POT-Flags (mask = 0x00)

E2E:
- Namespace-ID (mask = 0xffff)
- IOAM-E2E-Type (mask = 0xffff)
RFC-ietf-ippm-ioam-data-integrity-20, Section 5
0x01-0xFE Unassigned
0xFF Reserved RFC-ietf-ippm-ioam-data-integrity-20