Internet Protocol Version 6 (IPv6) Parameters

Last Updated

  • 2025-12-24

Available Formats


Next Header Types

Reference

  • RFC 8200: Internet Protocol, Version 6 (IPv6) Specification
  • RFC 2780: IANA Allocation Guidelines For Values In the Internet Protocol and Related Headers
  • RFC 7045: Transmission and Processing of IPv6 Extension Headers

Note

This registry has been closed in favor of the IPv6 Extension Header Types registry, also located at Internet Protocol Version 6 (IPv6) Parameters.


IPv6 Extension Header Types

Registration Procedure(s)

  • Standards Action or IESG Approval

Reference

  • RFC 2780: IANA Allocation Guidelines For Values In the Internet Protocol and Related Headers
  • RFC 5237: IANA Allocation Guidelines for the Protocol Field
  • RFC 7045: Transmission and Processing of IPv6 Extension Headers
  • RFC 9899: Extensions to the YANG Data Model for Access Control Lists (ACLs)

Note

The "IPv6 Extension Header" field in the Assigned Internet Protocol Numbers registry at Protocol Numbers should be updated for any Protocol Number added to this registry.

Note

When a new code is assigned to an IPv6 Extension Header, the next available free bit in IPFIX ipv6ExtensionHeaders Bits is selected for this new Extension Header. IPFIX ipv6ExtensionHeaders Bits is updated accordingly. Modifications to existing registrations must be mirrored in IPFIX ipv6ExtensionHeaders Bits.

Note

When this registry is modified, the YANG module "iana-ipv6-ext-types" YANG Parameters must be updated as defined in RFC 9899.

Available Formats

Protocol Number Description Reference
0 IPv6 Hop-by-Hop Option RFC 8200
43 Routing Header for IPv6 RFC 8200; RFC 5095
44 Fragment Header for IPv6 RFC 8200
50 Encapsulating Security Payload RFC 4303
51 Authentication Header RFC 4302
60 Destination Options for IPv6 RFC 8200
135 Mobility Header RFC 6275
139 Host Identity Protocol RFC 7401
140 Shim6 Protocol RFC 5533
253 Use for experimentation and testing RFC 3692; RFC 4727
254 Use for experimentation and testing RFC 3692; RFC 4727

Destination Options and Hop-by-Hop Options

Registration Procedure(s)

  • IESG Approval, IETF Review or Standards Action

Reference

  • RFC 8200: Internet Protocol, Version 6 (IPv6) Specification
  • RFC 2780: IANA Allocation Guidelines For Values In the Internet Protocol and Related Headers
  • RFC 9673: IPv6 Hop-by-Hop Options Processing Procedures

Note

From RFC 8200 IPv6 Option Types are 8-bit values, structured as three subfields, are defined in Section 4.2 of RFC 8200.

Each distinct 8-bit Option Type identifies a different option, i.e., the high-order 3 bits are considered part of the option identification. However, it is recommended that Option Types be assigned with distinct values in the "rest" subfield, until and unless that 5-bit space becomes full.

Available Formats

Hex Value Binary Value Description Reference
act chg rest
0x00 00 0 00000 Pad1 RFC 2460
0x01 00 0 00001 PadN RFC 2460
0xC2 11 0 00010 Jumbo Payload RFC 2675
0x23 00 1 00011 RPL Option RFC 9008
0x63 01 1 00011 RPL Option (DEPRECATED) RFC 6553; RFC 9008
0x04 00 0 00100 Tunnel Encapsulation Limit RFC 2473
0x05 00 0 00101 Router Alert (DEPRECATED for New Protocols) RFC 2711; RFC 9805
0x26 00 1 00110 Quick-Start RFC 4782; RFC Errata 2034
0x07 00 0 00111 CALIPSO RFC 5570
0x08 00 0 01000 SMF_DPD RFC 6621
0xC9 11 0 01001 Home Address RFC 6275
0x8A 10 0 01010 Endpoint Identification (DEPRECATED) [CHARLES LYNN]
0x8B 10 0 01011 ILNP Nonce RFC 6744
0x8C 10 0 01100 Line-Identification Option RFC 6788
0x4D 01 0 01101 Deprecated RFC 7731
0x6D 01 1 01101 MPL Option RFC 7731
0xEE 11 1 01110 IP_DFF RFC 6971
0x0F 00 0 01111 Performance and Diagnostic Metrics (PDM) RFC 8250
0x30 00 1 10000 Minimum Path MTU Hop-by-Hop Option RFC 9268
0x11 00 0 10001 IOAM Destination Option and IOAM Hop-by-Hop Option RFC 9486
0x31 00 1 10001 IOAM Destination Option and IOAM Hop-by-Hop Option RFC 9486
0x12 00 0 10010 AltMark RFC 9343
10011-11101 Unassigned
0x1E 00 0 11110 RFC3692-style Experiment [1] RFC 4727
0x3E 00 1 11110 RFC3692-style Experiment [1] RFC 4727
0x5E 01 0 11110 RFC3692-style Experiment [1] RFC 4727
0x7E 01 1 11110 RFC3692-style Experiment [1] RFC 4727
0x9E 10 0 11110 RFC3692-style Experiment [1] RFC 4727
0xBE 10 1 11110 RFC3692-style Experiment [1] RFC 4727
0xDE 11 0 11110 RFC3692-style Experiment [1] RFC 4727
0xFE 11 1 11110 RFC3692-style Experiment [1] RFC 4727
11111 Unassigned

Routing Types

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 8200: Internet Protocol, Version 6 (IPv6) Specification
  • RFC 5871: IANA Allocation Guidelines for the IPv6 Routing Header

Note

For Traffic Class related information, please see RFC 2474, RFC 3168, and Differentiated Services Field Codepoints (DSCP).

For IPv6 Router Alert Option Values, please see:

IPv6 Router Alert Option Values

Available Formats

Value Description Reference
0 Source Route (DEPRECATED) RFC 2460; RFC 5095
1 Nimrod (DEPRECATED 2009-05-06)
2 Type 2 Routing Header RFC 6275
3 RPL Source Route Header RFC 6554
4 Segment Routing Header (SRH) RFC 8754
5 CRH-16 RFC 9631
6 CRH-32 RFC 9631
7-252 Unassigned
253 RFC3692-style Experiment 1 [2] RFC 4727
254 RFC3692-style Experiment 2 [2] RFC 4727
255 Reserved

RPL-option-TLV

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 6553: The Routing Protocol for Low-Power and Lossy Networks (RPL) Option for Carrying RPL Information in Data-Plane Datagrams

Available Formats

Value Description Reference
0-254 Unassigned
255 Reserved RFC 6553

TaggerId Types

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 6621: Simplified Multicast Forwarding

Available Formats

Type Mnemonic Description Reference
0 NULL No TaggerId field is present RFC 6621
1 DEFAULT A TaggerId of non-specific context is present RFC 6621
2 IPv4 A TaggerId representing an IPv4 address is present RFC 6621
3 IPv6 A TaggerId representing an IPv6 address is present RFC 6621
4-7 Unassigned

Segment Routing Header Flags

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8754: IPv6 Segment Routing Header (SRH)

Available Formats

Bit Description Reference
0-1 Unassigned
2 O-flag RFC 9259
3-7 Unassigned

Segment Routing Header TLVs

Registration Procedure(s)

  • IETF Review

Reference

Note

  • 0-127: TLVs that do not change en route.
  • 128-255: TLVs that may change en route.

Available Formats

Value Description Reference
0 Pad1 TLV RFC 8754
1 Reserved RFC 8754
2 Reserved RFC 8754
3 Reserved RFC 8754
4 PadN TLV RFC 8754
5 HMAC TLV RFC 8754
6 Reserved RFC 8754
7-123 Unassigned
124-126 Experimentation and Test RFC 8754
127 Reserved RFC 8754
128-251 Unassigned
252-254 Experimentation and Test RFC 8754
255 Reserved RFC 8754

Footnotes

[1]

It is only appropriate to use these values in explicitly-configured experiments; they MUST NOT be shipped as defaults in implementations. See RFC 3692 for details.

[2]

It is only appropriate to use these values in explicitly-configured experiments; they MUST NOT be shipped as defaults in implementations. See RFC 3692 for details.